source: MondoRescue/branches/2.2.0/mindi-busybox/distributions/debian/rules@ 988

Last change on this file since 988 was 988, checked in by Bruno Cornec, 17 years ago

Idem

  • Property svn:executable set to *
File size: 1.7 KB
Line 
1#!/usr/bin/make -f
2# Sample debian/rules that uses debhelper.
3# GNU copyright 1997 to 1999 by Joey Hess.
4
5# Uncomment this to turn on verbose mode.
6#export DH_VERBOSE=1
7
8# Define package name for a one-stop change.
9PACKAGE_NAME = mindi-busybox
10
11# Don't set any compiler flags - busybox does that just fine
12
13configure: configure-stamp
14
15configure-stamp:
16 dh_testdir
17 touch configure-stamp
18
19# Build both architecture dependent and independent
20build: build-stamp
21
22build-stamp: configure-stamp
23 dh_testdir
24
25 # Compile the package.
26 mv .config .config.sav
27 $(MAKE) distclean
28 mv .config.sav .config
29 $(MAKE) oldconfig
30 $(MAKE) busybox
31
32 touch build-stamp
33
34clean:
35 dh_testdir
36 dh_testroot
37 rm -f build-stamp configure-stamp
38 # Clean temporary document directory
39 rm -rf debian/doc-temp
40 # Clean up.
41 -mv .config .config.sav
42 -$(MAKE) distclean
43 -mv .config.sav .config
44 -rm -f busybox
45
46 dh_clean
47
48# Install architecture dependent and independent
49install: build
50 dh_testdir
51 dh_testroot
52 dh_clean -k
53 dh_installdirs
54
55 # Install the package files into build directory:
56 # - start with upstream make install
57 $(MAKE) install PREFIX=$(CURDIR)/debian/$(PACKAGE_NAME)/usr/lib/mindi/rootfs
58 # - copy doc
59 mkdir -p debian/doc-temp
60 cp -a ChangeLog INSTALL LICENSE AUTHORS README TODO changelog svn.log debian/doc-temp
61
62 dh_install -s
63
64# Build architecture independant packages using the common target.
65binary-indep: build install
66 # None
67
68# Build architecture dependant packages using the common target.
69binary-arch: build install
70 dh_testdir
71 dh_testroot
72 dh_installchangelogs Changelog
73 dh_installdocs
74 dh_strip
75 dh_compress
76 dh_fixperms
77 dh_installdeb
78 dh_gencontrol
79 dh_md5sums
80 dh_builddeb
81
82binary: binary-arch binary-indep
83.PHONY: build clean binary-indep binary-arch binary install configure
Note: See TracBrowser for help on using the repository browser.