source: MondoRescue/branches/2.2.0/mindi-busybox/distributions/debian/rules@ 988

Last change on this file since 988 was 988, checked in by Bruno Cornec, 17 years ago

Idem

  • Property svn:executable set to *
File size: 1.7 KB
RevLine 
[823]1#!/usr/bin/make -f
2# Sample debian/rules that uses debhelper.
3# GNU copyright 1997 to 1999 by Joey Hess.
4
5# Uncomment this to turn on verbose mode.
6#export DH_VERBOSE=1
7
8# Define package name for a one-stop change.
9PACKAGE_NAME = mindi-busybox
10
[987]11# Don't set any compiler flags - busybox does that just fine
[823]12
[987]13configure: configure-stamp
[988]14
[987]15configure-stamp:
16 dh_testdir
[988]17 touch configure-stamp
[823]18
[983]19# Build both architecture dependent and independent
[987]20build: build-stamp
[983]21
[987]22build-stamp: configure-stamp
[983]23 dh_testdir
24
25 # Compile the package.
[987]26 mv .config .config.sav
27 $(MAKE) distclean
28 mv .config.sav .config
[983]29 $(MAKE) oldconfig
30 $(MAKE) busybox
31
32 touch build-stamp
33
[823]34clean:
35 dh_testdir
36 dh_testroot
[987]37 rm -f build-stamp configure-stamp
[983]38 # Clean temporary document directory
39 rm -rf debian/doc-temp
40 # Clean up.
[987]41 -mv .config .config.sav
[983]42 -$(MAKE) distclean
[987]43 -mv .config.sav .config
44 -rm -f busybox
[983]45
[823]46 dh_clean
47
[983]48# Install architecture dependent and independent
[987]49install: build
[823]50 dh_testdir
51 dh_testroot
[987]52 dh_clean -k
53 dh_installdirs
[823]54
[983]55 # Install the package files into build directory:
56 # - start with upstream make install
57 $(MAKE) install PREFIX=$(CURDIR)/debian/$(PACKAGE_NAME)/usr/lib/mindi/rootfs
58 # - copy doc
59 mkdir -p debian/doc-temp
[987]60 cp -a ChangeLog INSTALL LICENSE AUTHORS README TODO changelog svn.log debian/doc-temp
[823]61
[983]62 dh_install -s
63
[987]64# Build architecture independant packages using the common target.
65binary-indep: build install
66 # None
[983]67
[987]68# Build architecture dependant packages using the common target.
69binary-arch: build install
[983]70 dh_testdir
71 dh_testroot
[987]72 dh_installchangelogs Changelog
[823]73 dh_installdocs
74 dh_strip
75 dh_compress
76 dh_fixperms
77 dh_installdeb
78 dh_gencontrol
79 dh_md5sums
80 dh_builddeb
81
[983]82binary: binary-arch binary-indep
[987]83.PHONY: build clean binary-indep binary-arch binary install configure
Note: See TracBrowser for help on using the repository browser.