source: MondoRescue/branches/2.05/mindi/mindi.spec@ 241

Last change on this file since 241 was 241, checked in by bcornec, 18 years ago
  • Fix bug in post for mindi (no chmod needed on symlinks) (Sébastien Aperghis-Tramoni)
  • sles9 adaptations for mindi (DOCDIR) (Bruno Cornec)
  • remove useless cat in init (Sébastien Aperghis-Tramoni)
  • remove dependency on cdrecord for mondo RPMS (Bruno Cornec)
  • Property svn:keywords set to Id
File size: 11.6 KB
Line 
1#
2# $Id: mindi.spec 241 2005-12-20 01:17:23Z bcornec $
3#
4%define is_mandriva %(test -e /etc/mandriva-release && echo 1 || echo 0)
5%define is_mandrake %(test -e /etc/mandrake-release && echo 1 || echo 0)
6%define is_suse %(test -e /etc/SuSE-release && echo 1 || echo 0)
7%define is_fedora %(test -e /etc/fedora-release && echo 1 || echo 0)
8%define is_redhat %(test -e /etc/redhat-release && echo 1 || echo 0)
9
10%define name mindi
11%define version VVV
12%define mrel 1
13
14%if %is_redhat
15%define src %{name}-%{version}.tgz
16Group: Applications/Archiving
17Autoreq: 0
18%endif
19
20%if %is_mandrake
21%define src %{name}-%{version}.tar.bz2
22Group: Archiving/Backup
23Autoreqprov: no
24%endif
25
26%if %is_mandriva
27%define src %{name}-%{version}.tar.bz2
28Group: Archiving/Backup
29Autoreqprov: no
30%endif
31
32%if %is_suse
33%define src %{name}-%{version}.tgz
34Group: Archiving/Backup
35%endif
36
37Summary: Mindi creates emergency boot disks/CDs using your kernel, tools and modules
38Name: %name
39Version: %version
40Release: %mrel
41License: GPL
42Group: System/Kernel and hardware
43Url: http://mondorescue.berlios.de
44Source: %{src}
45BuildRoot: %{_tmppath}/%{name}-%{version}
46Requires: bzip2 >= 0.9, mkisofs, ncurses, binutils, gawk, dosfstools, afio, which
47# Not on all systems
48#Conflicts: bonnie++
49
50%description
51Mindi takes your kernel, modules, tools and libraries, and puts them on N
52bootable disks (or 1 bootable CD image). You may then boot from the disks/CD
53and do system maintenance - e.g. format partitions, backup/restore data,
54verify packages, etc.
55
56%prep
57%{__rm} -rf $RPM_BUILD_ROOT
58%setup -n %name-%{version}
59
60%build
61%ifarch ia64
62%{__make} -f Makefile.parted2fdisk clean
63%{__make} -f Makefile.parted2fdisk
64%endif
65
66%install
67export DONT_RELINK=1
68
69%{__rm} -rf $RPM_BUILD_ROOT
70export PREFIX=${RPM_BUILD_ROOT}%{_exec_prefix}
71export CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}
72export RPMBUILDMINDI="true"
73
74./install.sh
75
76%clean
77%{__rm} -rf $RPM_BUILD_ROOT
78
79%post
80for i in %{_libdir}/mindi/aux-tools/sbin/* %{_libdir}/mindi/rootfs/bin/* %{_libdir}/mindi/rootfs/sbin/* ; do
81 if [ ! -h $i ]; then
82 %{__chmod} 755 $i
83 fi
84done
85if [ -f /usr/local/sbin/mindi ]; then
86 echo "WARNING: /usr/local/sbin/mindi exists. You should probably remove your manual mindi installation !"
87fi
88
89%files
90%defattr(644,root,root,755)
91%config(noreplace) %{_sysconfdir}/mindi/deplist.txt
92%doc CHANGES INSTALL COPYING README TODO README.ia64 README.pxe README.busybox
93%{_mandir}
94%{_libdir}/mindi
95%attr(755,root,root) %{_sbindir}/*
96
97%changelog
98* Fri Nov 05 2005 Bruno Cornec <bcornec@users.berlios.de> 1.05
99- ia64 is now working
100- use install.sh script
101- use libdir for binary data
102
103* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 1.04_berlios
104- Merge of patches mentionned on mondo ML + ia64 updates
105- Fix bugs when called alone
106
107* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 1.04_cvs_20050503
108- supports exec-shield
109
110* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 1.03
111- better support of SLES 8
112
113* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 1.02
114- better kernel-level logging
115- added ACL, xattr binaries to deplist.txt
116- fixed obscure bug which occasionally stopped mindi from correctly finding
117 and documenting all LVM2 LVM-on-RAID volumes
118
119* Fri Jun 25 2004 Hugo Rabson <hugorabson@msn.com> 1.01
120- added ide_tape and other modules to mindi's config detection
121- unmount errant ramdisk ($mtpt) if fail to create boot floppy
122- better support of ISO dirs at restore-time (Conor Daly)
123
124* Fri Jun 18 2004 Hugo Rabson <hugorabson@msn.com> 1.00
125- first 1.0x release
126- busybox now static
127- trap Ctrl-Alt-Del; trigger soft reset
128- better SuSE 9.1 support
129- added parted2fdisk.pl (IA64) (Bruno Cornec)
130- add LVM2 support for kernel 2.6 (Takeru Komoriya)
131- better detection of multiple Mindis (Martin Fürstenau)
132- don't complain if just a Mindi boot CD & not a platform for Mondo
133- updated busybox to 1.0.0pre10
134- removed uClibc
135- add memtest support
136- 2.6 kernel support
137- removed Embleer files (Andree Leidenfrost)
138- added kernel-only floppy support, to accommodate really big kernels
139- updated+rebuilt busybox
140- added star support
141- mount /sys at boot-time
142- better 64-bit and 2.6 kernel support
143- better LVM, failsafe kernel support (Jim Richard)
144- use LILO, not raw kernel, on 1.4MB boot floppy
145- record names of unsaved modules, for future reference
146- enlarged ramdisk by 8MB
147
148* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 0.95
149- changed some '==' to '=' --- now more RH6-friendly
150- allow absolute pathnames again in deplist
151- disable multifunc cd thing
152- better Gentoo support (Bill)
153- better OnStream support
154- better Slackware support (Laurenz)
155- added partimagehack-static to deplist.txt
156- recompiled Busybox - now 10k smaller; better stack-handling
157- fixed boot screen typo
158- added support for 'auto' fs format
159- better devfs support for Mandrake users
160- better Debian+LVM support (Ralph Grewe)
161- updated analyze-my-lvm to handle floating-point gigabyte -L values
162
163* Thu Jul 24 2003 Anonymous <root@rohan> 0.94
164- altered rootfs's /dev entry to stop cvs from becoming confused
165- tweaked MAX_COMPRESSED_SIZE
166- added multi-function CD support to mindi and sbin/post-init
167- re-mount root as rw just in case
168- ask user to remove last data (floppy) disk if nec. (Tom Mortell)
169- added support for 5th column in mountlist.txt for labels
170- added symlinks.tgz
171- suppress erroneous error msgs re: failsafe kernel
172
173* Sun May 18 2003 Hugo Rabson <hugorabson@msn.com> 0.93
174- added cciss.o to SCSI_MODS
175- if format type is (e.g.) ext3,ext2 then use 1st entry
176- re-enabled fsck*
177- if cciss in use the enable it at boot-time
178- added /dev/ataraid/* to boot disk via ataraid.tgz (Luc S.)
179- better ISO support
180- tweaked Mindi to use 10-15% fewer floppies
181- added RUN_AFTER_INITIAL_BOOT_PHASE to let user specify a command
182 to be run by Mindi before it bootstraps to aux data disks;
183 e.g. 'echo engage > /proc/scsi/something'
184- added RUN_AFTER_BOOT_PHASE_COMPLETE to let user specify a command
185 to be run by Mindi after it boots but before it runs mondorestore
186- allow for Debian & other Stiefkinder that use 'none', not 'swap'
187 as the mountpoint of the swap partition
188- removed afio dependency
189- re-worked install.sh and tarball not to use tgz's
190- cleared up the boot msg
191- updated busybox to 0.60.5; updated uClibc to 0.9.19
192- add #!/bin/sh to start of insert-all-my-modules
193- fixed obscure bug in install-additional-tools
194- changed grep -m to grep | head -n1 for Debian users
195- moved vmlinuz, lib.tar.bz2 to mindi-kernel tarball/rpm
196
197* Wed Apr 09 2003 Hugo Rabson <hugorabson@msn.com> 0.92
198- fixed LVM/RAID bugs (Brian Borgeson)
199- if bad lilo, give more verbose error before quitting
200- added mt and perl to deplist.txt
201- insist on gawk being present
202- insmod ide-cd, cdrom, isofs, just in case
203- boot-time tmpfs ramdisk is now 40m (was 34m)
204- cleaned up logs
205- iso mode now calls Interactive
206- make SizeOfPartition() more Debian-friendly (Andree Leidenfrost)
207- clean up some calls to grep, esp. partition_mountpt=...
208- corrected some bashisms, to suit Debian ped- er, users
209- made first line refer to bash, not sh, to make sure
210 the Debian people know Mindi requires bash, not hs
211- changed grep -v "#" and grep -vx "#.*" to grep -vx " *#.*"
212- disabled code which would have made Mindi use sfdisk instead of fdisk
213 if it looked as if Debian's fdisk would misbehave
214
215* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 0.91
216- new devel branch
217- EXTRA_SPACE=16384
218- updated ResolveSoftlinks() to work better with b0rkn Gentoo devfs /dev
219- patched analyze-my-lvm (Benjamin Mampaey)
220- detect built-in boot.b files in lilo
221- cleaned up spec file a bit, more use of macros (Jesse Keating)
222- return w/err, don't abort, if Matt Nelson's RH8 system is farked
223- better at finding isolinux.bin
224- better at analyzing dependencies when running on broken distributions
225- try harder to boot from CD, even if tape fails
226- added ADDITIONAL_BOOT_PARAMS to be sent to kernel
227- better resolution of relative softlinks, leading to fewer
228 duplicates on data disks and therefore fewer data disks
229- detect Debian+devfs; use sfdisk instead of fdisk in that
230 eventuality, to work around yet another of Debian's warts
231- removed /lib/libuuid.* from rootfs.tgz
232- fixed vi
233- mindi now uses gawk --traditional (making gawk behave in a functionally
234 identical way to awk) - PASS; great, so now Debian needs to fix its awk :)
235- removed / from list of dirs accessed when trying to resolve deplist entry
236- spinner bugfix; handle odd LABELs properly (Tom Mortell)
237- fixed LVM/RAID bugs (Brian Borgeson)
238
239* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 0.72_20021202
240- misc code clean-up
241- save boot device's boot sector
242- detect and beware Compaq diagnostic partitions
243- better handling of devfs V non-devfs kernels and boot devs
244- trimmed busybox 0.60.3 binary on boot disk
245- mindi now resides in /usr/local/bin
246- removed lilo from dependencies
247- more Gentoo-friendly
248
249* Sun Nov 18 2002 Hugo Rabson <hugo@firstlinux.net> 0.71
250- if your kernel's builddate doesn't match any of the kernels in
251 your /boot directory then fudge the issue & find the closest
252 match (*grumble* Debian)
253- scan tape & CD at start, to force inclusion of modules on boot device
254- double EXTRA_SPACE if >7 disks
255- slimmer, more lithesome logfile
256- now accepts --findkernel
257- line 1982 - dd count=24000 should be count=$ramdisksize (Andras Korn)
258- better handling of non-Linux partitions on DevFS-enabled kernels
259- misc clean-ups
260- fixed Debian/ramdisksize/bloat problem (Johannes Franken)
261- fixed 2.4.20/fdisk eccentricity (Alistair Stevens)
262- updated kernel to 2.4.18-mdk6
263- generate mountlist in dev-abetical order ;)
264- fixed minor bug in .spec file
265- better at finding /boot/boot.b if your distro breaks the de facto standard
266- fixed minor bug in MakeMountlist
267- fixed install.sh
268- cleaned up deplist.txt
269- added rudimentary -v / --version flag
270- line 1180 or so --- duplicate mindi.iso entries --- fixed
271- added /bin/[ - a softlink to /bin/sh
272- ListAllPartitions() - sanity fix (KP)
273- fixed .spec bug
274- better feedback
275- added Markus's RAID patch
276- ListAllPartitions() - include /mnt/win* (Hugo)
277
278* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 0.70
279- better logging by dependency-calculating code
280- better handling of dependencies, specifically softlinks
281- if called by mondo then use mondo's temp dir as our temp dir too
282- changed gawk to $AWK in a few places, to allow for Debian
283- added host* config files to deplist
284- added tftp, ifconfig to busybox
285- added RPC support to uClibc
286- cleaned up creation of Mondo-Mindi configuration file
287- fixed bug in TryToFindKernelPath which stopped it from handling
288 multiple, same-version kernels gracefully
289- cleaned up deplist.txt
290- receive 'DIFFERENTIAL' variable from Mondo
291- better Debian compatibility, esp. w/detection of ver# (Hector Alvarez)
292- better devfs support; call fgrep in places instead of grep (Andrew Korn)
293- fixed analyze-my-lvm (Ralph Gruwe)
294- moved 50K of stuff from rootfs.tgz to aux-tools.tgz
295- added x11-tools.tgz option
296- updated /dev/console and /dev/tty0 (Paul Stevens)
297- cleaned up /mnt/groovy-stuff V /tmp/tmpfs code
298- catch sigint, sighup, etc.
299- fixed LILO-related message.txt mistake
300- .spec file clean-up; automation; config file (Carl Wilhem Soderstrom)
301- better devfs support (Andrew Korn)
302
303* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 0.64-1
304- fixed RH7.3 readonly bug
305- improved nfs config file creation
306- search more locations for isolinux.bin
307- added isonuke option
308- faster data disk creation
309- better DevFS support (Hector Alvarez, DuckX)
310- nfs-related fix (Hans Lie)
311- abort if vfat filesystem present but mkfs.vfat missing
312- removed softlink to pico
313- allow Mondo to say no compression will be used
314- added [ to ramdisk
315- tar data disks with -b [block size] of 32k
316- don't autoboot to 'RESTORE' screen - it's scary!
317- let user choose lilo or syslinux as boot loader
318- added syslinux support
319- cleaned up message screens
320
Note: See TracBrowser for help on using the repository browser.