source: MondoRescue/trunk/mondo/mondo.spec@ 317

Last change on this file since 317 was 317, checked in by bcornec, 18 years ago

merge -r309:316 $SVN_M/branches/2.06

  • Property svn:keywords set to Id
File size: 18.5 KB
Line 
1#
2# $Id: mondo.spec 317 2006-01-13 19:46:06Z bcornec $
3#
4%define is_mandriva %(test -e /etc/mandriva-release && echo 1 || echo 0)
5%define is_mandrake %(test -e /etc/mandrake-release && echo 1 || echo 0)
6%define is_suse %(test -e /etc/SuSE-release && echo 1 || echo 0)
7%define is_fedora %(test -e /etc/fedora-release && echo 1 || echo 0)
8%define is_redhat %(test -e /etc/redhat-release && echo 1 || echo 0)
9
10%define name mondo
11%define version VVV
12%define mrel RRR
13# if mandriva official build (rpm --with is_official)
14%{?is_official:%define rel %{mkrel} %{mrel}}%{!?is_official:%define rel %{mrel}}
15%define src %{name}-%{version}.tgz
16%define grp Archiving/Backup
17%define addreqb mindi >= 1.05, bzip2 >= 0.9, afio, mkisofs, binutils, newt >= 0.50, slang >= 1.4.1
18
19%if %is_redhat
20%define grp Applications/Archiving
21%define addreq %{addreqb}
22Autoreq: 0
23%endif
24
25%if %is_mandrake
26%define src %{name}-%{version}.tar.bz2
27%define addreq %{addreqb}
28Autoreqprov: no
29%endif
30
31%if %is_mandriva
32%define src %{name}-%{version}.tar.bz2
33%define addreq %{addreqb}
34Autoreqprov: no
35%endif
36
37%if %is_suse
38%define addreq %{addreqb}
39%endif
40
41Summary: A program which a Linux user can utilize to create a rescue/restore CD/tape
42Summary(fr): Un programme pour les utilisateurs de Linux pour cr�r un CD/tape de sauvegarde/restauration
43Summary(it): Un programma per utenti Linux per creare un CD/tape di rescue
44Summary(sp): Un programa para los usuarios de Linux por crear una CD/cinta de restoracion/rescate
45
46Name: %{name}
47Version: %{version}
48Release: %{mrel}
49License: GPL
50Group: %{grp}
51Url: http://mondorescue.berlios.de
52Source: %{src}
53BuildRoot: %{_tmppath}/%{name}-%{version}
54BuildRequires: newt-devel >= 0.50, slang-devel >= 1.4.1, gcc
55%ifarch ia64
56Requires: %{addreq}, elilo, parted
57%else
58Requires: %{addreq}, syslinux >= 1.52
59%endif
60
61#%package %{name}-devel
62#Summary: Header files for building against Mondo
63#%if %is_mandrake
64#Group: Development/Libraries
65#%endif
66#if %is_redhat
67#Group: Development/Other
68#%endif
69#Provides: libmondo-devel mondo-devel
70#Obsoletes: libmondo-devel
71#
72#%description -n %{name}-devel
73#Mondo libraries and includes
74
75%description
76Mondo is a GPL disaster recovery solution to create backup media (CD, DVD, tape, network images) that can be used to redeploy the damaged system, as well as deploy similar or less similar systems.
77
78%description -l fr
79Objectif
80""""""""
81Mondo est une solution GPL de sauvegarde en cas de désastre pour créer des médias (CD, DVD, bande, images réseau) qui peuvent être utilisés pour redéployer le système endomangé, aussi bien que des systèmes similaires, ou moins similaires.
82
83%description -l it
84Scopo
85"""""
86Mondo e' un programma che permette a qualsiasi utente Linux
87di creare un cd di rescue/restore (o piu' cd qualora l'installazione
88dovesse occupare piu' di 2Gb circa). Funziona con gli azionamenti di
89nastro, ed il NFS, anche.
90
91%description -l sp
92Objectivo
93"""""""""
94Mondo es un programa que permite cualquier usuario de Linux a crear una CD
95de restoracion/rescate (o CDs, si su instalacion es >2GO aprox.). Funciona
96con cintas y NFS, tambien.
97
98%prep
99%setup -q -n %name-%{version}
100
101%build
102%configure
103%{__make} VERSION=%{version} CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_REENTRANT"
104
105%install
106%{__rm} -rf $RPM_BUILD_ROOT
107%makeinstall
108%if %is_suse
109%{__rm} -rf $RPM_BUILD_ROOT/%{_datadir}/doc/%name-%{version}
110%endif
111
112%post
113/sbin/ldconfig
114%{__chmod} 755 %{_libdir}/%{name}/restore-scripts/%{name}/*
115
116%postun
117/sbin/ldconfig
118
119%clean
120%{__rm} -rf $RPM_BUILD_ROOT
121
122%files
123%defattr(644,root,root,755)
124%doc ChangeLog svn.log mondo/docs/en/1.6x-howto/*
125%doc INSTALL COPYING README TODO AUTHORS NEWS
126
127%attr(755,root,root) %{_sbindir}/*
128#%attr(755,root,root) %{_libdir}/%{name}/restore-scripts/%{name}/*
129%{_libdir}
130%{_mandir}
131
132%changelog
133* Tue Oct 06 2005 Bruno Cornec <bcornec@users.berlios.de> 2.05_berlios
134- Memory management revision
135- use libdir instead of datadir
136
137* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 2.04_berlios
138- Merge of patches mentionned on mondo ML + ia64 updates
139- Option -p added
140
141* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 2.04_cvs_20050503
142- made mondo more clever about finding its home. Avoids mondo considering
143 directories like '/usr/share/doc/momdo' as its home.
144
145* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 2.03
146- test sanity of user-specified tempdir
147- better SLES8 support
148
149* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 2.02
150- instead of using 'dd' to erase partition table, delete existing
151 partitions w/ the same call to fdisk that is used to create the
152 new partitions; this should avoids locking up the partition table
153- set bootable partition in the above same call to fdisk, for
154 the same reason (avoids locking up the partition table)
155- better software RAID support
156- mount ext3 partitions as ext2 when restoring - better for Debian
157- better star, ACL support
158- added ACL, xattr support for afio users
159
160* Fri Jun 26 2004 Hugo Rabson <hugorabson@msn.com> 2.01
161- fixed cvs for SuSE systems
162- fixed NTFS backup/restore bug relating to partimagehack
163 log file overflow and NTFS v non-NTFS differentiation
164- more reliable extraction of config info from CDs, floppies
165- better support of ISO dirs at restore-time (Conor Daly)
166- fixed spec file for SuSE users
167- added ldconfig to install section
168
169* Fri Jun 19 2004 Hugo Rabson <hugorabson@msn.com> 2.00
170- first 2.0 release
171- updated grub-install.patched to support SuSE and Red Hat
172- call 'mt' to set block size to 32K before opening in/out tape
173- updated mondo-prep.c to create each disk's partitions all at once
174 (one call per drive) instead of one call to fdisk per partition
175- when extracting cfg file and mountlist from all.tar.gz (tape copy),
176 use block size of INTERNAL_TAPE_BLK_SIZE, not TAPE_BLOCK_SIZE
177- added star and rudimentary SELinux support
178- fixed lots of bugs
179- all logging now goes to /var/log/mondo-archive.log, with symlink
180 to /tmp/mondo-restore.log for restore-time log-tracking
181- added grub-install.patched
182- removed embleer & other binaries
183- added '-b' to specify block size
184- added '-R' for star support
185
186* Thu Mar 25 2004 Bruno Cornec <Bruno.Cornec@hp.com> 1.7_cvs-20040325
187- ia64 fixes
188
189* Fri Nov 07 2003 Joshua Oreman <oremanj@get-linux.org> 1.7_cvs-20031107
190- fixed symbolic links for libraries
191- added support for boot/root multi floppies
192
193- added kdelibs as xmondo dependency
194- added xmondo pixmap installation
195- better find_cdrom_device(), to cope w/ multiple CD writers
196- fixed -m and -Vc flags
197- fixed NTFS support!
198- bootable CD uses native, not El Torito, support now
199- removed mondo-makefilelist
200- added 2.6 kernel support
201- if 2.6 kernel, insist that the user specify CD device
202- drop Embleer; insist on ms-sys and parted if Windows partition
203
204* Wed Nov 05 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031105.1
205- added -devel package
206
207* Tue Nov 04 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031104.1
208- made xmondo a second package
209- added ability to specify --without xmondo at build time
210
211* Sun Nov 02 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031102.1
212- Clean up, added spanish translation
213- Set prefix to be /usr
214- added/fixed Requires
215- remove CVS directories prior to building
216
217* Thu Oct 23 2003 Hugo Rabson <hugorabson@msn.com> 1.75_cvs_20031023
218- nothing yet
219
220* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 1.75
221- fixed chmod/chown bug (Jens Richter)
222- ask user to confirm NFS mountpoint in Interactive Mode
223- rewritten format_everything() to make sure LVMs, RAIDs and
224 regular partitions are prepped in the correct order
225- better magicdev support
226- rewritten external binary caller subroutine
227- DVD support added
228- better backup-time control gui; offer to exclude nfs if appl.
229- fixed multi-tape support
230- re-implemented -D and -J
231- fixed bug in extract_config_file_from_ramdisk() which
232 affected tape+floppy users
233- updated is_incoming_block_valid() to make it
234 return end-of-tape if >300 flotsam blocks
235- unmount CD-ROM before burning (necessary for RH8/9)
236- fixed some stray assert()'s
237- fixed bug in grub-MR (Christian)
238- make user remove floppy/CD before restoring interactively from tape
239- fixed bug in am_I_in_disaster_recovery_mode()
240- added code to nuke_mode() to make sure NFS
241 (backup) share is mounted in Nuke Mode
242- improved tape device detection code
243- better GRUB support
244- better logging of changed bigfiles at compare-time
245- better NTFS support, thanks to partimagehack-static
246- better logging
247- rewrote tape-handling code, breaking compatibility w/ previous versions
248- fixed ISO/CD biggiefile verification bug in mondoarchive
249- fixed bug which stopped boot/compare-time changelist from popping up
250- replaced mondo-makefilelist with C code - faster, cleaner
251- tweaked GUI - better feedback
252
253* Wed May 28 2003 Anonymous <root@rohan> 1.74
254- misc fixes (Michael Hanscho's friend)
255- added rudimentary support for SME
256- added better label support
257- fixed biggietime atime/ctime restoration bug 73
258- fixed 'default boot loader' detection bug (Joshua Oreman)
259- use single-threaded make_afioballs_and_images() if FreeBSD
260- fixed mondoarchive -Vi multi-CD verify bug (Tom Mortell)
261- superior get_phys_size_of_drive() (Joshua Oreman)
262- fixed RAID-related bug in where_is_root_mounted()
263- ISO tweaks
264- fixed silly bug in load_filelist() which stopped
265 funny German filenames from being handled properly
266- fixed various calls to popup_and_get_string()
267- fixed spec file
268- reject -E /
269- added partimagehack to the mix
270
271* Tue May 20 2003 Anonymous <root@rohan> 1.73
272- mark devices as bootable _after_ unmounting them
273- resolve boot device (-f) if softlink
274- post_param_configuration() --- store iso-dev and isodir
275- added post-nuke-sample.tgz to package
276- Nuke Mode now checks mountlist against hardware; offer user
277 opportunity to edit mountlist if insane; if user declines, abort
278- added lots of assert()'s and other checks
279- ran code thru Valgrind to catch & fix some memory leaks
280- made mondo-restore.c smaller by moving some subroutines to
281 common/libmondo-raid.c and mondorestore/mondo-rstr-compare.c
282- added '-Q' to let user test mondoarchive's ability to find
283 their boot loader and type
284- improved which_boot_loader()
285- when burning or comparing to a CD, defeat autorun if it is
286 running, to avoid confusing mondoarchive and the user
287- if original backup media no longer available at boot-time
288 then offer user chance to choose another media source
289- when booting, type 'nuke noresize' to nuke w/o resizing
290 mountlist to fill your drives
291- add 'textonly' when booting, to avoid using Newt gui
292- run nice(20) to prioritize mondoarchive at start
293- don't pause and wait for next blank CD at backup-time
294 unless necessary (e.g. previous CD has not been removed)
295- get_phys_size_of_drive() --- better support of older drives
296- don't eject if "donteject" is in kernel's command line
297- cleaned up segfault-handling
298- added Conor's strip_path() to improve file list display
299- added Herman Kuster's multi-level bkp patch
300- better boot-time screen/message
301- added Joshua Oreman's FreeBSD patches x3
302- fixed interactive/textonly support
303- fixed support for subdir-within-NFS-mount
304- fixed "Can't backup if ramdisk not mounted" bug
305- try to work around eccentricities of multi-CD drive PCs
306- misc clean-ups (Steve Hindle)
307
308* Tue Apr 08 2003 Hugo Rabson <hugorabson@msn.com> 1.72
309- LVM/RAID bugs fixed (Brian Borgeson)
310- major clean-up of code (Stan Benoit)
311- make-me-bootable fix (Juraj Ziegler)
312- fixed problem w/ multi-ISO verify cycle (Tom Mortell)
313- removed duplicate entry from makefile
314- if root is /dev/root then assume not a ramdisk
315- reject relative paths if -d flag (Alessandro Polverini)
316- fixed potentially infinite loop in log_to_screen (Tom Mortell)
317- add '/' to custom filelist as workaround for obscure bug
318- ask user speed of CDRW if writing to CD
319- find_cdrom_device() --- if nonexistent/not found then
320 make sure to return '' as dev str and 1 as res
321- tweaked restore scripts tgz
322- cleaned up find_cdrom_device()
323- if user creates /usr/share/mondo/payload.tgz then untar
324 payload to CD at backup-time
325- fixed insist_on_this_cd_number()
326- fixed am_i_in_disaster_recovery_mode()
327- misc clean-up (Tom Mortell)
328- made code more legible
329- fixed post-nuke support
330- added -e support
331- fixed nfs support
332- fixed iso support
333- at restore-time, only sort mountlist internally,
334 in mount_all_devices() and unmount_all_devices()
335- fixed cosmetic bug in label-partitions-as-necessary
336- updated documentation
337- fixed fstab-hacking scripts
338
339* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 1.71
340- log newt, slang, ncurses info
341- updated man page
342- handle %% chars in issue.net properly (Heiko Schlittermann)
343- fixed serious NFS restore bug
344- cleaned up spec file; it should cause fewer problems now (Jesse Keating)
345- changed various strcpy() calls to strncpy() calls
346- added mondo-makefilelist to makefile (Mikael Hultgren)
347- mount_cdrom() better at handling multiple CD drives
348- exclude /media/cdrom,cdrecorder,floppy
349- sensibly_set_tmpdir_and_scratchdir() --- exclude smb and smbfs
350- better logging by eval_call_to_make_ISO()
351- accept -J <fname> to let user provide their own fs catalog
352 instead of -I <paths> to backup
353- if dir excluded with -E or included with -I and dir is actually
354 a softlink then exclude/include the dir pointed to, as well
355- better location for manpage
356- adjusted block size of tarball at start of tape, to help
357 users w/ broken tape driver firmware
358- sort -u fstab after modifying it
359- if backup type is nfs then don't estimate noof media
360- fixed Makefile (Mikael Hultgren)
361- updated manpage
362
363* Mon Dec 07 2002 Hugo Rabson <hugo@firstlinux.net> 1.70
364- new devel branch opened
365
366* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 1.52
367- fixed bug in multithreading
368- use new grub-MR instead of grub-install
369- wipe only the partition table (not the MBR) when partitioning drives
370- ignore lilo.conf.anaconda when looking for lilo.conf file
371- accepts '-l RAW' to backup/restore original boot sector instead
372 of running grub or lilo to init it after restoring
373- fixed&updated stabgrub-me script; software RAID + GRUB work now
374- mount/unmount /boot partition for Gentoo 1.2 users
375- re-enabled extra tape checksums
376- disabled spurious warnings
377- unmount/remount supermounts at start/end of live restore, if nec.
378- cleaned up mondo's tape block handling (now, TAPE_BLOCK_SIZE=128K
379 and I've added INTERNAL_TAPE_BLK_SIZE=32K variable for buffering)
380- added Makefile
381- added -l RAW, to backup and restore original MBR
382- cleaned up iso_mode() and nfs restoring
383- create /mnt/RESTORING/mnt/.boot.d for Gentoo users
384- made mondorestore CD bootable for ArkLinux users
385- if user runs as 'su' not 'su -' then work around
386
387* Sun Nov 17 2002 Hugo Rabson <hugo@firstlinux.net> 1.51
388- pop-up list of changed files, at end of verification phase
389- better handling of changed.files list at restore-time
390- lots of CD-related fixes
391- added '-N' flag --- to let user exclude all NFS-related mounts&devices
392- better handling of 'kill'
393- restructuring of code to ease integration of mondo w/XMondo
394- fixed obscure bug in find_and_mount_actual_cd()
395- if / or /root has <50MB free then abort & complain
396- fixed install.sh
397- fixed .spec file
398- updated documentation
399- commented code
400- updated man page
401- added -v / --version flag
402- replace convoluted grep with wc (KP)
403- fixed bug affecting restoration of bigfiles from CD's created w/0 compression
404- fixed BurnProof-related bug
405- better at figuring out which is the best partition for temp/scratchdir
406- added do-not-compress-these (text file) to RPM
407- do not compress files of types listed in do-not-compress-these
408- dropped -U from call to afio - saves 20-30% runtime (Cosgrove)
409- added Cosgrove's do-not-compress-these list
410- included various patches from KP
411- chmod tmpdir, scratchdir to 700 before using
412- restore from specified backup device, even if its own cfg file disagrees
413- fixed multi-tape bug
414- fixed "Can't find first ISO when verifying nonbootable ISO" bug
415- multithreaded make_afioballs_and_images()
416- tmpdir and scratchdir are set sensibly whether mondoarchive is called with
417 command-line parameters or not
418- fixed bug in strip_spaces() which stopped it from handling
419 small strings correctly - affected mountlist editor
420- create a repaired copy of grub-install which is RAID-friendly;
421 use it when initializing boot sector with run_grub()
422- fixed bug in mondo-makefilelist
423
424* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 1.50
425- if restoring, don't try to find SCSI node of CD-ROM drive; find /dev entry
426- during selective restore, skip filesets which don't contain relevant archives
427- set /dev/null's perms to 777, just in case devfs-enabled kernel mangles it
428- remove /var/run/*.pid after restoring
429- move spurious lockfiles from /home/* to /home/*/.disabled
430- ask user to confirm the tape/CD device name
431- lots of multitape-related fixes
432- added code to autodetect the hardware of the user, if possible
433- if isodir does not exist then abort
434- more sanity-checking for -d flag
435- doubled 'biggiefile' threshold... to 32MB
436- exclude /root/images/mindi
437- fixed multi-imagedev bug (Emmanuel Druon)
438- unmount/remount /mnt/floppy before/after backing up, if Mandrake
439- restructured the source files
440- fixed serious bug in line 1546 - should have been !=, not ==; stopped
441 mondorestore from correctly restoring big files
442- added '#include <signal.h>' to my-stuff.h
443- exclude "incheckentry xwait()" from changed.files
444- fixed minor bug in find_cdrom_device()
445- fixed bug in friendly_sizestr...
446- insist on tape #1 when start verifying
447- added internal buffering, replacing the external 'buffer' exe
448- if differential backup then don't permit formatting or fdisking,
449 whether Interactive or Nuke mode
450- if mondorestore is run on live filesystem (or from ramdisk) without
451 parameters then mondorestore will ask which backup media (tape, CD, etc.)
452 was used; it will read the config file from the media and proceed from there
453- if tape streamer is softlink then resolve it first
454- incorporate post-nuke tarball
455- if user doesn't specify tape size, proceed anyway; behave intelligently
456 in the event of end-of-tape
457- prefix bkpinfo->restore_path to biggiefile fname before generating
458 checksum & comparing to archived biggiefile
459- if /etc/lilo.conf not found not /etc/lilo.conf.anaconda found
460 then create a softlink from the former to the latter, to work
461 around RH7.3's b0rken LILO support
462- LFS support (mharris, michele, hugo)
463- fixed verify bug --- CD#1 was being verified again & again & ...
464- differential mode fixed; supported again
465- ask user for boot loader + device if not detectible
466- list up to 512 files in file selection window at once (was 128)
467- better handling of bigfiles' checksums, perms and owns
468- delete final filelist if <=2 bytes long
469- if kernel not found and mondo in graphics mode then popup and ask
470 for kernel path+filename
471
472* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 1.45-1
473- 1.5x branch forked off from 1.4x branch
474
475
476
477
Note: See TracBrowser for help on using the repository browser.