source: MondoRescue/trunk/mindi/distributions/debian/rules@ 808

Last change on this file since 808 was 808, checked in by Bruno Cornec, 18 years ago

merge -r793:807 $SVN_M/branches/stable
src => common for the moment it's easier to manage merges

  • Property svn:executable set to *
File size: 1.1 KB
Line 
1#!/usr/bin/make -f
2# Sample debian/rules that uses debhelper.
3# GNU copyright 1997 to 1999 by Joey Hess.
4
5# Uncomment this to turn on verbose mode.
6#export DH_VERBOSE=1
7
8# Define package name for a one-stop change.
9PACKAGE_NAME = mindi
10
11configure:
12# Nothing to configure in this package.
13
14build:
15# Nothing to build in this package.
16
17clean:
18 dh_testdir
19 dh_testroot
20 dh_clean
21
22install:
23 dh_testdir
24 dh_testroot
25 dh_clean -k
26 dh_installdirs
27 # Build the installation tree:
28 ( export RPMBUILDMINDI=true && export PREFIX=$(CURDIR)/debian/$(PACKAGE_NAME)/usr && export CONFDIR=$(CURDIR)/debian/$(PACKAGE_NAME)/etc && ./install.sh )
29
30# Build architecture-independent files here.
31binary-indep: install
32# We have nothing to do by default.
33
34# Build architecture-dependent files here.
35binary-arch: install
36 dh_testdir
37 dh_testroot
38 dh_installchangelogs ChangeLog
39 dh_installdocs
40 dh_installexamples
41 dh_link
42 dh_strip
43 dh_compress
44 dh_fixperms
45 dh_installdeb
46 dh_gencontrol
47 dh_md5sums
48 dh_builddeb
49
50binary: binary-indep binary-arch
51.PHONY: build clean binary-indep binary-arch binary install configure
Note: See TracBrowser for help on using the repository browser.