Last change
on this file since 938 was 936, checked in by Bruno Cornec, 19 years ago |
Try to fix issues on x86_64 for rpm based distro. Still need work for debian and gentoo
|
File size:
1.2 KB
|
Line | |
---|
1 | # Copyright 1999-2004 Gentoo Foundation
|
---|
2 | # Distributed under the terms of the GNU General Public License v2
|
---|
3 | # $Header: $
|
---|
4 |
|
---|
5 | # $Id$
|
---|
6 |
|
---|
7 | DESCRIPTION="A program that creates emergency boot disks/CDs using your kernel, tools and modules."
|
---|
8 | HOMEPAGE="http://www.mondorescue.org"
|
---|
9 | SRC_URI="ftp://ftp.mondorescue.org/src/${P}.tar.gz"
|
---|
10 |
|
---|
11 | LICENSE="GPL-2"
|
---|
12 | SLOT="0"
|
---|
13 | KEYWORDS="~x86 -*"
|
---|
14 | IUSE=""
|
---|
15 |
|
---|
16 | DEPEND="virtual/libc"
|
---|
17 | RDEPEND=">=app-arch/bzip2-0.9
|
---|
18 | sys-libs/ncurses
|
---|
19 | sys-devel/binutils
|
---|
20 | sys-fs/dosfstools
|
---|
21 | sys-apps/gawk"
|
---|
22 |
|
---|
23 | src_unpack() {
|
---|
24 | unpack ${A} || die "Failed to unpack ${A}"
|
---|
25 | }
|
---|
26 |
|
---|
27 | src_install() {
|
---|
28 | export HEAD="${D}"
|
---|
29 | export PREFIX="/usr"
|
---|
30 | export CONFDIR="/etc"
|
---|
31 | export MANDIR="${PREFIX}/share/man"
|
---|
32 | export DOCDIR="${PREFIX}/share/doc"
|
---|
33 | export LIBDIR="${PREFIX}/lib"
|
---|
34 | export DONT_RELINK=1
|
---|
35 | export RPMBUILDMINDI="true"
|
---|
36 | "${WORKDIR}"/"${P}"/install.sh
|
---|
37 | }
|
---|
38 |
|
---|
39 | pkg_postinst() {
|
---|
40 | einfo "${P} was successfully installed."
|
---|
41 | einfo "Please read the associated docs for help."
|
---|
42 | einfo "Or visit the website @ ${HOMEPAGE}"
|
---|
43 | echo
|
---|
44 | ewarn "This package is still in unstable."
|
---|
45 | ewarn "Please report bugs to http://bugs.gentoo.org/"
|
---|
46 | ewarn "However, please do an advanced query to search for bugs"
|
---|
47 | ewarn "before reporting. This will keep down on duplicates."
|
---|
48 | echo
|
---|
49 | }
|
---|
Note:
See
TracBrowser
for help on using the repository browser.