source: MondoRescue/branches/stable/mindi-kernel/distributions/rpm/mindi.spec@ 553

Last change on this file since 553 was 551, checked in by bcornec, 18 years ago

mondo-doc & mindi-kernel structure updated for build management

  • Property svn:keywords set to Id
File size: 1.6 KB
RevLine 
[35]1#
2# $Id: mindi.spec 551 2006-05-15 23:37:07Z bcornec $
3#
[313]4%define mrel RRR
[388]5
[551]6Summary: Mindi Kernel provides a safe kernel for mindi
[550]7Name: mindi
8Version: VVV
9Release: %mrel
[1]10License: GPL
[550]11Group: GRP
[542]12Url: http://www.mondorescue.org
[550]13Source: SSS
[542]14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
[550]15Requires: bzip2 >= 0.9, mkisofs, ncurses, binutils, gawk, dosfstools DDD
[20]16# Not on all systems
17#Conflicts: bonnie++
[1]18
19%description
20Mindi takes your kernel, modules, tools and libraries, and puts them on N
21bootable disks (or 1 bootable CD image). You may then boot from the disks/CD
22and do system maintenance - e.g. format partitions, backup/restore data,
23verify packages, etc.
24
25%prep
[50]26%setup -n %name-%{version}
[1]27
28%build
29%ifarch ia64
[50]30%{__make} -f Makefile.parted2fdisk clean
31%{__make} -f Makefile.parted2fdisk
[1]32%endif
33
34%install
[542]35%{__rm} -rf $RPM_BUILD_ROOT
[50]36export DONT_RELINK=1
37
[235]38export PREFIX=${RPM_BUILD_ROOT}%{_exec_prefix}
39export CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}
[179]40export RPMBUILDMINDI="true"
[50]41
[179]42./install.sh
[50]43
[1]44%clean
45%{__rm} -rf $RPM_BUILD_ROOT
46
47%post
[179]48if [ -f /usr/local/sbin/mindi ]; then
49 echo "WARNING: /usr/local/sbin/mindi exists. You should probably remove your manual mindi installation !"
50fi
51
[1]52%files
[50]53%defattr(644,root,root,755)
[542]54%config(noreplace) %{_sysconfdir}/mindi
55%config(noreplace) %{_sysconfdir}/mindi/deplist.txt
[315]56%doc ChangeLog INSTALL COPYING README TODO README.ia64 README.pxe README.busybox svn.log
[423]57%{_mandir}/man8/*
[200]58%{_libdir}/mindi
[189]59%attr(755,root,root) %{_sbindir}/*
[423]60%attr(755,root,root) %{_libdir}/mindi/aux-tools/sbin/*
61%attr(755,root,root) %{_libdir}/mindi/rootfs/bin/*
62%attr(755,root,root) %{_libdir}/mindi/rootfs/sbin/*
[1]63
64%changelog
Note: See TracBrowser for help on using the repository browser.