source: MondoRescue/branches/2.2.1/mindi-busybox/distributions/gentoo/mindi-busybox.ebuild@ 1029

Last change on this file since 1029 was 1029, checked in by Bruno Cornec, 17 years ago

Attempt to fix gentoo mindi-busybox ebuild

File size: 1.2 KB
Line 
1# Copyright 1999-2006 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Id$
4
5inherit eutils flag-o-matic
6
7DESCRIPTION="The rescue part of a program that creates emergency boot disks/CDs using your kernel, tools and modules."
8HOMEPAGE="http://www.mondorescue.org"
9SRC_URI="ftp://ftp.mondorescue.org/src/${P}.tar.gz"
10LICENSE="GPL-2"
11SLOT="0"
12KEYWORDS="~x86 ia64 -*"
13DEPEND="virtual/libc"
14RDEPEND=">=app-arch/bzip2-0.9
15 sys-devel/binutils"
16
17src_unpack() {
18 unpack ${A} || die "Failed to unpack ${A}"
19 cd "${S}"
20 make oldconfig > /dev/null
21}
22
23src_compile() {
24 # work around broken ass powerpc compilers
25 emake EXTRA_CFLAGS="${CFLAGS}" busybox || die "build failed"
26}
27
28src_install() {
29 # bundle up the symlink files for use later
30 emake PREFIX="/usr/share/mindi/rootfs/bin" install || die
31 rm _install/bin/busybox
32 tar cf busybox-links.tar -C _install . || die
33 insinto /usr/share/mindi
34 doins busybox-links.tar || die
35}
36
37pkg_preinst() {
38 mv "${D}"/usr/share/mindi/busybox-links.tar "${T}"/ || die
39}
40
41pkg_postinst() {
42 cd "${T}" || die
43 mkdir _install
44 tar xf busybox-links.tar -C _install || die
45 cp -vpPR _install/* /usr/share/mindi/rootfs/bin || die "copying links for ${x} failed"
46
47 echo
48}
Note: See TracBrowser for help on using the repository browser.