Last change
on this file since 1664 was 576, checked in by bcornec, 19 years ago |
2.08 synced with stable as of r575
VERSION files updated
|
File size:
1.7 KB
|
Line | |
---|
1 | # Copyright 1999-2004 Gentoo Foundation
|
---|
2 | # Distributed under the terms of the GNU General Public License v2
|
---|
3 | # $Header: $
|
---|
4 |
|
---|
5 | # $Id$
|
---|
6 |
|
---|
7 | inherit libtool
|
---|
8 |
|
---|
9 | DESCRIPTION="The premier GPL disaster recovery solution."
|
---|
10 | HOMEPAGE="http://www.mondorescue.org"
|
---|
11 | SRC_URI="ftp://ftp.mondorecue.org/src/${PN/-rescue/}-${PV}-${PR}.tgz"
|
---|
12 |
|
---|
13 | LICENSE="GPL-2"
|
---|
14 | SLOT="0"
|
---|
15 | KEYWORDS="-* ~x86"
|
---|
16 | IUSE=""
|
---|
17 |
|
---|
18 | DEPEND="virtual/libc
|
---|
19 | >=sys-libs/slang-1.4.1
|
---|
20 | >=dev-libs/newt-0.50"
|
---|
21 | RDEPEND="app-arch/afio
|
---|
22 | sys-block/buffer
|
---|
23 | sys-devel/binutils
|
---|
24 | >=app-arch/bzip2-0.9
|
---|
25 | app-cdr/cdrtools
|
---|
26 | >=sys-apps/mindi-1.0.7
|
---|
27 | >=dev-libs/newt-0.50
|
---|
28 | >=sys-libs/slang-1.4.1
|
---|
29 | >=sys-boot/syslinux-1.52"
|
---|
30 |
|
---|
31 | S=${WORKDIR}/${PN/-rescue/}-${PV}-${PR}
|
---|
32 |
|
---|
33 | src_unpack() {
|
---|
34 | unpack ${A}
|
---|
35 | cd ${S}
|
---|
36 | chmod 750 configure
|
---|
37 | }
|
---|
38 |
|
---|
39 | src_compile() {
|
---|
40 | elibtoolize
|
---|
41 | econf || die "Configuration failed"
|
---|
42 | emake VERSION=VVV || die "Make failed"
|
---|
43 | }
|
---|
44 |
|
---|
45 | src_install() {
|
---|
46 | make install DESTDIR=${D} || die "make install failed"
|
---|
47 | #einstall || die "Install failed"
|
---|
48 | exeinto /usr/share/mondo
|
---|
49 | doexe mondo/autorun
|
---|
50 | }
|
---|
51 |
|
---|
52 | pkg_postinst() {
|
---|
53 | einfo "${P} was successfully installed."
|
---|
54 | einfo "Please read the associated docs for help."
|
---|
55 | einfo "Or visit the website @ ${HOMEPAGE}"
|
---|
56 | echo
|
---|
57 | ewarn "This package is a new version after a long gap."
|
---|
58 | ewarn "Please report bugs to http://bugs.gentoo.org/"
|
---|
59 | ewarn "However, please do an advanced query to search for bugs"
|
---|
60 | ewarn "before reporting. This will keep down on duplicates."
|
---|
61 | echo
|
---|
62 | einfo "Prior to running mondo, ensure /boot is mounted."
|
---|
63 | ewarn "Grub users need to have a symlink like this:"
|
---|
64 | ewarn "ln -s /boot/grub/menu.lst /etc/grub.conf"
|
---|
65 | einfo "Unless you want to have mondo backup your distfiles,"
|
---|
66 | einfo "append \"-E ${DISTDIR}\" to your mondoarchive command."
|
---|
67 | echo
|
---|
68 | }
|
---|
Note:
See
TracBrowser
for help on using the repository browser.