Ignore:
Timestamp:
Nov 26, 2006, 11:44:09 PM (17 years ago)
Author:
Bruno Cornec
Message:

Still mindi-busybox debian

File:
1 edited

Legend:

Unmodified
Added
Removed
  • branches/2.2.0/mindi-busybox/distributions/debian/rules

    r986 r987  
    99PACKAGE_NAME = mindi-busybox
    1010
    11 # These are used for cross-compiling and for saving the configure script
    12 # from having to guess our platform (since we know it already)
    13 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
    14 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
     11# Don't set any compiler flags - busybox does that just fine
    1512
    16 CFLAGS = -Wall
    17 
    18 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
    19     CFLAGS += -O0
    20 else
    21     CFLAGS += -O2
    22 endif
    23 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
    24     INSTALL_PROGRAM += -s
    25 endif
     13configure: configure-stamp
     14configure-stamp:
     15    dh_testdir
     16touch configure-stamp
    2617
    2718# Build both architecture dependent and independent
    28 build: build-arch build-indep
     19build: build-stamp
    2920
    30 # Build architecture dependent
    31 build-arch: build-arch-stamp
    32 
    33 build-arch-stamp:  Makefile
     21build-stamp: configure-stamp
    3422    dh_testdir
    3523
    3624    # Compile the package.
     25    mv .config .config.sav
     26    $(MAKE) distclean
     27    mv .config.sav .config
    3728    $(MAKE) oldconfig
    3829    $(MAKE) busybox
     
    4031    touch build-stamp
    4132
    42 # Build architecture independent
    43 build-indep: build-indep-stamp
    44 
    45 build-indep-stamp:  Makefile
    46     # Nothing to do, the only indep item is the manual which is available as html in original source
    47     touch build-indep-stamp
    48 
    4933clean:
    5034    dh_testdir
    5135    dh_testroot
    52     rm -f build-arch-stamp build-indep-stamp
     36    rm -f build-stamp configure-stamp
    5337    # Clean temporary document directory
    5438    rm -rf debian/doc-temp
    5539    # Clean up.
     40    -mv .config .config.sav
    5641    -$(MAKE) distclean
    57     rm -f config.log
    58 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
    59     cp -f /usr/share/misc/config.sub config.sub
    60 endif
    61 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
    62     cp -f /usr/share/misc/config.guess config.guess
    63 endif
     42    -mv .config.sav .config
     43    -rm -f busybox
    6444
    6545    dh_clean
    6646
    6747# Install architecture dependent and independent
    68 install: install-arch install-indep
    69 
    70 # Install architecture dependent
    71 install-arch: build-arch
     48install: build
    7249    dh_testdir
    7350    dh_testroot
    74     dh_clean -k -s
    75     dh_installdirs -s
     51    dh_clean -k
     52    dh_installdirs
    7653
    7754    # Install the package files into build directory:
     
    8057    # - copy doc
    8158    mkdir -p debian/doc-temp
    82     cp -a ChangeLog INSTALL LICENSE AUTHORS README TODO changelog svn.log debian/doc-temp/html
     59    cp -a ChangeLog INSTALL LICENSE AUTHORS README TODO changelog svn.log debian/doc-temp
    8360
    8461    dh_install -s
    8562
    86 # Install architecture independent
    87 install-indep: build-indep
     63# Build architecture independant packages using the common target.
     64binary-indep: build install
     65    # None
     66
     67# Build architecture dependant packages using the common target.
     68binary-arch: build install
    8869    dh_testdir
    8970    dh_testroot
    90     dh_clean -k -i
    91     dh_installdirs -i
    92     dh_install -i
    93 
    94 # Must not depend on anything. This is to be called by
    95 # binary-arch/binary-indep
    96 # in another 'make' thread.
    97 binary-common:
    98     dh_testdir
    99     dh_testroot
    100     dh_installchangelogs ChangeLog
     71    dh_installchangelogs Changelog
    10172    dh_installdocs
    102     dh_installman
    103     dh_link
    10473    dh_strip
    10574    dh_compress
    10675    dh_fixperms
    10776    dh_installdeb
    108     dh_shlibdeps
    10977    dh_gencontrol
    11078    dh_md5sums
    11179    dh_builddeb
    11280
    113 # Build architecture independant packages using the common target.
    114 binary-indep: build-indep install-indep
    115     $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
    116 
    117 # Build architecture dependant packages using the common target.
    118 binary-arch: build-arch install-arch
    119     $(MAKE) -f debian/rules DH_OPTIONS=-a binary-common
    120 
    121 # Build architecture depdendent and independent packages
    12281binary: binary-arch binary-indep
    123 .PHONY: clean binary
     82.PHONY: build clean binary-indep binary-arch binary install configure
Note: See TracChangeset for help on using the changeset viewer.