Ignore:
Timestamp:
Nov 13, 2006, 10:16:19 AM (17 years ago)
Author:
Bruno Cornec
Message:

ebuild for mindi-busybox

File:
1 edited

Legend:

Unmodified
Added
Removed
  • branches/stable/mindi-busybox/distributions/gentoo/mindi-busybox.ebuild

    r823 r927  
    1 # Copyright 1999-2004 Gentoo Foundation
     1# Copyright 1999-2006 Gentoo Foundation
    22# Distributed under the terms of the GNU General Public License v2
    3 # $Header: $
    4 
    53# $Id$
    64
    7 DESCRIPTION="A program that creates emergency boot disks/CDs using your kernel, tools and modules."
     5inherit eutils flag-o-matic
     6
     7DESCRIPTION="The rescue part of a program that creates emergency boot disks/CDs using your kernel, tools and modules."
    88HOMEPAGE="http://www.mondorescue.org"
    99SRC_URI="ftp://ftp.mondorescue.org/src/${P}.tar.gz"
    10 
    1110LICENSE="GPL-2"
    1211SLOT="0"
    13 KEYWORDS="~x86 -*"
    14 IUSE=""
    15 
     12KEYWORDS="~x86 ia64 -*"
    1613DEPEND="virtual/libc"
    1714RDEPEND=">=app-arch/bzip2-0.9
     
    2017src_unpack() {
    2118    unpack ${A} || die "Failed to unpack ${A}"
     19    make oldconfig > /dev/null
     20}
     21
     22src_compile() {
     23    # work around broken ass powerpc compilers
     24    emake EXTRA_CFLAGS="${CFLAGS}" busybox || die "build failed"
    2225}
    2326
    2427src_install() {
    25     export PREFIX="${D}/usr"
    26     export RPMBUILDMINDI="true"
    27     "${WORKDIR}"/"${P}"/install.sh
     28    # bundle up the symlink files for use later
     29    emake PREFIX="/usr/share/mindi/rootfs/bin" install || die
     30    rm _install/bin/busybox
     31    tar cf busybox-links.tar -C _install . || die
     32    insinto /usr/share/mindi
     33    doins busybox-links.tar || die
     34}
     35
     36pkg_preinst() {
     37    mv "${D}"/usr/share/mindi/busybox-links.tar "${T}"/ || die
    2838}
    2939
    3040pkg_postinst() {
    31     einfo "${P} was successfully installed."
    32     einfo "Please read the associated docs for help."
    33     einfo "Or visit the website @ ${HOMEPAGE}"
    34     echo
    35     ewarn "This package is still in unstable."
    36     ewarn "Please report bugs to http://bugs.gentoo.org/"
    37     ewarn "However, please do an advanced query to search for bugs"
    38     ewarn "before reporting. This will keep down on duplicates."
     41    cd "${T}" || die
     42    mkdir _install
     43    tar xf busybox-links.tar -C _install || die
     44    cp -vpPR _install/* /usr/share/mindi/rootfs/bin || die "copying links for ${x} failed"
     45
    3946    echo
    4047}
Note: See TracChangeset for help on using the changeset viewer.