Changeset 1937


Ignore:
Timestamp:
May 15, 2008, 1:58:56 PM (11 years ago)
Author:
bruno
Message:

Attempt to fix problem with SuSE 10.2 boot loader not reinstalled - may also fix other SLES issues reported with the same problem - by mounting /proc and /sys in the chroot during mount_all_devices

File:
1 edited

Legend:

Unmodified
Added
Removed
  • branches/2.2.6/mondo/src/mondorestore/mondo-rstr-tools.c

    r1934 r1937  
    563563    sprintf(tmp, "Mounting device %s   ", device);
    564564    log_msg(1, tmp);
    565     if (writeable) {
    566         strcpy(additional_parameters, "-o rw");
    567     } else {
    568         strcpy(additional_parameters, "-o ro");
    569     }
    570     if (find_home_of_exe("setfattr")) {
    571         strcat(additional_parameters, ",user_xattr");
    572     }
    573     if (find_home_of_exe("setfacl")) {
    574         strcat(additional_parameters, ",acl");
     565    /* Deal with additional params only if not /proc or /sys */
     566    if (strcmp(format, "proc") && strcmp(format, "sys")) {
     567        if (writeable) {
     568            strcpy(additional_parameters, "-o rw");
     569        } else {
     570            strcpy(additional_parameters, "-o ro");
     571        }
     572        if (find_home_of_exe("setfattr")) {
     573            strcat(additional_parameters, ",user_xattr");
     574        }
     575        if (find_home_of_exe("setfacl")) {
     576            strcat(additional_parameters, ",acl");
     577        }
    575578    }
    576579
     
    727730        mvaddstr_and_log_it(g_currentY++, 74, "Done.");
    728731    }
     732    /* Also mounting under MNT_RESTORING  special FS */
     733    (void)mount_device("/proc","/proc","proc",TRUE);
     734    (void)mount_device("/sys","/sys","sysfs",TRUE);
    729735    run_program_and_log_output("df -m", 3);
    730736    paranoid_free(mountlist);
Note: See TracChangeset for help on using the changeset viewer.