source: MondoRescue/trunk/mondo/mondo.spec@ 56

Last change on this file since 56 was 55, checked in by bcornec, 19 years ago

Merge patches from branch 2.04_berlios (r51-r54)

  • Property svn:keywords set to Id
File size: 19.0 KB
Line 
1#
2# $Id: mondo.spec 55 2005-10-08 00:11:26Z bcornec $
3#
4%define is_mandriva %(test -e /etc/mandriva-release && echo 1 || echo 0)
5%define is_mandrake %(test -e /etc/mandrake-release && echo 1 || echo 0)
6%define is_suse %(test -e /etc/SuSE-release && echo 1 || echo 0)
7%define is_fedora %(test -e /etc/fedora-release && echo 1 || echo 0)
8%define is_redhat %(test -e /etc/redhat-release && echo 1 || echo 0)
9
10%define name mondo
11%define version 2.04_berlios
12%define mrel 1
13
14%if %is_redhat
15%define release %{mrel}
16%define src %{name}-%{version}.tgz
17Group: Applications/Archiving
18Autoreq: 0
19%endif
20
21%if %is_mandrake
22%define release %{mrel}mdk
23%define src %{name}-%{version}.tar.bz2
24Group: Archiving/Backup
25Autoreqprov: no
26%endif
27
28Summary: A program which a Linux user can utilize to create a rescue/restore CD/tape
29Summary(fr): Un programme pour les utilisateurs de Linux pour cr�r un CD/tape de sauvegarde/restauration
30Summary(it): Un programma per utenti Linux per creare un CD/tape di rescue
31Summary(sp): Un programa para los usuarios de Linux por crear una CD/cinta de restoracion/rescate
32<<<<<<< .working
33Name: mondo
34Version: 2.05_berlios
35Release: 1
36=======
37
38Name: %{name}
39Version: %{version}
40Release: %{release}
41>>>>>>> .merge-right.r54
42License: GPL
43Url: http://mondorescue.berlios.de
44Source: %{src}
45BuildRoot: %{_tmppath}/%{name}-%{version}
46BuildRequires: newt-devel >= 0.50, slang-devel >= 1.4.1, gcc
47%ifarch ia64
48Requires: mindi >= 1.04_berlios, bzip2 >= 0.9, afio, mkisofs, binutils, elilo, newt >= 0.50, slang >= 1.4.1, buffer, parted
49%{!?_without_xmondo:BuildRequires: gcc-c++, XFree86-devel, qt-devel, kdelibs-devel, libpng-devel}
50%else
51Requires: mindi >= 1.04_berlios, bzip2 >= 0.9, afio, mkisofs, binutils, syslinux >= 1.52, newt >= 0.50, slang >= 1.4.1, cdrecord, buffer
52%{!?_without_xmondo:BuildRequires: gcc-c++, XFree86-devel, qt-devel, kdelibs-devel, arts-devel, libart_lgpl-devel, libpng-devel}
53%endif
54
55#%package xmondo
56#Summary: A QT based graphical front end for %{name}
57#Group: Applications/Archiving
58#Requires: %{name} = %{version}-${release}, qt, kdelibs
59#
60#%package %{name}-devel
61#Summary: Header files for building against Mondo
62#%if %is_mandrake
63#Group: Development/Libraries
64#%endif
65#if %is_redhat
66#Group: Development/Other
67#%endif
68#Provides: libmondo-devel mondo-devel
69#Obsoletes: libmondo-devel
70#
71#%description -n %{name}-devel
72#Mondo libraries and includes
73
74%description
75Mondo is a GPL disaster recovery solution to create backup media (CD, DVD, tape, network images) that can be used to redeploy the damaged system, as well as deploy similar or less similar systems.
76
77%description -l fr
78Objectif
79""""""""
80Mondo est une solution GPL de sauvegarde en cas de désastre pour créer des médias (CD, DVD, bande, images réseau) qui peuvent être utilisés pour redéployer le système endomangé, aussi bien que des systèmes similaires, ou moins similaires.
81
82%description -l it
83Scopo
84"""""
85Mondo e' un programma che permette a qualsiasi utente Linux
86di creare un cd di rescue/restore (o piu' cd qualora l'installazione
87dovesse occupare piu' di 2Gb circa). Funziona con gli azionamenti di
88nastro, ed il NFS, anche.
89
90%description -l sp
91Objectivo
92"""""""""
93Mondo es un programa que permite cualquier usuario de Linux a crear una CD
94de restoracion/rescate (o CDs, si su instalacion es >2GO aprox.). Funciona
95con cintas y NFS, tambien.
96
97#%description xmondo
98#Xmondo is a QT based graphical frontend to mondoarchive. It can help you
99#set up a backup by following onscreen prompts.
100
101%prep
102%setup -q -n %name-%{version}
103
104%build
105%configure %{!?_without_xmondo:--with-x11}
106%{__make} VERSION=%{version} CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_REENTRANT"
107
108%install
109%{__rm} -rf $RPM_BUILD_ROOT
110%makeinstall
111
112%post
113/sbin/ldconfig
114
115%postun
116/sbin/ldconfig
117
118%clean
119%{__rm} -rf $RPM_BUILD_ROOT
120
121%files
122%defattr(644,root,root,755)
123%doc ChangeLog mondo/docs/en/1.6x-howto/*
124%doc INSTALL COPYING README TODO AUTHORS NEWS
125
126%attr(755,root,root) %{_sbindir}/*
127%attr(755,root,root) %{_datadir}/%{name}/restore-scripts/%{name}
128%{_datadir}/%{name}
129%{_mandir}/*
130%{_libdir}/*
131
132%{!?_without_xmondo:%files xmondo}
133%{!?_without_xmondo:%{_sbindir}/xmondo}
134%{!?_without_xmondo:%{_libdir}/libXmondo-%{libversion}.so}
135%{!?_without_xmondo:%{_libdir}/libXmondo.so}
136%{!?_without_xmondo:%{_datadir}/mondo/mondo.png}
137
138%changelog
139* Tue Oct 06 2005 Bruno Cornec <bcornec@users.berlios.de> 2.05_berlios
140- Memory management revision
141
142* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 2.04_berlios
143- Merge of patches mentionned on mondo ML + ia64 updates
144- Option -p added
145
146* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 2.04_cvs_20050503
147- made mondo more clever about finding its home. Avoids mondo considering
148 directories like '/usr/share/doc/momdo' as its home.
149
150* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 2.03
151- test sanity of user-specified tempdir
152- better SLES8 support
153
154* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 2.02
155- instead of using 'dd' to erase partition table, delete existing
156 partitions w/ the same call to fdisk that is used to create the
157 new partitions; this should avoids locking up the partition table
158- set bootable partition in the above same call to fdisk, for
159 the same reason (avoids locking up the partition table)
160- better software RAID support
161- mount ext3 partitions as ext2 when restoring - better for Debian
162- better star, ACL support
163- added ACL, xattr support for afio users
164
165* Fri Jun 26 2004 Hugo Rabson <hugorabson@msn.com> 2.01
166- fixed cvs for SuSE systems
167- fixed NTFS backup/restore bug relating to partimagehack
168 log file overflow and NTFS v non-NTFS differentiation
169- more reliable extraction of config info from CDs, floppies
170- better support of ISO dirs at restore-time (Conor Daly)
171- fixed spec file for SuSE users
172- added ldconfig to install section
173
174* Fri Jun 19 2004 Hugo Rabson <hugorabson@msn.com> 2.00
175- first 2.0 release
176- updated grub-install.patched to support SuSE and Red Hat
177- call 'mt' to set block size to 32K before opening in/out tape
178- updated mondo-prep.c to create each disk's partitions all at once
179 (one call per drive) instead of one call to fdisk per partition
180- when extracting cfg file and mountlist from all.tar.gz (tape copy),
181 use block size of INTERNAL_TAPE_BLK_SIZE, not TAPE_BLOCK_SIZE
182- added star and rudimentary SELinux support
183- fixed lots of bugs
184- all logging now goes to /var/log/mondo-archive.log, with symlink
185 to /tmp/mondo-restore.log for restore-time log-tracking
186- added grub-install.patched
187- removed embleer & other binaries
188- added '-b' to specify block size
189- added '-R' for star support
190
191* Thu Mar 25 2004 Bruno Cornec <Bruno.Cornec@hp.com> 1.7_cvs-20040325
192- ia64 fixes
193
194* Fri Nov 07 2003 Joshua Oreman <oremanj@get-linux.org> 1.7_cvs-20031107
195- fixed symbolic links for libraries
196- added support for boot/root multi floppies
197
198- added kdelibs as xmondo dependency
199- added xmondo pixmap installation
200- better find_cdrom_device(), to cope w/ multiple CD writers
201- fixed -m and -Vc flags
202- fixed NTFS support!
203- bootable CD uses native, not El Torito, support now
204- removed mondo-makefilelist
205- added 2.6 kernel support
206- if 2.6 kernel, insist that the user specify CD device
207- drop Embleer; insist on ms-sys and parted if Windows partition
208
209* Wed Nov 05 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031105.1
210- added -devel package
211
212* Tue Nov 04 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031104.1
213- made xmondo a second package
214- added ability to specify --without xmondo at build time
215
216* Sun Nov 02 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031102.1
217- Clean up, added spanish translation
218- Set prefix to be /usr
219- added/fixed Requires
220- remove CVS directories prior to building
221
222* Thu Oct 23 2003 Hugo Rabson <hugorabson@msn.com> 1.75_cvs_20031023
223- nothing yet
224
225* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 1.75
226- fixed chmod/chown bug (Jens Richter)
227- ask user to confirm NFS mountpoint in Interactive Mode
228- rewritten format_everything() to make sure LVMs, RAIDs and
229 regular partitions are prepped in the correct order
230- better magicdev support
231- rewritten external binary caller subroutine
232- DVD support added
233- better backup-time control gui; offer to exclude nfs if appl.
234- fixed multi-tape support
235- re-implemented -D and -J
236- fixed bug in extract_config_file_from_ramdisk() which
237 affected tape+floppy users
238- updated is_incoming_block_valid() to make it
239 return end-of-tape if >300 flotsam blocks
240- unmount CD-ROM before burning (necessary for RH8/9)
241- fixed some stray assert()'s
242- fixed bug in grub-MR (Christian)
243- make user remove floppy/CD before restoring interactively from tape
244- fixed bug in am_I_in_disaster_recovery_mode()
245- added code to nuke_mode() to make sure NFS
246 (backup) share is mounted in Nuke Mode
247- improved tape device detection code
248- better GRUB support
249- better logging of changed bigfiles at compare-time
250- better NTFS support, thanks to partimagehack-static
251- better logging
252- rewrote tape-handling code, breaking compatibility w/ previous versions
253- fixed ISO/CD biggiefile verification bug in mondoarchive
254- fixed bug which stopped boot/compare-time changelist from popping up
255- replaced mondo-makefilelist with C code - faster, cleaner
256- tweaked GUI - better feedback
257
258* Wed May 28 2003 Anonymous <root@rohan> 1.74
259- misc fixes (Michael Hanscho's friend)
260- added rudimentary support for SME
261- added better label support
262- fixed biggietime atime/ctime restoration bug 73
263- fixed 'default boot loader' detection bug (Joshua Oreman)
264- use single-threaded make_afioballs_and_images() if FreeBSD
265- fixed mondoarchive -Vi multi-CD verify bug (Tom Mortell)
266- superior get_phys_size_of_drive() (Joshua Oreman)
267- fixed RAID-related bug in where_is_root_mounted()
268- ISO tweaks
269- fixed silly bug in load_filelist() which stopped
270 funny German filenames from being handled properly
271- fixed various calls to popup_and_get_string()
272- fixed spec file
273- reject -E /
274- added partimagehack to the mix
275
276* Tue May 20 2003 Anonymous <root@rohan> 1.73
277- mark devices as bootable _after_ unmounting them
278- resolve boot device (-f) if softlink
279- post_param_configuration() --- store iso-dev and isodir
280- added post-nuke-sample.tgz to package
281- Nuke Mode now checks mountlist against hardware; offer user
282 opportunity to edit mountlist if insane; if user declines, abort
283- added lots of assert()'s and other checks
284- ran code thru Valgrind to catch & fix some memory leaks
285- made mondo-restore.c smaller by moving some subroutines to
286 common/libmondo-raid.c and mondorestore/mondo-rstr-compare.c
287- added '-Q' to let user test mondoarchive's ability to find
288 their boot loader and type
289- improved which_boot_loader()
290- when burning or comparing to a CD, defeat autorun if it is
291 running, to avoid confusing mondoarchive and the user
292- if original backup media no longer available at boot-time
293 then offer user chance to choose another media source
294- when booting, type 'nuke noresize' to nuke w/o resizing
295 mountlist to fill your drives
296- add 'textonly' when booting, to avoid using Newt gui
297- run nice(20) to prioritize mondoarchive at start
298- don't pause and wait for next blank CD at backup-time
299 unless necessary (e.g. previous CD has not been removed)
300- get_phys_size_of_drive() --- better support of older drives
301- don't eject if "donteject" is in kernel's command line
302- cleaned up segfault-handling
303- added Conor's strip_path() to improve file list display
304- added Herman Kuster's multi-level bkp patch
305- better boot-time screen/message
306- added Joshua Oreman's FreeBSD patches x3
307- fixed interactive/textonly support
308- fixed support for subdir-within-NFS-mount
309- fixed "Can't backup if ramdisk not mounted" bug
310- try to work around eccentricities of multi-CD drive PCs
311- misc clean-ups (Steve Hindle)
312
313* Tue Apr 08 2003 Hugo Rabson <hugorabson@msn.com> 1.72
314- LVM/RAID bugs fixed (Brian Borgeson)
315- major clean-up of code (Stan Benoit)
316- make-me-bootable fix (Juraj Ziegler)
317- fixed problem w/ multi-ISO verify cycle (Tom Mortell)
318- removed duplicate entry from makefile
319- if root is /dev/root then assume not a ramdisk
320- reject relative paths if -d flag (Alessandro Polverini)
321- fixed potentially infinite loop in log_to_screen (Tom Mortell)
322- add '/' to custom filelist as workaround for obscure bug
323- ask user speed of CDRW if writing to CD
324- find_cdrom_device() --- if nonexistent/not found then
325 make sure to return '' as dev str and 1 as res
326- tweaked restore scripts tgz
327- cleaned up find_cdrom_device()
328- if user creates /usr/share/mondo/payload.tgz then untar
329 payload to CD at backup-time
330- fixed insist_on_this_cd_number()
331- fixed am_i_in_disaster_recovery_mode()
332- misc clean-up (Tom Mortell)
333- made code more legible
334- fixed post-nuke support
335- added -e support
336- fixed nfs support
337- fixed iso support
338- at restore-time, only sort mountlist internally,
339 in mount_all_devices() and unmount_all_devices()
340- fixed cosmetic bug in label-partitions-as-necessary
341- updated documentation
342- fixed fstab-hacking scripts
343
344* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 1.71
345- log newt, slang, ncurses info
346- updated man page
347- handle %% chars in issue.net properly (Heiko Schlittermann)
348- fixed serious NFS restore bug
349- cleaned up spec file; it should cause fewer problems now (Jesse Keating)
350- changed various strcpy() calls to strncpy() calls
351- added mondo-makefilelist to makefile (Mikael Hultgren)
352- mount_cdrom() better at handling multiple CD drives
353- exclude /media/cdrom,cdrecorder,floppy
354- sensibly_set_tmpdir_and_scratchdir() --- exclude smb and smbfs
355- better logging by eval_call_to_make_ISO()
356- accept -J <fname> to let user provide their own fs catalog
357 instead of -I <paths> to backup
358- if dir excluded with -E or included with -I and dir is actually
359 a softlink then exclude/include the dir pointed to, as well
360- better location for manpage
361- adjusted block size of tarball at start of tape, to help
362 users w/ broken tape driver firmware
363- sort -u fstab after modifying it
364- if backup type is nfs then don't estimate noof media
365- fixed Makefile (Mikael Hultgren)
366- updated manpage
367
368* Mon Dec 07 2002 Hugo Rabson <hugo@firstlinux.net> 1.70
369- new devel branch opened
370
371* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 1.52
372- fixed bug in multithreading
373- use new grub-MR instead of grub-install
374- wipe only the partition table (not the MBR) when partitioning drives
375- ignore lilo.conf.anaconda when looking for lilo.conf file
376- accepts '-l RAW' to backup/restore original boot sector instead
377 of running grub or lilo to init it after restoring
378- fixed&updated stabgrub-me script; software RAID + GRUB work now
379- mount/unmount /boot partition for Gentoo 1.2 users
380- re-enabled extra tape checksums
381- disabled spurious warnings
382- unmount/remount supermounts at start/end of live restore, if nec.
383- cleaned up mondo's tape block handling (now, TAPE_BLOCK_SIZE=128K
384 and I've added INTERNAL_TAPE_BLK_SIZE=32K variable for buffering)
385- added Makefile
386- added -l RAW, to backup and restore original MBR
387- cleaned up iso_mode() and nfs restoring
388- create /mnt/RESTORING/mnt/.boot.d for Gentoo users
389- made mondorestore CD bootable for ArkLinux users
390- if user runs as 'su' not 'su -' then work around
391
392* Sun Nov 17 2002 Hugo Rabson <hugo@firstlinux.net> 1.51
393- pop-up list of changed files, at end of verification phase
394- better handling of changed.files list at restore-time
395- lots of CD-related fixes
396- added '-N' flag --- to let user exclude all NFS-related mounts&devices
397- better handling of 'kill'
398- restructuring of code to ease integration of mondo w/XMondo
399- fixed obscure bug in find_and_mount_actual_cd()
400- if / or /root has <50MB free then abort & complain
401- fixed install.sh
402- fixed .spec file
403- updated documentation
404- commented code
405- updated man page
406- added -v / --version flag
407- replace convoluted grep with wc (KP)
408- fixed bug affecting restoration of bigfiles from CD's created w/0 compression
409- fixed BurnProof-related bug
410- better at figuring out which is the best partition for temp/scratchdir
411- added do-not-compress-these (text file) to RPM
412- do not compress files of types listed in do-not-compress-these
413- dropped -U from call to afio - saves 20-30% runtime (Cosgrove)
414- added Cosgrove's do-not-compress-these list
415- included various patches from KP
416- chmod tmpdir, scratchdir to 700 before using
417- restore from specified backup device, even if its own cfg file disagrees
418- fixed multi-tape bug
419- fixed "Can't find first ISO when verifying nonbootable ISO" bug
420- multithreaded make_afioballs_and_images()
421- tmpdir and scratchdir are set sensibly whether mondoarchive is called with
422 command-line parameters or not
423- fixed bug in strip_spaces() which stopped it from handling
424 small strings correctly - affected mountlist editor
425- create a repaired copy of grub-install which is RAID-friendly;
426 use it when initializing boot sector with run_grub()
427- fixed bug in mondo-makefilelist
428
429* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 1.50
430- if restoring, don't try to find SCSI node of CD-ROM drive; find /dev entry
431- during selective restore, skip filesets which don't contain relevant archives
432- set /dev/null's perms to 777, just in case devfs-enabled kernel mangles it
433- remove /var/run/*.pid after restoring
434- move spurious lockfiles from /home/* to /home/*/.disabled
435- ask user to confirm the tape/CD device name
436- lots of multitape-related fixes
437- added code to autodetect the hardware of the user, if possible
438- if isodir does not exist then abort
439- more sanity-checking for -d flag
440- doubled 'biggiefile' threshold... to 32MB
441- exclude /root/images/mindi
442- fixed multi-imagedev bug (Emmanuel Druon)
443- unmount/remount /mnt/floppy before/after backing up, if Mandrake
444- restructured the source files
445- fixed serious bug in line 1546 - should have been !=, not ==; stopped
446 mondorestore from correctly restoring big files
447- added '#include <signal.h>' to my-stuff.h
448- exclude "incheckentry xwait()" from changed.files
449- fixed minor bug in find_cdrom_device()
450- fixed bug in friendly_sizestr...
451- insist on tape #1 when start verifying
452- added internal buffering, replacing the external 'buffer' exe
453- if differential backup then don't permit formatting or fdisking,
454 whether Interactive or Nuke mode
455- if mondorestore is run on live filesystem (or from ramdisk) without
456 parameters then mondorestore will ask which backup media (tape, CD, etc.)
457 was used; it will read the config file from the media and proceed from there
458- if tape streamer is softlink then resolve it first
459- incorporate post-nuke tarball
460- if user doesn't specify tape size, proceed anyway; behave intelligently
461 in the event of end-of-tape
462- prefix bkpinfo->restore_path to biggiefile fname before generating
463 checksum & comparing to archived biggiefile
464- if /etc/lilo.conf not found not /etc/lilo.conf.anaconda found
465 then create a softlink from the former to the latter, to work
466 around RH7.3's b0rken LILO support
467- LFS support (mharris, michele, hugo)
468- fixed verify bug --- CD#1 was being verified again & again & ...
469- differential mode fixed; supported again
470- ask user for boot loader + device if not detectible
471- list up to 512 files in file selection window at once (was 128)
472- better handling of bigfiles' checksums, perms and owns
473- delete final filelist if <=2 bytes long
474- if kernel not found and mondo in graphics mode then popup and ask
475 for kernel path+filename
476
477* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 1.45-1
478- 1.5x branch forked off from 1.4x branch
479
480
481
482
Note: See TracBrowser for help on using the repository browser.