source: MondoRescue/trunk/mondo/mondo.spec@ 236

Last change on this file since 236 was 236, checked in by bcornec, 18 years ago

merge -r229:235 $SVN_M/branches/2.05

  • Property svn:keywords set to Id
File size: 18.4 KB
Line 
1#
2# $Id: mondo.spec 236 2005-12-19 18:31:56Z bcornec $
3#
4%define is_mandriva %(test -e /etc/mandriva-release && echo 1 || echo 0)
5%define is_mandrake %(test -e /etc/mandrake-release && echo 1 || echo 0)
6%define is_suse %(test -e /etc/SuSE-release && echo 1 || echo 0)
7%define is_fedora %(test -e /etc/fedora-release && echo 1 || echo 0)
8%define is_redhat %(test -e /etc/redhat-release && echo 1 || echo 0)
9
10%define name mondo
11%define version 2.04_berlios
12%define mrel 1
13
14%if %is_redhat
15%define src %{name}-%{version}.tgz
16Group: Applications/Archiving
17Autoreq: 0
18%endif
19
20%if %is_mandrake
21%define src %{name}-%{version}.tar.bz2
22Group: Archiving/Backup
23Autoreqprov: no
24%endif
25
26%if %is_mandriva
27%define src %{name}-%{version}.tar.bz2
28Group: Archiving/Backup
29Autoreqprov: no
30%endif
31
32%if %is_suse
33%define src %{name}-%{version}.tgz
34Group: Archiving/Backup
35%endif
36
37Summary: A program which a Linux user can utilize to create a rescue/restore CD/tape
38Summary(fr): Un programme pour les utilisateurs de Linux pour cr�r un CD/tape de sauvegarde/restauration
39Summary(it): Un programma per utenti Linux per creare un CD/tape di rescue
40Summary(sp): Un programa para los usuarios de Linux por crear una CD/cinta de restoracion/rescate
41
42Name: %{name}
43Version: %{version}
44Release: %{mrel}
45License: GPL
46Url: http://mondorescue.berlios.de
47Source: %{src}
48BuildRoot: %{_tmppath}/%{name}-%{version}
49BuildRequires: newt-devel >= 0.50, slang-devel >= 1.4.1, gcc
50%ifarch ia64
51Requires: mindi >= 1.05, bzip2 >= 0.9, afio, mkisofs, binutils, elilo, newt >= 0.50, slang >= 1.4.1, buffer, parted
52%else
53Requires: mindi >= 1.05, bzip2 >= 0.9, afio, mkisofs, binutils, syslinux >= 1.52, newt >= 0.50, slang >= 1.4.1, cdrecord, buffer
54%endif
55
56#%package %{name}-devel
57#Summary: Header files for building against Mondo
58#%if %is_mandrake
59#Group: Development/Libraries
60#%endif
61#if %is_redhat
62#Group: Development/Other
63#%endif
64#Provides: libmondo-devel mondo-devel
65#Obsoletes: libmondo-devel
66#
67#%description -n %{name}-devel
68#Mondo libraries and includes
69
70%description
71Mondo is a GPL disaster recovery solution to create backup media (CD, DVD, tape, network images) that can be used to redeploy the damaged system, as well as deploy similar or less similar systems.
72
73%description -l fr
74Objectif
75""""""""
76Mondo est une solution GPL de sauvegarde en cas de désastre pour créer des médias (CD, DVD, bande, images réseau) qui peuvent être utilisés pour redéployer le système endomangé, aussi bien que des systèmes similaires, ou moins similaires.
77
78%description -l it
79Scopo
80"""""
81Mondo e' un programma che permette a qualsiasi utente Linux
82di creare un cd di rescue/restore (o piu' cd qualora l'installazione
83dovesse occupare piu' di 2Gb circa). Funziona con gli azionamenti di
84nastro, ed il NFS, anche.
85
86%description -l sp
87Objectivo
88"""""""""
89Mondo es un programa que permite cualquier usuario de Linux a crear una CD
90de restoracion/rescate (o CDs, si su instalacion es >2GO aprox.). Funciona
91con cintas y NFS, tambien.
92
93%prep
94%setup -q -n %name-%{version}
95
96%build
97%configure
98%{__make} VERSION=%{version} CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_REENTRANT"
99
100%install
101%{__rm} -rf $RPM_BUILD_ROOT
102%makeinstall
103
104%post
105/sbin/ldconfig
106%{__chmod} 755 %{_libdir}/%{name}/restore-scripts/%{name}/*
107
108%postun
109/sbin/ldconfig
110
111%clean
112%{__rm} -rf $RPM_BUILD_ROOT
113
114%files
115%defattr(644,root,root,755)
116%doc ChangeLog mondo/docs/en/1.6x-howto/*
117%doc INSTALL COPYING README TODO AUTHORS NEWS
118
119%attr(755,root,root) %{_sbindir}/*
120#%attr(755,root,root) %{_libdir}/%{name}/restore-scripts/%{name}/*
121%{_libdir}
122%{_mandir}
123
124%changelog
125* Tue Oct 06 2005 Bruno Cornec <bcornec@users.berlios.de> 2.05_berlios
126- Memory management revision
127- use libdir instead of datadir
128
129* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 2.04_berlios
130- Merge of patches mentionned on mondo ML + ia64 updates
131- Option -p added
132
133* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 2.04_cvs_20050503
134- made mondo more clever about finding its home. Avoids mondo considering
135 directories like '/usr/share/doc/momdo' as its home.
136
137* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 2.03
138- test sanity of user-specified tempdir
139- better SLES8 support
140
141* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 2.02
142- instead of using 'dd' to erase partition table, delete existing
143 partitions w/ the same call to fdisk that is used to create the
144 new partitions; this should avoids locking up the partition table
145- set bootable partition in the above same call to fdisk, for
146 the same reason (avoids locking up the partition table)
147- better software RAID support
148- mount ext3 partitions as ext2 when restoring - better for Debian
149- better star, ACL support
150- added ACL, xattr support for afio users
151
152* Fri Jun 26 2004 Hugo Rabson <hugorabson@msn.com> 2.01
153- fixed cvs for SuSE systems
154- fixed NTFS backup/restore bug relating to partimagehack
155 log file overflow and NTFS v non-NTFS differentiation
156- more reliable extraction of config info from CDs, floppies
157- better support of ISO dirs at restore-time (Conor Daly)
158- fixed spec file for SuSE users
159- added ldconfig to install section
160
161* Fri Jun 19 2004 Hugo Rabson <hugorabson@msn.com> 2.00
162- first 2.0 release
163- updated grub-install.patched to support SuSE and Red Hat
164- call 'mt' to set block size to 32K before opening in/out tape
165- updated mondo-prep.c to create each disk's partitions all at once
166 (one call per drive) instead of one call to fdisk per partition
167- when extracting cfg file and mountlist from all.tar.gz (tape copy),
168 use block size of INTERNAL_TAPE_BLK_SIZE, not TAPE_BLOCK_SIZE
169- added star and rudimentary SELinux support
170- fixed lots of bugs
171- all logging now goes to /var/log/mondo-archive.log, with symlink
172 to /tmp/mondo-restore.log for restore-time log-tracking
173- added grub-install.patched
174- removed embleer & other binaries
175- added '-b' to specify block size
176- added '-R' for star support
177
178* Thu Mar 25 2004 Bruno Cornec <Bruno.Cornec@hp.com> 1.7_cvs-20040325
179- ia64 fixes
180
181* Fri Nov 07 2003 Joshua Oreman <oremanj@get-linux.org> 1.7_cvs-20031107
182- fixed symbolic links for libraries
183- added support for boot/root multi floppies
184
185- added kdelibs as xmondo dependency
186- added xmondo pixmap installation
187- better find_cdrom_device(), to cope w/ multiple CD writers
188- fixed -m and -Vc flags
189- fixed NTFS support!
190- bootable CD uses native, not El Torito, support now
191- removed mondo-makefilelist
192- added 2.6 kernel support
193- if 2.6 kernel, insist that the user specify CD device
194- drop Embleer; insist on ms-sys and parted if Windows partition
195
196* Wed Nov 05 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031105.1
197- added -devel package
198
199* Tue Nov 04 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031104.1
200- made xmondo a second package
201- added ability to specify --without xmondo at build time
202
203* Sun Nov 02 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031102.1
204- Clean up, added spanish translation
205- Set prefix to be /usr
206- added/fixed Requires
207- remove CVS directories prior to building
208
209* Thu Oct 23 2003 Hugo Rabson <hugorabson@msn.com> 1.75_cvs_20031023
210- nothing yet
211
212* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 1.75
213- fixed chmod/chown bug (Jens Richter)
214- ask user to confirm NFS mountpoint in Interactive Mode
215- rewritten format_everything() to make sure LVMs, RAIDs and
216 regular partitions are prepped in the correct order
217- better magicdev support
218- rewritten external binary caller subroutine
219- DVD support added
220- better backup-time control gui; offer to exclude nfs if appl.
221- fixed multi-tape support
222- re-implemented -D and -J
223- fixed bug in extract_config_file_from_ramdisk() which
224 affected tape+floppy users
225- updated is_incoming_block_valid() to make it
226 return end-of-tape if >300 flotsam blocks
227- unmount CD-ROM before burning (necessary for RH8/9)
228- fixed some stray assert()'s
229- fixed bug in grub-MR (Christian)
230- make user remove floppy/CD before restoring interactively from tape
231- fixed bug in am_I_in_disaster_recovery_mode()
232- added code to nuke_mode() to make sure NFS
233 (backup) share is mounted in Nuke Mode
234- improved tape device detection code
235- better GRUB support
236- better logging of changed bigfiles at compare-time
237- better NTFS support, thanks to partimagehack-static
238- better logging
239- rewrote tape-handling code, breaking compatibility w/ previous versions
240- fixed ISO/CD biggiefile verification bug in mondoarchive
241- fixed bug which stopped boot/compare-time changelist from popping up
242- replaced mondo-makefilelist with C code - faster, cleaner
243- tweaked GUI - better feedback
244
245* Wed May 28 2003 Anonymous <root@rohan> 1.74
246- misc fixes (Michael Hanscho's friend)
247- added rudimentary support for SME
248- added better label support
249- fixed biggietime atime/ctime restoration bug 73
250- fixed 'default boot loader' detection bug (Joshua Oreman)
251- use single-threaded make_afioballs_and_images() if FreeBSD
252- fixed mondoarchive -Vi multi-CD verify bug (Tom Mortell)
253- superior get_phys_size_of_drive() (Joshua Oreman)
254- fixed RAID-related bug in where_is_root_mounted()
255- ISO tweaks
256- fixed silly bug in load_filelist() which stopped
257 funny German filenames from being handled properly
258- fixed various calls to popup_and_get_string()
259- fixed spec file
260- reject -E /
261- added partimagehack to the mix
262
263* Tue May 20 2003 Anonymous <root@rohan> 1.73
264- mark devices as bootable _after_ unmounting them
265- resolve boot device (-f) if softlink
266- post_param_configuration() --- store iso-dev and isodir
267- added post-nuke-sample.tgz to package
268- Nuke Mode now checks mountlist against hardware; offer user
269 opportunity to edit mountlist if insane; if user declines, abort
270- added lots of assert()'s and other checks
271- ran code thru Valgrind to catch & fix some memory leaks
272- made mondo-restore.c smaller by moving some subroutines to
273 common/libmondo-raid.c and mondorestore/mondo-rstr-compare.c
274- added '-Q' to let user test mondoarchive's ability to find
275 their boot loader and type
276- improved which_boot_loader()
277- when burning or comparing to a CD, defeat autorun if it is
278 running, to avoid confusing mondoarchive and the user
279- if original backup media no longer available at boot-time
280 then offer user chance to choose another media source
281- when booting, type 'nuke noresize' to nuke w/o resizing
282 mountlist to fill your drives
283- add 'textonly' when booting, to avoid using Newt gui
284- run nice(20) to prioritize mondoarchive at start
285- don't pause and wait for next blank CD at backup-time
286 unless necessary (e.g. previous CD has not been removed)
287- get_phys_size_of_drive() --- better support of older drives
288- don't eject if "donteject" is in kernel's command line
289- cleaned up segfault-handling
290- added Conor's strip_path() to improve file list display
291- added Herman Kuster's multi-level bkp patch
292- better boot-time screen/message
293- added Joshua Oreman's FreeBSD patches x3
294- fixed interactive/textonly support
295- fixed support for subdir-within-NFS-mount
296- fixed "Can't backup if ramdisk not mounted" bug
297- try to work around eccentricities of multi-CD drive PCs
298- misc clean-ups (Steve Hindle)
299
300* Tue Apr 08 2003 Hugo Rabson <hugorabson@msn.com> 1.72
301- LVM/RAID bugs fixed (Brian Borgeson)
302- major clean-up of code (Stan Benoit)
303- make-me-bootable fix (Juraj Ziegler)
304- fixed problem w/ multi-ISO verify cycle (Tom Mortell)
305- removed duplicate entry from makefile
306- if root is /dev/root then assume not a ramdisk
307- reject relative paths if -d flag (Alessandro Polverini)
308- fixed potentially infinite loop in log_to_screen (Tom Mortell)
309- add '/' to custom filelist as workaround for obscure bug
310- ask user speed of CDRW if writing to CD
311- find_cdrom_device() --- if nonexistent/not found then
312 make sure to return '' as dev str and 1 as res
313- tweaked restore scripts tgz
314- cleaned up find_cdrom_device()
315- if user creates /usr/share/mondo/payload.tgz then untar
316 payload to CD at backup-time
317- fixed insist_on_this_cd_number()
318- fixed am_i_in_disaster_recovery_mode()
319- misc clean-up (Tom Mortell)
320- made code more legible
321- fixed post-nuke support
322- added -e support
323- fixed nfs support
324- fixed iso support
325- at restore-time, only sort mountlist internally,
326 in mount_all_devices() and unmount_all_devices()
327- fixed cosmetic bug in label-partitions-as-necessary
328- updated documentation
329- fixed fstab-hacking scripts
330
331* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 1.71
332- log newt, slang, ncurses info
333- updated man page
334- handle %% chars in issue.net properly (Heiko Schlittermann)
335- fixed serious NFS restore bug
336- cleaned up spec file; it should cause fewer problems now (Jesse Keating)
337- changed various strcpy() calls to strncpy() calls
338- added mondo-makefilelist to makefile (Mikael Hultgren)
339- mount_cdrom() better at handling multiple CD drives
340- exclude /media/cdrom,cdrecorder,floppy
341- sensibly_set_tmpdir_and_scratchdir() --- exclude smb and smbfs
342- better logging by eval_call_to_make_ISO()
343- accept -J <fname> to let user provide their own fs catalog
344 instead of -I <paths> to backup
345- if dir excluded with -E or included with -I and dir is actually
346 a softlink then exclude/include the dir pointed to, as well
347- better location for manpage
348- adjusted block size of tarball at start of tape, to help
349 users w/ broken tape driver firmware
350- sort -u fstab after modifying it
351- if backup type is nfs then don't estimate noof media
352- fixed Makefile (Mikael Hultgren)
353- updated manpage
354
355* Mon Dec 07 2002 Hugo Rabson <hugo@firstlinux.net> 1.70
356- new devel branch opened
357
358* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 1.52
359- fixed bug in multithreading
360- use new grub-MR instead of grub-install
361- wipe only the partition table (not the MBR) when partitioning drives
362- ignore lilo.conf.anaconda when looking for lilo.conf file
363- accepts '-l RAW' to backup/restore original boot sector instead
364 of running grub or lilo to init it after restoring
365- fixed&updated stabgrub-me script; software RAID + GRUB work now
366- mount/unmount /boot partition for Gentoo 1.2 users
367- re-enabled extra tape checksums
368- disabled spurious warnings
369- unmount/remount supermounts at start/end of live restore, if nec.
370- cleaned up mondo's tape block handling (now, TAPE_BLOCK_SIZE=128K
371 and I've added INTERNAL_TAPE_BLK_SIZE=32K variable for buffering)
372- added Makefile
373- added -l RAW, to backup and restore original MBR
374- cleaned up iso_mode() and nfs restoring
375- create /mnt/RESTORING/mnt/.boot.d for Gentoo users
376- made mondorestore CD bootable for ArkLinux users
377- if user runs as 'su' not 'su -' then work around
378
379* Sun Nov 17 2002 Hugo Rabson <hugo@firstlinux.net> 1.51
380- pop-up list of changed files, at end of verification phase
381- better handling of changed.files list at restore-time
382- lots of CD-related fixes
383- added '-N' flag --- to let user exclude all NFS-related mounts&devices
384- better handling of 'kill'
385- restructuring of code to ease integration of mondo w/XMondo
386- fixed obscure bug in find_and_mount_actual_cd()
387- if / or /root has <50MB free then abort & complain
388- fixed install.sh
389- fixed .spec file
390- updated documentation
391- commented code
392- updated man page
393- added -v / --version flag
394- replace convoluted grep with wc (KP)
395- fixed bug affecting restoration of bigfiles from CD's created w/0 compression
396- fixed BurnProof-related bug
397- better at figuring out which is the best partition for temp/scratchdir
398- added do-not-compress-these (text file) to RPM
399- do not compress files of types listed in do-not-compress-these
400- dropped -U from call to afio - saves 20-30% runtime (Cosgrove)
401- added Cosgrove's do-not-compress-these list
402- included various patches from KP
403- chmod tmpdir, scratchdir to 700 before using
404- restore from specified backup device, even if its own cfg file disagrees
405- fixed multi-tape bug
406- fixed "Can't find first ISO when verifying nonbootable ISO" bug
407- multithreaded make_afioballs_and_images()
408- tmpdir and scratchdir are set sensibly whether mondoarchive is called with
409 command-line parameters or not
410- fixed bug in strip_spaces() which stopped it from handling
411 small strings correctly - affected mountlist editor
412- create a repaired copy of grub-install which is RAID-friendly;
413 use it when initializing boot sector with run_grub()
414- fixed bug in mondo-makefilelist
415
416* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 1.50
417- if restoring, don't try to find SCSI node of CD-ROM drive; find /dev entry
418- during selective restore, skip filesets which don't contain relevant archives
419- set /dev/null's perms to 777, just in case devfs-enabled kernel mangles it
420- remove /var/run/*.pid after restoring
421- move spurious lockfiles from /home/* to /home/*/.disabled
422- ask user to confirm the tape/CD device name
423- lots of multitape-related fixes
424- added code to autodetect the hardware of the user, if possible
425- if isodir does not exist then abort
426- more sanity-checking for -d flag
427- doubled 'biggiefile' threshold... to 32MB
428- exclude /root/images/mindi
429- fixed multi-imagedev bug (Emmanuel Druon)
430- unmount/remount /mnt/floppy before/after backing up, if Mandrake
431- restructured the source files
432- fixed serious bug in line 1546 - should have been !=, not ==; stopped
433 mondorestore from correctly restoring big files
434- added '#include <signal.h>' to my-stuff.h
435- exclude "incheckentry xwait()" from changed.files
436- fixed minor bug in find_cdrom_device()
437- fixed bug in friendly_sizestr...
438- insist on tape #1 when start verifying
439- added internal buffering, replacing the external 'buffer' exe
440- if differential backup then don't permit formatting or fdisking,
441 whether Interactive or Nuke mode
442- if mondorestore is run on live filesystem (or from ramdisk) without
443 parameters then mondorestore will ask which backup media (tape, CD, etc.)
444 was used; it will read the config file from the media and proceed from there
445- if tape streamer is softlink then resolve it first
446- incorporate post-nuke tarball
447- if user doesn't specify tape size, proceed anyway; behave intelligently
448 in the event of end-of-tape
449- prefix bkpinfo->restore_path to biggiefile fname before generating
450 checksum & comparing to archived biggiefile
451- if /etc/lilo.conf not found not /etc/lilo.conf.anaconda found
452 then create a softlink from the former to the latter, to work
453 around RH7.3's b0rken LILO support
454- LFS support (mharris, michele, hugo)
455- fixed verify bug --- CD#1 was being verified again & again & ...
456- differential mode fixed; supported again
457- ask user for boot loader + device if not detectible
458- list up to 512 files in file selection window at once (was 128)
459- better handling of bigfiles' checksums, perms and owns
460- delete final filelist if <=2 bytes long
461- if kernel not found and mondo in graphics mode then popup and ask
462 for kernel path+filename
463
464* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 1.45-1
465- 1.5x branch forked off from 1.4x branch
466
467
468
469
Note: See TracBrowser for help on using the repository browser.