source: MondoRescue/trunk/mondo/mondo.spec@ 173

Last change on this file since 173 was 129, checked in by bcornec, 18 years ago

Removal of the code related to Xmondo/X11/KDE

  • Property svn:keywords set to Id
File size: 18.3 KB
Line 
1#
2# $Id: mondo.spec 129 2005-11-22 00:04:31Z bcornec $
3#
4%define is_mandriva %(test -e /etc/mandriva-release && echo 1 || echo 0)
5%define is_mandrake %(test -e /etc/mandrake-release && echo 1 || echo 0)
6%define is_suse %(test -e /etc/SuSE-release && echo 1 || echo 0)
7%define is_fedora %(test -e /etc/fedora-release && echo 1 || echo 0)
8%define is_redhat %(test -e /etc/redhat-release && echo 1 || echo 0)
9
10%define name mondo
11%define version 2.04_berlios
12%define mrel 1
13
14%if %is_redhat
15%define src %{name}-%{version}.tgz
16Group: Applications/Archiving
17Autoreq: 0
18%endif
19
20%if %is_mandrake
21%define src %{name}-%{version}.tar.bz2
22Group: Archiving/Backup
23Autoreqprov: no
24%endif
25
26%if %is_mandriva
27%define src %{name}-%{version}.tar.bz2
28Group: Archiving/Backup
29Autoreqprov: no
30%endif
31
32
33Summary: A program which a Linux user can utilize to create a rescue/restore CD/tape
34Summary(fr): Un programme pour les utilisateurs de Linux pour cr�r un CD/tape de sauvegarde/restauration
35Summary(it): Un programma per utenti Linux per creare un CD/tape di rescue
36Summary(sp): Un programa para los usuarios de Linux por crear una CD/cinta de restoracion/rescate
37<<<<<<< .working
38Name: mondo
39Version: 2.05_berlios
40Release: 1
41=======
42
43Name: %{name}
44Version: %{version}
45Release: %{mrel}
46>>>>>>> .merge-right.r54
47License: GPL
48Url: http://mondorescue.berlios.de
49Source: %{src}
50BuildRoot: %{_tmppath}/%{name}-%{version}
51BuildRequires: newt-devel >= 0.50, slang-devel >= 1.4.1, gcc
52%ifarch ia64
53Requires: mindi >= 1.04_berlios, bzip2 >= 0.9, afio, mkisofs, binutils, elilo, newt >= 0.50, slang >= 1.4.1, buffer, parted
54%else
55Requires: mindi >= 1.04_berlios, bzip2 >= 0.9, afio, mkisofs, binutils, syslinux >= 1.52, newt >= 0.50, slang >= 1.4.1, cdrecord, buffer
56%endif
57
58#%package %{name}-devel
59#Summary: Header files for building against Mondo
60#%if %is_mandrake
61#Group: Development/Libraries
62#%endif
63#if %is_redhat
64#Group: Development/Other
65#%endif
66#Provides: libmondo-devel mondo-devel
67#Obsoletes: libmondo-devel
68#
69#%description -n %{name}-devel
70#Mondo libraries and includes
71
72%description
73Mondo is a GPL disaster recovery solution to create backup media (CD, DVD, tape, network images) that can be used to redeploy the damaged system, as well as deploy similar or less similar systems.
74
75%description -l fr
76Objectif
77""""""""
78Mondo est une solution GPL de sauvegarde en cas de désastre pour créer des médias (CD, DVD, bande, images réseau) qui peuvent être utilisés pour redéployer le système endomangé, aussi bien que des systèmes similaires, ou moins similaires.
79
80%description -l it
81Scopo
82"""""
83Mondo e' un programma che permette a qualsiasi utente Linux
84di creare un cd di rescue/restore (o piu' cd qualora l'installazione
85dovesse occupare piu' di 2Gb circa). Funziona con gli azionamenti di
86nastro, ed il NFS, anche.
87
88%description -l sp
89Objectivo
90"""""""""
91Mondo es un programa que permite cualquier usuario de Linux a crear una CD
92de restoracion/rescate (o CDs, si su instalacion es >2GO aprox.). Funciona
93con cintas y NFS, tambien.
94
95%prep
96%setup -q -n %name-%{version}
97
98%build
99%configure
100%{__make} VERSION=%{version} CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_REENTRANT"
101
102%install
103%{__rm} -rf $RPM_BUILD_ROOT
104%makeinstall
105
106%post
107/sbin/ldconfig
108
109%postun
110/sbin/ldconfig
111
112%clean
113%{__rm} -rf $RPM_BUILD_ROOT
114
115%files
116%defattr(644,root,root,755)
117%doc ChangeLog mondo/docs/en/1.6x-howto/*
118%doc INSTALL COPYING README TODO AUTHORS NEWS
119
120%attr(755,root,root) %{_sbindir}/*
121%attr(755,root,root) %{_datadir}/%{name}/restore-scripts/%{name}
122%{_datadir}/%{name}
123%{_mandir}/*
124%{_libdir}/*
125
126%changelog
127* Tue Oct 06 2005 Bruno Cornec <bcornec@users.berlios.de> 2.05_berlios
128- Memory management revision
129
130* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 2.04_berlios
131- Merge of patches mentionned on mondo ML + ia64 updates
132- Option -p added
133
134* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 2.04_cvs_20050503
135- made mondo more clever about finding its home. Avoids mondo considering
136 directories like '/usr/share/doc/momdo' as its home.
137
138* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 2.03
139- test sanity of user-specified tempdir
140- better SLES8 support
141
142* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 2.02
143- instead of using 'dd' to erase partition table, delete existing
144 partitions w/ the same call to fdisk that is used to create the
145 new partitions; this should avoids locking up the partition table
146- set bootable partition in the above same call to fdisk, for
147 the same reason (avoids locking up the partition table)
148- better software RAID support
149- mount ext3 partitions as ext2 when restoring - better for Debian
150- better star, ACL support
151- added ACL, xattr support for afio users
152
153* Fri Jun 26 2004 Hugo Rabson <hugorabson@msn.com> 2.01
154- fixed cvs for SuSE systems
155- fixed NTFS backup/restore bug relating to partimagehack
156 log file overflow and NTFS v non-NTFS differentiation
157- more reliable extraction of config info from CDs, floppies
158- better support of ISO dirs at restore-time (Conor Daly)
159- fixed spec file for SuSE users
160- added ldconfig to install section
161
162* Fri Jun 19 2004 Hugo Rabson <hugorabson@msn.com> 2.00
163- first 2.0 release
164- updated grub-install.patched to support SuSE and Red Hat
165- call 'mt' to set block size to 32K before opening in/out tape
166- updated mondo-prep.c to create each disk's partitions all at once
167 (one call per drive) instead of one call to fdisk per partition
168- when extracting cfg file and mountlist from all.tar.gz (tape copy),
169 use block size of INTERNAL_TAPE_BLK_SIZE, not TAPE_BLOCK_SIZE
170- added star and rudimentary SELinux support
171- fixed lots of bugs
172- all logging now goes to /var/log/mondo-archive.log, with symlink
173 to /tmp/mondo-restore.log for restore-time log-tracking
174- added grub-install.patched
175- removed embleer & other binaries
176- added '-b' to specify block size
177- added '-R' for star support
178
179* Thu Mar 25 2004 Bruno Cornec <Bruno.Cornec@hp.com> 1.7_cvs-20040325
180- ia64 fixes
181
182* Fri Nov 07 2003 Joshua Oreman <oremanj@get-linux.org> 1.7_cvs-20031107
183- fixed symbolic links for libraries
184- added support for boot/root multi floppies
185
186- added kdelibs as xmondo dependency
187- added xmondo pixmap installation
188- better find_cdrom_device(), to cope w/ multiple CD writers
189- fixed -m and -Vc flags
190- fixed NTFS support!
191- bootable CD uses native, not El Torito, support now
192- removed mondo-makefilelist
193- added 2.6 kernel support
194- if 2.6 kernel, insist that the user specify CD device
195- drop Embleer; insist on ms-sys and parted if Windows partition
196
197* Wed Nov 05 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031105.1
198- added -devel package
199
200* Tue Nov 04 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031104.1
201- made xmondo a second package
202- added ability to specify --without xmondo at build time
203
204* Sun Nov 02 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031102.1
205- Clean up, added spanish translation
206- Set prefix to be /usr
207- added/fixed Requires
208- remove CVS directories prior to building
209
210* Thu Oct 23 2003 Hugo Rabson <hugorabson@msn.com> 1.75_cvs_20031023
211- nothing yet
212
213* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 1.75
214- fixed chmod/chown bug (Jens Richter)
215- ask user to confirm NFS mountpoint in Interactive Mode
216- rewritten format_everything() to make sure LVMs, RAIDs and
217 regular partitions are prepped in the correct order
218- better magicdev support
219- rewritten external binary caller subroutine
220- DVD support added
221- better backup-time control gui; offer to exclude nfs if appl.
222- fixed multi-tape support
223- re-implemented -D and -J
224- fixed bug in extract_config_file_from_ramdisk() which
225 affected tape+floppy users
226- updated is_incoming_block_valid() to make it
227 return end-of-tape if >300 flotsam blocks
228- unmount CD-ROM before burning (necessary for RH8/9)
229- fixed some stray assert()'s
230- fixed bug in grub-MR (Christian)
231- make user remove floppy/CD before restoring interactively from tape
232- fixed bug in am_I_in_disaster_recovery_mode()
233- added code to nuke_mode() to make sure NFS
234 (backup) share is mounted in Nuke Mode
235- improved tape device detection code
236- better GRUB support
237- better logging of changed bigfiles at compare-time
238- better NTFS support, thanks to partimagehack-static
239- better logging
240- rewrote tape-handling code, breaking compatibility w/ previous versions
241- fixed ISO/CD biggiefile verification bug in mondoarchive
242- fixed bug which stopped boot/compare-time changelist from popping up
243- replaced mondo-makefilelist with C code - faster, cleaner
244- tweaked GUI - better feedback
245
246* Wed May 28 2003 Anonymous <root@rohan> 1.74
247- misc fixes (Michael Hanscho's friend)
248- added rudimentary support for SME
249- added better label support
250- fixed biggietime atime/ctime restoration bug 73
251- fixed 'default boot loader' detection bug (Joshua Oreman)
252- use single-threaded make_afioballs_and_images() if FreeBSD
253- fixed mondoarchive -Vi multi-CD verify bug (Tom Mortell)
254- superior get_phys_size_of_drive() (Joshua Oreman)
255- fixed RAID-related bug in where_is_root_mounted()
256- ISO tweaks
257- fixed silly bug in load_filelist() which stopped
258 funny German filenames from being handled properly
259- fixed various calls to popup_and_get_string()
260- fixed spec file
261- reject -E /
262- added partimagehack to the mix
263
264* Tue May 20 2003 Anonymous <root@rohan> 1.73
265- mark devices as bootable _after_ unmounting them
266- resolve boot device (-f) if softlink
267- post_param_configuration() --- store iso-dev and isodir
268- added post-nuke-sample.tgz to package
269- Nuke Mode now checks mountlist against hardware; offer user
270 opportunity to edit mountlist if insane; if user declines, abort
271- added lots of assert()'s and other checks
272- ran code thru Valgrind to catch & fix some memory leaks
273- made mondo-restore.c smaller by moving some subroutines to
274 common/libmondo-raid.c and mondorestore/mondo-rstr-compare.c
275- added '-Q' to let user test mondoarchive's ability to find
276 their boot loader and type
277- improved which_boot_loader()
278- when burning or comparing to a CD, defeat autorun if it is
279 running, to avoid confusing mondoarchive and the user
280- if original backup media no longer available at boot-time
281 then offer user chance to choose another media source
282- when booting, type 'nuke noresize' to nuke w/o resizing
283 mountlist to fill your drives
284- add 'textonly' when booting, to avoid using Newt gui
285- run nice(20) to prioritize mondoarchive at start
286- don't pause and wait for next blank CD at backup-time
287 unless necessary (e.g. previous CD has not been removed)
288- get_phys_size_of_drive() --- better support of older drives
289- don't eject if "donteject" is in kernel's command line
290- cleaned up segfault-handling
291- added Conor's strip_path() to improve file list display
292- added Herman Kuster's multi-level bkp patch
293- better boot-time screen/message
294- added Joshua Oreman's FreeBSD patches x3
295- fixed interactive/textonly support
296- fixed support for subdir-within-NFS-mount
297- fixed "Can't backup if ramdisk not mounted" bug
298- try to work around eccentricities of multi-CD drive PCs
299- misc clean-ups (Steve Hindle)
300
301* Tue Apr 08 2003 Hugo Rabson <hugorabson@msn.com> 1.72
302- LVM/RAID bugs fixed (Brian Borgeson)
303- major clean-up of code (Stan Benoit)
304- make-me-bootable fix (Juraj Ziegler)
305- fixed problem w/ multi-ISO verify cycle (Tom Mortell)
306- removed duplicate entry from makefile
307- if root is /dev/root then assume not a ramdisk
308- reject relative paths if -d flag (Alessandro Polverini)
309- fixed potentially infinite loop in log_to_screen (Tom Mortell)
310- add '/' to custom filelist as workaround for obscure bug
311- ask user speed of CDRW if writing to CD
312- find_cdrom_device() --- if nonexistent/not found then
313 make sure to return '' as dev str and 1 as res
314- tweaked restore scripts tgz
315- cleaned up find_cdrom_device()
316- if user creates /usr/share/mondo/payload.tgz then untar
317 payload to CD at backup-time
318- fixed insist_on_this_cd_number()
319- fixed am_i_in_disaster_recovery_mode()
320- misc clean-up (Tom Mortell)
321- made code more legible
322- fixed post-nuke support
323- added -e support
324- fixed nfs support
325- fixed iso support
326- at restore-time, only sort mountlist internally,
327 in mount_all_devices() and unmount_all_devices()
328- fixed cosmetic bug in label-partitions-as-necessary
329- updated documentation
330- fixed fstab-hacking scripts
331
332* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 1.71
333- log newt, slang, ncurses info
334- updated man page
335- handle %% chars in issue.net properly (Heiko Schlittermann)
336- fixed serious NFS restore bug
337- cleaned up spec file; it should cause fewer problems now (Jesse Keating)
338- changed various strcpy() calls to strncpy() calls
339- added mondo-makefilelist to makefile (Mikael Hultgren)
340- mount_cdrom() better at handling multiple CD drives
341- exclude /media/cdrom,cdrecorder,floppy
342- sensibly_set_tmpdir_and_scratchdir() --- exclude smb and smbfs
343- better logging by eval_call_to_make_ISO()
344- accept -J <fname> to let user provide their own fs catalog
345 instead of -I <paths> to backup
346- if dir excluded with -E or included with -I and dir is actually
347 a softlink then exclude/include the dir pointed to, as well
348- better location for manpage
349- adjusted block size of tarball at start of tape, to help
350 users w/ broken tape driver firmware
351- sort -u fstab after modifying it
352- if backup type is nfs then don't estimate noof media
353- fixed Makefile (Mikael Hultgren)
354- updated manpage
355
356* Mon Dec 07 2002 Hugo Rabson <hugo@firstlinux.net> 1.70
357- new devel branch opened
358
359* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 1.52
360- fixed bug in multithreading
361- use new grub-MR instead of grub-install
362- wipe only the partition table (not the MBR) when partitioning drives
363- ignore lilo.conf.anaconda when looking for lilo.conf file
364- accepts '-l RAW' to backup/restore original boot sector instead
365 of running grub or lilo to init it after restoring
366- fixed&updated stabgrub-me script; software RAID + GRUB work now
367- mount/unmount /boot partition for Gentoo 1.2 users
368- re-enabled extra tape checksums
369- disabled spurious warnings
370- unmount/remount supermounts at start/end of live restore, if nec.
371- cleaned up mondo's tape block handling (now, TAPE_BLOCK_SIZE=128K
372 and I've added INTERNAL_TAPE_BLK_SIZE=32K variable for buffering)
373- added Makefile
374- added -l RAW, to backup and restore original MBR
375- cleaned up iso_mode() and nfs restoring
376- create /mnt/RESTORING/mnt/.boot.d for Gentoo users
377- made mondorestore CD bootable for ArkLinux users
378- if user runs as 'su' not 'su -' then work around
379
380* Sun Nov 17 2002 Hugo Rabson <hugo@firstlinux.net> 1.51
381- pop-up list of changed files, at end of verification phase
382- better handling of changed.files list at restore-time
383- lots of CD-related fixes
384- added '-N' flag --- to let user exclude all NFS-related mounts&devices
385- better handling of 'kill'
386- restructuring of code to ease integration of mondo w/XMondo
387- fixed obscure bug in find_and_mount_actual_cd()
388- if / or /root has <50MB free then abort & complain
389- fixed install.sh
390- fixed .spec file
391- updated documentation
392- commented code
393- updated man page
394- added -v / --version flag
395- replace convoluted grep with wc (KP)
396- fixed bug affecting restoration of bigfiles from CD's created w/0 compression
397- fixed BurnProof-related bug
398- better at figuring out which is the best partition for temp/scratchdir
399- added do-not-compress-these (text file) to RPM
400- do not compress files of types listed in do-not-compress-these
401- dropped -U from call to afio - saves 20-30% runtime (Cosgrove)
402- added Cosgrove's do-not-compress-these list
403- included various patches from KP
404- chmod tmpdir, scratchdir to 700 before using
405- restore from specified backup device, even if its own cfg file disagrees
406- fixed multi-tape bug
407- fixed "Can't find first ISO when verifying nonbootable ISO" bug
408- multithreaded make_afioballs_and_images()
409- tmpdir and scratchdir are set sensibly whether mondoarchive is called with
410 command-line parameters or not
411- fixed bug in strip_spaces() which stopped it from handling
412 small strings correctly - affected mountlist editor
413- create a repaired copy of grub-install which is RAID-friendly;
414 use it when initializing boot sector with run_grub()
415- fixed bug in mondo-makefilelist
416
417* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 1.50
418- if restoring, don't try to find SCSI node of CD-ROM drive; find /dev entry
419- during selective restore, skip filesets which don't contain relevant archives
420- set /dev/null's perms to 777, just in case devfs-enabled kernel mangles it
421- remove /var/run/*.pid after restoring
422- move spurious lockfiles from /home/* to /home/*/.disabled
423- ask user to confirm the tape/CD device name
424- lots of multitape-related fixes
425- added code to autodetect the hardware of the user, if possible
426- if isodir does not exist then abort
427- more sanity-checking for -d flag
428- doubled 'biggiefile' threshold... to 32MB
429- exclude /root/images/mindi
430- fixed multi-imagedev bug (Emmanuel Druon)
431- unmount/remount /mnt/floppy before/after backing up, if Mandrake
432- restructured the source files
433- fixed serious bug in line 1546 - should have been !=, not ==; stopped
434 mondorestore from correctly restoring big files
435- added '#include <signal.h>' to my-stuff.h
436- exclude "incheckentry xwait()" from changed.files
437- fixed minor bug in find_cdrom_device()
438- fixed bug in friendly_sizestr...
439- insist on tape #1 when start verifying
440- added internal buffering, replacing the external 'buffer' exe
441- if differential backup then don't permit formatting or fdisking,
442 whether Interactive or Nuke mode
443- if mondorestore is run on live filesystem (or from ramdisk) without
444 parameters then mondorestore will ask which backup media (tape, CD, etc.)
445 was used; it will read the config file from the media and proceed from there
446- if tape streamer is softlink then resolve it first
447- incorporate post-nuke tarball
448- if user doesn't specify tape size, proceed anyway; behave intelligently
449 in the event of end-of-tape
450- prefix bkpinfo->restore_path to biggiefile fname before generating
451 checksum & comparing to archived biggiefile
452- if /etc/lilo.conf not found not /etc/lilo.conf.anaconda found
453 then create a softlink from the former to the latter, to work
454 around RH7.3's b0rken LILO support
455- LFS support (mharris, michele, hugo)
456- fixed verify bug --- CD#1 was being verified again & again & ...
457- differential mode fixed; supported again
458- ask user for boot loader + device if not detectible
459- list up to 512 files in file selection window at once (was 128)
460- better handling of bigfiles' checksums, perms and owns
461- delete final filelist if <=2 bytes long
462- if kernel not found and mondo in graphics mode then popup and ask
463 for kernel path+filename
464
465* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 1.45-1
466- 1.5x branch forked off from 1.4x branch
467
468
469
470
Note: See TracBrowser for help on using the repository browser.