source: MondoRescue/trunk/mondo/mondo.spec@ 198

Last change on this file since 198 was 198, checked in by bcornec, 18 years ago

typo

  • Property svn:keywords set to Id
File size: 18.3 KB
RevLine 
[35]1#
2# $Id: mondo.spec 198 2005-12-13 23:46:48Z bcornec $
3#
[55]4%define is_mandriva %(test -e /etc/mandriva-release && echo 1 || echo 0)
5%define is_mandrake %(test -e /etc/mandrake-release && echo 1 || echo 0)
6%define is_suse %(test -e /etc/SuSE-release && echo 1 || echo 0)
7%define is_fedora %(test -e /etc/fedora-release && echo 1 || echo 0)
8%define is_redhat %(test -e /etc/redhat-release && echo 1 || echo 0)
[1]9
[55]10%define name mondo
11%define version 2.04_berlios
12%define mrel 1
13
14%if %is_redhat
15%define src %{name}-%{version}.tgz
16Group: Applications/Archiving
17Autoreq: 0
18%endif
19
20%if %is_mandrake
21%define src %{name}-%{version}.tar.bz2
22Group: Archiving/Backup
23Autoreqprov: no
24%endif
25
[65]26%if %is_mandriva
27%define src %{name}-%{version}.tar.bz2
28Group: Archiving/Backup
29Autoreqprov: no
30%endif
31
32
[1]33Summary: A program which a Linux user can utilize to create a rescue/restore CD/tape
34Summary(fr): Un programme pour les utilisateurs de Linux pour cr�r un CD/tape de sauvegarde/restauration
35Summary(it): Un programma per utenti Linux per creare un CD/tape di rescue
36Summary(sp): Un programa para los usuarios de Linux por crear una CD/cinta de restoracion/rescate
[55]37
38Name: %{name}
39Version: %{version}
[65]40Release: %{mrel}
[1]41License: GPL
[55]42Url: http://mondorescue.berlios.de
43Source: %{src}
44BuildRoot: %{_tmppath}/%{name}-%{version}
[1]45BuildRequires: newt-devel >= 0.50, slang-devel >= 1.4.1, gcc
46%ifarch ia64
[55]47Requires: mindi >= 1.04_berlios, bzip2 >= 0.9, afio, mkisofs, binutils, elilo, newt >= 0.50, slang >= 1.4.1, buffer, parted
[1]48%else
[55]49Requires: mindi >= 1.04_berlios, bzip2 >= 0.9, afio, mkisofs, binutils, syslinux >= 1.52, newt >= 0.50, slang >= 1.4.1, cdrecord, buffer
[1]50%endif
51
[55]52#%package %{name}-devel
53#Summary: Header files for building against Mondo
54#%if %is_mandrake
55#Group: Development/Libraries
56#%endif
57#if %is_redhat
58#Group: Development/Other
59#%endif
60#Provides: libmondo-devel mondo-devel
61#Obsoletes: libmondo-devel
62#
63#%description -n %{name}-devel
64#Mondo libraries and includes
[1]65
66%description
[55]67Mondo is a GPL disaster recovery solution to create backup media (CD, DVD, tape, network images) that can be used to redeploy the damaged system, as well as deploy similar or less similar systems.
[1]68
69%description -l fr
70Objectif
71""""""""
[55]72Mondo est une solution GPL de sauvegarde en cas de désastre pour créer des médias (CD, DVD, bande, images réseau) qui peuvent être utilisés pour redéployer le système endomangé, aussi bien que des systèmes similaires, ou moins similaires.
[1]73
74%description -l it
75Scopo
76"""""
77Mondo e' un programma che permette a qualsiasi utente Linux
78di creare un cd di rescue/restore (o piu' cd qualora l'installazione
79dovesse occupare piu' di 2Gb circa). Funziona con gli azionamenti di
80nastro, ed il NFS, anche.
81
82%description -l sp
83Objectivo
84"""""""""
85Mondo es un programa que permite cualquier usuario de Linux a crear una CD
86de restoracion/rescate (o CDs, si su instalacion es >2GO aprox.). Funciona
87con cintas y NFS, tambien.
88
89%prep
[55]90%setup -q -n %name-%{version}
[1]91
[55]92%build
[129]93%configure
[1]94%{__make} VERSION=%{version} CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_REENTRANT"
95
96%install
[55]97%{__rm} -rf $RPM_BUILD_ROOT
98%makeinstall
[1]99
[55]100%post
101/sbin/ldconfig
[188]102%{__chmod} 755 %{_libdir}/%{name}/restore-scripts/%{name}/*
[1]103
[55]104%postun
105/sbin/ldconfig
[1]106
107%clean
108%{__rm} -rf $RPM_BUILD_ROOT
109
110%files
[55]111%defattr(644,root,root,755)
112%doc ChangeLog mondo/docs/en/1.6x-howto/*
113%doc INSTALL COPYING README TODO AUTHORS NEWS
[1]114
[55]115%attr(755,root,root) %{_sbindir}/*
[188]116#%attr(755,root,root) %{_libdir}/%{name}/restore-scripts/%{name}/*
117%{_libdir}
118%{_mandir}
[55]119
[1]120%changelog
[41]121* Tue Oct 06 2005 Bruno Cornec <bcornec@users.berlios.de> 2.05_berlios
122- Memory management revision
[181]123- use libdir instead of datadir
[41]124
[14]125* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 2.04_berlios
[13]126- Merge of patches mentionned on mondo ML + ia64 updates
[41]127- Option -p added
[13]128
[1]129* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 2.04_cvs_20050503
130- made mondo more clever about finding its home. Avoids mondo considering
131 directories like '/usr/share/doc/momdo' as its home.
132
133* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 2.03
134- test sanity of user-specified tempdir
135- better SLES8 support
136
137* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 2.02
138- instead of using 'dd' to erase partition table, delete existing
139 partitions w/ the same call to fdisk that is used to create the
140 new partitions; this should avoids locking up the partition table
141- set bootable partition in the above same call to fdisk, for
142 the same reason (avoids locking up the partition table)
143- better software RAID support
144- mount ext3 partitions as ext2 when restoring - better for Debian
145- better star, ACL support
146- added ACL, xattr support for afio users
147
148* Fri Jun 26 2004 Hugo Rabson <hugorabson@msn.com> 2.01
149- fixed cvs for SuSE systems
150- fixed NTFS backup/restore bug relating to partimagehack
151 log file overflow and NTFS v non-NTFS differentiation
152- more reliable extraction of config info from CDs, floppies
153- better support of ISO dirs at restore-time (Conor Daly)
154- fixed spec file for SuSE users
155- added ldconfig to install section
156
157* Fri Jun 19 2004 Hugo Rabson <hugorabson@msn.com> 2.00
158- first 2.0 release
159- updated grub-install.patched to support SuSE and Red Hat
160- call 'mt' to set block size to 32K before opening in/out tape
161- updated mondo-prep.c to create each disk's partitions all at once
162 (one call per drive) instead of one call to fdisk per partition
163- when extracting cfg file and mountlist from all.tar.gz (tape copy),
164 use block size of INTERNAL_TAPE_BLK_SIZE, not TAPE_BLOCK_SIZE
165- added star and rudimentary SELinux support
166- fixed lots of bugs
167- all logging now goes to /var/log/mondo-archive.log, with symlink
168 to /tmp/mondo-restore.log for restore-time log-tracking
169- added grub-install.patched
170- removed embleer & other binaries
171- added '-b' to specify block size
172- added '-R' for star support
173
174* Thu Mar 25 2004 Bruno Cornec <Bruno.Cornec@hp.com> 1.7_cvs-20040325
175- ia64 fixes
176
177* Fri Nov 07 2003 Joshua Oreman <oremanj@get-linux.org> 1.7_cvs-20031107
178- fixed symbolic links for libraries
179- added support for boot/root multi floppies
180
181- added kdelibs as xmondo dependency
182- added xmondo pixmap installation
183- better find_cdrom_device(), to cope w/ multiple CD writers
184- fixed -m and -Vc flags
185- fixed NTFS support!
186- bootable CD uses native, not El Torito, support now
187- removed mondo-makefilelist
188- added 2.6 kernel support
189- if 2.6 kernel, insist that the user specify CD device
190- drop Embleer; insist on ms-sys and parted if Windows partition
191
192* Wed Nov 05 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031105.1
193- added -devel package
194
195* Tue Nov 04 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031104.1
196- made xmondo a second package
197- added ability to specify --without xmondo at build time
198
199* Sun Nov 02 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031102.1
200- Clean up, added spanish translation
201- Set prefix to be /usr
202- added/fixed Requires
203- remove CVS directories prior to building
204
205* Thu Oct 23 2003 Hugo Rabson <hugorabson@msn.com> 1.75_cvs_20031023
206- nothing yet
207
208* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 1.75
209- fixed chmod/chown bug (Jens Richter)
210- ask user to confirm NFS mountpoint in Interactive Mode
211- rewritten format_everything() to make sure LVMs, RAIDs and
212 regular partitions are prepped in the correct order
213- better magicdev support
214- rewritten external binary caller subroutine
215- DVD support added
216- better backup-time control gui; offer to exclude nfs if appl.
217- fixed multi-tape support
218- re-implemented -D and -J
219- fixed bug in extract_config_file_from_ramdisk() which
220 affected tape+floppy users
221- updated is_incoming_block_valid() to make it
222 return end-of-tape if >300 flotsam blocks
223- unmount CD-ROM before burning (necessary for RH8/9)
224- fixed some stray assert()'s
225- fixed bug in grub-MR (Christian)
226- make user remove floppy/CD before restoring interactively from tape
227- fixed bug in am_I_in_disaster_recovery_mode()
228- added code to nuke_mode() to make sure NFS
229 (backup) share is mounted in Nuke Mode
230- improved tape device detection code
231- better GRUB support
232- better logging of changed bigfiles at compare-time
233- better NTFS support, thanks to partimagehack-static
234- better logging
235- rewrote tape-handling code, breaking compatibility w/ previous versions
236- fixed ISO/CD biggiefile verification bug in mondoarchive
237- fixed bug which stopped boot/compare-time changelist from popping up
238- replaced mondo-makefilelist with C code - faster, cleaner
239- tweaked GUI - better feedback
240
241* Wed May 28 2003 Anonymous <root@rohan> 1.74
242- misc fixes (Michael Hanscho's friend)
243- added rudimentary support for SME
244- added better label support
245- fixed biggietime atime/ctime restoration bug 73
246- fixed 'default boot loader' detection bug (Joshua Oreman)
247- use single-threaded make_afioballs_and_images() if FreeBSD
248- fixed mondoarchive -Vi multi-CD verify bug (Tom Mortell)
249- superior get_phys_size_of_drive() (Joshua Oreman)
250- fixed RAID-related bug in where_is_root_mounted()
251- ISO tweaks
252- fixed silly bug in load_filelist() which stopped
253 funny German filenames from being handled properly
254- fixed various calls to popup_and_get_string()
255- fixed spec file
256- reject -E /
257- added partimagehack to the mix
258
259* Tue May 20 2003 Anonymous <root@rohan> 1.73
260- mark devices as bootable _after_ unmounting them
261- resolve boot device (-f) if softlink
262- post_param_configuration() --- store iso-dev and isodir
263- added post-nuke-sample.tgz to package
264- Nuke Mode now checks mountlist against hardware; offer user
265 opportunity to edit mountlist if insane; if user declines, abort
266- added lots of assert()'s and other checks
267- ran code thru Valgrind to catch & fix some memory leaks
268- made mondo-restore.c smaller by moving some subroutines to
269 common/libmondo-raid.c and mondorestore/mondo-rstr-compare.c
270- added '-Q' to let user test mondoarchive's ability to find
271 their boot loader and type
272- improved which_boot_loader()
273- when burning or comparing to a CD, defeat autorun if it is
274 running, to avoid confusing mondoarchive and the user
275- if original backup media no longer available at boot-time
276 then offer user chance to choose another media source
277- when booting, type 'nuke noresize' to nuke w/o resizing
278 mountlist to fill your drives
279- add 'textonly' when booting, to avoid using Newt gui
280- run nice(20) to prioritize mondoarchive at start
281- don't pause and wait for next blank CD at backup-time
282 unless necessary (e.g. previous CD has not been removed)
283- get_phys_size_of_drive() --- better support of older drives
284- don't eject if "donteject" is in kernel's command line
285- cleaned up segfault-handling
286- added Conor's strip_path() to improve file list display
287- added Herman Kuster's multi-level bkp patch
288- better boot-time screen/message
289- added Joshua Oreman's FreeBSD patches x3
290- fixed interactive/textonly support
291- fixed support for subdir-within-NFS-mount
292- fixed "Can't backup if ramdisk not mounted" bug
293- try to work around eccentricities of multi-CD drive PCs
294- misc clean-ups (Steve Hindle)
295
296* Tue Apr 08 2003 Hugo Rabson <hugorabson@msn.com> 1.72
297- LVM/RAID bugs fixed (Brian Borgeson)
298- major clean-up of code (Stan Benoit)
299- make-me-bootable fix (Juraj Ziegler)
300- fixed problem w/ multi-ISO verify cycle (Tom Mortell)
301- removed duplicate entry from makefile
302- if root is /dev/root then assume not a ramdisk
303- reject relative paths if -d flag (Alessandro Polverini)
304- fixed potentially infinite loop in log_to_screen (Tom Mortell)
305- add '/' to custom filelist as workaround for obscure bug
306- ask user speed of CDRW if writing to CD
307- find_cdrom_device() --- if nonexistent/not found then
308 make sure to return '' as dev str and 1 as res
309- tweaked restore scripts tgz
310- cleaned up find_cdrom_device()
311- if user creates /usr/share/mondo/payload.tgz then untar
312 payload to CD at backup-time
313- fixed insist_on_this_cd_number()
314- fixed am_i_in_disaster_recovery_mode()
315- misc clean-up (Tom Mortell)
316- made code more legible
317- fixed post-nuke support
318- added -e support
319- fixed nfs support
320- fixed iso support
321- at restore-time, only sort mountlist internally,
322 in mount_all_devices() and unmount_all_devices()
323- fixed cosmetic bug in label-partitions-as-necessary
324- updated documentation
325- fixed fstab-hacking scripts
326
327* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 1.71
328- log newt, slang, ncurses info
329- updated man page
330- handle %% chars in issue.net properly (Heiko Schlittermann)
331- fixed serious NFS restore bug
332- cleaned up spec file; it should cause fewer problems now (Jesse Keating)
333- changed various strcpy() calls to strncpy() calls
334- added mondo-makefilelist to makefile (Mikael Hultgren)
335- mount_cdrom() better at handling multiple CD drives
336- exclude /media/cdrom,cdrecorder,floppy
337- sensibly_set_tmpdir_and_scratchdir() --- exclude smb and smbfs
338- better logging by eval_call_to_make_ISO()
339- accept -J <fname> to let user provide their own fs catalog
340 instead of -I <paths> to backup
341- if dir excluded with -E or included with -I and dir is actually
342 a softlink then exclude/include the dir pointed to, as well
343- better location for manpage
344- adjusted block size of tarball at start of tape, to help
345 users w/ broken tape driver firmware
346- sort -u fstab after modifying it
347- if backup type is nfs then don't estimate noof media
348- fixed Makefile (Mikael Hultgren)
349- updated manpage
350
351* Mon Dec 07 2002 Hugo Rabson <hugo@firstlinux.net> 1.70
352- new devel branch opened
353
354* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 1.52
355- fixed bug in multithreading
356- use new grub-MR instead of grub-install
357- wipe only the partition table (not the MBR) when partitioning drives
358- ignore lilo.conf.anaconda when looking for lilo.conf file
359- accepts '-l RAW' to backup/restore original boot sector instead
360 of running grub or lilo to init it after restoring
361- fixed&updated stabgrub-me script; software RAID + GRUB work now
362- mount/unmount /boot partition for Gentoo 1.2 users
363- re-enabled extra tape checksums
364- disabled spurious warnings
365- unmount/remount supermounts at start/end of live restore, if nec.
366- cleaned up mondo's tape block handling (now, TAPE_BLOCK_SIZE=128K
367 and I've added INTERNAL_TAPE_BLK_SIZE=32K variable for buffering)
368- added Makefile
369- added -l RAW, to backup and restore original MBR
370- cleaned up iso_mode() and nfs restoring
371- create /mnt/RESTORING/mnt/.boot.d for Gentoo users
372- made mondorestore CD bootable for ArkLinux users
373- if user runs as 'su' not 'su -' then work around
374
375* Sun Nov 17 2002 Hugo Rabson <hugo@firstlinux.net> 1.51
376- pop-up list of changed files, at end of verification phase
377- better handling of changed.files list at restore-time
378- lots of CD-related fixes
379- added '-N' flag --- to let user exclude all NFS-related mounts&devices
380- better handling of 'kill'
381- restructuring of code to ease integration of mondo w/XMondo
382- fixed obscure bug in find_and_mount_actual_cd()
383- if / or /root has <50MB free then abort & complain
384- fixed install.sh
385- fixed .spec file
386- updated documentation
387- commented code
388- updated man page
389- added -v / --version flag
390- replace convoluted grep with wc (KP)
391- fixed bug affecting restoration of bigfiles from CD's created w/0 compression
392- fixed BurnProof-related bug
393- better at figuring out which is the best partition for temp/scratchdir
394- added do-not-compress-these (text file) to RPM
395- do not compress files of types listed in do-not-compress-these
396- dropped -U from call to afio - saves 20-30% runtime (Cosgrove)
397- added Cosgrove's do-not-compress-these list
398- included various patches from KP
399- chmod tmpdir, scratchdir to 700 before using
400- restore from specified backup device, even if its own cfg file disagrees
401- fixed multi-tape bug
402- fixed "Can't find first ISO when verifying nonbootable ISO" bug
403- multithreaded make_afioballs_and_images()
404- tmpdir and scratchdir are set sensibly whether mondoarchive is called with
405 command-line parameters or not
406- fixed bug in strip_spaces() which stopped it from handling
407 small strings correctly - affected mountlist editor
408- create a repaired copy of grub-install which is RAID-friendly;
409 use it when initializing boot sector with run_grub()
410- fixed bug in mondo-makefilelist
411
412* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 1.50
413- if restoring, don't try to find SCSI node of CD-ROM drive; find /dev entry
414- during selective restore, skip filesets which don't contain relevant archives
415- set /dev/null's perms to 777, just in case devfs-enabled kernel mangles it
416- remove /var/run/*.pid after restoring
417- move spurious lockfiles from /home/* to /home/*/.disabled
418- ask user to confirm the tape/CD device name
419- lots of multitape-related fixes
420- added code to autodetect the hardware of the user, if possible
421- if isodir does not exist then abort
422- more sanity-checking for -d flag
423- doubled 'biggiefile' threshold... to 32MB
424- exclude /root/images/mindi
425- fixed multi-imagedev bug (Emmanuel Druon)
426- unmount/remount /mnt/floppy before/after backing up, if Mandrake
427- restructured the source files
428- fixed serious bug in line 1546 - should have been !=, not ==; stopped
429 mondorestore from correctly restoring big files
430- added '#include <signal.h>' to my-stuff.h
431- exclude "incheckentry xwait()" from changed.files
432- fixed minor bug in find_cdrom_device()
433- fixed bug in friendly_sizestr...
434- insist on tape #1 when start verifying
435- added internal buffering, replacing the external 'buffer' exe
436- if differential backup then don't permit formatting or fdisking,
437 whether Interactive or Nuke mode
438- if mondorestore is run on live filesystem (or from ramdisk) without
439 parameters then mondorestore will ask which backup media (tape, CD, etc.)
440 was used; it will read the config file from the media and proceed from there
441- if tape streamer is softlink then resolve it first
442- incorporate post-nuke tarball
443- if user doesn't specify tape size, proceed anyway; behave intelligently
444 in the event of end-of-tape
445- prefix bkpinfo->restore_path to biggiefile fname before generating
446 checksum & comparing to archived biggiefile
447- if /etc/lilo.conf not found not /etc/lilo.conf.anaconda found
448 then create a softlink from the former to the latter, to work
449 around RH7.3's b0rken LILO support
450- LFS support (mharris, michele, hugo)
451- fixed verify bug --- CD#1 was being verified again & again & ...
452- differential mode fixed; supported again
453- ask user for boot loader + device if not detectible
454- list up to 512 files in file selection window at once (was 128)
455- better handling of bigfiles' checksums, perms and owns
456- delete final filelist if <=2 bytes long
457- if kernel not found and mondo in graphics mode then popup and ask
458 for kernel path+filename
459
460* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 1.45-1
461- 1.5x branch forked off from 1.4x branch
462
463
464
465
Note: See TracBrowser for help on using the repository browser.