source: MondoRescue/trunk/mondo/distributions/rpm/mondo.spec@ 416

Last change on this file since 416 was 416, checked in by bcornec, 18 years ago

merge -r414:415 $SVN_M/branches/stable

  • Property svn:keywords set to Id
File size: 17.6 KB
Line 
1#
2# $Id: mondo.spec 416 2006-02-20 18:33:30Z bcornec $
3#
4
5%define name mondo
6%define version VVV
7%define mrel RRR
8# if mandriva official build (rpm --with is_official)
9%{?is_official:%define rel %{mkrel} %{mrel}}%{!?is_official:%define rel %{mrel}}
10%define src SSS
11%define grp GRP
12%define addreqb mindi >= 1.05, bzip2 >= 0.9, afio, mkisofs, binutils, newt >= 0.50, slang >= 1.4.1
13
14Summary: A program which a Linux user can utilize to create a rescue/restore CD/tape
15Summary(fr): Un programme pour les utilisateurs de Linux pour cr�r un CD/tape de sauvegarde/restauration
16Summary(it): Un programma per utenti Linux per creare un CD/tape di rescue
17Summary(sp): Un programa para los usuarios de Linux por crear una CD/cinta de restoracion/rescate
18
19Name: %{name}
20Version: %{version}
21Release: %{mrel}
22License: GPL
23Group: %{grp}
24Url: http://mondorescue.berlios.de
25Source: %{src}
26BuildRoot: %{_tmppath}/%{name}-%{version}
27BuildRequires: newt-devel >= 0.50, slang-devel >= 1.4.1, gcc
28%ifarch ia64
29Requires: %{addreq}, elilo, parted
30%else
31Requires: %{addreq}, syslinux >= 1.52
32%endif
33
34%description
35Mondo is a GPL disaster recovery solution to create backup media (CD, DVD, tape, network images) that can be used to redeploy the damaged system, as well as deploy similar or less similar systems.
36
37%description -l fr
38Objectif
39""""""""
40Mondo est une solution GPL de sauvegarde en cas de désastre pour créer des médias (CD, DVD, bande, images réseau) qui peuvent être utilisés pour redéployer le système endomangé, aussi bien que des systèmes similaires, ou moins similaires.
41
42%description -l it
43Scopo
44"""""
45Mondo e' un programma che permette a qualsiasi utente Linux
46di creare un cd di rescue/restore (o piu' cd qualora l'installazione
47dovesse occupare piu' di 2Gb circa). Funziona con gli azionamenti di
48nastro, ed il NFS, anche.
49
50%description -l sp
51Objectivo
52"""""""""
53Mondo es un programa que permite cualquier usuario de Linux a crear una CD
54de restoracion/rescate (o CDs, si su instalacion es >2GO aprox.). Funciona
55con cintas y NFS, tambien.
56
57%debug_package
58%prep
59%setup -q -n %name-%{version}
60
61%build
62%configure
63%{__make} VERSION=%{version}
64
65%install
66%{__rm} -rf $RPM_BUILD_ROOT
67%makeinstall
68%if %is_suse
69%{__rm} -rf $RPM_BUILD_ROOT/%{_datadir}/doc/%name-%{version}
70%endif
71
72%post
73/sbin/ldconfig
74%{__chmod} 755 %{_libdir}/%{name}/restore-scripts/%{name}/*
75
76%postun
77/sbin/ldconfig
78
79%clean
80%{__rm} -rf $RPM_BUILD_ROOT
81
82%files
83%defattr(644,root,root,755)
84%doc ChangeLog svn.log
85%doc INSTALL COPYING README TODO AUTHORS NEWS
86%doc docs/en/mondorescue-howto.html docs/en/mondorescue-howto.pdf
87
88%attr(755,root,root) %{_sbindir}/*
89#%attr(755,root,root) %{_libdir}/%{name}/restore-scripts/%{name}/*
90%{_libdir}
91%{_mandir}
92
93%changelog
94* Fri Feb 17 2006 Bruno Cornec <bcornec@users.berlios.de> 2.0.7
95- Updated to 2.0.7
96- RPM sepc files are now generated
97
98* Fri Nov 05 2005 Bruno Cornec <bcornec@users.berlios.de> 1.05
99- ia64 is now working
100- -p option related bug fixed
101- use libdir instead of datadir
102
103* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 2.04_berlios
104- Merge of patches mentionned on mondo ML + ia64 updates
105- Add -p option
106
107* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 2.04_cvs_20050503
108- made mondo more clever about finding its home. Avoids mondo considering
109 directories like '/usr/share/doc/momdo' as its home.
110
111* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 2.03
112- test sanity of user-specified tempdir
113- better SLES8 support
114
115* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 2.02
116- instead of using 'dd' to erase partition table, delete existing
117 partitions w/ the same call to fdisk that is used to create the
118 new partitions; this should avoids locking up the partition table
119- set bootable partition in the above same call to fdisk, for
120 the same reason (avoids locking up the partition table)
121- better software RAID support
122- mount ext3 partitions as ext2 when restoring - better for Debian
123- better star, ACL support
124- added ACL, xattr support for afio users
125
126* Fri Jun 26 2004 Hugo Rabson <hugorabson@msn.com> 2.01
127- fixed cvs for SuSE systems
128- fixed NTFS backup/restore bug relating to partimagehack
129 log file overflow and NTFS v non-NTFS differentiation
130- more reliable extraction of config info from CDs, floppies
131- better support of ISO dirs at restore-time (Conor Daly)
132- fixed spec file for SuSE users
133- added ldconfig to install section
134
135* Fri Jun 19 2004 Hugo Rabson <hugorabson@msn.com> 2.00
136- first 2.0 release
137- updated grub-install.patched to support SuSE and Red Hat
138- call 'mt' to set block size to 32K before opening in/out tape
139- updated mondo-prep.c to create each disk's partitions all at once
140 (one call per drive) instead of one call to fdisk per partition
141- when extracting cfg file and mountlist from all.tar.gz (tape copy),
142 use block size of INTERNAL_TAPE_BLK_SIZE, not TAPE_BLOCK_SIZE
143- added star and rudimentary SELinux support
144- fixed lots of bugs
145- all logging now goes to /var/log/mondo-archive.log, with symlink
146 to /tmp/mondo-restore.log for restore-time log-tracking
147- added grub-install.patched
148- removed embleer & other binaries
149- added '-b' to specify block size
150- added '-R' for star support
151
152* Thu Mar 25 2004 Bruno Cornec <Bruno.Cornec@hp.com> 1.7_cvs-20040325
153- ia64 fixes
154
155* Fri Nov 07 2003 Joshua Oreman <oremanj@get-linux.org> 1.7_cvs-20031107
156- fixed symbolic links for libraries
157- added support for boot/root multi floppies
158
159- added kdelibs as xmondo dependency
160- added xmondo pixmap installation
161- better find_cdrom_device(), to cope w/ multiple CD writers
162- fixed -m and -Vc flags
163- fixed NTFS support!
164- bootable CD uses native, not El Torito, support now
165- removed mondo-makefilelist
166- added 2.6 kernel support
167- if 2.6 kernel, insist that the user specify CD device
168- drop Embleer; insist on ms-sys and parted if Windows partition
169
170* Wed Nov 05 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031105.1
171- added -devel package
172
173* Tue Nov 04 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031104.1
174- made xmondo a second package
175- added ability to specify --without xmondo at build time
176
177* Sun Nov 02 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031102.1
178- Clean up, added spanish translation
179- Set prefix to be /usr
180- added/fixed Requires
181- remove CVS directories prior to building
182
183* Thu Oct 23 2003 Hugo Rabson <hugorabson@msn.com> 1.75_cvs_20031023
184- nothing yet
185
186* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 1.75
187- fixed chmod/chown bug (Jens Richter)
188- ask user to confirm NFS mountpoint in Interactive Mode
189- rewritten format_everything() to make sure LVMs, RAIDs and
190 regular partitions are prepped in the correct order
191- better magicdev support
192- rewritten external binary caller subroutine
193- DVD support added
194- better backup-time control gui; offer to exclude nfs if appl.
195- fixed multi-tape support
196- re-implemented -D and -J
197- fixed bug in extract_config_file_from_ramdisk() which
198 affected tape+floppy users
199- updated is_incoming_block_valid() to make it
200 return end-of-tape if >300 flotsam blocks
201- unmount CD-ROM before burning (necessary for RH8/9)
202- fixed some stray assert()'s
203- fixed bug in grub-MR (Christian)
204- make user remove floppy/CD before restoring interactively from tape
205- fixed bug in am_I_in_disaster_recovery_mode()
206- added code to nuke_mode() to make sure NFS
207 (backup) share is mounted in Nuke Mode
208- improved tape device detection code
209- better GRUB support
210- better logging of changed bigfiles at compare-time
211- better NTFS support, thanks to partimagehack-static
212- better logging
213- rewrote tape-handling code, breaking compatibility w/ previous versions
214- fixed ISO/CD biggiefile verification bug in mondoarchive
215- fixed bug which stopped boot/compare-time changelist from popping up
216- replaced mondo-makefilelist with C code - faster, cleaner
217- tweaked GUI - better feedback
218
219* Wed May 28 2003 Anonymous <root@rohan> 1.74
220- misc fixes (Michael Hanscho's friend)
221- added rudimentary support for SME
222- added better label support
223- fixed biggietime atime/ctime restoration bug 73
224- fixed 'default boot loader' detection bug (Joshua Oreman)
225- use single-threaded make_afioballs_and_images() if FreeBSD
226- fixed mondoarchive -Vi multi-CD verify bug (Tom Mortell)
227- superior get_phys_size_of_drive() (Joshua Oreman)
228- fixed RAID-related bug in where_is_root_mounted()
229- ISO tweaks
230- fixed silly bug in load_filelist() which stopped
231 funny German filenames from being handled properly
232- fixed various calls to popup_and_get_string()
233- fixed spec file
234- reject -E /
235- added partimagehack to the mix
236
237* Tue May 20 2003 Anonymous <root@rohan> 1.73
238- mark devices as bootable _after_ unmounting them
239- resolve boot device (-f) if softlink
240- post_param_configuration() --- store iso-dev and isodir
241- added post-nuke-sample.tgz to package
242- Nuke Mode now checks mountlist against hardware; offer user
243 opportunity to edit mountlist if insane; if user declines, abort
244- added lots of assert()'s and other checks
245- ran code thru Valgrind to catch & fix some memory leaks
246- made mondo-restore.c smaller by moving some subroutines to
247 common/libmondo-raid.c and mondorestore/mondo-rstr-compare.c
248- added '-Q' to let user test mondoarchive's ability to find
249 their boot loader and type
250- improved which_boot_loader()
251- when burning or comparing to a CD, defeat autorun if it is
252 running, to avoid confusing mondoarchive and the user
253- if original backup media no longer available at boot-time
254 then offer user chance to choose another media source
255- when booting, type 'nuke noresize' to nuke w/o resizing
256 mountlist to fill your drives
257- add 'textonly' when booting, to avoid using Newt gui
258- run nice(20) to prioritize mondoarchive at start
259- don't pause and wait for next blank CD at backup-time
260 unless necessary (e.g. previous CD has not been removed)
261- get_phys_size_of_drive() --- better support of older drives
262- don't eject if "donteject" is in kernel's command line
263- cleaned up segfault-handling
264- added Conor's strip_path() to improve file list display
265- added Herman Kuster's multi-level bkp patch
266- better boot-time screen/message
267- added Joshua Oreman's FreeBSD patches x3
268- fixed interactive/textonly support
269- fixed support for subdir-within-NFS-mount
270- fixed "Can't backup if ramdisk not mounted" bug
271- try to work around eccentricities of multi-CD drive PCs
272- misc clean-ups (Steve Hindle)
273
274* Tue Apr 08 2003 Hugo Rabson <hugorabson@msn.com> 1.72
275- LVM/RAID bugs fixed (Brian Borgeson)
276- major clean-up of code (Stan Benoit)
277- make-me-bootable fix (Juraj Ziegler)
278- fixed problem w/ multi-ISO verify cycle (Tom Mortell)
279- removed duplicate entry from makefile
280- if root is /dev/root then assume not a ramdisk
281- reject relative paths if -d flag (Alessandro Polverini)
282- fixed potentially infinite loop in log_to_screen (Tom Mortell)
283- add '/' to custom filelist as workaround for obscure bug
284- ask user speed of CDRW if writing to CD
285- find_cdrom_device() --- if nonexistent/not found then
286 make sure to return '' as dev str and 1 as res
287- tweaked restore scripts tgz
288- cleaned up find_cdrom_device()
289- if user creates /usr/share/mondo/payload.tgz then untar
290 payload to CD at backup-time
291- fixed insist_on_this_cd_number()
292- fixed am_i_in_disaster_recovery_mode()
293- misc clean-up (Tom Mortell)
294- made code more legible
295- fixed post-nuke support
296- added -e support
297- fixed nfs support
298- fixed iso support
299- at restore-time, only sort mountlist internally,
300 in mount_all_devices() and unmount_all_devices()
301- fixed cosmetic bug in label-partitions-as-necessary
302- updated documentation
303- fixed fstab-hacking scripts
304
305* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 1.71
306- log newt, slang, ncurses info
307- updated man page
308- handle %% chars in issue.net properly (Heiko Schlittermann)
309- fixed serious NFS restore bug
310- cleaned up spec file; it should cause fewer problems now (Jesse Keating)
311- changed various strcpy() calls to strncpy() calls
312- added mondo-makefilelist to makefile (Mikael Hultgren)
313- mount_cdrom() better at handling multiple CD drives
314- exclude /media/cdrom,cdrecorder,floppy
315- sensibly_set_tmpdir_and_scratchdir() --- exclude smb and smbfs
316- better logging by eval_call_to_make_ISO()
317- accept -J <fname> to let user provide their own fs catalog
318 instead of -I <paths> to backup
319- if dir excluded with -E or included with -I and dir is actually
320 a softlink then exclude/include the dir pointed to, as well
321- better location for manpage
322- adjusted block size of tarball at start of tape, to help
323 users w/ broken tape driver firmware
324- sort -u fstab after modifying it
325- if backup type is nfs then don't estimate noof media
326- fixed Makefile (Mikael Hultgren)
327- updated manpage
328
329* Mon Dec 07 2002 Hugo Rabson <hugo@firstlinux.net> 1.70
330- new devel branch opened
331
332* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 1.52
333- fixed bug in multithreading
334- use new grub-MR instead of grub-install
335- wipe only the partition table (not the MBR) when partitioning drives
336- ignore lilo.conf.anaconda when looking for lilo.conf file
337- accepts '-l RAW' to backup/restore original boot sector instead
338 of running grub or lilo to init it after restoring
339- fixed&updated stabgrub-me script; software RAID + GRUB work now
340- mount/unmount /boot partition for Gentoo 1.2 users
341- re-enabled extra tape checksums
342- disabled spurious warnings
343- unmount/remount supermounts at start/end of live restore, if nec.
344- cleaned up mondo's tape block handling (now, TAPE_BLOCK_SIZE=128K
345 and I've added INTERNAL_TAPE_BLK_SIZE=32K variable for buffering)
346- added Makefile
347- added -l RAW, to backup and restore original MBR
348- cleaned up iso_mode() and nfs restoring
349- create /mnt/RESTORING/mnt/.boot.d for Gentoo users
350- made mondorestore CD bootable for ArkLinux users
351- if user runs as 'su' not 'su -' then work around
352
353* Sun Nov 17 2002 Hugo Rabson <hugo@firstlinux.net> 1.51
354- pop-up list of changed files, at end of verification phase
355- better handling of changed.files list at restore-time
356- lots of CD-related fixes
357- added '-N' flag --- to let user exclude all NFS-related mounts&devices
358- better handling of 'kill'
359- restructuring of code to ease integration of mondo w/XMondo
360- fixed obscure bug in find_and_mount_actual_cd()
361- if / or /root has <50MB free then abort & complain
362- fixed install.sh
363- fixed .spec file
364- updated documentation
365- commented code
366- updated man page
367- added -v / --version flag
368- replace convoluted grep with wc (KP)
369- fixed bug affecting restoration of bigfiles from CD's created w/0 compression
370- fixed BurnProof-related bug
371- better at figuring out which is the best partition for temp/scratchdir
372- added do-not-compress-these (text file) to RPM
373- do not compress files of types listed in do-not-compress-these
374- dropped -U from call to afio - saves 20-30% runtime (Cosgrove)
375- added Cosgrove's do-not-compress-these list
376- included various patches from KP
377- chmod tmpdir, scratchdir to 700 before using
378- restore from specified backup device, even if its own cfg file disagrees
379- fixed multi-tape bug
380- fixed "Can't find first ISO when verifying nonbootable ISO" bug
381- multithreaded make_afioballs_and_images()
382- tmpdir and scratchdir are set sensibly whether mondoarchive is called with
383 command-line parameters or not
384- fixed bug in strip_spaces() which stopped it from handling
385 small strings correctly - affected mountlist editor
386- create a repaired copy of grub-install which is RAID-friendly;
387 use it when initializing boot sector with run_grub()
388- fixed bug in mondo-makefilelist
389
390* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 1.50
391- if restoring, don't try to find SCSI node of CD-ROM drive; find /dev entry
392- during selective restore, skip filesets which don't contain relevant archives
393- set /dev/null's perms to 777, just in case devfs-enabled kernel mangles it
394- remove /var/run/*.pid after restoring
395- move spurious lockfiles from /home/* to /home/*/.disabled
396- ask user to confirm the tape/CD device name
397- lots of multitape-related fixes
398- added code to autodetect the hardware of the user, if possible
399- if isodir does not exist then abort
400- more sanity-checking for -d flag
401- doubled 'biggiefile' threshold... to 32MB
402- exclude /root/images/mindi
403- fixed multi-imagedev bug (Emmanuel Druon)
404- unmount/remount /mnt/floppy before/after backing up, if Mandrake
405- restructured the source files
406- fixed serious bug in line 1546 - should have been !=, not ==; stopped
407 mondorestore from correctly restoring big files
408- added '#include <signal.h>' to my-stuff.h
409- exclude "incheckentry xwait()" from changed.files
410- fixed minor bug in find_cdrom_device()
411- fixed bug in friendly_sizestr...
412- insist on tape #1 when start verifying
413- added internal buffering, replacing the external 'buffer' exe
414- if differential backup then don't permit formatting or fdisking,
415 whether Interactive or Nuke mode
416- if mondorestore is run on live filesystem (or from ramdisk) without
417 parameters then mondorestore will ask which backup media (tape, CD, etc.)
418 was used; it will read the config file from the media and proceed from there
419- if tape streamer is softlink then resolve it first
420- incorporate post-nuke tarball
421- if user doesn't specify tape size, proceed anyway; behave intelligently
422 in the event of end-of-tape
423- prefix bkpinfo->restore_path to biggiefile fname before generating
424 checksum & comparing to archived biggiefile
425- if /etc/lilo.conf not found not /etc/lilo.conf.anaconda found
426 then create a softlink from the former to the latter, to work
427 around RH7.3's b0rken LILO support
428- LFS support (mharris, michele, hugo)
429- fixed verify bug --- CD#1 was being verified again & again & ...
430- differential mode fixed; supported again
431- ask user for boot loader + device if not detectible
432- list up to 512 files in file selection window at once (was 128)
433- better handling of bigfiles' checksums, perms and owns
434- delete final filelist if <=2 bytes long
435- if kernel not found and mondo in graphics mode then popup and ask
436 for kernel path+filename
437
438* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 1.45-1
439- 1.5x branch forked off from 1.4x branch
440
441
442
443
Note: See TracBrowser for help on using the repository browser.