source: MondoRescue/trunk/mondo/distributions/gentoo/mondo.ebuild@ 561

Last change on this file since 561 was 561, checked in by bcornec, 18 years ago

merge -r 542:560 $SVN_M/branches/stable

File size: 1.6 KB
Line 
1# Copyright 1999-2005 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Id$
4
5inherit libtool
6
7DESCRIPTION="The premier GPL disaster recovery solution."
8HOMEPAGE="http://www.mondorescue.org"
9SRC_URI="ftp://ftp.mondorecue.org/src/${PN/-rescue/}-${PV}-${PR}.tgz"
10
11LICENSE="GPL-2"
12SLOT="0"
13KEYWORDS="-* ~x86"
14IUSE=""
15
16DEPEND="virtual/libc
17 >=sys-libs/slang-1.4.1
18 >=dev-libs/newt-0.50"
19RDEPEND="app-arch/afio
20 sys-block/buffer
21 sys-devel/binutils
22 >=app-arch/bzip2-0.9
23 app-cdr/cdrtools
24 >=sys-apps/mindi-1.0.7
25 >=dev-libs/newt-0.50
26 >=sys-libs/slang-1.4.1
27 >=sys-boot/syslinux-1.52"
28
29S=${WORKDIR}/${PN/-rescue/}-${PV}-${PR}
30
31src_unpack() {
32 unpack ${A}
33 cd ${S}
34 chmod 750 configure
35}
36
37src_compile() {
38 elibtoolize
39 econf || die "Configuration failed"
40 emake VERSION=VVV || die "Make failed"
41}
42
43src_install() {
44 make install DESTDIR=${D} || die "make install failed"
45 #einstall || die "Install failed"
46 exeinto /usr/share/mondo
47 doexe mondo/autorun
48}
49
50pkg_postinst() {
51 einfo "${P} was successfully installed."
52 einfo "Please read the associated docs for help."
53 einfo "Or visit the website @ ${HOMEPAGE}"
54 echo
55 ewarn "This package is a new version after a long gap."
56 ewarn "Please report bugs to http://bugs.gentoo.org/"
57 ewarn "However, please do an advanced query to search for bugs"
58 ewarn "before reporting. This will keep down on duplicates."
59 echo
60 einfo "Prior to running mondo, ensure /boot is mounted."
61 ewarn "Grub users need to have a symlink like this:"
62 ewarn "ln -s /boot/grub/menu.lst /etc/grub.conf"
63 einfo "Unless you want to have mondo backup your distfiles,"
64 einfo "append \"-E ${DISTDIR}\" to your mondoarchive command."
65 echo
66}
Note: See TracBrowser for help on using the repository browser.