source: MondoRescue/trunk/mindi/mindi.spec@ 35

Last change on this file since 35 was 35, checked in by bcornec, 19 years ago

Again tagging improved

  • Property svn:keywords set to Id
File size: 11.7 KB
Line 
1#
2# $Id: mindi.spec 35 2005-09-29 01:16:57Z bcornec $
3#
4%define _prefix /usr
5Summary: Mindi creates emergency boot disks/CDs using your kernel, tools and modules
6Name: mindi
7Version: 1.04_berlios
8Release: 1
9License: GPL
10Group: System/Kernel and hardware
11Url: http://www.mondorescue.org
12Source: %{name}-%{version}.tgz
13BuildRoot: %{_tmppath}/%{name}-%{version}
14Requires: bzip2 >= 0.9, mkisofs, ncurses, binutils, gawk, dosfstools
15# Not on all systems
16#Conflicts: bonnie++
17Prefix: %{_prefix}
18Autoreq: 0
19
20%description
21Mindi takes your kernel, modules, tools and libraries, and puts them on N
22bootable disks (or 1 bootable CD image). You may then boot from the disks/CD
23and do system maintenance - e.g. format partitions, backup/restore data,
24verify packages, etc.
25
26%prep
27%setup
28
29%build
30%ifarch ia64
31make -f Makefile.parted2fdisk clean
32make -f Makefile.parted2fdisk
33%endif
34
35%install
36%{__rm} -Rf /usr/local/share/mindi
37%{__rm} -rf $RPM_BUILD_ROOT
38MINDIDIR=$RPM_BUILD_ROOT%{_datadir}/mindi
39%{__mkdir_p} $MINDIDIR $RPM_BUILD_ROOT%{_bindir} $RPM_BUILD_ROOT%{_sysconfdir}/mindi
40%{__mv} deplist.txt $RPM_BUILD_ROOT%{_sysconfdir}/mindi/
41%{__cp} -af * $MINDIDIR
42%ifarch ia64
43 make -f Makefile.parted2fdisk DEST=${MINDIDIR}/ install
44 %{__mv} $MINDIDIR/rootfs/bin/busybox-ia64 $MINDIDIR/rootfs/bin/busybox
45 %{__mv} $MINDIDIR/rootfs/sbin/parted2fdisk-ia64 $MINDIDIR/rootfs/sbin/parted2fdisk
46%else
47 %{__mv} $MINDIDIR/rootfs/bin/busybox-i386 $MINDIDIR/rootfs/bin/busybox
48 %{__mv} $MINDIDIR/rootfs/bin/busybox-i386.net $MINDIDIR/rootfs/bin/busybox.net
49 %{__ln_s} fdisk $MINDIDIR/rootfs/sbin/parted2fdisk
50%endif
51%{__rm} -f $MINDIDIR/rootfs/bin/busybox-ia64 $MINDIDIR/rootfs/sbin/parted2fdisk-ia64 $MINDIDIR/rootfs/bin/busybox-i386 $MINDIDIR/rootfs/bin/busybox-i386.net
52#
53# These are installed twice if not removed here
54( cd $MINDIDIR
55%{__rm} -f CHANGES INSTALL COPYING README TODO README.ia64 README.pxe
56)
57cd $RPM_BUILD_ROOT%{_bindir}
58%{__ln_s} -f %{_datadir}/mindi/mindi .
59%{__ln_s} -f %{_datadir}/mindi/parted2fdisk.pl .
60%{__ln_s} -f %{_datadir}/mindi/analyze-my-lvm .
61chmod +x $MINDIDIR/mindi
62
63%clean
64%{__rm} -rf $RPM_BUILD_ROOT
65
66%post
67%ifarch ia64
68 %{__mkdir_p} /usr/local/bin
69 if [ "`file /sbin/fdisk |grep 'LF 64-bit LSB executable'`" ] ; then
70 %{__cp} /sbin/fdisk /sbin/fdisk.mondosav
71 %{__mv} /sbin/fdisk /usr/local/bin/fdisk
72 %{__ln_s} -f /usr/share/mindi/parted2fdisk.pl /sbin/fdisk
73 echo "Warning: you fdisk binary is now under /usr/local/bin"
74 fi
75%endif
76
77%files
78%defattr(-,root,root,-)
79%config(noreplace) %{_sysconfdir}/mindi/deplist.txt
80%doc CHANGES INSTALL COPYING README TODO README.ia64 README.pxe
81#%attr(755,root,root) %{_datadir}/mindi/mindi
82
83%{_datadir}/mindi
84%{_bindir}/analyze-my-lvm
85%{_bindir}/mindi
86%{_bindir}/parted2fdisk.pl
87
88%changelog
89* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 1.04_berlios
90- Merge of patches mentionned on mondo ML + ia64 updates
91
92* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 1.04_cvs_20050503
93- supports exec-shield
94
95* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 1.03
96- better support of SLES 8
97
98* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 1.02
99- better kernel-level logging
100- added ACL, xattr binaries to deplist.txt
101- fixed obscure bug which occasionally stopped mindi from correctly finding
102 and documenting all LVM2 LVM-on-RAID volumes
103
104* Fri Jun 25 2004 Hugo Rabson <hugorabson@msn.com> 1.01
105- added ide_tape and other modules to mindi's config detection
106- unmount errant ramdisk ($mtpt) if fail to create boot floppy
107- better support of ISO dirs at restore-time (Conor Daly)
108
109* Fri Jun 18 2004 Hugo Rabson <hugorabson@msn.com> 1.00
110- first 1.0x release
111- busybox now static
112- trap Ctrl-Alt-Del; trigger soft reset
113- better SuSE 9.1 support
114- added parted2fdisk.pl (IA64) (Bruno Cornec)
115- add LVM2 support for kernel 2.6 (Takeru Komoriya)
116- better detection of multiple Mindis (Martin Fürstenau)
117- don't complain if just a Mindi boot CD & not a platform for Mondo
118- updated busybox to 1.0.0pre10
119- removed uClibc
120- add memtest support
121- 2.6 kernel support
122- removed Embleer files (Andree Leidenfrost)
123- added kernel-only floppy support, to accommodate really big kernels
124- updated+rebuilt busybox
125- added star support
126- mount /sys at boot-time
127- better 64-bit and 2.6 kernel support
128- better LVM, failsafe kernel support (Jim Richard)
129- use LILO, not raw kernel, on 1.4MB boot floppy
130- record names of unsaved modules, for future reference
131- enlarged ramdisk by 8MB
132
133* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 0.95
134- changed some '==' to '=' --- now more RH6-friendly
135- allow absolute pathnames again in deplist
136- disable multifunc cd thing
137- better Gentoo support (Bill)
138- better OnStream support
139- better Slackware support (Laurenz)
140- added partimagehack-static to deplist.txt
141- recompiled Busybox - now 10k smaller; better stack-handling
142- fixed boot screen typo
143- added support for 'auto' fs format
144- better devfs support for Mandrake users
145- better Debian+LVM support (Ralph Grewe)
146- updated analyze-my-lvm to handle floating-point gigabyte -L values
147
148* Thu Jul 24 2003 Anonymous <root@rohan> 0.94
149- altered rootfs's /dev entry to stop cvs from becoming confused
150- tweaked MAX_COMPRESSED_SIZE
151- added multi-function CD support to mindi and sbin/post-init
152- re-mount root as rw just in case
153- ask user to remove last data (floppy) disk if nec. (Tom Mortell)
154- added support for 5th column in mountlist.txt for labels
155- added symlinks.tgz
156- suppress erroneous error msgs re: failsafe kernel
157
158* Sun May 18 2003 Hugo Rabson <hugorabson@msn.com> 0.93
159- added cciss.o to SCSI_MODS
160- if format type is (e.g.) ext3,ext2 then use 1st entry
161- re-enabled fsck*
162- if cciss in use the enable it at boot-time
163- added /dev/ataraid/* to boot disk via ataraid.tgz (Luc S.)
164- better ISO support
165- tweaked Mindi to use 10-15% fewer floppies
166- added RUN_AFTER_INITIAL_BOOT_PHASE to let user specify a command
167 to be run by Mindi before it bootstraps to aux data disks;
168 e.g. 'echo engage > /proc/scsi/something'
169- added RUN_AFTER_BOOT_PHASE_COMPLETE to let user specify a command
170 to be run by Mindi after it boots but before it runs mondorestore
171- allow for Debian & other Stiefkinder that use 'none', not 'swap'
172 as the mountpoint of the swap partition
173- removed afio dependency
174- re-worked install.sh and tarball not to use tgz's
175- cleared up the boot msg
176- updated busybox to 0.60.5; updated uClibc to 0.9.19
177- add #!/bin/sh to start of insert-all-my-modules
178- fixed obscure bug in install-additional-tools
179- changed grep -m to grep | head -n1 for Debian users
180- moved vmlinuz, lib.tar.bz2 to mindi-kernel tarball/rpm
181
182* Wed Apr 09 2003 Hugo Rabson <hugorabson@msn.com> 0.92
183- fixed LVM/RAID bugs (Brian Borgeson)
184- if bad lilo, give more verbose error before quitting
185- added mt and perl to deplist.txt
186- insist on gawk being present
187- insmod ide-cd, cdrom, isofs, just in case
188- boot-time tmpfs ramdisk is now 40m (was 34m)
189- cleaned up logs
190- iso mode now calls Interactive
191- make SizeOfPartition() more Debian-friendly (Andree Leidenfrost)
192- clean up some calls to grep, esp. partition_mountpt=...
193- corrected some bashisms, to suit Debian ped- er, users
194- made first line refer to bash, not sh, to make sure
195 the Debian people know Mindi requires bash, not hs
196- changed grep -v "#" and grep -vx "#.*" to grep -vx " *#.*"
197- disabled code which would have made Mindi use sfdisk instead of fdisk
198 if it looked as if Debian's fdisk would misbehave
199
200* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 0.91
201- new devel branch
202- EXTRA_SPACE=16384
203- updated ResolveSoftlinks() to work better with b0rkn Gentoo devfs /dev
204- patched analyze-my-lvm (Benjamin Mampaey)
205- detect built-in boot.b files in lilo
206- cleaned up spec file a bit, more use of macros (Jesse Keating)
207- return w/err, don't abort, if Matt Nelson's RH8 system is farked
208- better at finding isolinux.bin
209- better at analyzing dependencies when running on broken distributions
210- try harder to boot from CD, even if tape fails
211- added ADDITIONAL_BOOT_PARAMS to be sent to kernel
212- better resolution of relative softlinks, leading to fewer
213 duplicates on data disks and therefore fewer data disks
214- detect Debian+devfs; use sfdisk instead of fdisk in that
215 eventuality, to work around yet another of Debian's warts
216- removed /lib/libuuid.* from rootfs.tgz
217- fixed vi
218- mindi now uses gawk --traditional (making gawk behave in a functionally
219 identical way to awk) - PASS; great, so now Debian needs to fix its awk :)
220- removed / from list of dirs accessed when trying to resolve deplist entry
221- spinner bugfix; handle odd LABELs properly (Tom Mortell)
222- fixed LVM/RAID bugs (Brian Borgeson)
223
224* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 0.72_20021202
225- misc code clean-up
226- save boot device's boot sector
227- detect and beware Compaq diagnostic partitions
228- better handling of devfs V non-devfs kernels and boot devs
229- trimmed busybox 0.60.3 binary on boot disk
230- mindi now resides in /usr/local/bin
231- removed lilo from dependencies
232- more Gentoo-friendly
233
234* Sun Nov 18 2002 Hugo Rabson <hugo@firstlinux.net> 0.71
235- if your kernel's builddate doesn't match any of the kernels in
236 your /boot directory then fudge the issue & find the closest
237 match (*grumble* Debian)
238- scan tape & CD at start, to force inclusion of modules on boot device
239- double EXTRA_SPACE if >7 disks
240- slimmer, more lithesome logfile
241- now accepts --findkernel
242- line 1982 - dd count=24000 should be count=$ramdisksize (Andras Korn)
243- better handling of non-Linux partitions on DevFS-enabled kernels
244- misc clean-ups
245- fixed Debian/ramdisksize/bloat problem (Johannes Franken)
246- fixed 2.4.20/fdisk eccentricity (Alistair Stevens)
247- updated kernel to 2.4.18-mdk6
248- generate mountlist in dev-abetical order ;)
249- fixed minor bug in .spec file
250- better at finding /boot/boot.b if your distro breaks the de facto standard
251- fixed minor bug in MakeMountlist
252- fixed install.sh
253- cleaned up deplist.txt
254- added rudimentary -v / --version flag
255- line 1180 or so --- duplicate mindi.iso entries --- fixed
256- added /bin/[ - a softlink to /bin/sh
257- ListAllPartitions() - sanity fix (KP)
258- fixed .spec bug
259- better feedback
260- added Markus's RAID patch
261- ListAllPartitions() - include /mnt/win* (Hugo)
262
263* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 0.70
264- better logging by dependency-calculating code
265- better handling of dependencies, specifically softlinks
266- if called by mondo then use mondo's temp dir as our temp dir too
267- changed gawk to $AWK in a few places, to allow for Debian
268- added host* config files to deplist
269- added tftp, ifconfig to busybox
270- added RPC support to uClibc
271- cleaned up creation of Mondo-Mindi configuration file
272- fixed bug in TryToFindKernelPath which stopped it from handling
273 multiple, same-version kernels gracefully
274- cleaned up deplist.txt
275- receive 'DIFFERENTIAL' variable from Mondo
276- better Debian compatibility, esp. w/detection of ver# (Hector Alvarez)
277- better devfs support; call fgrep in places instead of grep (Andrew Korn)
278- fixed analyze-my-lvm (Ralph Gruwe)
279- moved 50K of stuff from rootfs.tgz to aux-tools.tgz
280- added x11-tools.tgz option
281- updated /dev/console and /dev/tty0 (Paul Stevens)
282- cleaned up /mnt/groovy-stuff V /tmp/tmpfs code
283- catch sigint, sighup, etc.
284- fixed LILO-related message.txt mistake
285- .spec file clean-up; automation; config file (Carl Wilhem Soderstrom)
286- better devfs support (Andrew Korn)
287
288* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 0.64-1
289- fixed RH7.3 readonly bug
290- improved nfs config file creation
291- search more locations for isolinux.bin
292- added isonuke option
293- faster data disk creation
294- better DevFS support (Hector Alvarez, DuckX)
295- nfs-related fix (Hans Lie)
296- abort if vfat filesystem present but mkfs.vfat missing
297- removed softlink to pico
298- allow Mondo to say no compression will be used
299- added [ to ramdisk
300- tar data disks with -b [block size] of 32k
301- don't autoboot to 'RESTORE' screen - it's scary!
302- let user choose lilo or syslinux as boot loader
303- added syslinux support
304- cleaned up message screens
305
Note: See TracBrowser for help on using the repository browser.