source: MondoRescue/trunk/mindi/mindi.spec@ 278

Last change on this file since 278 was 262, checked in by bcornec, 18 years ago

merge -r253:261 $SVN_M/branches/2.05

  • Property svn:keywords set to Id
File size: 11.6 KB
Line 
1#
2# $Id: mindi.spec 262 2005-12-23 16:25:52Z bcornec $
3#
4%define is_mandriva %(test -e /etc/mandriva-release && echo 1 || echo 0)
5%define is_mandrake %(test -e /etc/mandrake-release && echo 1 || echo 0)
6%define is_suse %(test -e /etc/SuSE-release && echo 1 || echo 0)
7%define is_fedora %(test -e /etc/fedora-release && echo 1 || echo 0)
8%define is_redhat %(test -e /etc/redhat-release && echo 1 || echo 0)
9
10%define name mindi
11%define version VVV
12%define mrel 1
13%define src %{name}-%{version}.tgz
14
15%if %is_redhat
16Group: Applications/Archiving
17Autoreq: 0
18%endif
19
20%if %is_mandrake
21%define src %{name}-%{version}.tar.bz2
22Group: Archiving/Backup
23Autoreqprov: no
24%endif
25
26%if %is_mandriva
27%define src %{name}-%{version}.tar.bz2
28Group: Archiving/Backup
29Autoreqprov: no
30%endif
31
32%if %is_suse
33Group: Archiving/Backup
34%endif
35
36Summary: Mindi creates emergency boot disks/CDs using your kernel, tools and modules
37Name: %name
38Version: %version
39Release: %mrel
40License: GPL
41Group: System/Kernel and hardware
42Url: http://mondorescue.berlios.de
43Source: %{src}
44BuildRoot: %{_tmppath}/%{name}-%{version}
45Requires: bzip2 >= 0.9, mkisofs, ncurses, binutils, gawk, dosfstools, afio, which
46# Not on all systems
47#Conflicts: bonnie++
48
49%description
50Mindi takes your kernel, modules, tools and libraries, and puts them on N
51bootable disks (or 1 bootable CD image). You may then boot from the disks/CD
52and do system maintenance - e.g. format partitions, backup/restore data,
53verify packages, etc.
54
55%prep
56%{__rm} -rf $RPM_BUILD_ROOT
57%setup -n %name-%{version}
58
59%build
60%ifarch ia64
61%{__make} -f Makefile.parted2fdisk clean
62%{__make} -f Makefile.parted2fdisk
63%endif
64
65%install
66export DONT_RELINK=1
67
68%{__rm} -rf $RPM_BUILD_ROOT
69export PREFIX=${RPM_BUILD_ROOT}%{_exec_prefix}
70export CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}
71export RPMBUILDMINDI="true"
72
73./install.sh
74
75%if %is_suse
76%{__rm} -rf $RPM_BUILD_ROOT/%{_datadir}/doc/%name-%{version}
77%endif
78
79%clean
80%{__rm} -rf $RPM_BUILD_ROOT
81
82%post
83for i in %{_libdir}/mindi/aux-tools/sbin/* %{_libdir}/mindi/rootfs/bin/* %{_libdir}/mindi/rootfs/sbin/* ; do
84 if [ ! -h $i ]; then
85 %{__chmod} 755 $i
86 fi
87done
88if [ -f /usr/local/sbin/mindi ]; then
89 echo "WARNING: /usr/local/sbin/mindi exists. You should probably remove your manual mindi installation !"
90fi
91
92%files
93%defattr(644,root,root,755)
94%config(noreplace) %{_sysconfdir}/mindi/deplist.txt
95%doc ChangeLog INSTALL COPYING README TODO README.ia64 README.pxe README.busybox
96%{_mandir}
97%{_libdir}/mindi
98%attr(755,root,root) %{_sbindir}/*
99
100%changelog
101* Fri Nov 05 2005 Bruno Cornec <bcornec@users.berlios.de> 1.05
102- ia64 is now working
103- use install.sh script
104- use libdir for binary data
105
106* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 1.04_berlios
107- Merge of patches mentionned on mondo ML + ia64 updates
108- Fix bugs when called alone
109
110* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 1.04_cvs_20050503
111- supports exec-shield
112
113* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 1.03
114- better support of SLES 8
115
116* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 1.02
117- better kernel-level logging
118- added ACL, xattr binaries to deplist.txt
119- fixed obscure bug which occasionally stopped mindi from correctly finding
120 and documenting all LVM2 LVM-on-RAID volumes
121
122* Fri Jun 25 2004 Hugo Rabson <hugorabson@msn.com> 1.01
123- added ide_tape and other modules to mindi's config detection
124- unmount errant ramdisk ($mtpt) if fail to create boot floppy
125- better support of ISO dirs at restore-time (Conor Daly)
126
127* Fri Jun 18 2004 Hugo Rabson <hugorabson@msn.com> 1.00
128- first 1.0x release
129- busybox now static
130- trap Ctrl-Alt-Del; trigger soft reset
131- better SuSE 9.1 support
132- added parted2fdisk.pl (IA64) (Bruno Cornec)
133- add LVM2 support for kernel 2.6 (Takeru Komoriya)
134- better detection of multiple Mindis (Martin Fürstenau)
135- don't complain if just a Mindi boot CD & not a platform for Mondo
136- updated busybox to 1.0.0pre10
137- removed uClibc
138- add memtest support
139- 2.6 kernel support
140- removed Embleer files (Andree Leidenfrost)
141- added kernel-only floppy support, to accommodate really big kernels
142- updated+rebuilt busybox
143- added star support
144- mount /sys at boot-time
145- better 64-bit and 2.6 kernel support
146- better LVM, failsafe kernel support (Jim Richard)
147- use LILO, not raw kernel, on 1.4MB boot floppy
148- record names of unsaved modules, for future reference
149- enlarged ramdisk by 8MB
150
151* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 0.95
152- changed some '==' to '=' --- now more RH6-friendly
153- allow absolute pathnames again in deplist
154- disable multifunc cd thing
155- better Gentoo support (Bill)
156- better OnStream support
157- better Slackware support (Laurenz)
158- added partimagehack-static to deplist.txt
159- recompiled Busybox - now 10k smaller; better stack-handling
160- fixed boot screen typo
161- added support for 'auto' fs format
162- better devfs support for Mandrake users
163- better Debian+LVM support (Ralph Grewe)
164- updated analyze-my-lvm to handle floating-point gigabyte -L values
165
166* Thu Jul 24 2003 Anonymous <root@rohan> 0.94
167- altered rootfs's /dev entry to stop cvs from becoming confused
168- tweaked MAX_COMPRESSED_SIZE
169- added multi-function CD support to mindi and sbin/post-init
170- re-mount root as rw just in case
171- ask user to remove last data (floppy) disk if nec. (Tom Mortell)
172- added support for 5th column in mountlist.txt for labels
173- added symlinks.tgz
174- suppress erroneous error msgs re: failsafe kernel
175
176* Sun May 18 2003 Hugo Rabson <hugorabson@msn.com> 0.93
177- added cciss.o to SCSI_MODS
178- if format type is (e.g.) ext3,ext2 then use 1st entry
179- re-enabled fsck*
180- if cciss in use the enable it at boot-time
181- added /dev/ataraid/* to boot disk via ataraid.tgz (Luc S.)
182- better ISO support
183- tweaked Mindi to use 10-15% fewer floppies
184- added RUN_AFTER_INITIAL_BOOT_PHASE to let user specify a command
185 to be run by Mindi before it bootstraps to aux data disks;
186 e.g. 'echo engage > /proc/scsi/something'
187- added RUN_AFTER_BOOT_PHASE_COMPLETE to let user specify a command
188 to be run by Mindi after it boots but before it runs mondorestore
189- allow for Debian & other Stiefkinder that use 'none', not 'swap'
190 as the mountpoint of the swap partition
191- removed afio dependency
192- re-worked install.sh and tarball not to use tgz's
193- cleared up the boot msg
194- updated busybox to 0.60.5; updated uClibc to 0.9.19
195- add #!/bin/sh to start of insert-all-my-modules
196- fixed obscure bug in install-additional-tools
197- changed grep -m to grep | head -n1 for Debian users
198- moved vmlinuz, lib.tar.bz2 to mindi-kernel tarball/rpm
199
200* Wed Apr 09 2003 Hugo Rabson <hugorabson@msn.com> 0.92
201- fixed LVM/RAID bugs (Brian Borgeson)
202- if bad lilo, give more verbose error before quitting
203- added mt and perl to deplist.txt
204- insist on gawk being present
205- insmod ide-cd, cdrom, isofs, just in case
206- boot-time tmpfs ramdisk is now 40m (was 34m)
207- cleaned up logs
208- iso mode now calls Interactive
209- make SizeOfPartition() more Debian-friendly (Andree Leidenfrost)
210- clean up some calls to grep, esp. partition_mountpt=...
211- corrected some bashisms, to suit Debian ped- er, users
212- made first line refer to bash, not sh, to make sure
213 the Debian people know Mindi requires bash, not hs
214- changed grep -v "#" and grep -vx "#.*" to grep -vx " *#.*"
215- disabled code which would have made Mindi use sfdisk instead of fdisk
216 if it looked as if Debian's fdisk would misbehave
217
218* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 0.91
219- new devel branch
220- EXTRA_SPACE=16384
221- updated ResolveSoftlinks() to work better with b0rkn Gentoo devfs /dev
222- patched analyze-my-lvm (Benjamin Mampaey)
223- detect built-in boot.b files in lilo
224- cleaned up spec file a bit, more use of macros (Jesse Keating)
225- return w/err, don't abort, if Matt Nelson's RH8 system is farked
226- better at finding isolinux.bin
227- better at analyzing dependencies when running on broken distributions
228- try harder to boot from CD, even if tape fails
229- added ADDITIONAL_BOOT_PARAMS to be sent to kernel
230- better resolution of relative softlinks, leading to fewer
231 duplicates on data disks and therefore fewer data disks
232- detect Debian+devfs; use sfdisk instead of fdisk in that
233 eventuality, to work around yet another of Debian's warts
234- removed /lib/libuuid.* from rootfs.tgz
235- fixed vi
236- mindi now uses gawk --traditional (making gawk behave in a functionally
237 identical way to awk) - PASS; great, so now Debian needs to fix its awk :)
238- removed / from list of dirs accessed when trying to resolve deplist entry
239- spinner bugfix; handle odd LABELs properly (Tom Mortell)
240- fixed LVM/RAID bugs (Brian Borgeson)
241
242* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 0.72_20021202
243- misc code clean-up
244- save boot device's boot sector
245- detect and beware Compaq diagnostic partitions
246- better handling of devfs V non-devfs kernels and boot devs
247- trimmed busybox 0.60.3 binary on boot disk
248- mindi now resides in /usr/local/bin
249- removed lilo from dependencies
250- more Gentoo-friendly
251
252* Sun Nov 18 2002 Hugo Rabson <hugo@firstlinux.net> 0.71
253- if your kernel's builddate doesn't match any of the kernels in
254 your /boot directory then fudge the issue & find the closest
255 match (*grumble* Debian)
256- scan tape & CD at start, to force inclusion of modules on boot device
257- double EXTRA_SPACE if >7 disks
258- slimmer, more lithesome logfile
259- now accepts --findkernel
260- line 1982 - dd count=24000 should be count=$ramdisksize (Andras Korn)
261- better handling of non-Linux partitions on DevFS-enabled kernels
262- misc clean-ups
263- fixed Debian/ramdisksize/bloat problem (Johannes Franken)
264- fixed 2.4.20/fdisk eccentricity (Alistair Stevens)
265- updated kernel to 2.4.18-mdk6
266- generate mountlist in dev-abetical order ;)
267- fixed minor bug in .spec file
268- better at finding /boot/boot.b if your distro breaks the de facto standard
269- fixed minor bug in MakeMountlist
270- fixed install.sh
271- cleaned up deplist.txt
272- added rudimentary -v / --version flag
273- line 1180 or so --- duplicate mindi.iso entries --- fixed
274- added /bin/[ - a softlink to /bin/sh
275- ListAllPartitions() - sanity fix (KP)
276- fixed .spec bug
277- better feedback
278- added Markus's RAID patch
279- ListAllPartitions() - include /mnt/win* (Hugo)
280
281* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 0.70
282- better logging by dependency-calculating code
283- better handling of dependencies, specifically softlinks
284- if called by mondo then use mondo's temp dir as our temp dir too
285- changed gawk to $AWK in a few places, to allow for Debian
286- added host* config files to deplist
287- added tftp, ifconfig to busybox
288- added RPC support to uClibc
289- cleaned up creation of Mondo-Mindi configuration file
290- fixed bug in TryToFindKernelPath which stopped it from handling
291 multiple, same-version kernels gracefully
292- cleaned up deplist.txt
293- receive 'DIFFERENTIAL' variable from Mondo
294- better Debian compatibility, esp. w/detection of ver# (Hector Alvarez)
295- better devfs support; call fgrep in places instead of grep (Andrew Korn)
296- fixed analyze-my-lvm (Ralph Gruwe)
297- moved 50K of stuff from rootfs.tgz to aux-tools.tgz
298- added x11-tools.tgz option
299- updated /dev/console and /dev/tty0 (Paul Stevens)
300- cleaned up /mnt/groovy-stuff V /tmp/tmpfs code
301- catch sigint, sighup, etc.
302- fixed LILO-related message.txt mistake
303- .spec file clean-up; automation; config file (Carl Wilhem Soderstrom)
304- better devfs support (Andrew Korn)
305
306* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 0.64-1
307- fixed RH7.3 readonly bug
308- improved nfs config file creation
309- search more locations for isolinux.bin
310- added isonuke option
311- faster data disk creation
312- better DevFS support (Hector Alvarez, DuckX)
313- nfs-related fix (Hans Lie)
314- abort if vfat filesystem present but mkfs.vfat missing
315- removed softlink to pico
316- allow Mondo to say no compression will be used
317- added [ to ramdisk
318- tar data disks with -b [block size] of 32k
319- don't autoboot to 'RESTORE' screen - it's scary!
320- let user choose lilo or syslinux as boot loader
321- added syslinux support
322- cleaned up message screens
323
Note: See TracBrowser for help on using the repository browser.