source: MondoRescue/trunk/mindi/mindi.spec@ 15

Last change on this file since 15 was 15, checked in by bcornec, 19 years ago

Dependancies updated in .spec

File size: 11.7 KB
Line 
1%define _prefix /usr
2Summary: Mindi creates emergency boot disks/CDs using your kernel, tools and modules
3Name: mindi
4Version: 1.04_berlios
5Release: 1
6License: GPL
7Group: System/Kernel and hardware
8Url: http://www.mondorescue.org
9Source: %{name}-%{version}.tgz
10BuildRoot: %{_tmppath}/%{name}-%{version}
11Requires: bzip2 >= 0.9, mkisofs, ncurses, binutils, gawk, dosfstools
12Conflicts: bonnie++
13Prefix: %{_prefix}
14Autoreq: 0
15
16%description
17Mindi takes your kernel, modules, tools and libraries, and puts them on N
18bootable disks (or 1 bootable CD image). You may then boot from the disks/CD
19and do system maintenance - e.g. format partitions, backup/restore data,
20verify packages, etc.
21
22%prep
23%setup
24
25%build
26%ifarch ia64
27make -f Makefile.parted2fdisk clean
28make -f Makefile.parted2fdisk
29%endif
30
31%install
32%{__rm} -Rf /usr/local/share/mindi
33%{__rm} -rf $RPM_BUILD_ROOT
34MINDIDIR=$RPM_BUILD_ROOT%{_datadir}/mindi
35%{__mkdir_p} $MINDIDIR $RPM_BUILD_ROOT%{_bindir} $RPM_BUILD_ROOT%{_sysconfdir}/mindi
36%{__mv} deplist.txt $RPM_BUILD_ROOT%{_sysconfdir}/mindi/
37%{__cp} -af * $MINDIDIR
38%ifarch ia64
39 make -f Makefile.parted2fdisk DEST=${MINDIDIR}/ install
40 %{__mv} $MINDIDIR/rootfs/bin/busybox-ia64 $MINDIDIR/rootfs/bin/busybox
41 %{__mv} $MINDIDIR/rootfs/sbin/parted2fdisk-ia64 $MINDIDIR/rootfs/sbin/parted2fdisk
42%else
43 %{__mv} $MINDIDIR/rootfs/bin/busybox-i386 $MINDIDIR/rootfs/bin/busybox
44 %{__mv} $MINDIDIR/rootfs/bin/busybox-i386.net $MINDIDIR/rootfs/bin/busybox.net
45 %{__ln_s} fdisk $MINDIDIR/rootfs/sbin/parted2fdisk
46%endif
47%{__rm} -f $MINDIDIR/rootfs/bin/busybox-ia64 $MINDIDIR/rootfs/sbin/parted2fdisk-ia64 $MINDIDIR/rootfs/bin/busybox-i386 $MINDIDIR/rootfs/bin/busybox-i386.net
48#
49# These are installed twice if not removed here
50( cd $MINDIDIR
51%{__rm} -f CHANGES INSTALL COPYING README TODO README.ia64 README.pxe
52)
53cd $RPM_BUILD_ROOT%{_bindir}
54%{__ln_s} -f %{_datadir}/mindi/mindi .
55%{__ln_s} -f %{_datadir}/mindi/parted2fdisk.pl .
56%{__ln_s} -f %{_datadir}/mindi/analyze-my-lvm .
57chmod +x $MINDIDIR/mindi
58
59%clean
60%{__rm} -rf $RPM_BUILD_ROOT
61
62%post
63%ifarch ia64
64 %{__mkdir_p} /usr/local/bin
65 if [ "`file /sbin/fdisk |grep 'LF 64-bit LSB executable'`" ] ; then
66 %{__cp} /sbin/fdisk /sbin/fdisk.mondosav
67 %{__mv} /sbin/fdisk /usr/local/bin/fdisk
68 %{__ln_s} -f /usr/share/mindi/parted2fdisk.pl /sbin/fdisk
69 echo "Warning: you fdisk binary is now under /usr/local/bin"
70 fi
71%endif
72
73%files
74%defattr(-,root,root,-)
75%config(noreplace) %{_sysconfdir}/mindi/deplist.txt
76%doc CHANGES INSTALL COPYING README TODO README.ia64 README.pxe
77#%attr(755,root,root) %{_datadir}/mindi/mindi
78
79%{_datadir}/mindi
80%{_bindir}/analyze-my-lvm
81%{_bindir}/mindi
82%{_bindir}/parted2fdisk.pl
83
84%changelog
85* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 1.04_berlios
86- Merge of patches mentionned on mondo ML + ia64 updates
87
88* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 1.04_cvs_20050503
89- supports exec-shield
90
91* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 1.03
92- better support of SLES 8
93
94* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 1.02
95- better kernel-level logging
96- added ACL, xattr binaries to deplist.txt
97- fixed obscure bug which occasionally stopped mindi from correctly finding
98 and documenting all LVM2 LVM-on-RAID volumes
99
100* Fri Jun 25 2004 Hugo Rabson <hugorabson@msn.com> 1.01
101- added ide_tape and other modules to mindi's config detection
102- unmount errant ramdisk ($mtpt) if fail to create boot floppy
103- better support of ISO dirs at restore-time (Conor Daly)
104
105* Fri Jun 18 2004 Hugo Rabson <hugorabson@msn.com> 1.00
106- first 1.0x release
107- busybox now static
108- trap Ctrl-Alt-Del; trigger soft reset
109- better SuSE 9.1 support
110- added parted2fdisk.pl (IA64) (Bruno Cornec)
111- add LVM2 support for kernel 2.6 (Takeru Komoriya)
112- better detection of multiple Mindis (Martin Fürstenau)
113- don't complain if just a Mindi boot CD & not a platform for Mondo
114- updated busybox to 1.0.0pre10
115- removed uClibc
116- add memtest support
117- 2.6 kernel support
118- removed Embleer files (Andree Leidenfrost)
119- added kernel-only floppy support, to accommodate really big kernels
120- updated+rebuilt busybox
121- added star support
122- mount /sys at boot-time
123- better 64-bit and 2.6 kernel support
124- better LVM, failsafe kernel support (Jim Richard)
125- use LILO, not raw kernel, on 1.4MB boot floppy
126- record names of unsaved modules, for future reference
127- enlarged ramdisk by 8MB
128
129* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 0.95
130- changed some '==' to '=' --- now more RH6-friendly
131- allow absolute pathnames again in deplist
132- disable multifunc cd thing
133- better Gentoo support (Bill)
134- better OnStream support
135- better Slackware support (Laurenz)
136- added partimagehack-static to deplist.txt
137- recompiled Busybox - now 10k smaller; better stack-handling
138- fixed boot screen typo
139- added support for 'auto' fs format
140- better devfs support for Mandrake users
141- better Debian+LVM support (Ralph Grewe)
142- updated analyze-my-lvm to handle floating-point gigabyte -L values
143
144* Thu Jul 24 2003 Anonymous <root@rohan> 0.94
145- altered rootfs's /dev entry to stop cvs from becoming confused
146- tweaked MAX_COMPRESSED_SIZE
147- added multi-function CD support to mindi and sbin/post-init
148- re-mount root as rw just in case
149- ask user to remove last data (floppy) disk if nec. (Tom Mortell)
150- added support for 5th column in mountlist.txt for labels
151- added symlinks.tgz
152- suppress erroneous error msgs re: failsafe kernel
153
154* Sun May 18 2003 Hugo Rabson <hugorabson@msn.com> 0.93
155- added cciss.o to SCSI_MODS
156- if format type is (e.g.) ext3,ext2 then use 1st entry
157- re-enabled fsck*
158- if cciss in use the enable it at boot-time
159- added /dev/ataraid/* to boot disk via ataraid.tgz (Luc S.)
160- better ISO support
161- tweaked Mindi to use 10-15% fewer floppies
162- added RUN_AFTER_INITIAL_BOOT_PHASE to let user specify a command
163 to be run by Mindi before it bootstraps to aux data disks;
164 e.g. 'echo engage > /proc/scsi/something'
165- added RUN_AFTER_BOOT_PHASE_COMPLETE to let user specify a command
166 to be run by Mindi after it boots but before it runs mondorestore
167- allow for Debian & other Stiefkinder that use 'none', not 'swap'
168 as the mountpoint of the swap partition
169- removed afio dependency
170- re-worked install.sh and tarball not to use tgz's
171- cleared up the boot msg
172- updated busybox to 0.60.5; updated uClibc to 0.9.19
173- add #!/bin/sh to start of insert-all-my-modules
174- fixed obscure bug in install-additional-tools
175- changed grep -m to grep | head -n1 for Debian users
176- moved vmlinuz, lib.tar.bz2 to mindi-kernel tarball/rpm
177
178* Wed Apr 09 2003 Hugo Rabson <hugorabson@msn.com> 0.92
179- fixed LVM/RAID bugs (Brian Borgeson)
180- if bad lilo, give more verbose error before quitting
181- added mt and perl to deplist.txt
182- insist on gawk being present
183- insmod ide-cd, cdrom, isofs, just in case
184- boot-time tmpfs ramdisk is now 40m (was 34m)
185- cleaned up logs
186- iso mode now calls Interactive
187- make SizeOfPartition() more Debian-friendly (Andree Leidenfrost)
188- clean up some calls to grep, esp. partition_mountpt=...
189- corrected some bashisms, to suit Debian ped- er, users
190- made first line refer to bash, not sh, to make sure
191 the Debian people know Mindi requires bash, not hs
192- changed grep -v "#" and grep -vx "#.*" to grep -vx " *#.*"
193- disabled code which would have made Mindi use sfdisk instead of fdisk
194 if it looked as if Debian's fdisk would misbehave
195
196* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 0.91
197- new devel branch
198- EXTRA_SPACE=16384
199- updated ResolveSoftlinks() to work better with b0rkn Gentoo devfs /dev
200- patched analyze-my-lvm (Benjamin Mampaey)
201- detect built-in boot.b files in lilo
202- cleaned up spec file a bit, more use of macros (Jesse Keating)
203- return w/err, don't abort, if Matt Nelson's RH8 system is farked
204- better at finding isolinux.bin
205- better at analyzing dependencies when running on broken distributions
206- try harder to boot from CD, even if tape fails
207- added ADDITIONAL_BOOT_PARAMS to be sent to kernel
208- better resolution of relative softlinks, leading to fewer
209 duplicates on data disks and therefore fewer data disks
210- detect Debian+devfs; use sfdisk instead of fdisk in that
211 eventuality, to work around yet another of Debian's warts
212- removed /lib/libuuid.* from rootfs.tgz
213- fixed vi
214- mindi now uses gawk --traditional (making gawk behave in a functionally
215 identical way to awk) - PASS; great, so now Debian needs to fix its awk :)
216- removed / from list of dirs accessed when trying to resolve deplist entry
217- spinner bugfix; handle odd LABELs properly (Tom Mortell)
218- fixed LVM/RAID bugs (Brian Borgeson)
219
220* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 0.72_20021202
221- misc code clean-up
222- save boot device's boot sector
223- detect and beware Compaq diagnostic partitions
224- better handling of devfs V non-devfs kernels and boot devs
225- trimmed busybox 0.60.3 binary on boot disk
226- mindi now resides in /usr/local/bin
227- removed lilo from dependencies
228- more Gentoo-friendly
229
230* Sun Nov 18 2002 Hugo Rabson <hugo@firstlinux.net> 0.71
231- if your kernel's builddate doesn't match any of the kernels in
232 your /boot directory then fudge the issue & find the closest
233 match (*grumble* Debian)
234- scan tape & CD at start, to force inclusion of modules on boot device
235- double EXTRA_SPACE if >7 disks
236- slimmer, more lithesome logfile
237- now accepts --findkernel
238- line 1982 - dd count=24000 should be count=$ramdisksize (Andras Korn)
239- better handling of non-Linux partitions on DevFS-enabled kernels
240- misc clean-ups
241- fixed Debian/ramdisksize/bloat problem (Johannes Franken)
242- fixed 2.4.20/fdisk eccentricity (Alistair Stevens)
243- updated kernel to 2.4.18-mdk6
244- generate mountlist in dev-abetical order ;)
245- fixed minor bug in .spec file
246- better at finding /boot/boot.b if your distro breaks the de facto standard
247- fixed minor bug in MakeMountlist
248- fixed install.sh
249- cleaned up deplist.txt
250- added rudimentary -v / --version flag
251- line 1180 or so --- duplicate mindi.iso entries --- fixed
252- added /bin/[ - a softlink to /bin/sh
253- ListAllPartitions() - sanity fix (KP)
254- fixed .spec bug
255- better feedback
256- added Markus's RAID patch
257- ListAllPartitions() - include /mnt/win* (Hugo)
258
259* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 0.70
260- better logging by dependency-calculating code
261- better handling of dependencies, specifically softlinks
262- if called by mondo then use mondo's temp dir as our temp dir too
263- changed gawk to $AWK in a few places, to allow for Debian
264- added host* config files to deplist
265- added tftp, ifconfig to busybox
266- added RPC support to uClibc
267- cleaned up creation of Mondo-Mindi configuration file
268- fixed bug in TryToFindKernelPath which stopped it from handling
269 multiple, same-version kernels gracefully
270- cleaned up deplist.txt
271- receive 'DIFFERENTIAL' variable from Mondo
272- better Debian compatibility, esp. w/detection of ver# (Hector Alvarez)
273- better devfs support; call fgrep in places instead of grep (Andrew Korn)
274- fixed analyze-my-lvm (Ralph Gruwe)
275- moved 50K of stuff from rootfs.tgz to aux-tools.tgz
276- added x11-tools.tgz option
277- updated /dev/console and /dev/tty0 (Paul Stevens)
278- cleaned up /mnt/groovy-stuff V /tmp/tmpfs code
279- catch sigint, sighup, etc.
280- fixed LILO-related message.txt mistake
281- .spec file clean-up; automation; config file (Carl Wilhem Soderstrom)
282- better devfs support (Andrew Korn)
283
284* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 0.64-1
285- fixed RH7.3 readonly bug
286- improved nfs config file creation
287- search more locations for isolinux.bin
288- added isonuke option
289- faster data disk creation
290- better DevFS support (Hector Alvarez, DuckX)
291- nfs-related fix (Hans Lie)
292- abort if vfat filesystem present but mkfs.vfat missing
293- removed softlink to pico
294- allow Mondo to say no compression will be used
295- added [ to ramdisk
296- tar data disks with -b [block size] of 32k
297- don't autoboot to 'RESTORE' screen - it's scary!
298- let user choose lilo or syslinux as boot loader
299- added syslinux support
300- cleaned up message screens
301
Note: See TracBrowser for help on using the repository browser.