source: MondoRescue/trunk/mindi/distributions/rpm/mindi.spec@ 496

Last change on this file since 496 was 496, checked in by bcornec, 18 years ago

merge -r 489:495 $SVN_M/branches/stable

  • Property svn:keywords set to Id
File size: 2.0 KB
RevLine 
[35]1#
2# $Id: mindi.spec 496 2006-04-21 23:10:04Z bcornec $
3#
[50]4%define name mindi
[237]5%define version VVV
[313]6%define mrel RRR
[388]7%define src SSS
8%define grp GRP
9%define addreqb bzip2 >= 0.9, mkisofs, ncurses, binutils, gawk, dosfstools
10%define addreq DDD
[426]11%define rel %{mrel}
[388]12
[1]13Summary: Mindi creates emergency boot disks/CDs using your kernel, tools and modules
[50]14Name: %name
15Version: %version
[316]16Release: %rel
[1]17License: GPL
[313]18Group: %{grp}
[496]19Url: http://www.mondorescue.org
[50]20Source: %{src}
[496]21BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
[314]22Requires: %{addreq}
[461]23Epoch: %(echo EEE | cut -d- -f1 | sed "s~M~~")
[20]24# Not on all systems
25#Conflicts: bonnie++
[1]26
27%description
28Mindi takes your kernel, modules, tools and libraries, and puts them on N
29bootable disks (or 1 bootable CD image). You may then boot from the disks/CD
30and do system maintenance - e.g. format partitions, backup/restore data,
31verify packages, etc.
32
33%prep
[50]34%setup -n %name-%{version}
[1]35
36%build
37%ifarch ia64
[50]38%{__make} -f Makefile.parted2fdisk clean
39%{__make} -f Makefile.parted2fdisk
[1]40%endif
41
42%install
[496]43%{__rm} -rf $RPM_BUILD_ROOT
[50]44export DONT_RELINK=1
45
[235]46export PREFIX=${RPM_BUILD_ROOT}%{_exec_prefix}
47export CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}
[179]48export RPMBUILDMINDI="true"
[50]49
[179]50./install.sh
[50]51
[1]52%clean
53%{__rm} -rf $RPM_BUILD_ROOT
54
55%post
[179]56if [ -f /usr/local/sbin/mindi ]; then
57 echo "WARNING: /usr/local/sbin/mindi exists. You should probably remove your manual mindi installation !"
58fi
59
[1]60%files
[50]61%defattr(644,root,root,755)
[496]62%config(noreplace) %{_sysconfdir}/mindi
[461]63%config(noreplace) %{_sysconfdir}/mindi/deplist.txt
64%config(noreplace) %{_sysconfdir}/mindi/deplist.d/*
65%config(noreplace) %{_sysconfdir}/mindi/mindi.conf
[315]66%doc ChangeLog INSTALL COPYING README TODO README.ia64 README.pxe README.busybox svn.log
[426]67%{_mandir}/man8/*
[200]68%{_libdir}/mindi
[461]69%attr(755,root,root) %{_sysconfdir}/mindi/mindi.conf
[189]70%attr(755,root,root) %{_sbindir}/*
[426]71%attr(755,root,root) %{_libdir}/mindi/aux-tools/sbin/*
72%attr(755,root,root) %{_libdir}/mindi/rootfs/bin/*
73%attr(755,root,root) %{_libdir}/mindi/rootfs/sbin/*
[1]74
75%changelog
Note: See TracBrowser for help on using the repository browser.