source: MondoRescue/branches/stable/mondo/distributions/rpm/mondo.spec@ 401

Last change on this file since 401 was 401, checked in by bcornec, 18 years ago
  • Integrate some SuSE patches and spec tips
  • all the doc is now under documentation (man pages, pdf, generated doc)
  • delivery process adapted consequently
  • Property svn:keywords set to Id
File size: 17.7 KB
Line 
1#
2# $Id: mondo.spec 401 2006-02-17 14:37:04Z bcornec $
3#
4
5%define name mondo
6%define version VVV
7%define mrel RRR
8# if mandriva official build (rpm --with is_official)
9%{?is_official:%define rel %{mkrel} %{mrel}}%{!?is_official:%define rel %{mrel}}
10%define src SSS
11%define grp GRP
12%define addreqb mindi >= 1.05, bzip2 >= 0.9, afio, mkisofs, binutils, newt >= 0.50, slang >= 1.4.1
13%define addreq DDD
14
15Summary: A program which a Linux user can utilize to create a rescue/restore CD/tape
16Summary(fr): Un programme pour les utilisateurs de Linux pour cr�r un CD/tape de sauvegarde/restauration
17Summary(it): Un programma per utenti Linux per creare un CD/tape di rescue
18Summary(sp): Un programa para los usuarios de Linux por crear una CD/cinta de restoracion/rescate
19
20Name: %{name}
21Version: %{version}
22Release: %{mrel}
23License: GPL
24Group: %{grp}
25Url: http://mondorescue.berlios.de
26Source: %{src}
27BuildRoot: %{_tmppath}/%{name}-%{version}
28BuildRequires: newt-devel >= 0.50, slang-devel >= 1.4.1, gcc
29%ifarch ia64
30Requires: %{addreq}, elilo, parted
31%else
32Requires: %{addreq}, syslinux >= 1.52
33%endif
34
35%description
36Mondo is a GPL disaster recovery solution to create backup media (CD, DVD, tape, network images) that can be used to redeploy the damaged system, as well as deploy similar or less similar systems.
37
38%description -l fr
39Objectif
40""""""""
41Mondo est une solution GPL de sauvegarde en cas de désastre pour créer des médias (CD, DVD, bande, images réseau) qui peuvent être utilisés pour redéployer le système endomangé, aussi bien que des systèmes similaires, ou moins similaires.
42
43%description -l it
44Scopo
45"""""
46Mondo e' un programma che permette a qualsiasi utente Linux
47di creare un cd di rescue/restore (o piu' cd qualora l'installazione
48dovesse occupare piu' di 2Gb circa). Funziona con gli azionamenti di
49nastro, ed il NFS, anche.
50
51%description -l sp
52Objectivo
53"""""""""
54Mondo es un programa que permite cualquier usuario de Linux a crear una CD
55de restoracion/rescate (o CDs, si su instalacion es >2GO aprox.). Funciona
56con cintas y NFS, tambien.
57
58%debug_package
59%prep
60%setup -q -n %name-%{version}
61
62%build
63%configure %{!?_without_xmondo:--with-x11}
64%{__make} VERSION=%{version} CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_REENTRANT"
65
66%install
67%{__rm} -rf $RPM_BUILD_ROOT
68%makeinstall
69
70%post
71/sbin/ldconfig
72%{__chmod} 755 %{_libdir}/%{name}/restore-scripts/%{name}/*
73
74%postun
75/sbin/ldconfig
76
77%clean
78%{__rm} -rf $RPM_BUILD_ROOT
79
80%files
81%defattr(644,root,root,755)
82%doc ChangeLog svn.log
83%doc INSTALL COPYING README TODO AUTHORS NEWS
84
85%attr(755,root,root) %{_sbindir}/*
86#%attr(755,root,root) %{_libdir}/%{name}/restore-scripts/%{name}/*
87%{_libdir}
88%{_mandir}
89
90#%{!?_without_xmondo:%files xmondo}
91#%{!?_without_xmondo:%{_sbindir}/xmondo}
92#%{!?_without_xmondo:%{_libdir}/libXmondo-%{libversion}.so}
93#%{!?_without_xmondo:%{_libdir}/libXmondo.so}
94#%{!?_without_xmondo:%{_datadir}/mondo/mondo.png}
95
96%changelog
97* Fri Nov 05 2005 Bruno Cornec <bcornec@users.berlios.de> 1.05
98- ia64 is now working
99- -p option related bug fixed
100- use libdir instead of datadir
101
102* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 2.04_berlios
103- Merge of patches mentionned on mondo ML + ia64 updates
104- Add -p option
105
106* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 2.04_cvs_20050503
107- made mondo more clever about finding its home. Avoids mondo considering
108 directories like '/usr/share/doc/momdo' as its home.
109
110* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 2.03
111- test sanity of user-specified tempdir
112- better SLES8 support
113
114* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 2.02
115- instead of using 'dd' to erase partition table, delete existing
116 partitions w/ the same call to fdisk that is used to create the
117 new partitions; this should avoids locking up the partition table
118- set bootable partition in the above same call to fdisk, for
119 the same reason (avoids locking up the partition table)
120- better software RAID support
121- mount ext3 partitions as ext2 when restoring - better for Debian
122- better star, ACL support
123- added ACL, xattr support for afio users
124
125* Fri Jun 26 2004 Hugo Rabson <hugorabson@msn.com> 2.01
126- fixed cvs for SuSE systems
127- fixed NTFS backup/restore bug relating to partimagehack
128 log file overflow and NTFS v non-NTFS differentiation
129- more reliable extraction of config info from CDs, floppies
130- better support of ISO dirs at restore-time (Conor Daly)
131- fixed spec file for SuSE users
132- added ldconfig to install section
133
134* Fri Jun 19 2004 Hugo Rabson <hugorabson@msn.com> 2.00
135- first 2.0 release
136- updated grub-install.patched to support SuSE and Red Hat
137- call 'mt' to set block size to 32K before opening in/out tape
138- updated mondo-prep.c to create each disk's partitions all at once
139 (one call per drive) instead of one call to fdisk per partition
140- when extracting cfg file and mountlist from all.tar.gz (tape copy),
141 use block size of INTERNAL_TAPE_BLK_SIZE, not TAPE_BLOCK_SIZE
142- added star and rudimentary SELinux support
143- fixed lots of bugs
144- all logging now goes to /var/log/mondo-archive.log, with symlink
145 to /tmp/mondo-restore.log for restore-time log-tracking
146- added grub-install.patched
147- removed embleer & other binaries
148- added '-b' to specify block size
149- added '-R' for star support
150
151* Thu Mar 25 2004 Bruno Cornec <Bruno.Cornec@hp.com> 1.7_cvs-20040325
152- ia64 fixes
153
154* Fri Nov 07 2003 Joshua Oreman <oremanj@get-linux.org> 1.7_cvs-20031107
155- fixed symbolic links for libraries
156- added support for boot/root multi floppies
157
158- added kdelibs as xmondo dependency
159- added xmondo pixmap installation
160- better find_cdrom_device(), to cope w/ multiple CD writers
161- fixed -m and -Vc flags
162- fixed NTFS support!
163- bootable CD uses native, not El Torito, support now
164- removed mondo-makefilelist
165- added 2.6 kernel support
166- if 2.6 kernel, insist that the user specify CD device
167- drop Embleer; insist on ms-sys and parted if Windows partition
168
169* Wed Nov 05 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031105.1
170- added -devel package
171
172* Tue Nov 04 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031104.1
173- made xmondo a second package
174- added ability to specify --without xmondo at build time
175
176* Sun Nov 02 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031102.1
177- Clean up, added spanish translation
178- Set prefix to be /usr
179- added/fixed Requires
180- remove CVS directories prior to building
181
182* Thu Oct 23 2003 Hugo Rabson <hugorabson@msn.com> 1.75_cvs_20031023
183- nothing yet
184
185* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 1.75
186- fixed chmod/chown bug (Jens Richter)
187- ask user to confirm NFS mountpoint in Interactive Mode
188- rewritten format_everything() to make sure LVMs, RAIDs and
189 regular partitions are prepped in the correct order
190- better magicdev support
191- rewritten external binary caller subroutine
192- DVD support added
193- better backup-time control gui; offer to exclude nfs if appl.
194- fixed multi-tape support
195- re-implemented -D and -J
196- fixed bug in extract_config_file_from_ramdisk() which
197 affected tape+floppy users
198- updated is_incoming_block_valid() to make it
199 return end-of-tape if >300 flotsam blocks
200- unmount CD-ROM before burning (necessary for RH8/9)
201- fixed some stray assert()'s
202- fixed bug in grub-MR (Christian)
203- make user remove floppy/CD before restoring interactively from tape
204- fixed bug in am_I_in_disaster_recovery_mode()
205- added code to nuke_mode() to make sure NFS
206 (backup) share is mounted in Nuke Mode
207- improved tape device detection code
208- better GRUB support
209- better logging of changed bigfiles at compare-time
210- better NTFS support, thanks to partimagehack-static
211- better logging
212- rewrote tape-handling code, breaking compatibility w/ previous versions
213- fixed ISO/CD biggiefile verification bug in mondoarchive
214- fixed bug which stopped boot/compare-time changelist from popping up
215- replaced mondo-makefilelist with C code - faster, cleaner
216- tweaked GUI - better feedback
217
218* Wed May 28 2003 Anonymous <root@rohan> 1.74
219- misc fixes (Michael Hanscho's friend)
220- added rudimentary support for SME
221- added better label support
222- fixed biggietime atime/ctime restoration bug 73
223- fixed 'default boot loader' detection bug (Joshua Oreman)
224- use single-threaded make_afioballs_and_images() if FreeBSD
225- fixed mondoarchive -Vi multi-CD verify bug (Tom Mortell)
226- superior get_phys_size_of_drive() (Joshua Oreman)
227- fixed RAID-related bug in where_is_root_mounted()
228- ISO tweaks
229- fixed silly bug in load_filelist() which stopped
230 funny German filenames from being handled properly
231- fixed various calls to popup_and_get_string()
232- fixed spec file
233- reject -E /
234- added partimagehack to the mix
235
236* Tue May 20 2003 Anonymous <root@rohan> 1.73
237- mark devices as bootable _after_ unmounting them
238- resolve boot device (-f) if softlink
239- post_param_configuration() --- store iso-dev and isodir
240- added post-nuke-sample.tgz to package
241- Nuke Mode now checks mountlist against hardware; offer user
242 opportunity to edit mountlist if insane; if user declines, abort
243- added lots of assert()'s and other checks
244- ran code thru Valgrind to catch & fix some memory leaks
245- made mondo-restore.c smaller by moving some subroutines to
246 common/libmondo-raid.c and mondorestore/mondo-rstr-compare.c
247- added '-Q' to let user test mondoarchive's ability to find
248 their boot loader and type
249- improved which_boot_loader()
250- when burning or comparing to a CD, defeat autorun if it is
251 running, to avoid confusing mondoarchive and the user
252- if original backup media no longer available at boot-time
253 then offer user chance to choose another media source
254- when booting, type 'nuke noresize' to nuke w/o resizing
255 mountlist to fill your drives
256- add 'textonly' when booting, to avoid using Newt gui
257- run nice(20) to prioritize mondoarchive at start
258- don't pause and wait for next blank CD at backup-time
259 unless necessary (e.g. previous CD has not been removed)
260- get_phys_size_of_drive() --- better support of older drives
261- don't eject if "donteject" is in kernel's command line
262- cleaned up segfault-handling
263- added Conor's strip_path() to improve file list display
264- added Herman Kuster's multi-level bkp patch
265- better boot-time screen/message
266- added Joshua Oreman's FreeBSD patches x3
267- fixed interactive/textonly support
268- fixed support for subdir-within-NFS-mount
269- fixed "Can't backup if ramdisk not mounted" bug
270- try to work around eccentricities of multi-CD drive PCs
271- misc clean-ups (Steve Hindle)
272
273* Tue Apr 08 2003 Hugo Rabson <hugorabson@msn.com> 1.72
274- LVM/RAID bugs fixed (Brian Borgeson)
275- major clean-up of code (Stan Benoit)
276- make-me-bootable fix (Juraj Ziegler)
277- fixed problem w/ multi-ISO verify cycle (Tom Mortell)
278- removed duplicate entry from makefile
279- if root is /dev/root then assume not a ramdisk
280- reject relative paths if -d flag (Alessandro Polverini)
281- fixed potentially infinite loop in log_to_screen (Tom Mortell)
282- add '/' to custom filelist as workaround for obscure bug
283- ask user speed of CDRW if writing to CD
284- find_cdrom_device() --- if nonexistent/not found then
285 make sure to return '' as dev str and 1 as res
286- tweaked restore scripts tgz
287- cleaned up find_cdrom_device()
288- if user creates /usr/share/mondo/payload.tgz then untar
289 payload to CD at backup-time
290- fixed insist_on_this_cd_number()
291- fixed am_i_in_disaster_recovery_mode()
292- misc clean-up (Tom Mortell)
293- made code more legible
294- fixed post-nuke support
295- added -e support
296- fixed nfs support
297- fixed iso support
298- at restore-time, only sort mountlist internally,
299 in mount_all_devices() and unmount_all_devices()
300- fixed cosmetic bug in label-partitions-as-necessary
301- updated documentation
302- fixed fstab-hacking scripts
303
304* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 1.71
305- log newt, slang, ncurses info
306- updated man page
307- handle %% chars in issue.net properly (Heiko Schlittermann)
308- fixed serious NFS restore bug
309- cleaned up spec file; it should cause fewer problems now (Jesse Keating)
310- changed various strcpy() calls to strncpy() calls
311- added mondo-makefilelist to makefile (Mikael Hultgren)
312- mount_cdrom() better at handling multiple CD drives
313- exclude /media/cdrom,cdrecorder,floppy
314- sensibly_set_tmpdir_and_scratchdir() --- exclude smb and smbfs
315- better logging by eval_call_to_make_ISO()
316- accept -J <fname> to let user provide their own fs catalog
317 instead of -I <paths> to backup
318- if dir excluded with -E or included with -I and dir is actually
319 a softlink then exclude/include the dir pointed to, as well
320- better location for manpage
321- adjusted block size of tarball at start of tape, to help
322 users w/ broken tape driver firmware
323- sort -u fstab after modifying it
324- if backup type is nfs then don't estimate noof media
325- fixed Makefile (Mikael Hultgren)
326- updated manpage
327
328* Mon Dec 07 2002 Hugo Rabson <hugo@firstlinux.net> 1.70
329- new devel branch opened
330
331* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 1.52
332- fixed bug in multithreading
333- use new grub-MR instead of grub-install
334- wipe only the partition table (not the MBR) when partitioning drives
335- ignore lilo.conf.anaconda when looking for lilo.conf file
336- accepts '-l RAW' to backup/restore original boot sector instead
337 of running grub or lilo to init it after restoring
338- fixed&updated stabgrub-me script; software RAID + GRUB work now
339- mount/unmount /boot partition for Gentoo 1.2 users
340- re-enabled extra tape checksums
341- disabled spurious warnings
342- unmount/remount supermounts at start/end of live restore, if nec.
343- cleaned up mondo's tape block handling (now, TAPE_BLOCK_SIZE=128K
344 and I've added INTERNAL_TAPE_BLK_SIZE=32K variable for buffering)
345- added Makefile
346- added -l RAW, to backup and restore original MBR
347- cleaned up iso_mode() and nfs restoring
348- create /mnt/RESTORING/mnt/.boot.d for Gentoo users
349- made mondorestore CD bootable for ArkLinux users
350- if user runs as 'su' not 'su -' then work around
351
352* Sun Nov 17 2002 Hugo Rabson <hugo@firstlinux.net> 1.51
353- pop-up list of changed files, at end of verification phase
354- better handling of changed.files list at restore-time
355- lots of CD-related fixes
356- added '-N' flag --- to let user exclude all NFS-related mounts&devices
357- better handling of 'kill'
358- restructuring of code to ease integration of mondo w/XMondo
359- fixed obscure bug in find_and_mount_actual_cd()
360- if / or /root has <50MB free then abort & complain
361- fixed install.sh
362- fixed .spec file
363- updated documentation
364- commented code
365- updated man page
366- added -v / --version flag
367- replace convoluted grep with wc (KP)
368- fixed bug affecting restoration of bigfiles from CD's created w/0 compression
369- fixed BurnProof-related bug
370- better at figuring out which is the best partition for temp/scratchdir
371- added do-not-compress-these (text file) to RPM
372- do not compress files of types listed in do-not-compress-these
373- dropped -U from call to afio - saves 20-30% runtime (Cosgrove)
374- added Cosgrove's do-not-compress-these list
375- included various patches from KP
376- chmod tmpdir, scratchdir to 700 before using
377- restore from specified backup device, even if its own cfg file disagrees
378- fixed multi-tape bug
379- fixed "Can't find first ISO when verifying nonbootable ISO" bug
380- multithreaded make_afioballs_and_images()
381- tmpdir and scratchdir are set sensibly whether mondoarchive is called with
382 command-line parameters or not
383- fixed bug in strip_spaces() which stopped it from handling
384 small strings correctly - affected mountlist editor
385- create a repaired copy of grub-install which is RAID-friendly;
386 use it when initializing boot sector with run_grub()
387- fixed bug in mondo-makefilelist
388
389* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 1.50
390- if restoring, don't try to find SCSI node of CD-ROM drive; find /dev entry
391- during selective restore, skip filesets which don't contain relevant archives
392- set /dev/null's perms to 777, just in case devfs-enabled kernel mangles it
393- remove /var/run/*.pid after restoring
394- move spurious lockfiles from /home/* to /home/*/.disabled
395- ask user to confirm the tape/CD device name
396- lots of multitape-related fixes
397- added code to autodetect the hardware of the user, if possible
398- if isodir does not exist then abort
399- more sanity-checking for -d flag
400- doubled 'biggiefile' threshold... to 32MB
401- exclude /root/images/mindi
402- fixed multi-imagedev bug (Emmanuel Druon)
403- unmount/remount /mnt/floppy before/after backing up, if Mandrake
404- restructured the source files
405- fixed serious bug in line 1546 - should have been !=, not ==; stopped
406 mondorestore from correctly restoring big files
407- added '#include <signal.h>' to my-stuff.h
408- exclude "incheckentry xwait()" from changed.files
409- fixed minor bug in find_cdrom_device()
410- fixed bug in friendly_sizestr...
411- insist on tape #1 when start verifying
412- added internal buffering, replacing the external 'buffer' exe
413- if differential backup then don't permit formatting or fdisking,
414 whether Interactive or Nuke mode
415- if mondorestore is run on live filesystem (or from ramdisk) without
416 parameters then mondorestore will ask which backup media (tape, CD, etc.)
417 was used; it will read the config file from the media and proceed from there
418- if tape streamer is softlink then resolve it first
419- incorporate post-nuke tarball
420- if user doesn't specify tape size, proceed anyway; behave intelligently
421 in the event of end-of-tape
422- prefix bkpinfo->restore_path to biggiefile fname before generating
423 checksum & comparing to archived biggiefile
424- if /etc/lilo.conf not found not /etc/lilo.conf.anaconda found
425 then create a softlink from the former to the latter, to work
426 around RH7.3's b0rken LILO support
427- LFS support (mharris, michele, hugo)
428- fixed verify bug --- CD#1 was being verified again & again & ...
429- differential mode fixed; supported again
430- ask user for boot loader + device if not detectible
431- list up to 512 files in file selection window at once (was 128)
432- better handling of bigfiles' checksums, perms and owns
433- delete final filelist if <=2 bytes long
434- if kernel not found and mondo in graphics mode then popup and ask
435 for kernel path+filename
436
437* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 1.45-1
438- 1.5x branch forked off from 1.4x branch
439
440
441
442
Note: See TracBrowser for help on using the repository browser.