source: MondoRescue/branches/stable/mondo/distributions/rpm/mondo.spec@ 390

Last change on this file since 390 was 388, checked in by bcornec, 18 years ago

RPMs are now made with a .spec containing m4 macros expanded with tools/mkrpm
this allows for a simpler spec file at the end,
which should be suited for at least Mandriva official packages.
Added a new mkspec tool which does the expansion
This way of dealing with distributions will be used is some other areas in the future

  • Property svn:keywords set to Id
File size: 18.4 KB
Line 
1#
2# $Id: mondo.spec 388 2006-02-14 22:36:15Z bcornec $
3#
4
5%define name mondo
6%define version VVV
7%define mrel RRR
8# if mandriva official build (rpm --with is_official)
9%{?is_official:%define rel %{mkrel} %{mrel}}%{!?is_official:%define rel %{mrel}}
10%define src SSS
11%define grp GRP
12%define addreqb mindi >= 1.05, bzip2 >= 0.9, afio, mkisofs, binutils, newt >= 0.50, slang >= 1.4.1
13
14Summary: A program which a Linux user can utilize to create a rescue/restore CD/tape
15Summary(fr): Un programme pour les utilisateurs de Linux pour cr�r un CD/tape de sauvegarde/restauration
16Summary(it): Un programma per utenti Linux per creare un CD/tape di rescue
17Summary(sp): Un programa para los usuarios de Linux por crear una CD/cinta de restoracion/rescate
18
19Name: %{name}
20Version: %{version}
21Release: %{mrel}
22License: GPL
23Group: %{grp}
24Url: http://mondorescue.berlios.de
25Source: %{src}
26BuildRoot: %{_tmppath}/%{name}-%{version}
27BuildRequires: newt-devel >= 0.50, slang-devel >= 1.4.1, gcc
28%ifarch ia64
29Requires: %{addreq}, elilo, parted
30%else
31Requires: %{addreq}, syslinux >= 1.52
32%endif
33
34#%package xmondo
35#Summary: A QT based graphical front end for %{name}
36#Group: Applications/Archiving
37#Requires: %{name} = %{version}-${release}, qt, kdelibs
38#
39#%package %{name}-devel
40#Summary: Header files for building against Mondo
41#%if %is_mandrake
42#Group: Development/Libraries
43#%endif
44#if %is_redhat
45#Group: Development/Other
46#%endif
47#Provides: libmondo-devel mondo-devel
48#Obsoletes: libmondo-devel
49#
50#%description -n %{name}-devel
51#Mondo libraries and includes
52
53%description
54Mondo is a GPL disaster recovery solution to create backup media (CD, DVD, tape, network images) that can be used to redeploy the damaged system, as well as deploy similar or less similar systems.
55
56%description -l fr
57Objectif
58""""""""
59Mondo est une solution GPL de sauvegarde en cas de désastre pour créer des médias (CD, DVD, bande, images réseau) qui peuvent être utilisés pour redéployer le système endomangé, aussi bien que des systèmes similaires, ou moins similaires.
60
61%description -l it
62Scopo
63"""""
64Mondo e' un programma che permette a qualsiasi utente Linux
65di creare un cd di rescue/restore (o piu' cd qualora l'installazione
66dovesse occupare piu' di 2Gb circa). Funziona con gli azionamenti di
67nastro, ed il NFS, anche.
68
69%description -l sp
70Objectivo
71"""""""""
72Mondo es un programa que permite cualquier usuario de Linux a crear una CD
73de restoracion/rescate (o CDs, si su instalacion es >2GO aprox.). Funciona
74con cintas y NFS, tambien.
75
76#%description xmondo
77#Xmondo is a QT based graphical frontend to mondoarchive. It can help you
78#set up a backup by following onscreen prompts.
79
80%prep
81%setup -q -n %name-%{version}
82
83%build
84%configure %{!?_without_xmondo:--with-x11}
85%{__make} VERSION=%{version} CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_REENTRANT"
86
87%install
88%{__rm} -rf $RPM_BUILD_ROOT
89%makeinstall
90%if %is_suse
91%{__rm} -rf $RPM_BUILD_ROOT/%{_datadir}/doc/%name-%{version}
92%endif
93
94%post
95/sbin/ldconfig
96%{__chmod} 755 %{_libdir}/%{name}/restore-scripts/%{name}/*
97
98%postun
99/sbin/ldconfig
100
101%clean
102%{__rm} -rf $RPM_BUILD_ROOT
103
104%files
105%defattr(644,root,root,755)
106%doc ChangeLog svn.log
107%doc INSTALL COPYING README TODO AUTHORS NEWS
108
109%attr(755,root,root) %{_sbindir}/*
110#%attr(755,root,root) %{_libdir}/%{name}/restore-scripts/%{name}/*
111%{_libdir}
112%{_mandir}
113
114#%{!?_without_xmondo:%files xmondo}
115#%{!?_without_xmondo:%{_sbindir}/xmondo}
116#%{!?_without_xmondo:%{_libdir}/libXmondo-%{libversion}.so}
117#%{!?_without_xmondo:%{_libdir}/libXmondo.so}
118#%{!?_without_xmondo:%{_datadir}/mondo/mondo.png}
119
120%changelog
121* Fri Nov 05 2005 Bruno Cornec <bcornec@users.berlios.de> 1.05
122- ia64 is now working
123- -p option related bug fixed
124- use libdir instead of datadir
125
126* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 2.04_berlios
127- Merge of patches mentionned on mondo ML + ia64 updates
128- Add -p option
129
130* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 2.04_cvs_20050503
131- made mondo more clever about finding its home. Avoids mondo considering
132 directories like '/usr/share/doc/momdo' as its home.
133
134* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 2.03
135- test sanity of user-specified tempdir
136- better SLES8 support
137
138* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 2.02
139- instead of using 'dd' to erase partition table, delete existing
140 partitions w/ the same call to fdisk that is used to create the
141 new partitions; this should avoids locking up the partition table
142- set bootable partition in the above same call to fdisk, for
143 the same reason (avoids locking up the partition table)
144- better software RAID support
145- mount ext3 partitions as ext2 when restoring - better for Debian
146- better star, ACL support
147- added ACL, xattr support for afio users
148
149* Fri Jun 26 2004 Hugo Rabson <hugorabson@msn.com> 2.01
150- fixed cvs for SuSE systems
151- fixed NTFS backup/restore bug relating to partimagehack
152 log file overflow and NTFS v non-NTFS differentiation
153- more reliable extraction of config info from CDs, floppies
154- better support of ISO dirs at restore-time (Conor Daly)
155- fixed spec file for SuSE users
156- added ldconfig to install section
157
158* Fri Jun 19 2004 Hugo Rabson <hugorabson@msn.com> 2.00
159- first 2.0 release
160- updated grub-install.patched to support SuSE and Red Hat
161- call 'mt' to set block size to 32K before opening in/out tape
162- updated mondo-prep.c to create each disk's partitions all at once
163 (one call per drive) instead of one call to fdisk per partition
164- when extracting cfg file and mountlist from all.tar.gz (tape copy),
165 use block size of INTERNAL_TAPE_BLK_SIZE, not TAPE_BLOCK_SIZE
166- added star and rudimentary SELinux support
167- fixed lots of bugs
168- all logging now goes to /var/log/mondo-archive.log, with symlink
169 to /tmp/mondo-restore.log for restore-time log-tracking
170- added grub-install.patched
171- removed embleer & other binaries
172- added '-b' to specify block size
173- added '-R' for star support
174
175* Thu Mar 25 2004 Bruno Cornec <Bruno.Cornec@hp.com> 1.7_cvs-20040325
176- ia64 fixes
177
178* Fri Nov 07 2003 Joshua Oreman <oremanj@get-linux.org> 1.7_cvs-20031107
179- fixed symbolic links for libraries
180- added support for boot/root multi floppies
181
182- added kdelibs as xmondo dependency
183- added xmondo pixmap installation
184- better find_cdrom_device(), to cope w/ multiple CD writers
185- fixed -m and -Vc flags
186- fixed NTFS support!
187- bootable CD uses native, not El Torito, support now
188- removed mondo-makefilelist
189- added 2.6 kernel support
190- if 2.6 kernel, insist that the user specify CD device
191- drop Embleer; insist on ms-sys and parted if Windows partition
192
193* Wed Nov 05 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031105.1
194- added -devel package
195
196* Tue Nov 04 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031104.1
197- made xmondo a second package
198- added ability to specify --without xmondo at build time
199
200* Sun Nov 02 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031102.1
201- Clean up, added spanish translation
202- Set prefix to be /usr
203- added/fixed Requires
204- remove CVS directories prior to building
205
206* Thu Oct 23 2003 Hugo Rabson <hugorabson@msn.com> 1.75_cvs_20031023
207- nothing yet
208
209* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 1.75
210- fixed chmod/chown bug (Jens Richter)
211- ask user to confirm NFS mountpoint in Interactive Mode
212- rewritten format_everything() to make sure LVMs, RAIDs and
213 regular partitions are prepped in the correct order
214- better magicdev support
215- rewritten external binary caller subroutine
216- DVD support added
217- better backup-time control gui; offer to exclude nfs if appl.
218- fixed multi-tape support
219- re-implemented -D and -J
220- fixed bug in extract_config_file_from_ramdisk() which
221 affected tape+floppy users
222- updated is_incoming_block_valid() to make it
223 return end-of-tape if >300 flotsam blocks
224- unmount CD-ROM before burning (necessary for RH8/9)
225- fixed some stray assert()'s
226- fixed bug in grub-MR (Christian)
227- make user remove floppy/CD before restoring interactively from tape
228- fixed bug in am_I_in_disaster_recovery_mode()
229- added code to nuke_mode() to make sure NFS
230 (backup) share is mounted in Nuke Mode
231- improved tape device detection code
232- better GRUB support
233- better logging of changed bigfiles at compare-time
234- better NTFS support, thanks to partimagehack-static
235- better logging
236- rewrote tape-handling code, breaking compatibility w/ previous versions
237- fixed ISO/CD biggiefile verification bug in mondoarchive
238- fixed bug which stopped boot/compare-time changelist from popping up
239- replaced mondo-makefilelist with C code - faster, cleaner
240- tweaked GUI - better feedback
241
242* Wed May 28 2003 Anonymous <root@rohan> 1.74
243- misc fixes (Michael Hanscho's friend)
244- added rudimentary support for SME
245- added better label support
246- fixed biggietime atime/ctime restoration bug 73
247- fixed 'default boot loader' detection bug (Joshua Oreman)
248- use single-threaded make_afioballs_and_images() if FreeBSD
249- fixed mondoarchive -Vi multi-CD verify bug (Tom Mortell)
250- superior get_phys_size_of_drive() (Joshua Oreman)
251- fixed RAID-related bug in where_is_root_mounted()
252- ISO tweaks
253- fixed silly bug in load_filelist() which stopped
254 funny German filenames from being handled properly
255- fixed various calls to popup_and_get_string()
256- fixed spec file
257- reject -E /
258- added partimagehack to the mix
259
260* Tue May 20 2003 Anonymous <root@rohan> 1.73
261- mark devices as bootable _after_ unmounting them
262- resolve boot device (-f) if softlink
263- post_param_configuration() --- store iso-dev and isodir
264- added post-nuke-sample.tgz to package
265- Nuke Mode now checks mountlist against hardware; offer user
266 opportunity to edit mountlist if insane; if user declines, abort
267- added lots of assert()'s and other checks
268- ran code thru Valgrind to catch & fix some memory leaks
269- made mondo-restore.c smaller by moving some subroutines to
270 common/libmondo-raid.c and mondorestore/mondo-rstr-compare.c
271- added '-Q' to let user test mondoarchive's ability to find
272 their boot loader and type
273- improved which_boot_loader()
274- when burning or comparing to a CD, defeat autorun if it is
275 running, to avoid confusing mondoarchive and the user
276- if original backup media no longer available at boot-time
277 then offer user chance to choose another media source
278- when booting, type 'nuke noresize' to nuke w/o resizing
279 mountlist to fill your drives
280- add 'textonly' when booting, to avoid using Newt gui
281- run nice(20) to prioritize mondoarchive at start
282- don't pause and wait for next blank CD at backup-time
283 unless necessary (e.g. previous CD has not been removed)
284- get_phys_size_of_drive() --- better support of older drives
285- don't eject if "donteject" is in kernel's command line
286- cleaned up segfault-handling
287- added Conor's strip_path() to improve file list display
288- added Herman Kuster's multi-level bkp patch
289- better boot-time screen/message
290- added Joshua Oreman's FreeBSD patches x3
291- fixed interactive/textonly support
292- fixed support for subdir-within-NFS-mount
293- fixed "Can't backup if ramdisk not mounted" bug
294- try to work around eccentricities of multi-CD drive PCs
295- misc clean-ups (Steve Hindle)
296
297* Tue Apr 08 2003 Hugo Rabson <hugorabson@msn.com> 1.72
298- LVM/RAID bugs fixed (Brian Borgeson)
299- major clean-up of code (Stan Benoit)
300- make-me-bootable fix (Juraj Ziegler)
301- fixed problem w/ multi-ISO verify cycle (Tom Mortell)
302- removed duplicate entry from makefile
303- if root is /dev/root then assume not a ramdisk
304- reject relative paths if -d flag (Alessandro Polverini)
305- fixed potentially infinite loop in log_to_screen (Tom Mortell)
306- add '/' to custom filelist as workaround for obscure bug
307- ask user speed of CDRW if writing to CD
308- find_cdrom_device() --- if nonexistent/not found then
309 make sure to return '' as dev str and 1 as res
310- tweaked restore scripts tgz
311- cleaned up find_cdrom_device()
312- if user creates /usr/share/mondo/payload.tgz then untar
313 payload to CD at backup-time
314- fixed insist_on_this_cd_number()
315- fixed am_i_in_disaster_recovery_mode()
316- misc clean-up (Tom Mortell)
317- made code more legible
318- fixed post-nuke support
319- added -e support
320- fixed nfs support
321- fixed iso support
322- at restore-time, only sort mountlist internally,
323 in mount_all_devices() and unmount_all_devices()
324- fixed cosmetic bug in label-partitions-as-necessary
325- updated documentation
326- fixed fstab-hacking scripts
327
328* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 1.71
329- log newt, slang, ncurses info
330- updated man page
331- handle %% chars in issue.net properly (Heiko Schlittermann)
332- fixed serious NFS restore bug
333- cleaned up spec file; it should cause fewer problems now (Jesse Keating)
334- changed various strcpy() calls to strncpy() calls
335- added mondo-makefilelist to makefile (Mikael Hultgren)
336- mount_cdrom() better at handling multiple CD drives
337- exclude /media/cdrom,cdrecorder,floppy
338- sensibly_set_tmpdir_and_scratchdir() --- exclude smb and smbfs
339- better logging by eval_call_to_make_ISO()
340- accept -J <fname> to let user provide their own fs catalog
341 instead of -I <paths> to backup
342- if dir excluded with -E or included with -I and dir is actually
343 a softlink then exclude/include the dir pointed to, as well
344- better location for manpage
345- adjusted block size of tarball at start of tape, to help
346 users w/ broken tape driver firmware
347- sort -u fstab after modifying it
348- if backup type is nfs then don't estimate noof media
349- fixed Makefile (Mikael Hultgren)
350- updated manpage
351
352* Mon Dec 07 2002 Hugo Rabson <hugo@firstlinux.net> 1.70
353- new devel branch opened
354
355* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 1.52
356- fixed bug in multithreading
357- use new grub-MR instead of grub-install
358- wipe only the partition table (not the MBR) when partitioning drives
359- ignore lilo.conf.anaconda when looking for lilo.conf file
360- accepts '-l RAW' to backup/restore original boot sector instead
361 of running grub or lilo to init it after restoring
362- fixed&updated stabgrub-me script; software RAID + GRUB work now
363- mount/unmount /boot partition for Gentoo 1.2 users
364- re-enabled extra tape checksums
365- disabled spurious warnings
366- unmount/remount supermounts at start/end of live restore, if nec.
367- cleaned up mondo's tape block handling (now, TAPE_BLOCK_SIZE=128K
368 and I've added INTERNAL_TAPE_BLK_SIZE=32K variable for buffering)
369- added Makefile
370- added -l RAW, to backup and restore original MBR
371- cleaned up iso_mode() and nfs restoring
372- create /mnt/RESTORING/mnt/.boot.d for Gentoo users
373- made mondorestore CD bootable for ArkLinux users
374- if user runs as 'su' not 'su -' then work around
375
376* Sun Nov 17 2002 Hugo Rabson <hugo@firstlinux.net> 1.51
377- pop-up list of changed files, at end of verification phase
378- better handling of changed.files list at restore-time
379- lots of CD-related fixes
380- added '-N' flag --- to let user exclude all NFS-related mounts&devices
381- better handling of 'kill'
382- restructuring of code to ease integration of mondo w/XMondo
383- fixed obscure bug in find_and_mount_actual_cd()
384- if / or /root has <50MB free then abort & complain
385- fixed install.sh
386- fixed .spec file
387- updated documentation
388- commented code
389- updated man page
390- added -v / --version flag
391- replace convoluted grep with wc (KP)
392- fixed bug affecting restoration of bigfiles from CD's created w/0 compression
393- fixed BurnProof-related bug
394- better at figuring out which is the best partition for temp/scratchdir
395- added do-not-compress-these (text file) to RPM
396- do not compress files of types listed in do-not-compress-these
397- dropped -U from call to afio - saves 20-30% runtime (Cosgrove)
398- added Cosgrove's do-not-compress-these list
399- included various patches from KP
400- chmod tmpdir, scratchdir to 700 before using
401- restore from specified backup device, even if its own cfg file disagrees
402- fixed multi-tape bug
403- fixed "Can't find first ISO when verifying nonbootable ISO" bug
404- multithreaded make_afioballs_and_images()
405- tmpdir and scratchdir are set sensibly whether mondoarchive is called with
406 command-line parameters or not
407- fixed bug in strip_spaces() which stopped it from handling
408 small strings correctly - affected mountlist editor
409- create a repaired copy of grub-install which is RAID-friendly;
410 use it when initializing boot sector with run_grub()
411- fixed bug in mondo-makefilelist
412
413* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 1.50
414- if restoring, don't try to find SCSI node of CD-ROM drive; find /dev entry
415- during selective restore, skip filesets which don't contain relevant archives
416- set /dev/null's perms to 777, just in case devfs-enabled kernel mangles it
417- remove /var/run/*.pid after restoring
418- move spurious lockfiles from /home/* to /home/*/.disabled
419- ask user to confirm the tape/CD device name
420- lots of multitape-related fixes
421- added code to autodetect the hardware of the user, if possible
422- if isodir does not exist then abort
423- more sanity-checking for -d flag
424- doubled 'biggiefile' threshold... to 32MB
425- exclude /root/images/mindi
426- fixed multi-imagedev bug (Emmanuel Druon)
427- unmount/remount /mnt/floppy before/after backing up, if Mandrake
428- restructured the source files
429- fixed serious bug in line 1546 - should have been !=, not ==; stopped
430 mondorestore from correctly restoring big files
431- added '#include <signal.h>' to my-stuff.h
432- exclude "incheckentry xwait()" from changed.files
433- fixed minor bug in find_cdrom_device()
434- fixed bug in friendly_sizestr...
435- insist on tape #1 when start verifying
436- added internal buffering, replacing the external 'buffer' exe
437- if differential backup then don't permit formatting or fdisking,
438 whether Interactive or Nuke mode
439- if mondorestore is run on live filesystem (or from ramdisk) without
440 parameters then mondorestore will ask which backup media (tape, CD, etc.)
441 was used; it will read the config file from the media and proceed from there
442- if tape streamer is softlink then resolve it first
443- incorporate post-nuke tarball
444- if user doesn't specify tape size, proceed anyway; behave intelligently
445 in the event of end-of-tape
446- prefix bkpinfo->restore_path to biggiefile fname before generating
447 checksum & comparing to archived biggiefile
448- if /etc/lilo.conf not found not /etc/lilo.conf.anaconda found
449 then create a softlink from the former to the latter, to work
450 around RH7.3's b0rken LILO support
451- LFS support (mharris, michele, hugo)
452- fixed verify bug --- CD#1 was being verified again & again & ...
453- differential mode fixed; supported again
454- ask user for boot loader + device if not detectible
455- list up to 512 files in file selection window at once (was 128)
456- better handling of bigfiles' checksums, perms and owns
457- delete final filelist if <=2 bytes long
458- if kernel not found and mondo in graphics mode then popup and ask
459 for kernel path+filename
460
461* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 1.45-1
462- 1.5x branch forked off from 1.4x branch
463
464
465
466
Note: See TracBrowser for help on using the repository browser.