source: MondoRescue/branches/stable/mondo/distributions/rpm/mondo.spec@ 395

Last change on this file since 395 was 395, checked in by bcornec, 18 years ago

Fix a warning in mondo
New RPM Build env working

  • Property svn:keywords set to Id
File size: 18.3 KB
RevLine 
[35]1#
2# $Id: mondo.spec 395 2006-02-15 15:37:36Z bcornec $
3#
[1]4
[53]5%define name mondo
[237]6%define version VVV
[313]7%define mrel RRR
[316]8# if mandriva official build (rpm --with is_official)
9%{?is_official:%define rel %{mkrel} %{mrel}}%{!?is_official:%define rel %{mrel}}
[388]10%define src SSS
11%define grp GRP
[315]12%define addreqb mindi >= 1.05, bzip2 >= 0.9, afio, mkisofs, binutils, newt >= 0.50, slang >= 1.4.1
[395]13%define addreq DDD
[53]14
[1]15Summary: A program which a Linux user can utilize to create a rescue/restore CD/tape
16Summary(fr): Un programme pour les utilisateurs de Linux pour cr�r un CD/tape de sauvegarde/restauration
17Summary(it): Un programma per utenti Linux per creare un CD/tape di rescue
18Summary(sp): Un programa para los usuarios de Linux por crear una CD/cinta de restoracion/rescate
[53]19
20Name: %{name}
21Version: %{version}
[64]22Release: %{mrel}
[1]23License: GPL
[313]24Group: %{grp}
[53]25Url: http://mondorescue.berlios.de
26Source: %{src}
27BuildRoot: %{_tmppath}/%{name}-%{version}
[1]28BuildRequires: newt-devel >= 0.50, slang-devel >= 1.4.1, gcc
29%ifarch ia64
[315]30Requires: %{addreq}, elilo, parted
[1]31%else
[315]32Requires: %{addreq}, syslinux >= 1.52
[1]33%endif
34
[53]35#%package xmondo
36#Summary: A QT based graphical front end for %{name}
37#Group: Applications/Archiving
38#Requires: %{name} = %{version}-${release}, qt, kdelibs
39#
40#%package %{name}-devel
41#Summary: Header files for building against Mondo
42#%if %is_mandrake
43#Group: Development/Libraries
44#%endif
45#if %is_redhat
46#Group: Development/Other
47#%endif
48#Provides: libmondo-devel mondo-devel
49#Obsoletes: libmondo-devel
50#
51#%description -n %{name}-devel
52#Mondo libraries and includes
[1]53
54%description
[53]55Mondo is a GPL disaster recovery solution to create backup media (CD, DVD, tape, network images) that can be used to redeploy the damaged system, as well as deploy similar or less similar systems.
[1]56
57%description -l fr
58Objectif
59""""""""
[53]60Mondo est une solution GPL de sauvegarde en cas de désastre pour créer des médias (CD, DVD, bande, images réseau) qui peuvent être utilisés pour redéployer le système endomangé, aussi bien que des systèmes similaires, ou moins similaires.
[1]61
62%description -l it
63Scopo
64"""""
65Mondo e' un programma che permette a qualsiasi utente Linux
66di creare un cd di rescue/restore (o piu' cd qualora l'installazione
67dovesse occupare piu' di 2Gb circa). Funziona con gli azionamenti di
68nastro, ed il NFS, anche.
69
70%description -l sp
71Objectivo
72"""""""""
73Mondo es un programa que permite cualquier usuario de Linux a crear una CD
74de restoracion/rescate (o CDs, si su instalacion es >2GO aprox.). Funciona
75con cintas y NFS, tambien.
76
[53]77#%description xmondo
78#Xmondo is a QT based graphical frontend to mondoarchive. It can help you
79#set up a backup by following onscreen prompts.
[1]80
81%prep
[53]82%setup -q -n %name-%{version}
[1]83
[53]84%build
[1]85%configure %{!?_without_xmondo:--with-x11}
86%{__make} VERSION=%{version} CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_REENTRANT"
87
88%install
[53]89%{__rm} -rf $RPM_BUILD_ROOT
90%makeinstall
[1]91
[53]92%post
93/sbin/ldconfig
[187]94%{__chmod} 755 %{_libdir}/%{name}/restore-scripts/%{name}/*
[1]95
[53]96%postun
97/sbin/ldconfig
[1]98
99%clean
100%{__rm} -rf $RPM_BUILD_ROOT
101
102%files
[53]103%defattr(644,root,root,755)
[367]104%doc ChangeLog svn.log
[53]105%doc INSTALL COPYING README TODO AUTHORS NEWS
[1]106
[53]107%attr(755,root,root) %{_sbindir}/*
[187]108#%attr(755,root,root) %{_libdir}/%{name}/restore-scripts/%{name}/*
109%{_libdir}
110%{_mandir}
[53]111
[79]112#%{!?_without_xmondo:%files xmondo}
113#%{!?_without_xmondo:%{_sbindir}/xmondo}
114#%{!?_without_xmondo:%{_libdir}/libXmondo-%{libversion}.so}
115#%{!?_without_xmondo:%{_libdir}/libXmondo.so}
116#%{!?_without_xmondo:%{_datadir}/mondo/mondo.png}
[1]117
118%changelog
[102]119* Fri Nov 05 2005 Bruno Cornec <bcornec@users.berlios.de> 1.05
120- ia64 is now working
121- -p option related bug fixed
[179]122- use libdir instead of datadir
[102]123
[14]124* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 2.04_berlios
[13]125- Merge of patches mentionned on mondo ML + ia64 updates
[53]126- Add -p option
[13]127
[1]128* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 2.04_cvs_20050503
129- made mondo more clever about finding its home. Avoids mondo considering
130 directories like '/usr/share/doc/momdo' as its home.
131
132* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 2.03
133- test sanity of user-specified tempdir
134- better SLES8 support
135
136* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 2.02
137- instead of using 'dd' to erase partition table, delete existing
138 partitions w/ the same call to fdisk that is used to create the
139 new partitions; this should avoids locking up the partition table
140- set bootable partition in the above same call to fdisk, for
141 the same reason (avoids locking up the partition table)
142- better software RAID support
143- mount ext3 partitions as ext2 when restoring - better for Debian
144- better star, ACL support
145- added ACL, xattr support for afio users
146
147* Fri Jun 26 2004 Hugo Rabson <hugorabson@msn.com> 2.01
148- fixed cvs for SuSE systems
149- fixed NTFS backup/restore bug relating to partimagehack
150 log file overflow and NTFS v non-NTFS differentiation
151- more reliable extraction of config info from CDs, floppies
152- better support of ISO dirs at restore-time (Conor Daly)
153- fixed spec file for SuSE users
154- added ldconfig to install section
155
156* Fri Jun 19 2004 Hugo Rabson <hugorabson@msn.com> 2.00
157- first 2.0 release
158- updated grub-install.patched to support SuSE and Red Hat
159- call 'mt' to set block size to 32K before opening in/out tape
160- updated mondo-prep.c to create each disk's partitions all at once
161 (one call per drive) instead of one call to fdisk per partition
162- when extracting cfg file and mountlist from all.tar.gz (tape copy),
163 use block size of INTERNAL_TAPE_BLK_SIZE, not TAPE_BLOCK_SIZE
164- added star and rudimentary SELinux support
165- fixed lots of bugs
166- all logging now goes to /var/log/mondo-archive.log, with symlink
167 to /tmp/mondo-restore.log for restore-time log-tracking
168- added grub-install.patched
169- removed embleer & other binaries
170- added '-b' to specify block size
171- added '-R' for star support
172
173* Thu Mar 25 2004 Bruno Cornec <Bruno.Cornec@hp.com> 1.7_cvs-20040325
174- ia64 fixes
175
176* Fri Nov 07 2003 Joshua Oreman <oremanj@get-linux.org> 1.7_cvs-20031107
177- fixed symbolic links for libraries
178- added support for boot/root multi floppies
179
180- added kdelibs as xmondo dependency
181- added xmondo pixmap installation
182- better find_cdrom_device(), to cope w/ multiple CD writers
183- fixed -m and -Vc flags
184- fixed NTFS support!
185- bootable CD uses native, not El Torito, support now
186- removed mondo-makefilelist
187- added 2.6 kernel support
188- if 2.6 kernel, insist that the user specify CD device
189- drop Embleer; insist on ms-sys and parted if Windows partition
190
191* Wed Nov 05 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031105.1
192- added -devel package
193
194* Tue Nov 04 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031104.1
195- made xmondo a second package
196- added ability to specify --without xmondo at build time
197
198* Sun Nov 02 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031102.1
199- Clean up, added spanish translation
200- Set prefix to be /usr
201- added/fixed Requires
202- remove CVS directories prior to building
203
204* Thu Oct 23 2003 Hugo Rabson <hugorabson@msn.com> 1.75_cvs_20031023
205- nothing yet
206
207* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 1.75
208- fixed chmod/chown bug (Jens Richter)
209- ask user to confirm NFS mountpoint in Interactive Mode
210- rewritten format_everything() to make sure LVMs, RAIDs and
211 regular partitions are prepped in the correct order
212- better magicdev support
213- rewritten external binary caller subroutine
214- DVD support added
215- better backup-time control gui; offer to exclude nfs if appl.
216- fixed multi-tape support
217- re-implemented -D and -J
218- fixed bug in extract_config_file_from_ramdisk() which
219 affected tape+floppy users
220- updated is_incoming_block_valid() to make it
221 return end-of-tape if >300 flotsam blocks
222- unmount CD-ROM before burning (necessary for RH8/9)
223- fixed some stray assert()'s
224- fixed bug in grub-MR (Christian)
225- make user remove floppy/CD before restoring interactively from tape
226- fixed bug in am_I_in_disaster_recovery_mode()
227- added code to nuke_mode() to make sure NFS
228 (backup) share is mounted in Nuke Mode
229- improved tape device detection code
230- better GRUB support
231- better logging of changed bigfiles at compare-time
232- better NTFS support, thanks to partimagehack-static
233- better logging
234- rewrote tape-handling code, breaking compatibility w/ previous versions
235- fixed ISO/CD biggiefile verification bug in mondoarchive
236- fixed bug which stopped boot/compare-time changelist from popping up
237- replaced mondo-makefilelist with C code - faster, cleaner
238- tweaked GUI - better feedback
239
240* Wed May 28 2003 Anonymous <root@rohan> 1.74
241- misc fixes (Michael Hanscho's friend)
242- added rudimentary support for SME
243- added better label support
244- fixed biggietime atime/ctime restoration bug 73
245- fixed 'default boot loader' detection bug (Joshua Oreman)
246- use single-threaded make_afioballs_and_images() if FreeBSD
247- fixed mondoarchive -Vi multi-CD verify bug (Tom Mortell)
248- superior get_phys_size_of_drive() (Joshua Oreman)
249- fixed RAID-related bug in where_is_root_mounted()
250- ISO tweaks
251- fixed silly bug in load_filelist() which stopped
252 funny German filenames from being handled properly
253- fixed various calls to popup_and_get_string()
254- fixed spec file
255- reject -E /
256- added partimagehack to the mix
257
258* Tue May 20 2003 Anonymous <root@rohan> 1.73
259- mark devices as bootable _after_ unmounting them
260- resolve boot device (-f) if softlink
261- post_param_configuration() --- store iso-dev and isodir
262- added post-nuke-sample.tgz to package
263- Nuke Mode now checks mountlist against hardware; offer user
264 opportunity to edit mountlist if insane; if user declines, abort
265- added lots of assert()'s and other checks
266- ran code thru Valgrind to catch & fix some memory leaks
267- made mondo-restore.c smaller by moving some subroutines to
268 common/libmondo-raid.c and mondorestore/mondo-rstr-compare.c
269- added '-Q' to let user test mondoarchive's ability to find
270 their boot loader and type
271- improved which_boot_loader()
272- when burning or comparing to a CD, defeat autorun if it is
273 running, to avoid confusing mondoarchive and the user
274- if original backup media no longer available at boot-time
275 then offer user chance to choose another media source
276- when booting, type 'nuke noresize' to nuke w/o resizing
277 mountlist to fill your drives
278- add 'textonly' when booting, to avoid using Newt gui
279- run nice(20) to prioritize mondoarchive at start
280- don't pause and wait for next blank CD at backup-time
281 unless necessary (e.g. previous CD has not been removed)
282- get_phys_size_of_drive() --- better support of older drives
283- don't eject if "donteject" is in kernel's command line
284- cleaned up segfault-handling
285- added Conor's strip_path() to improve file list display
286- added Herman Kuster's multi-level bkp patch
287- better boot-time screen/message
288- added Joshua Oreman's FreeBSD patches x3
289- fixed interactive/textonly support
290- fixed support for subdir-within-NFS-mount
291- fixed "Can't backup if ramdisk not mounted" bug
292- try to work around eccentricities of multi-CD drive PCs
293- misc clean-ups (Steve Hindle)
294
295* Tue Apr 08 2003 Hugo Rabson <hugorabson@msn.com> 1.72
296- LVM/RAID bugs fixed (Brian Borgeson)
297- major clean-up of code (Stan Benoit)
298- make-me-bootable fix (Juraj Ziegler)
299- fixed problem w/ multi-ISO verify cycle (Tom Mortell)
300- removed duplicate entry from makefile
301- if root is /dev/root then assume not a ramdisk
302- reject relative paths if -d flag (Alessandro Polverini)
303- fixed potentially infinite loop in log_to_screen (Tom Mortell)
304- add '/' to custom filelist as workaround for obscure bug
305- ask user speed of CDRW if writing to CD
306- find_cdrom_device() --- if nonexistent/not found then
307 make sure to return '' as dev str and 1 as res
308- tweaked restore scripts tgz
309- cleaned up find_cdrom_device()
310- if user creates /usr/share/mondo/payload.tgz then untar
311 payload to CD at backup-time
312- fixed insist_on_this_cd_number()
313- fixed am_i_in_disaster_recovery_mode()
314- misc clean-up (Tom Mortell)
315- made code more legible
316- fixed post-nuke support
317- added -e support
318- fixed nfs support
319- fixed iso support
320- at restore-time, only sort mountlist internally,
321 in mount_all_devices() and unmount_all_devices()
322- fixed cosmetic bug in label-partitions-as-necessary
323- updated documentation
324- fixed fstab-hacking scripts
325
326* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 1.71
327- log newt, slang, ncurses info
328- updated man page
329- handle %% chars in issue.net properly (Heiko Schlittermann)
330- fixed serious NFS restore bug
331- cleaned up spec file; it should cause fewer problems now (Jesse Keating)
332- changed various strcpy() calls to strncpy() calls
333- added mondo-makefilelist to makefile (Mikael Hultgren)
334- mount_cdrom() better at handling multiple CD drives
335- exclude /media/cdrom,cdrecorder,floppy
336- sensibly_set_tmpdir_and_scratchdir() --- exclude smb and smbfs
337- better logging by eval_call_to_make_ISO()
338- accept -J <fname> to let user provide their own fs catalog
339 instead of -I <paths> to backup
340- if dir excluded with -E or included with -I and dir is actually
341 a softlink then exclude/include the dir pointed to, as well
342- better location for manpage
343- adjusted block size of tarball at start of tape, to help
344 users w/ broken tape driver firmware
345- sort -u fstab after modifying it
346- if backup type is nfs then don't estimate noof media
347- fixed Makefile (Mikael Hultgren)
348- updated manpage
349
350* Mon Dec 07 2002 Hugo Rabson <hugo@firstlinux.net> 1.70
351- new devel branch opened
352
353* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 1.52
354- fixed bug in multithreading
355- use new grub-MR instead of grub-install
356- wipe only the partition table (not the MBR) when partitioning drives
357- ignore lilo.conf.anaconda when looking for lilo.conf file
358- accepts '-l RAW' to backup/restore original boot sector instead
359 of running grub or lilo to init it after restoring
360- fixed&updated stabgrub-me script; software RAID + GRUB work now
361- mount/unmount /boot partition for Gentoo 1.2 users
362- re-enabled extra tape checksums
363- disabled spurious warnings
364- unmount/remount supermounts at start/end of live restore, if nec.
365- cleaned up mondo's tape block handling (now, TAPE_BLOCK_SIZE=128K
366 and I've added INTERNAL_TAPE_BLK_SIZE=32K variable for buffering)
367- added Makefile
368- added -l RAW, to backup and restore original MBR
369- cleaned up iso_mode() and nfs restoring
370- create /mnt/RESTORING/mnt/.boot.d for Gentoo users
371- made mondorestore CD bootable for ArkLinux users
372- if user runs as 'su' not 'su -' then work around
373
374* Sun Nov 17 2002 Hugo Rabson <hugo@firstlinux.net> 1.51
375- pop-up list of changed files, at end of verification phase
376- better handling of changed.files list at restore-time
377- lots of CD-related fixes
378- added '-N' flag --- to let user exclude all NFS-related mounts&devices
379- better handling of 'kill'
380- restructuring of code to ease integration of mondo w/XMondo
381- fixed obscure bug in find_and_mount_actual_cd()
382- if / or /root has <50MB free then abort & complain
383- fixed install.sh
384- fixed .spec file
385- updated documentation
386- commented code
387- updated man page
388- added -v / --version flag
389- replace convoluted grep with wc (KP)
390- fixed bug affecting restoration of bigfiles from CD's created w/0 compression
391- fixed BurnProof-related bug
392- better at figuring out which is the best partition for temp/scratchdir
393- added do-not-compress-these (text file) to RPM
394- do not compress files of types listed in do-not-compress-these
395- dropped -U from call to afio - saves 20-30% runtime (Cosgrove)
396- added Cosgrove's do-not-compress-these list
397- included various patches from KP
398- chmod tmpdir, scratchdir to 700 before using
399- restore from specified backup device, even if its own cfg file disagrees
400- fixed multi-tape bug
401- fixed "Can't find first ISO when verifying nonbootable ISO" bug
402- multithreaded make_afioballs_and_images()
403- tmpdir and scratchdir are set sensibly whether mondoarchive is called with
404 command-line parameters or not
405- fixed bug in strip_spaces() which stopped it from handling
406 small strings correctly - affected mountlist editor
407- create a repaired copy of grub-install which is RAID-friendly;
408 use it when initializing boot sector with run_grub()
409- fixed bug in mondo-makefilelist
410
411* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 1.50
412- if restoring, don't try to find SCSI node of CD-ROM drive; find /dev entry
413- during selective restore, skip filesets which don't contain relevant archives
414- set /dev/null's perms to 777, just in case devfs-enabled kernel mangles it
415- remove /var/run/*.pid after restoring
416- move spurious lockfiles from /home/* to /home/*/.disabled
417- ask user to confirm the tape/CD device name
418- lots of multitape-related fixes
419- added code to autodetect the hardware of the user, if possible
420- if isodir does not exist then abort
421- more sanity-checking for -d flag
422- doubled 'biggiefile' threshold... to 32MB
423- exclude /root/images/mindi
424- fixed multi-imagedev bug (Emmanuel Druon)
425- unmount/remount /mnt/floppy before/after backing up, if Mandrake
426- restructured the source files
427- fixed serious bug in line 1546 - should have been !=, not ==; stopped
428 mondorestore from correctly restoring big files
429- added '#include <signal.h>' to my-stuff.h
430- exclude "incheckentry xwait()" from changed.files
431- fixed minor bug in find_cdrom_device()
432- fixed bug in friendly_sizestr...
433- insist on tape #1 when start verifying
434- added internal buffering, replacing the external 'buffer' exe
435- if differential backup then don't permit formatting or fdisking,
436 whether Interactive or Nuke mode
437- if mondorestore is run on live filesystem (or from ramdisk) without
438 parameters then mondorestore will ask which backup media (tape, CD, etc.)
439 was used; it will read the config file from the media and proceed from there
440- if tape streamer is softlink then resolve it first
441- incorporate post-nuke tarball
442- if user doesn't specify tape size, proceed anyway; behave intelligently
443 in the event of end-of-tape
444- prefix bkpinfo->restore_path to biggiefile fname before generating
445 checksum & comparing to archived biggiefile
446- if /etc/lilo.conf not found not /etc/lilo.conf.anaconda found
447 then create a softlink from the former to the latter, to work
448 around RH7.3's b0rken LILO support
449- LFS support (mharris, michele, hugo)
450- fixed verify bug --- CD#1 was being verified again & again & ...
451- differential mode fixed; supported again
452- ask user for boot loader + device if not detectible
453- list up to 512 files in file selection window at once (was 128)
454- better handling of bigfiles' checksums, perms and owns
455- delete final filelist if <=2 bytes long
456- if kernel not found and mondo in graphics mode then popup and ask
457 for kernel path+filename
458
459* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 1.45-1
460- 1.5x branch forked off from 1.4x branch
461
462
463
464
Note: See TracBrowser for help on using the repository browser.