source: MondoRescue/branches/stable/mondo/distributions/debian/rules@ 1051

Last change on this file since 1051 was 580, checked in by bcornec, 18 years ago

Debian configuration files added (Andree Leidenfrost)

  • Property svn:executable set to *
File size: 3.2 KB
Line 
1#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4# GNU copyright 1997 to 1999 by Joey Hess.
5#
6# $Id$
7#
8
9# Uncomment this to turn on verbose mode.
10#export DH_VERBOSE=1
11
12# Define package name variable for a one-stop change.
13PACKAGE_NAME = mondo
14
15# These are used for cross-compiling and for saving the configure script
16# from having to guess our platform (since we know it already)
17DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
18DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
19
20CFLAGS = -Wall -g
21
22ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
23 CFLAGS += -O0
24else
25 CFLAGS += -O2
26endif
27ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
28 INSTALL_PROGRAM += -s
29endif
30
31config.status: configure
32 dh_testdir
33
34 # Configure the package.
35 CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man
36
37# Build both architecture dependent and independent
38build: build-arch build-indep
39
40# Build architecture dependent
41build-arch: build-arch-stamp
42
43build-arch-stamp: config.status
44 dh_testdir
45
46 # Compile the package.
47 $(MAKE)
48
49 touch build-stamp
50
51# Build architecture independent
52build-indep: build-indep-stamp
53
54build-indep-stamp: config.status
55 # Nothing to do, the only indep item is the manual which is available as html in original source
56 touch build-indep-stamp
57
58# Clean up
59clean:
60 dh_testdir
61 dh_testroot
62 rm -f build-arch-stamp build-indep-stamp #CONFIGURE-STAMP#
63 # Clean temporary document directory
64 rm -rf debian/doc-temp
65 # Clean up.
66 -$(MAKE) distclean
67 rm -f config.log
68ifneq "$(wildcard /usr/share/misc/config.sub)" ""
69 cp -f /usr/share/misc/config.sub config.sub
70endif
71ifneq "$(wildcard /usr/share/misc/config.guess)" ""
72 cp -f /usr/share/misc/config.guess config.guess
73endif
74
75 dh_clean
76
77# Install architecture dependent and independent
78install: install-arch install-indep
79
80# Install architecture dependent
81install-arch: build-arch
82 dh_testdir
83 dh_testroot
84 dh_clean -k -s
85 dh_installdirs -s
86
87 # Install the package files into build directory:
88 # - start with upstream make install
89 $(MAKE) install prefix=$(CURDIR)/debian/$(PACKAGE_NAME)/usr mandir=$(CURDIR)/debian/$(PACKAGE_NAME)/usr/share/man
90 # - copy html manual to temporary location for renaming
91 mkdir -p debian/doc-temp
92 cp -a docs/en/mondorescue-howto debian/doc-temp/html
93
94 dh_install -s
95
96# Install architecture independent
97install-indep: build-indep
98 dh_testdir
99 dh_testroot
100 dh_clean -k -i
101 dh_installdirs -i
102 dh_install -i
103
104# Must not depend on anything. This is to be called by
105# binary-arch/binary-indep
106# in another 'make' thread.
107binary-common:
108 dh_testdir
109 dh_testroot
110 dh_installchangelogs ChangeLog
111 dh_installdocs
112 dh_installman
113 dh_link
114 dh_strip
115 dh_compress
116 dh_fixperms
117 dh_installdeb
118 dh_shlibdeps
119 dh_gencontrol
120 dh_md5sums
121 dh_builddeb
122
123# Build architecture independant packages using the common target.
124binary-indep: build-indep install-indep
125 $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
126
127# Build architecture dependant packages using the common target.
128binary-arch: build-arch install-arch
129 $(MAKE) -f debian/rules DH_OPTIONS=-a binary-common
130
131# Build architecture depdendent and independent packages
132binary: binary-arch binary-indep
133.PHONY: clean binary
Note: See TracBrowser for help on using the repository browser.