source: MondoRescue/branches/stable/mindi/distributions/rpm/mindi.spec@ 933

Last change on this file since 933 was 933, checked in by Bruno Cornec, 17 years ago

Fix a rpm build issue on x86_64

  • Property svn:keywords set to Id
File size: 1.5 KB
Line 
1#
2# $Id: mindi.spec 933 2006-11-15 17:30:04Z bruno $
3#
4Summary: Mindi creates emergency boot disks/CDs using your kernel, tools and modules
5Name: mindi
6Version: VVV
7Release: RRR
8License: GPL
9Group: GRP
10Url: http://www.mondorescue.org
11Source: SSS
12BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
13ExcludeArch: ppc
14Requires: bzip2 >= 0.9, mkisofs, ncurses, binutils, gawk, dosfstools, mindi-busybox DDD
15OBS
16# Not on all systems
17#Conflicts: bonnie++
18
19%description
20Mindi takes your kernel, modules, tools and libraries, and puts them on N
21bootable disks (or 1 bootable CD image). You may then boot from the disks/CD
22and do system maintenance - e.g. format partitions, backup/restore data,
23verify packages, etc.
24
25%prep
26%setup -n %name-%{version}
27
28%build
29%ifarch ia64
30%{__make} -f Makefile.parted2fdisk clean
31%{__make} -f Makefile.parted2fdisk
32%endif
33
34%install
35%{__rm} -rf $RPM_BUILD_ROOT
36export DONT_RELINK=1
37
38export PREFIX=${RPM_BUILD_ROOT}%{_exec_prefix}
39export CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}
40export MANDIR=${RPM_BUILD_ROOT}%{_mandir}
41export LIBDIR=${RPM_BUILD_ROOT}%{_libdir}
42export DOCDIR=${RPM_BUILD_ROOT}%{_docdir}
43export RPMBUILDMINDI="true"
44
45./install.sh
46
47%clean
48%{__rm} -rf $RPM_BUILD_ROOT
49
50%post
51if [ -f /usr/local/sbin/mindi ]; then
52 echo "WARNING: /usr/local/sbin/mindi exists. You should probably remove your manual mindi installation !"
53fi
54
55%files
56%defattr(-,root,root)
57%config(noreplace) %{_sysconfdir}/mindi/deplist.txt
58%doc ChangeLog INSTALL COPYING README TODO README.ia64 README.pxe README.busybox svn.log
59%{_mandir}/man8/*
60%{_libdir}/mindi
61%{_sbindir}/*
62
63%changelog
Note: See TracBrowser for help on using the repository browser.