source: MondoRescue/branches/stable/mindi/distributions/rpm/mindi.spec@ 550

Last change on this file since 550 was 550, checked in by bcornec, 18 years ago

Cleanup in build process continue

  • removal of most small scripts
  • based on one main svn2build script
  • spec files reviewed for fedora remarks
  • changelog and TAG integrated
  • Property svn:keywords set to Id
File size: 1.6 KB
Line 
1#
2# $Id: mindi.spec 550 2006-05-14 17:54:15Z bcornec $
3#
4%define mrel RRR
5
6Summary: Mindi creates emergency boot disks/CDs using your kernel, tools and modules
7Name: mindi
8Version: VVV
9Release: %mrel
10License: GPL
11Group: GRP
12Url: http://www.mondorescue.org
13Source: SSS
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
15Requires: bzip2 >= 0.9, mkisofs, ncurses, binutils, gawk, dosfstools DDD
16# Not on all systems
17#Conflicts: bonnie++
18
19%description
20Mindi takes your kernel, modules, tools and libraries, and puts them on N
21bootable disks (or 1 bootable CD image). You may then boot from the disks/CD
22and do system maintenance - e.g. format partitions, backup/restore data,
23verify packages, etc.
24
25%prep
26%setup -n %name-%{version}
27
28%build
29%ifarch ia64
30%{__make} -f Makefile.parted2fdisk clean
31%{__make} -f Makefile.parted2fdisk
32%endif
33
34%install
35%{__rm} -rf $RPM_BUILD_ROOT
36export DONT_RELINK=1
37
38export PREFIX=${RPM_BUILD_ROOT}%{_exec_prefix}
39export CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}
40export RPMBUILDMINDI="true"
41
42./install.sh
43
44%clean
45%{__rm} -rf $RPM_BUILD_ROOT
46
47%post
48if [ -f /usr/local/sbin/mindi ]; then
49 echo "WARNING: /usr/local/sbin/mindi exists. You should probably remove your manual mindi installation !"
50fi
51
52%files
53%defattr(644,root,root,755)
54%config(noreplace) %{_sysconfdir}/mindi
55%config(noreplace) %{_sysconfdir}/mindi/deplist.txt
56%doc ChangeLog INSTALL COPYING README TODO README.ia64 README.pxe README.busybox svn.log
57%{_mandir}/man8/*
58%{_libdir}/mindi
59%attr(755,root,root) %{_sbindir}/*
60%attr(755,root,root) %{_libdir}/mindi/aux-tools/sbin/*
61%attr(755,root,root) %{_libdir}/mindi/rootfs/bin/*
62%attr(755,root,root) %{_libdir}/mindi/rootfs/sbin/*
63
64%changelog
Note: See TracBrowser for help on using the repository browser.