source: MondoRescue/branches/stable/mindi/distributions/rpm/mindi.spec@ 401

Last change on this file since 401 was 401, checked in by bcornec, 18 years ago
  • Integrate some SuSE patches and spec tips
  • all the doc is now under documentation (man pages, pdf, generated doc)
  • delivery process adapted consequently
  • Property svn:keywords set to Id
File size: 11.6 KB
Line 
1#
2# $Id: mindi.spec 401 2006-02-17 14:37:04Z bcornec $
3#
4%define name mindi
5%define version VVV
6%define mrel RRR
7%define src SSS
8%define grp GRP
9%define addreqb bzip2 >= 0.9, mkisofs, ncurses, binutils, gawk, dosfstools
10%define addreq DDD
11
12# if mandriva official build (rpm --with is_official)
13%{?is_official:%define rel %{mkrel} %{mrel}}%{!?is_official:%define rel %{mrel}}
14
15# define the mkrel macro if it is not already defined if mandriva offical build
16%if is_official
17%{?!mkrel:%define mkrel(c:) %{-c:0.%{-c*}.}%{!?_with_unstable:%(perl -e '$_="%{1}";m/(.\*)(\\d+)$/;$rel=${2}-1;re;print "$1$rel";').%{?subrel:%subrel}%{!?subrel:1}.%{?distversion:%distversion}%{?!distversion:%(echo $[%{mdkversion}/10])}}%{?_with_unstable:%{1}}%{?distsuffix:%distsuffix}%{?!distsuffix:mdk}}
18%endif
19
20Summary: Mindi creates emergency boot disks/CDs using your kernel, tools and modules
21Name: %name
22Version: %version
23Release: %rel
24License: GPL
25Group: %{grp}
26Url: http://mondorescue.berlios.de
27Source: %{src}
28BuildRoot: %{_tmppath}/%{name}-%{version}
29Requires: %{addreq}
30# Not on all systems
31#Conflicts: bonnie++
32
33%description
34Mindi takes your kernel, modules, tools and libraries, and puts them on N
35bootable disks (or 1 bootable CD image). You may then boot from the disks/CD
36and do system maintenance - e.g. format partitions, backup/restore data,
37verify packages, etc.
38
39%debug_package
40%prep
41%{__rm} -rf $RPM_BUILD_ROOT
42%setup -n %name-%{version}
43
44%build
45%ifarch ia64
46%{__make} -f Makefile.parted2fdisk clean
47%{__make} -f Makefile.parted2fdisk
48%endif
49
50%install
51export DONT_RELINK=1
52
53%{__rm} -rf $RPM_BUILD_ROOT
54export PREFIX=${RPM_BUILD_ROOT}%{_exec_prefix}
55export CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}
56export RPMBUILDMINDI="true"
57
58./install.sh
59
60%clean
61%{__rm} -rf $RPM_BUILD_ROOT
62
63%post
64for i in %{_libdir}/mindi/aux-tools/sbin/* %{_libdir}/mindi/rootfs/bin/* %{_libdir}/mindi/rootfs/sbin/* ; do
65 if [ ! -h $i ]; then
66 %{__chmod} 755 $i
67 fi
68done
69if [ -f /usr/local/sbin/mindi ]; then
70 echo "WARNING: /usr/local/sbin/mindi exists. You should probably remove your manual mindi installation !"
71fi
72
73%files
74%defattr(644,root,root,755)
75%config(noreplace) %{_sysconfdir}/mindi/deplist.txt
76%doc ChangeLog INSTALL COPYING README TODO README.ia64 README.pxe README.busybox svn.log
77%{_mandir}
78%{_libdir}/mindi
79%attr(755,root,root) %{_sbindir}/*
80
81%changelog
82* Fri Feb 16 2006 Bruno Cornec <bcornec@users.berlios.de> 1.0.7
83- Updated to 1.0.7
84- RPMS spec are now generated instead of using '%' variables
85
86* Fri Nov 05 2005 Bruno Cornec <bcornec@users.berlios.de> 1.05
87- ia64 is now working
88- use install.sh script
89- use libdir for binary data
90
91* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 1.04_berlios
92- Merge of patches mentionned on mondo ML + ia64 updates
93- Fix bugs when called alone
94
95* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 1.04_cvs_20050503
96- supports exec-shield
97
98* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 1.03
99- better support of SLES 8
100
101* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 1.02
102- better kernel-level logging
103- added ACL, xattr binaries to deplist.txt
104- fixed obscure bug which occasionally stopped mindi from correctly finding
105 and documenting all LVM2 LVM-on-RAID volumes
106
107* Fri Jun 25 2004 Hugo Rabson <hugorabson@msn.com> 1.01
108- added ide_tape and other modules to mindi's config detection
109- unmount errant ramdisk ($mtpt) if fail to create boot floppy
110- better support of ISO dirs at restore-time (Conor Daly)
111
112* Fri Jun 18 2004 Hugo Rabson <hugorabson@msn.com> 1.00
113- first 1.0x release
114- busybox now static
115- trap Ctrl-Alt-Del; trigger soft reset
116- better SuSE 9.1 support
117- added parted2fdisk.pl (IA64) (Bruno Cornec)
118- add LVM2 support for kernel 2.6 (Takeru Komoriya)
119- better detection of multiple Mindis (Martin Fürstenau)
120- don't complain if just a Mindi boot CD & not a platform for Mondo
121- updated busybox to 1.0.0pre10
122- removed uClibc
123- add memtest support
124- 2.6 kernel support
125- removed Embleer files (Andree Leidenfrost)
126- added kernel-only floppy support, to accommodate really big kernels
127- updated+rebuilt busybox
128- added star support
129- mount /sys at boot-time
130- better 64-bit and 2.6 kernel support
131- better LVM, failsafe kernel support (Jim Richard)
132- use LILO, not raw kernel, on 1.4MB boot floppy
133- record names of unsaved modules, for future reference
134- enlarged ramdisk by 8MB
135
136* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 0.95
137- changed some '==' to '=' --- now more RH6-friendly
138- allow absolute pathnames again in deplist
139- disable multifunc cd thing
140- better Gentoo support (Bill)
141- better OnStream support
142- better Slackware support (Laurenz)
143- added partimagehack-static to deplist.txt
144- recompiled Busybox - now 10k smaller; better stack-handling
145- fixed boot screen typo
146- added support for 'auto' fs format
147- better devfs support for Mandrake users
148- better Debian+LVM support (Ralph Grewe)
149- updated analyze-my-lvm to handle floating-point gigabyte -L values
150
151* Thu Jul 24 2003 Anonymous <root@rohan> 0.94
152- altered rootfs's /dev entry to stop cvs from becoming confused
153- tweaked MAX_COMPRESSED_SIZE
154- added multi-function CD support to mindi and sbin/post-init
155- re-mount root as rw just in case
156- ask user to remove last data (floppy) disk if nec. (Tom Mortell)
157- added support for 5th column in mountlist.txt for labels
158- added symlinks.tgz
159- suppress erroneous error msgs re: failsafe kernel
160
161* Sun May 18 2003 Hugo Rabson <hugorabson@msn.com> 0.93
162- added cciss.o to SCSI_MODS
163- if format type is (e.g.) ext3,ext2 then use 1st entry
164- re-enabled fsck*
165- if cciss in use the enable it at boot-time
166- added /dev/ataraid/* to boot disk via ataraid.tgz (Luc S.)
167- better ISO support
168- tweaked Mindi to use 10-15% fewer floppies
169- added RUN_AFTER_INITIAL_BOOT_PHASE to let user specify a command
170 to be run by Mindi before it bootstraps to aux data disks;
171 e.g. 'echo engage > /proc/scsi/something'
172- added RUN_AFTER_BOOT_PHASE_COMPLETE to let user specify a command
173 to be run by Mindi after it boots but before it runs mondorestore
174- allow for Debian & other Stiefkinder that use 'none', not 'swap'
175 as the mountpoint of the swap partition
176- removed afio dependency
177- re-worked install.sh and tarball not to use tgz's
178- cleared up the boot msg
179- updated busybox to 0.60.5; updated uClibc to 0.9.19
180- add #!/bin/sh to start of insert-all-my-modules
181- fixed obscure bug in install-additional-tools
182- changed grep -m to grep | head -n1 for Debian users
183- moved vmlinuz, lib.tar.bz2 to mindi-kernel tarball/rpm
184
185* Wed Apr 09 2003 Hugo Rabson <hugorabson@msn.com> 0.92
186- fixed LVM/RAID bugs (Brian Borgeson)
187- if bad lilo, give more verbose error before quitting
188- added mt and perl to deplist.txt
189- insist on gawk being present
190- insmod ide-cd, cdrom, isofs, just in case
191- boot-time tmpfs ramdisk is now 40m (was 34m)
192- cleaned up logs
193- iso mode now calls Interactive
194- make SizeOfPartition() more Debian-friendly (Andree Leidenfrost)
195- clean up some calls to grep, esp. partition_mountpt=...
196- corrected some bashisms, to suit Debian ped- er, users
197- made first line refer to bash, not sh, to make sure
198 the Debian people know Mindi requires bash, not hs
199- changed grep -v "#" and grep -vx "#.*" to grep -vx " *#.*"
200- disabled code which would have made Mindi use sfdisk instead of fdisk
201 if it looked as if Debian's fdisk would misbehave
202
203* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 0.91
204- new devel branch
205- EXTRA_SPACE=16384
206- updated ResolveSoftlinks() to work better with b0rkn Gentoo devfs /dev
207- patched analyze-my-lvm (Benjamin Mampaey)
208- detect built-in boot.b files in lilo
209- cleaned up spec file a bit, more use of macros (Jesse Keating)
210- return w/err, don't abort, if Matt Nelson's RH8 system is farked
211- better at finding isolinux.bin
212- better at analyzing dependencies when running on broken distributions
213- try harder to boot from CD, even if tape fails
214- added ADDITIONAL_BOOT_PARAMS to be sent to kernel
215- better resolution of relative softlinks, leading to fewer
216 duplicates on data disks and therefore fewer data disks
217- detect Debian+devfs; use sfdisk instead of fdisk in that
218 eventuality, to work around yet another of Debian's warts
219- removed /lib/libuuid.* from rootfs.tgz
220- fixed vi
221- mindi now uses gawk --traditional (making gawk behave in a functionally
222 identical way to awk) - PASS; great, so now Debian needs to fix its awk :)
223- removed / from list of dirs accessed when trying to resolve deplist entry
224- spinner bugfix; handle odd LABELs properly (Tom Mortell)
225- fixed LVM/RAID bugs (Brian Borgeson)
226
227* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 0.72_20021202
228- misc code clean-up
229- save boot device's boot sector
230- detect and beware Compaq diagnostic partitions
231- better handling of devfs V non-devfs kernels and boot devs
232- trimmed busybox 0.60.3 binary on boot disk
233- mindi now resides in /usr/local/bin
234- removed lilo from dependencies
235- more Gentoo-friendly
236
237* Sun Nov 18 2002 Hugo Rabson <hugo@firstlinux.net> 0.71
238- if your kernel's builddate doesn't match any of the kernels in
239 your /boot directory then fudge the issue & find the closest
240 match (*grumble* Debian)
241- scan tape & CD at start, to force inclusion of modules on boot device
242- double EXTRA_SPACE if >7 disks
243- slimmer, more lithesome logfile
244- now accepts --findkernel
245- line 1982 - dd count=24000 should be count=$ramdisksize (Andras Korn)
246- better handling of non-Linux partitions on DevFS-enabled kernels
247- misc clean-ups
248- fixed Debian/ramdisksize/bloat problem (Johannes Franken)
249- fixed 2.4.20/fdisk eccentricity (Alistair Stevens)
250- updated kernel to 2.4.18-mdk6
251- generate mountlist in dev-abetical order ;)
252- fixed minor bug in .spec file
253- better at finding /boot/boot.b if your distro breaks the de facto standard
254- fixed minor bug in MakeMountlist
255- fixed install.sh
256- cleaned up deplist.txt
257- added rudimentary -v / --version flag
258- line 1180 or so --- duplicate mindi.iso entries --- fixed
259- added /bin/[ - a softlink to /bin/sh
260- ListAllPartitions() - sanity fix (KP)
261- fixed .spec bug
262- better feedback
263- added Markus's RAID patch
264- ListAllPartitions() - include /mnt/win* (Hugo)
265
266* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 0.70
267- better logging by dependency-calculating code
268- better handling of dependencies, specifically softlinks
269- if called by mondo then use mondo's temp dir as our temp dir too
270- changed gawk to $AWK in a few places, to allow for Debian
271- added host* config files to deplist
272- added tftp, ifconfig to busybox
273- added RPC support to uClibc
274- cleaned up creation of Mondo-Mindi configuration file
275- fixed bug in TryToFindKernelPath which stopped it from handling
276 multiple, same-version kernels gracefully
277- cleaned up deplist.txt
278- receive 'DIFFERENTIAL' variable from Mondo
279- better Debian compatibility, esp. w/detection of ver# (Hector Alvarez)
280- better devfs support; call fgrep in places instead of grep (Andrew Korn)
281- fixed analyze-my-lvm (Ralph Gruwe)
282- moved 50K of stuff from rootfs.tgz to aux-tools.tgz
283- added x11-tools.tgz option
284- updated /dev/console and /dev/tty0 (Paul Stevens)
285- cleaned up /mnt/groovy-stuff V /tmp/tmpfs code
286- catch sigint, sighup, etc.
287- fixed LILO-related message.txt mistake
288- .spec file clean-up; automation; config file (Carl Wilhem Soderstrom)
289- better devfs support (Andrew Korn)
290
291* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 0.64-1
292- fixed RH7.3 readonly bug
293- improved nfs config file creation
294- search more locations for isolinux.bin
295- added isonuke option
296- faster data disk creation
297- better DevFS support (Hector Alvarez, DuckX)
298- nfs-related fix (Hans Lie)
299- abort if vfat filesystem present but mkfs.vfat missing
300- removed softlink to pico
301- allow Mondo to say no compression will be used
302- added [ to ramdisk
303- tar data disks with -b [block size] of 32k
304- don't autoboot to 'RESTORE' screen - it's scary!
305- let user choose lilo or syslinux as boot loader
306- added syslinux support
307- cleaned up message screens
308
Note: See TracBrowser for help on using the repository browser.