source: MondoRescue/branches/stable/mindi/distributions/rpm/mindi.spec@ 564

Last change on this file since 564 was 564, checked in by bcornec, 18 years ago

Forgot a path in the previous version. Should be complete now

  • Property svn:keywords set to Id
File size: 1.4 KB
RevLine 
[35]1#
2# $Id: mindi.spec 564 2006-05-20 21:40:40Z bcornec $
3#
[313]4%define mrel RRR
[554]5%define tag TTT
[388]6
[1]7Summary: Mindi creates emergency boot disks/CDs using your kernel, tools and modules
[550]8Name: mindi
9Version: VVV
10Release: %mrel
[1]11License: GPL
[550]12Group: GRP
[542]13Url: http://www.mondorescue.org
[550]14Source: SSS
[542]15BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
[550]16Requires: bzip2 >= 0.9, mkisofs, ncurses, binutils, gawk, dosfstools DDD
[20]17# Not on all systems
18#Conflicts: bonnie++
[1]19
20%description
21Mindi takes your kernel, modules, tools and libraries, and puts them on N
22bootable disks (or 1 bootable CD image). You may then boot from the disks/CD
23and do system maintenance - e.g. format partitions, backup/restore data,
24verify packages, etc.
25
26%prep
[555]27%setup -n %name-%{version}-%{tag}
[1]28
29%build
30%ifarch ia64
[50]31%{__make} -f Makefile.parted2fdisk clean
32%{__make} -f Makefile.parted2fdisk
[1]33%endif
34
35%install
[542]36%{__rm} -rf $RPM_BUILD_ROOT
[50]37export DONT_RELINK=1
38
[235]39export PREFIX=${RPM_BUILD_ROOT}%{_exec_prefix}
40export CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}
[179]41export RPMBUILDMINDI="true"
[50]42
[179]43./install.sh
[50]44
[1]45%clean
46%{__rm} -rf $RPM_BUILD_ROOT
47
48%post
[179]49if [ -f /usr/local/sbin/mindi ]; then
50 echo "WARNING: /usr/local/sbin/mindi exists. You should probably remove your manual mindi installation !"
51fi
52
[1]53%files
[542]54%config(noreplace) %{_sysconfdir}/mindi
55%config(noreplace) %{_sysconfdir}/mindi/deplist.txt
[315]56%doc ChangeLog INSTALL COPYING README TODO README.ia64 README.pxe README.busybox svn.log
[423]57%{_mandir}/man8/*
[200]58%{_libdir}/mindi
[564]59%{_sbindir}/*
[1]60
61%changelog
Note: See TracBrowser for help on using the repository browser.