source: MondoRescue/branches/stable/mindi/distributions/rpm/mindi.spec@ 460

Last change on this file since 460 was 460, checked in by bcornec, 18 years ago

merge -r 453:456 $SVN_M/branches/2.0.7 (delivery process adapted for 2.0.7)

  • Property svn:keywords set to Id
File size: 1.9 KB
RevLine 
[35]1#
2# $Id: mindi.spec 460 2006-04-02 22:50:50Z bcornec $
3#
[50]4%define name mindi
[237]5%define version VVV
[313]6%define mrel RRR
[388]7%define src SSS
8%define grp GRP
9%define addreqb bzip2 >= 0.9, mkisofs, ncurses, binutils, gawk, dosfstools
10%define addreq DDD
[423]11%define rel %{mrel}
[388]12
[1]13Summary: Mindi creates emergency boot disks/CDs using your kernel, tools and modules
[50]14Name: %name
15Version: %version
[316]16Release: %rel
[1]17License: GPL
[313]18Group: %{grp}
[50]19Url: http://mondorescue.berlios.de
20Source: %{src}
[1]21BuildRoot: %{_tmppath}/%{name}-%{version}
[314]22Requires: %{addreq}
[460]23Epoch: %(echo EEE | cut -d- -f1 | sed "s~M~~")
[20]24# Not on all systems
25#Conflicts: bonnie++
[1]26
27%description
28Mindi takes your kernel, modules, tools and libraries, and puts them on N
29bootable disks (or 1 bootable CD image). You may then boot from the disks/CD
30and do system maintenance - e.g. format partitions, backup/restore data,
31verify packages, etc.
32
33%prep
[50]34%{__rm} -rf $RPM_BUILD_ROOT
35%setup -n %name-%{version}
[1]36
37%build
38%ifarch ia64
[50]39%{__make} -f Makefile.parted2fdisk clean
40%{__make} -f Makefile.parted2fdisk
[1]41%endif
42
43%install
[50]44export DONT_RELINK=1
45
[1]46%{__rm} -rf $RPM_BUILD_ROOT
[235]47export PREFIX=${RPM_BUILD_ROOT}%{_exec_prefix}
48export CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}
[179]49export RPMBUILDMINDI="true"
[50]50
[179]51./install.sh
[50]52
[1]53%clean
54%{__rm} -rf $RPM_BUILD_ROOT
55
56%post
[179]57if [ -f /usr/local/sbin/mindi ]; then
58 echo "WARNING: /usr/local/sbin/mindi exists. You should probably remove your manual mindi installation !"
59fi
60
[1]61%files
[50]62%defattr(644,root,root,755)
[454]63%config(noreplace) %{_sysconfdir}/mindi/deplist.txt
64%config(noreplace) %{_sysconfdir}/mindi/deplist.d/*
65%config(noreplace) %{_sysconfdir}/mindi/mindi.conf
[315]66%doc ChangeLog INSTALL COPYING README TODO README.ia64 README.pxe README.busybox svn.log
[423]67%{_mandir}/man8/*
[200]68%{_libdir}/mindi
[449]69%attr(755,root,root) %{_sysconfdir}/mindi/mindi.conf
[189]70%attr(755,root,root) %{_sbindir}/*
[423]71%attr(755,root,root) %{_libdir}/mindi/aux-tools/sbin/*
72%attr(755,root,root) %{_libdir}/mindi/rootfs/bin/*
73%attr(755,root,root) %{_libdir}/mindi/rootfs/sbin/*
[1]74
75%changelog
Note: See TracBrowser for help on using the repository browser.