source: MondoRescue/branches/stable/mindi/distributions/gentoo/mindi.ebuild@ 556

Last change on this file since 556 was 556, checked in by bcornec, 18 years ago

mondo-doc should now generate

File size: 1.1 KB
Line 
1# Copyright 1999-2005 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Id$
4# $Header$
5
6DESCRIPTION="A program that creates emergency boot disks/CDs using your kernel, tools and modules."
7HOMEPAGE="http://www.mondorescue.org"
8SRC_URI="ftp://ftp.mondorescue.org/src/${PVR}.tar.gz"
9
10LICENSE="GPL-2"
11SLOT="0"
12KEYWORDS="~x86 -*"
13IUSE=""
14
15DEPEND="virtual/libc"
16RDEPEND=">=app-arch/bzip2-0.9
17 sys-libs/ncurses
18 sys-devel/binutils
19 sys-fs/dosfstools
20 sys-apps/gawk"
21
22src_unpack() {
23 unpack ${A} || die "Failed to unpack ${A}"
24}
25
26src_install() {
27 export PREFIX="/usr"
28 export CONFDIR="/etc"
29 export DONT_RELINK=1
30 export RPMBUILDMINDI="true"
31 ./install.sh
32}
33
34pkg_postinst() {
35 einfo "${P} was successfully installed."
36 einfo "Please read the associated docs for help."
37 einfo "Or visit the website @ ${HOMEPAGE}"
38 echo
39 ewarn "This package is still in unstable."
40 ewarn "Please report bugs to http://bugs.gentoo.org/"
41 ewarn "However, please do an advanced query to search for bugs"
42 ewarn "before reporting. This will keep down on duplicates."
43 echo
44}
Note: See TracBrowser for help on using the repository browser.