source: MondoRescue/branches/stable/mindi-kernel/distributions/rpm/mindi.spec@ 554

Last change on this file since 554 was 554, checked in by bcornec, 18 years ago

Add new tag variable in spec and corresponding TTT macro in m4 files for filename correct handling during build

  • Property svn:keywords set to Id
File size: 1.6 KB
Line 
1#
2# $Id: mindi.spec 554 2006-05-17 23:03:26Z bcornec $
3#
4%define mrel RRR
5%define tag TTT
6
7Summary: Mindi Kernel provides a safe kernel for mindi
8Name: mindi
9Version: VVV
10Release: %mrel
11License: GPL
12Group: GRP
13Url: http://www.mondorescue.org
14Source: SSS
15BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
16Requires: bzip2 >= 0.9, mkisofs, ncurses, binutils, gawk, dosfstools DDD
17# Not on all systems
18#Conflicts: bonnie++
19
20%description
21Mindi takes your kernel, modules, tools and libraries, and puts them on N
22bootable disks (or 1 bootable CD image). You may then boot from the disks/CD
23and do system maintenance - e.g. format partitions, backup/restore data,
24verify packages, etc.
25
26%prep
27%setup -n %name-%{version}
28
29%build
30%ifarch ia64
31%{__make} -f Makefile.parted2fdisk clean
32%{__make} -f Makefile.parted2fdisk
33%endif
34
35%install
36%{__rm} -rf $RPM_BUILD_ROOT
37export DONT_RELINK=1
38
39export PREFIX=${RPM_BUILD_ROOT}%{_exec_prefix}
40export CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}
41export RPMBUILDMINDI="true"
42
43./install.sh
44
45%clean
46%{__rm} -rf $RPM_BUILD_ROOT
47
48%post
49if [ -f /usr/local/sbin/mindi ]; then
50 echo "WARNING: /usr/local/sbin/mindi exists. You should probably remove your manual mindi installation !"
51fi
52
53%files
54%defattr(644,root,root,755)
55%config(noreplace) %{_sysconfdir}/mindi
56%config(noreplace) %{_sysconfdir}/mindi/deplist.txt
57%doc ChangeLog INSTALL COPYING README TODO README.ia64 README.pxe README.busybox svn.log
58%{_mandir}/man8/*
59%{_libdir}/mindi
60%attr(755,root,root) %{_sbindir}/*
61%attr(755,root,root) %{_libdir}/mindi/aux-tools/sbin/*
62%attr(755,root,root) %{_libdir}/mindi/rootfs/bin/*
63%attr(755,root,root) %{_libdir}/mindi/rootfs/sbin/*
64
65%changelog
Note: See TracBrowser for help on using the repository browser.