source: MondoRescue/branches/stable/mindi-busybox/distributions/gentoo/mindi-busybox.ebuild@ 927

Last change on this file since 927 was 927, checked in by Bruno Cornec, 17 years ago

ebuild for mindi-busybox

File size: 1.2 KB
Line 
1# Copyright 1999-2006 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Id$
4
5inherit eutils flag-o-matic
6
7DESCRIPTION="The rescue part of a program that creates emergency boot disks/CDs using your kernel, tools and modules."
8HOMEPAGE="http://www.mondorescue.org"
9SRC_URI="ftp://ftp.mondorescue.org/src/${P}.tar.gz"
10LICENSE="GPL-2"
11SLOT="0"
12KEYWORDS="~x86 ia64 -*"
13DEPEND="virtual/libc"
14RDEPEND=">=app-arch/bzip2-0.9
15 sys-devel/binutils"
16
17src_unpack() {
18 unpack ${A} || die "Failed to unpack ${A}"
19 make oldconfig > /dev/null
20}
21
22src_compile() {
23 # work around broken ass powerpc compilers
24 emake EXTRA_CFLAGS="${CFLAGS}" busybox || die "build failed"
25}
26
27src_install() {
28 # bundle up the symlink files for use later
29 emake PREFIX="/usr/share/mindi/rootfs/bin" install || die
30 rm _install/bin/busybox
31 tar cf busybox-links.tar -C _install . || die
32 insinto /usr/share/mindi
33 doins busybox-links.tar || die
34}
35
36pkg_preinst() {
37 mv "${D}"/usr/share/mindi/busybox-links.tar "${T}"/ || die
38}
39
40pkg_postinst() {
41 cd "${T}" || die
42 mkdir _install
43 tar xf busybox-links.tar -C _install || die
44 cp -vpPR _install/* /usr/share/mindi/rootfs/bin || die "copying links for ${x} failed"
45
46 echo
47}
Note: See TracBrowser for help on using the repository browser.