source: MondoRescue/branches/stable/mindi-busybox/distributions/gentoo/mindi-busybox.ebuild@ 1529

Last change on this file since 1529 was 1529, checked in by Bruno Cornec, 17 years ago
  • ChangeLogs updated for upcoming 2.2.4
  • Attempt to fix #177 by removing first headers and repodata directory before regenerating them.
  • Fix a problem in directory link handling in mindi (seen on gentoo 64) with the precious help of Francesco Talamona ti.liame_at_email.it
  • Gentoo ebuild are now unmasked on my side
  • usb-storage instead of usb_storage as a module name for Virtual CD support seems better
  • Document support for Proliant Virtual Media with mindi
  • Mandriva packages go first to contrib/testing not backport
  • Size of DVD is 4482 (or more surely 4480 to avoid problems). Fixed everywhere.
  • Fix a bug in Mandriva official package creation

(merge -r1519:1528 $SVN_M/branches/2.2.4)

File size: 820 bytes
Line 
1# Copyright 1999-2006 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Id$
4
5inherit eutils flag-o-matic
6
7DESCRIPTION="The rescue part of a program that creates emergency boot disks/CDs using your kernel, tools and modules."
8HOMEPAGE="http://www.mondorescue.org"
9SRC_URI="ftp://ftp.mondorescue.org/src/${P}.tar.gz"
10LICENSE="GPL-2"
11SLOT="0"
12KEYWORDS="x86 ia64 -*"
13DEPEND="virtual/libc"
14RDEPEND=">=app-arch/bzip2-0.9
15 sys-devel/binutils"
16
17src_unpack() {
18 unpack ${A} || die "Failed to unpack ${A}"
19 cd ${P}
20 make oldconfig > /dev/null
21}
22
23src_compile() {
24 # work around broken ass powerpc compilers
25 emake EXTRA_CFLAGS="${CFLAGS}" busybox || die "build failed"
26}
27
28src_install() {
29 # bundle up the symlink files for use later
30 emake PREFIX="${D}/usr/lib/mindi/rootfs" install || die
31}
Note: See TracBrowser for help on using the repository browser.