source: MondoRescue/branches/2.2.5/pbconf/mondo/ebuild/mondo-rescue.ebuild@ 1861

Last change on this file since 1861 was 1861, checked in by Bruno Cornec, 16 years ago

mondo ebuild now depends on mindi 2.0.0

File size: 1.7 KB
RevLine 
[572]1# Copyright 1999-2004 Gentoo Foundation
[307]2# Distributed under the terms of the GNU General Public License v2
[572]3# $Header: $
4
[307]5# $Id$
6
7inherit libtool
8
9DESCRIPTION="The premier GPL disaster recovery solution."
10HOMEPAGE="http://www.mondorescue.org"
[761]11SRC_URI="ftp://ftp.mondorescue.org/src/${PN/-rescue/}-${PV}.tar.gz"
[307]12
13LICENSE="GPL-2"
14SLOT="0"
[1586]15KEYWORDS="~x86 ~ia64 ~amd64 -*"
[307]16IUSE=""
17
18DEPEND="virtual/libc
19 >=sys-libs/slang-1.4.1
20 >=dev-libs/newt-0.50"
21RDEPEND="app-arch/afio
22 sys-block/buffer
23 sys-devel/binutils
24 >=app-arch/bzip2-0.9
[1860]25 virtual/cdrtools
[1861]26 >=sys-apps/mindi-2.0.0
[307]27 >=dev-libs/newt-0.50
28 >=sys-libs/slang-1.4.1
[1860]29 sys-apps/parted
[307]30 >=sys-boot/syslinux-1.52"
31
[781]32S="${WORKDIR}/${PN/-rescue/}-${PV}"
[307]33
34src_unpack() {
[781]35 unpack ${A}
[770]36 cd "${S}"
[307]37 chmod 750 configure
38}
39
40src_compile() {
41 elibtoolize
42 econf || die "Configuration failed"
[1698]43 emake VERSION=PBVER || die "Make failed"
[307]44}
45
46src_install() {
[770]47 make install DESTDIR="${D}" || die "make install failed"
[1510]48 mkdir -p "${D}/var/cache/mondo"
[307]49 exeinto /usr/share/mondo
50 doexe mondo/autorun
51}
52
53pkg_postinst() {
54 einfo "${P} was successfully installed."
55 einfo "Please read the associated docs for help."
56 einfo "Or visit the website @ ${HOMEPAGE}"
57 echo
[556]58 ewarn "This package is a new version after a long gap."
[307]59 ewarn "Please report bugs to http://bugs.gentoo.org/"
60 ewarn "However, please do an advanced query to search for bugs"
61 ewarn "before reporting. This will keep down on duplicates."
62 echo
63 einfo "Prior to running mondo, ensure /boot is mounted."
64 ewarn "Grub users need to have a symlink like this:"
65 ewarn "ln -s /boot/grub/menu.lst /etc/grub.conf"
66 einfo "Unless you want to have mondo backup your distfiles,"
67 einfo "append \"-E ${DISTDIR}\" to your mondoarchive command."
68 echo
69}
Note: See TracBrowser for help on using the repository browser.