source: MondoRescue/branches/2.2.5/pbconf/mindi-busybox/ebuild/mindi-busybox.ebuild@ 1862

Last change on this file since 1862 was 1862, checked in by Bruno Cornec, 16 years ago

Should solve the issue of mindi-busybox not installing on gentoo

File size: 836 bytes
RevLine 
[927]1# Copyright 1999-2006 Gentoo Foundation
[823]2# Distributed under the terms of the GNU General Public License v2
3# $Id$
4
[927]5inherit eutils flag-o-matic
6
7DESCRIPTION="The rescue part of a program that creates emergency boot disks/CDs using your kernel, tools and modules."
[823]8HOMEPAGE="http://www.mondorescue.org"
9SRC_URI="ftp://ftp.mondorescue.org/src/${P}.tar.gz"
10LICENSE="GPL-2"
11SLOT="0"
[1586]12KEYWORDS="~x86 ~ia64 ~amd64 -*"
[823]13DEPEND="virtual/libc"
14RDEPEND=">=app-arch/bzip2-0.9
15 sys-devel/binutils"
16
17src_unpack() {
18 unpack ${A} || die "Failed to unpack ${A}"
[1444]19 cd ${P}
[927]20 make oldconfig > /dev/null
[823]21}
22
[927]23src_compile() {
24 # work around broken ass powerpc compilers
25 emake EXTRA_CFLAGS="${CFLAGS}" busybox || die "build failed"
26}
27
[823]28src_install() {
[927]29 # bundle up the symlink files for use later
[1862]30 emake CONFIG_PREFIX="${D}/usr/lib/mindi/rootfs" install || die
[823]31}
Note: See TracBrowser for help on using the repository browser.