source: MondoRescue/branches/2.2.5/mindi/distributions/gentoo/mindi.ebuild@ 1533

Last change on this file since 1533 was 1526, checked in by Bruno Cornec, 17 years ago
  • Fix a problem in directory link handling in mindi (seen on gentoo 64) with the precious help of Francesco Talamona ti.liame_at_email.it
  • Gentoo ebuild are now unmasked on my side
File size: 1.3 KB
Line 
1# Copyright 1999-2004 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: $
4
5# $Id$
6
7DESCRIPTION="A program that creates emergency boot disks/CDs using your kernel, tools and modules."
8HOMEPAGE="http://www.mondorescue.org"
9SRC_URI="ftp://ftp.mondorescue.org/src/${P}.tar.gz"
10
11LICENSE="GPL-2"
12SLOT="0"
13KEYWORDS="x86 ia64 -*"
14IUSE=""
15
16DEPEND="virtual/libc"
17RDEPEND=">=app-arch/bzip2-0.9
18 sys-libs/ncurses
19 sys-devel/binutils
20 sys-fs/dosfstools
21 sys-apps/mindi-busybox
22 sys-apps/parted
23 sys-apps/gawk"
24
25src_unpack() {
26 unpack ${A} || die "Failed to unpack ${A}"
27}
28
29src_install() {
30 export HEAD="${D}"
31 export PREFIX="/usr"
32 export CONFDIR="/etc"
33 export CACHEDIR="/var/cache/mindi"
34 export MANDIR="${PREFIX}/share/man"
35 export DOCDIR="${PREFIX}/share/doc"
36 export LIBDIR="${PREFIX}/lib"
37 export DONT_RELINK=1
38 export PKGBUILDMINDI="true"
39 "${WORKDIR}"/"${P}"/install.sh
40}
41
42pkg_postinst() {
43 einfo "${P} was successfully installed."
44 einfo "Please read the associated docs for help."
45 einfo "Or visit the website @ ${HOMEPAGE}"
46 echo
47 ewarn "This package is still in unstable."
48 ewarn "Please report bugs to http://bugs.gentoo.org/"
49 ewarn "However, please do an advanced query to search for bugs"
50 ewarn "before reporting. This will keep down on duplicates."
51 echo
52}
Note: See TracBrowser for help on using the repository browser.