source: MondoRescue/branches/2.2.4/mondo/distributions/gentoo/mondo.ebuild@ 1462

Last change on this file since 1462 was 1462, checked in by Bruno Cornec, 17 years ago

mondo depends on buffer and cdrecord for the moment (added in spec files) (V. Danen fixes for MDV CS 4)

File size: 1.6 KB
RevLine 
[572]1# Copyright 1999-2004 Gentoo Foundation
[307]2# Distributed under the terms of the GNU General Public License v2
[572]3# $Header: $
4
[307]5# $Id$
6
7inherit libtool
8
9DESCRIPTION="The premier GPL disaster recovery solution."
10HOMEPAGE="http://www.mondorescue.org"
[761]11SRC_URI="ftp://ftp.mondorescue.org/src/${PN/-rescue/}-${PV}.tar.gz"
[307]12
13LICENSE="GPL-2"
14SLOT="0"
15KEYWORDS="-* ~x86"
16IUSE=""
17
18DEPEND="virtual/libc
19 >=sys-libs/slang-1.4.1
20 >=dev-libs/newt-0.50"
21RDEPEND="app-arch/afio
22 sys-block/buffer
23 sys-devel/binutils
24 >=app-arch/bzip2-0.9
25 app-cdr/cdrtools
[1462]26 >=sys-apps/mindi-1.2.3
[307]27 >=dev-libs/newt-0.50
28 >=sys-libs/slang-1.4.1
29 >=sys-boot/syslinux-1.52"
30
[781]31S="${WORKDIR}/${PN/-rescue/}-${PV}"
[307]32
33src_unpack() {
[781]34 unpack ${A}
[770]35 cd "${S}"
[307]36 chmod 750 configure
37}
38
39src_compile() {
40 elibtoolize
41 econf || die "Configuration failed"
[556]42 emake VERSION=VVV || die "Make failed"
[307]43}
44
45src_install() {
[770]46 make install DESTDIR="${D}" || die "make install failed"
[307]47 exeinto /usr/share/mondo
48 doexe mondo/autorun
49}
50
51pkg_postinst() {
52 einfo "${P} was successfully installed."
53 einfo "Please read the associated docs for help."
54 einfo "Or visit the website @ ${HOMEPAGE}"
55 echo
[556]56 ewarn "This package is a new version after a long gap."
[307]57 ewarn "Please report bugs to http://bugs.gentoo.org/"
58 ewarn "However, please do an advanced query to search for bugs"
59 ewarn "before reporting. This will keep down on duplicates."
60 echo
61 einfo "Prior to running mondo, ensure /boot is mounted."
62 ewarn "Grub users need to have a symlink like this:"
63 ewarn "ln -s /boot/grub/menu.lst /etc/grub.conf"
64 einfo "Unless you want to have mondo backup your distfiles,"
65 einfo "append \"-E ${DISTDIR}\" to your mondoarchive command."
66 echo
67}
Note: See TracBrowser for help on using the repository browser.