source: MondoRescue/branches/2.2.4/mindi/distributions/gentoo/mindi.ebuild@ 1461

Last change on this file since 1461 was 1461, checked in by Bruno Cornec, 17 years ago

parted is required by mindi (in format-and-kludge-vfat) so put in dependencies (Francesco Talamona ti.liame_at_email.it)

File size: 1.2 KB
Line 
1# Copyright 1999-2004 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: $
4
5# $Id$
6
7DESCRIPTION="A program that creates emergency boot disks/CDs using your kernel, tools and modules."
8HOMEPAGE="http://www.mondorescue.org"
9SRC_URI="ftp://ftp.mondorescue.org/src/${P}.tar.gz"
10
11LICENSE="GPL-2"
12SLOT="0"
13KEYWORDS="~x86 -*"
14IUSE=""
15
16DEPEND="virtual/libc"
17RDEPEND=">=app-arch/bzip2-0.9
18 sys-libs/ncurses
19 sys-devel/binutils
20 sys-fs/dosfstools
21 sys-apps/mindi-busybox
22 sys-apps/parted
23 sys-apps/gawk"
24
25src_unpack() {
26 unpack ${A} || die "Failed to unpack ${A}"
27}
28
29src_install() {
30 export HEAD="${D}"
31 export PREFIX="/usr"
32 export CONFDIR="/etc"
33 export MANDIR="${PREFIX}/share/man"
34 export DOCDIR="${PREFIX}/share/doc"
35 export LIBDIR="${PREFIX}/lib"
36 export DONT_RELINK=1
37 export RPMBUILDMINDI="true"
38 "${WORKDIR}"/"${P}"/install.sh
39}
40
41pkg_postinst() {
42 einfo "${P} was successfully installed."
43 einfo "Please read the associated docs for help."
44 einfo "Or visit the website @ ${HOMEPAGE}"
45 echo
46 ewarn "This package is still in unstable."
47 ewarn "Please report bugs to http://bugs.gentoo.org/"
48 ewarn "However, please do an advanced query to search for bugs"
49 ewarn "before reporting. This will keep down on duplicates."
50 echo
51}
Note: See TracBrowser for help on using the repository browser.