source: MondoRescue/branches/2.2.4/mindi/distributions/debian/rules@ 1510

Last change on this file since 1510 was 1510, checked in by Bruno Cornec, 17 years ago
  • RPMBUILDMINDI => PKGBUILDMINDI
  • /var/cache/mindi added to the build process + pkgs
  • Property svn:executable set to *
File size: 1.2 KB
Line 
1#!/usr/bin/make -f
2# Sample debian/rules that uses debhelper.
3# GNU copyright 1997 to 1999 by Joey Hess.
4
5# Uncomment this to turn on verbose mode.
6#export DH_VERBOSE=1
7
8# Define package name for a one-stop change.
9PACKAGE_NAME = mindi
10
11# PREFIX for installtion
12export PREFIX=/usr
13
14configure:
15# Nothing to configure in this package.
16
17build:
18# Nothing to build in this package.
19
20clean:
21 dh_testdir
22 dh_testroot
23 dh_clean
24
25install:
26 dh_testdir
27 dh_testroot
28 dh_clean -k
29 dh_installdirs
30 # Build the installation tree:
31 (export PKGBUILDMINDI=true && export HEAD=$(CURDIR)/debian/$(PACKAGE_NAME) && export CONFDIR=/etc && export MANDIR=$(PREFIX)/share/man && export LIBDIR=$(PREFIX)/lib && export DOCDIR=$(PREFIX)/share/doc && export CACHEDIR=/var/cache/$(PACKAGE_NAME) && ./install.sh )
32
33# Build architecture-independent files here.
34binary-indep: install
35# We have nothing to do by default.
36
37# Build architecture-dependent files here.
38binary-arch: install
39 dh_testdir
40 dh_testroot
41 dh_installchangelogs ChangeLog
42 dh_installdocs
43 dh_installexamples
44 dh_link
45 dh_strip
46 dh_compress
47 dh_fixperms
48 dh_installdeb
49 dh_gencontrol
50 dh_md5sums
51 dh_builddeb
52
53binary: binary-indep binary-arch
54.PHONY: build clean binary-indep binary-arch binary install configure
Note: See TracBrowser for help on using the repository browser.