source: MondoRescue/branches/2.2.3/mindi/distributions/debian/rules@ 1405

Last change on this file since 1405 was 1405, checked in by Bruno Cornec, 17 years ago

Fix a Debian packaging bug

  • Property svn:executable set to *
File size: 1.2 KB
RevLine 
[581]1#!/usr/bin/make -f
2# Sample debian/rules that uses debhelper.
3# GNU copyright 1997 to 1999 by Joey Hess.
4
5# Uncomment this to turn on verbose mode.
6#export DH_VERBOSE=1
7
8# Define package name for a one-stop change.
9PACKAGE_NAME = mindi
10
11configure:
12# Nothing to configure in this package.
13
14build:
15# Nothing to build in this package.
16
17clean:
18 dh_testdir
19 dh_testroot
20 dh_clean
21
22install:
23 dh_testdir
24 dh_testroot
25 dh_clean -k
26 dh_installdirs
27 # Build the installation tree:
[1405]28 export PREFIX=/usr
29 ( export RPMBUILDMINDI=true && export HEAD=$(CURDIR)/debian/$(PACKAGE_NAME) && export CONFDIR=/etc && export MANDIR=$(PREFIX)/share/man && export LIBDIR=$(PREFIX)/lib && export DOCDIR=$(PREFIX)/share/doc && ./install.sh )
[581]30
31# Build architecture-independent files here.
32binary-indep: install
33# We have nothing to do by default.
34
35# Build architecture-dependent files here.
36binary-arch: install
37 dh_testdir
38 dh_testroot
39 dh_installchangelogs ChangeLog
40 dh_installdocs
41 dh_installexamples
42 dh_link
43 dh_strip
44 dh_compress
45 dh_fixperms
46 dh_installdeb
47 dh_gencontrol
48 dh_md5sums
49 dh_builddeb
50
51binary: binary-indep binary-arch
52.PHONY: build clean binary-indep binary-arch binary install configure
Note: See TracBrowser for help on using the repository browser.