source: MondoRescue/branches/2.2.0/mindi-busybox/distributions/debian/rules@ 987

Last change on this file since 987 was 987, checked in by Bruno Cornec, 17 years ago

Still mindi-busybox debian

  • Property svn:executable set to *
File size: 1.7 KB
RevLine 
[823]1#!/usr/bin/make -f
2# Sample debian/rules that uses debhelper.
3# GNU copyright 1997 to 1999 by Joey Hess.
4
5# Uncomment this to turn on verbose mode.
6#export DH_VERBOSE=1
7
8# Define package name for a one-stop change.
9PACKAGE_NAME = mindi-busybox
10
[987]11# Don't set any compiler flags - busybox does that just fine
[823]12
[987]13configure: configure-stamp
14configure-stamp:
15 dh_testdir
16touch configure-stamp
[823]17
[983]18# Build both architecture dependent and independent
[987]19build: build-stamp
[983]20
[987]21build-stamp: configure-stamp
[983]22 dh_testdir
23
24 # Compile the package.
[987]25 mv .config .config.sav
26 $(MAKE) distclean
27 mv .config.sav .config
[983]28 $(MAKE) oldconfig
29 $(MAKE) busybox
30
31 touch build-stamp
32
[823]33clean:
34 dh_testdir
35 dh_testroot
[987]36 rm -f build-stamp configure-stamp
[983]37 # Clean temporary document directory
38 rm -rf debian/doc-temp
39 # Clean up.
[987]40 -mv .config .config.sav
[983]41 -$(MAKE) distclean
[987]42 -mv .config.sav .config
43 -rm -f busybox
[983]44
[823]45 dh_clean
46
[983]47# Install architecture dependent and independent
[987]48install: build
[823]49 dh_testdir
50 dh_testroot
[987]51 dh_clean -k
52 dh_installdirs
[823]53
[983]54 # Install the package files into build directory:
55 # - start with upstream make install
56 $(MAKE) install PREFIX=$(CURDIR)/debian/$(PACKAGE_NAME)/usr/lib/mindi/rootfs
57 # - copy doc
58 mkdir -p debian/doc-temp
[987]59 cp -a ChangeLog INSTALL LICENSE AUTHORS README TODO changelog svn.log debian/doc-temp
[823]60
[983]61 dh_install -s
62
[987]63# Build architecture independant packages using the common target.
64binary-indep: build install
65 # None
[983]66
[987]67# Build architecture dependant packages using the common target.
68binary-arch: build install
[983]69 dh_testdir
70 dh_testroot
[987]71 dh_installchangelogs Changelog
[823]72 dh_installdocs
73 dh_strip
74 dh_compress
75 dh_fixperms
76 dh_installdeb
77 dh_gencontrol
78 dh_md5sums
79 dh_builddeb
80
[983]81binary: binary-arch binary-indep
[987]82.PHONY: build clean binary-indep binary-arch binary install configure
Note: See TracBrowser for help on using the repository browser.