source: MondoRescue/branches/2.06/mondo/mondo.spec@ 315

Last change on this file since 315 was 315, checked in by bcornec, 18 years ago
  • svn.log now part of the rpms
  • .spec factorisation continues (mkrel, requires, ...)
  • Property svn:keywords set to Id
File size: 19.3 KB
Line 
1#
2# $Id: mondo.spec 315 2006-01-13 19:07:06Z bcornec $
3#
4%define is_mandriva %(test -e /etc/mandriva-release && echo 1 || echo 0)
5%define is_mandrake %(test -e /etc/mandrake-release && echo 1 || echo 0)
6%define is_suse %(test -e /etc/SuSE-release && echo 1 || echo 0)
7%define is_fedora %(test -e /etc/fedora-release && echo 1 || echo 0)
8%define is_redhat %(test -e /etc/redhat-release && echo 1 || echo 0)
9
10%define name mondo
11%define version VVV
12%define mrel RRR
13%define src %{name}-%{version}.tgz
14%define grp Archiving/Backup
15%define addreqb mindi >= 1.05, bzip2 >= 0.9, afio, mkisofs, binutils, newt >= 0.50, slang >= 1.4.1
16
17# define the mkrel macro if it is not already defined
18%{?!mkrel:%define mkrel(c:) %{-c:0.%{-c*}.}%{!?_with_unstable:%(perl -e '$_="%{1}";m/(.\*)(\\d+)$/;$rel=${2}-1;re;print "$1$rel";').%{?subrel:%subrel}%{!?subrel:1}.%{?distversion:%distversion}%{?!distversion:%(echo $[%{mdkversion}/10])}}%{?_with_unstable:%{1}}%{?distsuffix:%distsuffix}%{?!distsuffix:mdk}}
19
20%if %is_redhat
21%define grp Applications/Archiving
22%define addreq %{addreqb}
23Autoreq: 0
24%endif
25
26%if %is_mandrake
27%define src %{name}-%{version}.tar.bz2
28%define addreq %{addreqb}
29Autoreqprov: no
30%endif
31
32%if %is_mandriva
33%define src %{name}-%{version}.tar.bz2
34%define addreq %{addreqb}
35Autoreqprov: no
36%endif
37
38%if %is_suse
39%define addreq %{addreqb}
40%endif
41
42Summary: A program which a Linux user can utilize to create a rescue/restore CD/tape
43Summary(fr): Un programme pour les utilisateurs de Linux pour cr�r un CD/tape de sauvegarde/restauration
44Summary(it): Un programma per utenti Linux per creare un CD/tape di rescue
45Summary(sp): Un programa para los usuarios de Linux por crear una CD/cinta de restoracion/rescate
46
47Name: %{name}
48Version: %{version}
49Release: %{mrel}
50License: GPL
51Group: %{grp}
52Url: http://mondorescue.berlios.de
53Source: %{src}
54BuildRoot: %{_tmppath}/%{name}-%{version}
55BuildRequires: newt-devel >= 0.50, slang-devel >= 1.4.1, gcc
56%ifarch ia64
57Requires: %{addreq}, elilo, parted
58%else
59Requires: %{addreq}, syslinux >= 1.52
60%endif
61
62#%package xmondo
63#Summary: A QT based graphical front end for %{name}
64#Group: Applications/Archiving
65#Requires: %{name} = %{version}-${release}, qt, kdelibs
66#
67#%package %{name}-devel
68#Summary: Header files for building against Mondo
69#%if %is_mandrake
70#Group: Development/Libraries
71#%endif
72#if %is_redhat
73#Group: Development/Other
74#%endif
75#Provides: libmondo-devel mondo-devel
76#Obsoletes: libmondo-devel
77#
78#%description -n %{name}-devel
79#Mondo libraries and includes
80
81%description
82Mondo is a GPL disaster recovery solution to create backup media (CD, DVD, tape, network images) that can be used to redeploy the damaged system, as well as deploy similar or less similar systems.
83
84%description -l fr
85Objectif
86""""""""
87Mondo est une solution GPL de sauvegarde en cas de désastre pour créer des médias (CD, DVD, bande, images réseau) qui peuvent être utilisés pour redéployer le système endomangé, aussi bien que des systèmes similaires, ou moins similaires.
88
89%description -l it
90Scopo
91"""""
92Mondo e' un programma che permette a qualsiasi utente Linux
93di creare un cd di rescue/restore (o piu' cd qualora l'installazione
94dovesse occupare piu' di 2Gb circa). Funziona con gli azionamenti di
95nastro, ed il NFS, anche.
96
97%description -l sp
98Objectivo
99"""""""""
100Mondo es un programa que permite cualquier usuario de Linux a crear una CD
101de restoracion/rescate (o CDs, si su instalacion es >2GO aprox.). Funciona
102con cintas y NFS, tambien.
103
104#%description xmondo
105#Xmondo is a QT based graphical frontend to mondoarchive. It can help you
106#set up a backup by following onscreen prompts.
107
108%prep
109%setup -q -n %name-%{version}
110
111%build
112%configure %{!?_without_xmondo:--with-x11}
113%{__make} VERSION=%{version} CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_REENTRANT"
114
115%install
116%{__rm} -rf $RPM_BUILD_ROOT
117%makeinstall
118%if %is_suse
119%{__rm} -rf $RPM_BUILD_ROOT/%{_datadir}/doc/%name-%{version}
120%endif
121
122%post
123/sbin/ldconfig
124%{__chmod} 755 %{_libdir}/%{name}/restore-scripts/%{name}/*
125
126%postun
127/sbin/ldconfig
128
129%clean
130%{__rm} -rf $RPM_BUILD_ROOT
131
132%files
133%defattr(644,root,root,755)
134%doc ChangeLog svn.log mondo/docs/en/1.6x-howto/*
135%doc INSTALL COPYING README TODO AUTHORS NEWS
136
137%attr(755,root,root) %{_sbindir}/*
138#%attr(755,root,root) %{_libdir}/%{name}/restore-scripts/%{name}/*
139%{_libdir}
140%{_mandir}
141
142#%{!?_without_xmondo:%files xmondo}
143#%{!?_without_xmondo:%{_sbindir}/xmondo}
144#%{!?_without_xmondo:%{_libdir}/libXmondo-%{libversion}.so}
145#%{!?_without_xmondo:%{_libdir}/libXmondo.so}
146#%{!?_without_xmondo:%{_datadir}/mondo/mondo.png}
147
148%changelog
149* Fri Nov 05 2005 Bruno Cornec <bcornec@users.berlios.de> 1.05
150- ia64 is now working
151- -p option related bug fixed
152- use libdir instead of datadir
153
154* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 2.04_berlios
155- Merge of patches mentionned on mondo ML + ia64 updates
156- Add -p option
157
158* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 2.04_cvs_20050503
159- made mondo more clever about finding its home. Avoids mondo considering
160 directories like '/usr/share/doc/momdo' as its home.
161
162* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 2.03
163- test sanity of user-specified tempdir
164- better SLES8 support
165
166* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 2.02
167- instead of using 'dd' to erase partition table, delete existing
168 partitions w/ the same call to fdisk that is used to create the
169 new partitions; this should avoids locking up the partition table
170- set bootable partition in the above same call to fdisk, for
171 the same reason (avoids locking up the partition table)
172- better software RAID support
173- mount ext3 partitions as ext2 when restoring - better for Debian
174- better star, ACL support
175- added ACL, xattr support for afio users
176
177* Fri Jun 26 2004 Hugo Rabson <hugorabson@msn.com> 2.01
178- fixed cvs for SuSE systems
179- fixed NTFS backup/restore bug relating to partimagehack
180 log file overflow and NTFS v non-NTFS differentiation
181- more reliable extraction of config info from CDs, floppies
182- better support of ISO dirs at restore-time (Conor Daly)
183- fixed spec file for SuSE users
184- added ldconfig to install section
185
186* Fri Jun 19 2004 Hugo Rabson <hugorabson@msn.com> 2.00
187- first 2.0 release
188- updated grub-install.patched to support SuSE and Red Hat
189- call 'mt' to set block size to 32K before opening in/out tape
190- updated mondo-prep.c to create each disk's partitions all at once
191 (one call per drive) instead of one call to fdisk per partition
192- when extracting cfg file and mountlist from all.tar.gz (tape copy),
193 use block size of INTERNAL_TAPE_BLK_SIZE, not TAPE_BLOCK_SIZE
194- added star and rudimentary SELinux support
195- fixed lots of bugs
196- all logging now goes to /var/log/mondo-archive.log, with symlink
197 to /tmp/mondo-restore.log for restore-time log-tracking
198- added grub-install.patched
199- removed embleer & other binaries
200- added '-b' to specify block size
201- added '-R' for star support
202
203* Thu Mar 25 2004 Bruno Cornec <Bruno.Cornec@hp.com> 1.7_cvs-20040325
204- ia64 fixes
205
206* Fri Nov 07 2003 Joshua Oreman <oremanj@get-linux.org> 1.7_cvs-20031107
207- fixed symbolic links for libraries
208- added support for boot/root multi floppies
209
210- added kdelibs as xmondo dependency
211- added xmondo pixmap installation
212- better find_cdrom_device(), to cope w/ multiple CD writers
213- fixed -m and -Vc flags
214- fixed NTFS support!
215- bootable CD uses native, not El Torito, support now
216- removed mondo-makefilelist
217- added 2.6 kernel support
218- if 2.6 kernel, insist that the user specify CD device
219- drop Embleer; insist on ms-sys and parted if Windows partition
220
221* Wed Nov 05 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031105.1
222- added -devel package
223
224* Tue Nov 04 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031104.1
225- made xmondo a second package
226- added ability to specify --without xmondo at build time
227
228* Sun Nov 02 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031102.1
229- Clean up, added spanish translation
230- Set prefix to be /usr
231- added/fixed Requires
232- remove CVS directories prior to building
233
234* Thu Oct 23 2003 Hugo Rabson <hugorabson@msn.com> 1.75_cvs_20031023
235- nothing yet
236
237* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 1.75
238- fixed chmod/chown bug (Jens Richter)
239- ask user to confirm NFS mountpoint in Interactive Mode
240- rewritten format_everything() to make sure LVMs, RAIDs and
241 regular partitions are prepped in the correct order
242- better magicdev support
243- rewritten external binary caller subroutine
244- DVD support added
245- better backup-time control gui; offer to exclude nfs if appl.
246- fixed multi-tape support
247- re-implemented -D and -J
248- fixed bug in extract_config_file_from_ramdisk() which
249 affected tape+floppy users
250- updated is_incoming_block_valid() to make it
251 return end-of-tape if >300 flotsam blocks
252- unmount CD-ROM before burning (necessary for RH8/9)
253- fixed some stray assert()'s
254- fixed bug in grub-MR (Christian)
255- make user remove floppy/CD before restoring interactively from tape
256- fixed bug in am_I_in_disaster_recovery_mode()
257- added code to nuke_mode() to make sure NFS
258 (backup) share is mounted in Nuke Mode
259- improved tape device detection code
260- better GRUB support
261- better logging of changed bigfiles at compare-time
262- better NTFS support, thanks to partimagehack-static
263- better logging
264- rewrote tape-handling code, breaking compatibility w/ previous versions
265- fixed ISO/CD biggiefile verification bug in mondoarchive
266- fixed bug which stopped boot/compare-time changelist from popping up
267- replaced mondo-makefilelist with C code - faster, cleaner
268- tweaked GUI - better feedback
269
270* Wed May 28 2003 Anonymous <root@rohan> 1.74
271- misc fixes (Michael Hanscho's friend)
272- added rudimentary support for SME
273- added better label support
274- fixed biggietime atime/ctime restoration bug 73
275- fixed 'default boot loader' detection bug (Joshua Oreman)
276- use single-threaded make_afioballs_and_images() if FreeBSD
277- fixed mondoarchive -Vi multi-CD verify bug (Tom Mortell)
278- superior get_phys_size_of_drive() (Joshua Oreman)
279- fixed RAID-related bug in where_is_root_mounted()
280- ISO tweaks
281- fixed silly bug in load_filelist() which stopped
282 funny German filenames from being handled properly
283- fixed various calls to popup_and_get_string()
284- fixed spec file
285- reject -E /
286- added partimagehack to the mix
287
288* Tue May 20 2003 Anonymous <root@rohan> 1.73
289- mark devices as bootable _after_ unmounting them
290- resolve boot device (-f) if softlink
291- post_param_configuration() --- store iso-dev and isodir
292- added post-nuke-sample.tgz to package
293- Nuke Mode now checks mountlist against hardware; offer user
294 opportunity to edit mountlist if insane; if user declines, abort
295- added lots of assert()'s and other checks
296- ran code thru Valgrind to catch & fix some memory leaks
297- made mondo-restore.c smaller by moving some subroutines to
298 common/libmondo-raid.c and mondorestore/mondo-rstr-compare.c
299- added '-Q' to let user test mondoarchive's ability to find
300 their boot loader and type
301- improved which_boot_loader()
302- when burning or comparing to a CD, defeat autorun if it is
303 running, to avoid confusing mondoarchive and the user
304- if original backup media no longer available at boot-time
305 then offer user chance to choose another media source
306- when booting, type 'nuke noresize' to nuke w/o resizing
307 mountlist to fill your drives
308- add 'textonly' when booting, to avoid using Newt gui
309- run nice(20) to prioritize mondoarchive at start
310- don't pause and wait for next blank CD at backup-time
311 unless necessary (e.g. previous CD has not been removed)
312- get_phys_size_of_drive() --- better support of older drives
313- don't eject if "donteject" is in kernel's command line
314- cleaned up segfault-handling
315- added Conor's strip_path() to improve file list display
316- added Herman Kuster's multi-level bkp patch
317- better boot-time screen/message
318- added Joshua Oreman's FreeBSD patches x3
319- fixed interactive/textonly support
320- fixed support for subdir-within-NFS-mount
321- fixed "Can't backup if ramdisk not mounted" bug
322- try to work around eccentricities of multi-CD drive PCs
323- misc clean-ups (Steve Hindle)
324
325* Tue Apr 08 2003 Hugo Rabson <hugorabson@msn.com> 1.72
326- LVM/RAID bugs fixed (Brian Borgeson)
327- major clean-up of code (Stan Benoit)
328- make-me-bootable fix (Juraj Ziegler)
329- fixed problem w/ multi-ISO verify cycle (Tom Mortell)
330- removed duplicate entry from makefile
331- if root is /dev/root then assume not a ramdisk
332- reject relative paths if -d flag (Alessandro Polverini)
333- fixed potentially infinite loop in log_to_screen (Tom Mortell)
334- add '/' to custom filelist as workaround for obscure bug
335- ask user speed of CDRW if writing to CD
336- find_cdrom_device() --- if nonexistent/not found then
337 make sure to return '' as dev str and 1 as res
338- tweaked restore scripts tgz
339- cleaned up find_cdrom_device()
340- if user creates /usr/share/mondo/payload.tgz then untar
341 payload to CD at backup-time
342- fixed insist_on_this_cd_number()
343- fixed am_i_in_disaster_recovery_mode()
344- misc clean-up (Tom Mortell)
345- made code more legible
346- fixed post-nuke support
347- added -e support
348- fixed nfs support
349- fixed iso support
350- at restore-time, only sort mountlist internally,
351 in mount_all_devices() and unmount_all_devices()
352- fixed cosmetic bug in label-partitions-as-necessary
353- updated documentation
354- fixed fstab-hacking scripts
355
356* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 1.71
357- log newt, slang, ncurses info
358- updated man page
359- handle %% chars in issue.net properly (Heiko Schlittermann)
360- fixed serious NFS restore bug
361- cleaned up spec file; it should cause fewer problems now (Jesse Keating)
362- changed various strcpy() calls to strncpy() calls
363- added mondo-makefilelist to makefile (Mikael Hultgren)
364- mount_cdrom() better at handling multiple CD drives
365- exclude /media/cdrom,cdrecorder,floppy
366- sensibly_set_tmpdir_and_scratchdir() --- exclude smb and smbfs
367- better logging by eval_call_to_make_ISO()
368- accept -J <fname> to let user provide their own fs catalog
369 instead of -I <paths> to backup
370- if dir excluded with -E or included with -I and dir is actually
371 a softlink then exclude/include the dir pointed to, as well
372- better location for manpage
373- adjusted block size of tarball at start of tape, to help
374 users w/ broken tape driver firmware
375- sort -u fstab after modifying it
376- if backup type is nfs then don't estimate noof media
377- fixed Makefile (Mikael Hultgren)
378- updated manpage
379
380* Mon Dec 07 2002 Hugo Rabson <hugo@firstlinux.net> 1.70
381- new devel branch opened
382
383* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 1.52
384- fixed bug in multithreading
385- use new grub-MR instead of grub-install
386- wipe only the partition table (not the MBR) when partitioning drives
387- ignore lilo.conf.anaconda when looking for lilo.conf file
388- accepts '-l RAW' to backup/restore original boot sector instead
389 of running grub or lilo to init it after restoring
390- fixed&updated stabgrub-me script; software RAID + GRUB work now
391- mount/unmount /boot partition for Gentoo 1.2 users
392- re-enabled extra tape checksums
393- disabled spurious warnings
394- unmount/remount supermounts at start/end of live restore, if nec.
395- cleaned up mondo's tape block handling (now, TAPE_BLOCK_SIZE=128K
396 and I've added INTERNAL_TAPE_BLK_SIZE=32K variable for buffering)
397- added Makefile
398- added -l RAW, to backup and restore original MBR
399- cleaned up iso_mode() and nfs restoring
400- create /mnt/RESTORING/mnt/.boot.d for Gentoo users
401- made mondorestore CD bootable for ArkLinux users
402- if user runs as 'su' not 'su -' then work around
403
404* Sun Nov 17 2002 Hugo Rabson <hugo@firstlinux.net> 1.51
405- pop-up list of changed files, at end of verification phase
406- better handling of changed.files list at restore-time
407- lots of CD-related fixes
408- added '-N' flag --- to let user exclude all NFS-related mounts&devices
409- better handling of 'kill'
410- restructuring of code to ease integration of mondo w/XMondo
411- fixed obscure bug in find_and_mount_actual_cd()
412- if / or /root has <50MB free then abort & complain
413- fixed install.sh
414- fixed .spec file
415- updated documentation
416- commented code
417- updated man page
418- added -v / --version flag
419- replace convoluted grep with wc (KP)
420- fixed bug affecting restoration of bigfiles from CD's created w/0 compression
421- fixed BurnProof-related bug
422- better at figuring out which is the best partition for temp/scratchdir
423- added do-not-compress-these (text file) to RPM
424- do not compress files of types listed in do-not-compress-these
425- dropped -U from call to afio - saves 20-30% runtime (Cosgrove)
426- added Cosgrove's do-not-compress-these list
427- included various patches from KP
428- chmod tmpdir, scratchdir to 700 before using
429- restore from specified backup device, even if its own cfg file disagrees
430- fixed multi-tape bug
431- fixed "Can't find first ISO when verifying nonbootable ISO" bug
432- multithreaded make_afioballs_and_images()
433- tmpdir and scratchdir are set sensibly whether mondoarchive is called with
434 command-line parameters or not
435- fixed bug in strip_spaces() which stopped it from handling
436 small strings correctly - affected mountlist editor
437- create a repaired copy of grub-install which is RAID-friendly;
438 use it when initializing boot sector with run_grub()
439- fixed bug in mondo-makefilelist
440
441* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 1.50
442- if restoring, don't try to find SCSI node of CD-ROM drive; find /dev entry
443- during selective restore, skip filesets which don't contain relevant archives
444- set /dev/null's perms to 777, just in case devfs-enabled kernel mangles it
445- remove /var/run/*.pid after restoring
446- move spurious lockfiles from /home/* to /home/*/.disabled
447- ask user to confirm the tape/CD device name
448- lots of multitape-related fixes
449- added code to autodetect the hardware of the user, if possible
450- if isodir does not exist then abort
451- more sanity-checking for -d flag
452- doubled 'biggiefile' threshold... to 32MB
453- exclude /root/images/mindi
454- fixed multi-imagedev bug (Emmanuel Druon)
455- unmount/remount /mnt/floppy before/after backing up, if Mandrake
456- restructured the source files
457- fixed serious bug in line 1546 - should have been !=, not ==; stopped
458 mondorestore from correctly restoring big files
459- added '#include <signal.h>' to my-stuff.h
460- exclude "incheckentry xwait()" from changed.files
461- fixed minor bug in find_cdrom_device()
462- fixed bug in friendly_sizestr...
463- insist on tape #1 when start verifying
464- added internal buffering, replacing the external 'buffer' exe
465- if differential backup then don't permit formatting or fdisking,
466 whether Interactive or Nuke mode
467- if mondorestore is run on live filesystem (or from ramdisk) without
468 parameters then mondorestore will ask which backup media (tape, CD, etc.)
469 was used; it will read the config file from the media and proceed from there
470- if tape streamer is softlink then resolve it first
471- incorporate post-nuke tarball
472- if user doesn't specify tape size, proceed anyway; behave intelligently
473 in the event of end-of-tape
474- prefix bkpinfo->restore_path to biggiefile fname before generating
475 checksum & comparing to archived biggiefile
476- if /etc/lilo.conf not found not /etc/lilo.conf.anaconda found
477 then create a softlink from the former to the latter, to work
478 around RH7.3's b0rken LILO support
479- LFS support (mharris, michele, hugo)
480- fixed verify bug --- CD#1 was being verified again & again & ...
481- differential mode fixed; supported again
482- ask user for boot loader + device if not detectible
483- list up to 512 files in file selection window at once (was 128)
484- better handling of bigfiles' checksums, perms and owns
485- delete final filelist if <=2 bytes long
486- if kernel not found and mondo in graphics mode then popup and ask
487 for kernel path+filename
488
489* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 1.45-1
490- 1.5x branch forked off from 1.4x branch
491
492
493
494
Note: See TracBrowser for help on using the repository browser.