source: MondoRescue/branches/2.06/mondo/mondo.spec@ 313

Last change on this file since 313 was 313, checked in by bcornec, 18 years ago

spec file generation adapted (RRR used for revision, suffix now has the '.', Group is now a variable)

  • Property svn:keywords set to Id
File size: 18.9 KB
RevLine 
[35]1#
2# $Id: mondo.spec 313 2006-01-13 18:31:32Z bcornec $
3#
[53]4%define is_mandriva %(test -e /etc/mandriva-release && echo 1 || echo 0)
5%define is_mandrake %(test -e /etc/mandrake-release && echo 1 || echo 0)
6%define is_suse %(test -e /etc/SuSE-release && echo 1 || echo 0)
7%define is_fedora %(test -e /etc/fedora-release && echo 1 || echo 0)
8%define is_redhat %(test -e /etc/redhat-release && echo 1 || echo 0)
[1]9
[53]10%define name mondo
[237]11%define version VVV
[313]12%define mrel RRR
[247]13%define src %{name}-%{version}.tgz
[313]14%define grp Archiving/Backup
[53]15
16%if %is_redhat
[313]17%define src Applications/Archiving
[53]18Autoreq: 0
19%endif
20
21%if %is_mandrake
22%define src %{name}-%{version}.tar.bz2
23Autoreqprov: no
24%endif
25
[64]26%if %is_mandriva
27%define src %{name}-%{version}.tar.bz2
28Autoreqprov: no
29%endif
30
[233]31%if %is_suse
32%endif
[64]33
[1]34Summary: A program which a Linux user can utilize to create a rescue/restore CD/tape
35Summary(fr): Un programme pour les utilisateurs de Linux pour cr�r un CD/tape de sauvegarde/restauration
36Summary(it): Un programma per utenti Linux per creare un CD/tape di rescue
37Summary(sp): Un programa para los usuarios de Linux por crear una CD/cinta de restoracion/rescate
[53]38
39Name: %{name}
40Version: %{version}
[64]41Release: %{mrel}
[1]42License: GPL
[313]43Group: %{grp}
[53]44Url: http://mondorescue.berlios.de
45Source: %{src}
46BuildRoot: %{_tmppath}/%{name}-%{version}
[1]47BuildRequires: newt-devel >= 0.50, slang-devel >= 1.4.1, gcc
48%ifarch ia64
[102]49Requires: mindi >= 1.05, bzip2 >= 0.9, afio, mkisofs, binutils, elilo, newt >= 0.50, slang >= 1.4.1, buffer, parted
[1]50%else
[241]51Requires: mindi >= 1.05, bzip2 >= 0.9, afio, mkisofs, binutils, syslinux >= 1.52, newt >= 0.50, slang >= 1.4.1, buffer
[1]52%endif
53
[53]54#%package xmondo
55#Summary: A QT based graphical front end for %{name}
56#Group: Applications/Archiving
57#Requires: %{name} = %{version}-${release}, qt, kdelibs
58#
59#%package %{name}-devel
60#Summary: Header files for building against Mondo
61#%if %is_mandrake
62#Group: Development/Libraries
63#%endif
64#if %is_redhat
65#Group: Development/Other
66#%endif
67#Provides: libmondo-devel mondo-devel
68#Obsoletes: libmondo-devel
69#
70#%description -n %{name}-devel
71#Mondo libraries and includes
[1]72
73%description
[53]74Mondo is a GPL disaster recovery solution to create backup media (CD, DVD, tape, network images) that can be used to redeploy the damaged system, as well as deploy similar or less similar systems.
[1]75
76%description -l fr
77Objectif
78""""""""
[53]79Mondo est une solution GPL de sauvegarde en cas de désastre pour créer des médias (CD, DVD, bande, images réseau) qui peuvent être utilisés pour redéployer le système endomangé, aussi bien que des systèmes similaires, ou moins similaires.
[1]80
81%description -l it
82Scopo
83"""""
84Mondo e' un programma che permette a qualsiasi utente Linux
85di creare un cd di rescue/restore (o piu' cd qualora l'installazione
86dovesse occupare piu' di 2Gb circa). Funziona con gli azionamenti di
87nastro, ed il NFS, anche.
88
89%description -l sp
90Objectivo
91"""""""""
92Mondo es un programa que permite cualquier usuario de Linux a crear una CD
93de restoracion/rescate (o CDs, si su instalacion es >2GO aprox.). Funciona
94con cintas y NFS, tambien.
95
[53]96#%description xmondo
97#Xmondo is a QT based graphical frontend to mondoarchive. It can help you
98#set up a backup by following onscreen prompts.
[1]99
100%prep
[53]101%setup -q -n %name-%{version}
[1]102
[53]103%build
[1]104%configure %{!?_without_xmondo:--with-x11}
105%{__make} VERSION=%{version} CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_REENTRANT"
106
107%install
[53]108%{__rm} -rf $RPM_BUILD_ROOT
109%makeinstall
[247]110%if %is_suse
111%{__rm} -rf $RPM_BUILD_ROOT/%{_datadir}/doc/%name-%{version}
112%endif
[1]113
[53]114%post
115/sbin/ldconfig
[187]116%{__chmod} 755 %{_libdir}/%{name}/restore-scripts/%{name}/*
[1]117
[53]118%postun
119/sbin/ldconfig
[1]120
121%clean
122%{__rm} -rf $RPM_BUILD_ROOT
123
124%files
[53]125%defattr(644,root,root,755)
126%doc ChangeLog mondo/docs/en/1.6x-howto/*
127%doc INSTALL COPYING README TODO AUTHORS NEWS
[1]128
[53]129%attr(755,root,root) %{_sbindir}/*
[187]130#%attr(755,root,root) %{_libdir}/%{name}/restore-scripts/%{name}/*
131%{_libdir}
132%{_mandir}
[53]133
[79]134#%{!?_without_xmondo:%files xmondo}
135#%{!?_without_xmondo:%{_sbindir}/xmondo}
136#%{!?_without_xmondo:%{_libdir}/libXmondo-%{libversion}.so}
137#%{!?_without_xmondo:%{_libdir}/libXmondo.so}
138#%{!?_without_xmondo:%{_datadir}/mondo/mondo.png}
[1]139
140%changelog
[102]141* Fri Nov 05 2005 Bruno Cornec <bcornec@users.berlios.de> 1.05
142- ia64 is now working
143- -p option related bug fixed
[179]144- use libdir instead of datadir
[102]145
[14]146* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 2.04_berlios
[13]147- Merge of patches mentionned on mondo ML + ia64 updates
[53]148- Add -p option
[13]149
[1]150* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 2.04_cvs_20050503
151- made mondo more clever about finding its home. Avoids mondo considering
152 directories like '/usr/share/doc/momdo' as its home.
153
154* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 2.03
155- test sanity of user-specified tempdir
156- better SLES8 support
157
158* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 2.02
159- instead of using 'dd' to erase partition table, delete existing
160 partitions w/ the same call to fdisk that is used to create the
161 new partitions; this should avoids locking up the partition table
162- set bootable partition in the above same call to fdisk, for
163 the same reason (avoids locking up the partition table)
164- better software RAID support
165- mount ext3 partitions as ext2 when restoring - better for Debian
166- better star, ACL support
167- added ACL, xattr support for afio users
168
169* Fri Jun 26 2004 Hugo Rabson <hugorabson@msn.com> 2.01
170- fixed cvs for SuSE systems
171- fixed NTFS backup/restore bug relating to partimagehack
172 log file overflow and NTFS v non-NTFS differentiation
173- more reliable extraction of config info from CDs, floppies
174- better support of ISO dirs at restore-time (Conor Daly)
175- fixed spec file for SuSE users
176- added ldconfig to install section
177
178* Fri Jun 19 2004 Hugo Rabson <hugorabson@msn.com> 2.00
179- first 2.0 release
180- updated grub-install.patched to support SuSE and Red Hat
181- call 'mt' to set block size to 32K before opening in/out tape
182- updated mondo-prep.c to create each disk's partitions all at once
183 (one call per drive) instead of one call to fdisk per partition
184- when extracting cfg file and mountlist from all.tar.gz (tape copy),
185 use block size of INTERNAL_TAPE_BLK_SIZE, not TAPE_BLOCK_SIZE
186- added star and rudimentary SELinux support
187- fixed lots of bugs
188- all logging now goes to /var/log/mondo-archive.log, with symlink
189 to /tmp/mondo-restore.log for restore-time log-tracking
190- added grub-install.patched
191- removed embleer & other binaries
192- added '-b' to specify block size
193- added '-R' for star support
194
195* Thu Mar 25 2004 Bruno Cornec <Bruno.Cornec@hp.com> 1.7_cvs-20040325
196- ia64 fixes
197
198* Fri Nov 07 2003 Joshua Oreman <oremanj@get-linux.org> 1.7_cvs-20031107
199- fixed symbolic links for libraries
200- added support for boot/root multi floppies
201
202- added kdelibs as xmondo dependency
203- added xmondo pixmap installation
204- better find_cdrom_device(), to cope w/ multiple CD writers
205- fixed -m and -Vc flags
206- fixed NTFS support!
207- bootable CD uses native, not El Torito, support now
208- removed mondo-makefilelist
209- added 2.6 kernel support
210- if 2.6 kernel, insist that the user specify CD device
211- drop Embleer; insist on ms-sys and parted if Windows partition
212
213* Wed Nov 05 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031105.1
214- added -devel package
215
216* Tue Nov 04 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031104.1
217- made xmondo a second package
218- added ability to specify --without xmondo at build time
219
220* Sun Nov 02 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031102.1
221- Clean up, added spanish translation
222- Set prefix to be /usr
223- added/fixed Requires
224- remove CVS directories prior to building
225
226* Thu Oct 23 2003 Hugo Rabson <hugorabson@msn.com> 1.75_cvs_20031023
227- nothing yet
228
229* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 1.75
230- fixed chmod/chown bug (Jens Richter)
231- ask user to confirm NFS mountpoint in Interactive Mode
232- rewritten format_everything() to make sure LVMs, RAIDs and
233 regular partitions are prepped in the correct order
234- better magicdev support
235- rewritten external binary caller subroutine
236- DVD support added
237- better backup-time control gui; offer to exclude nfs if appl.
238- fixed multi-tape support
239- re-implemented -D and -J
240- fixed bug in extract_config_file_from_ramdisk() which
241 affected tape+floppy users
242- updated is_incoming_block_valid() to make it
243 return end-of-tape if >300 flotsam blocks
244- unmount CD-ROM before burning (necessary for RH8/9)
245- fixed some stray assert()'s
246- fixed bug in grub-MR (Christian)
247- make user remove floppy/CD before restoring interactively from tape
248- fixed bug in am_I_in_disaster_recovery_mode()
249- added code to nuke_mode() to make sure NFS
250 (backup) share is mounted in Nuke Mode
251- improved tape device detection code
252- better GRUB support
253- better logging of changed bigfiles at compare-time
254- better NTFS support, thanks to partimagehack-static
255- better logging
256- rewrote tape-handling code, breaking compatibility w/ previous versions
257- fixed ISO/CD biggiefile verification bug in mondoarchive
258- fixed bug which stopped boot/compare-time changelist from popping up
259- replaced mondo-makefilelist with C code - faster, cleaner
260- tweaked GUI - better feedback
261
262* Wed May 28 2003 Anonymous <root@rohan> 1.74
263- misc fixes (Michael Hanscho's friend)
264- added rudimentary support for SME
265- added better label support
266- fixed biggietime atime/ctime restoration bug 73
267- fixed 'default boot loader' detection bug (Joshua Oreman)
268- use single-threaded make_afioballs_and_images() if FreeBSD
269- fixed mondoarchive -Vi multi-CD verify bug (Tom Mortell)
270- superior get_phys_size_of_drive() (Joshua Oreman)
271- fixed RAID-related bug in where_is_root_mounted()
272- ISO tweaks
273- fixed silly bug in load_filelist() which stopped
274 funny German filenames from being handled properly
275- fixed various calls to popup_and_get_string()
276- fixed spec file
277- reject -E /
278- added partimagehack to the mix
279
280* Tue May 20 2003 Anonymous <root@rohan> 1.73
281- mark devices as bootable _after_ unmounting them
282- resolve boot device (-f) if softlink
283- post_param_configuration() --- store iso-dev and isodir
284- added post-nuke-sample.tgz to package
285- Nuke Mode now checks mountlist against hardware; offer user
286 opportunity to edit mountlist if insane; if user declines, abort
287- added lots of assert()'s and other checks
288- ran code thru Valgrind to catch & fix some memory leaks
289- made mondo-restore.c smaller by moving some subroutines to
290 common/libmondo-raid.c and mondorestore/mondo-rstr-compare.c
291- added '-Q' to let user test mondoarchive's ability to find
292 their boot loader and type
293- improved which_boot_loader()
294- when burning or comparing to a CD, defeat autorun if it is
295 running, to avoid confusing mondoarchive and the user
296- if original backup media no longer available at boot-time
297 then offer user chance to choose another media source
298- when booting, type 'nuke noresize' to nuke w/o resizing
299 mountlist to fill your drives
300- add 'textonly' when booting, to avoid using Newt gui
301- run nice(20) to prioritize mondoarchive at start
302- don't pause and wait for next blank CD at backup-time
303 unless necessary (e.g. previous CD has not been removed)
304- get_phys_size_of_drive() --- better support of older drives
305- don't eject if "donteject" is in kernel's command line
306- cleaned up segfault-handling
307- added Conor's strip_path() to improve file list display
308- added Herman Kuster's multi-level bkp patch
309- better boot-time screen/message
310- added Joshua Oreman's FreeBSD patches x3
311- fixed interactive/textonly support
312- fixed support for subdir-within-NFS-mount
313- fixed "Can't backup if ramdisk not mounted" bug
314- try to work around eccentricities of multi-CD drive PCs
315- misc clean-ups (Steve Hindle)
316
317* Tue Apr 08 2003 Hugo Rabson <hugorabson@msn.com> 1.72
318- LVM/RAID bugs fixed (Brian Borgeson)
319- major clean-up of code (Stan Benoit)
320- make-me-bootable fix (Juraj Ziegler)
321- fixed problem w/ multi-ISO verify cycle (Tom Mortell)
322- removed duplicate entry from makefile
323- if root is /dev/root then assume not a ramdisk
324- reject relative paths if -d flag (Alessandro Polverini)
325- fixed potentially infinite loop in log_to_screen (Tom Mortell)
326- add '/' to custom filelist as workaround for obscure bug
327- ask user speed of CDRW if writing to CD
328- find_cdrom_device() --- if nonexistent/not found then
329 make sure to return '' as dev str and 1 as res
330- tweaked restore scripts tgz
331- cleaned up find_cdrom_device()
332- if user creates /usr/share/mondo/payload.tgz then untar
333 payload to CD at backup-time
334- fixed insist_on_this_cd_number()
335- fixed am_i_in_disaster_recovery_mode()
336- misc clean-up (Tom Mortell)
337- made code more legible
338- fixed post-nuke support
339- added -e support
340- fixed nfs support
341- fixed iso support
342- at restore-time, only sort mountlist internally,
343 in mount_all_devices() and unmount_all_devices()
344- fixed cosmetic bug in label-partitions-as-necessary
345- updated documentation
346- fixed fstab-hacking scripts
347
348* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 1.71
349- log newt, slang, ncurses info
350- updated man page
351- handle %% chars in issue.net properly (Heiko Schlittermann)
352- fixed serious NFS restore bug
353- cleaned up spec file; it should cause fewer problems now (Jesse Keating)
354- changed various strcpy() calls to strncpy() calls
355- added mondo-makefilelist to makefile (Mikael Hultgren)
356- mount_cdrom() better at handling multiple CD drives
357- exclude /media/cdrom,cdrecorder,floppy
358- sensibly_set_tmpdir_and_scratchdir() --- exclude smb and smbfs
359- better logging by eval_call_to_make_ISO()
360- accept -J <fname> to let user provide their own fs catalog
361 instead of -I <paths> to backup
362- if dir excluded with -E or included with -I and dir is actually
363 a softlink then exclude/include the dir pointed to, as well
364- better location for manpage
365- adjusted block size of tarball at start of tape, to help
366 users w/ broken tape driver firmware
367- sort -u fstab after modifying it
368- if backup type is nfs then don't estimate noof media
369- fixed Makefile (Mikael Hultgren)
370- updated manpage
371
372* Mon Dec 07 2002 Hugo Rabson <hugo@firstlinux.net> 1.70
373- new devel branch opened
374
375* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 1.52
376- fixed bug in multithreading
377- use new grub-MR instead of grub-install
378- wipe only the partition table (not the MBR) when partitioning drives
379- ignore lilo.conf.anaconda when looking for lilo.conf file
380- accepts '-l RAW' to backup/restore original boot sector instead
381 of running grub or lilo to init it after restoring
382- fixed&updated stabgrub-me script; software RAID + GRUB work now
383- mount/unmount /boot partition for Gentoo 1.2 users
384- re-enabled extra tape checksums
385- disabled spurious warnings
386- unmount/remount supermounts at start/end of live restore, if nec.
387- cleaned up mondo's tape block handling (now, TAPE_BLOCK_SIZE=128K
388 and I've added INTERNAL_TAPE_BLK_SIZE=32K variable for buffering)
389- added Makefile
390- added -l RAW, to backup and restore original MBR
391- cleaned up iso_mode() and nfs restoring
392- create /mnt/RESTORING/mnt/.boot.d for Gentoo users
393- made mondorestore CD bootable for ArkLinux users
394- if user runs as 'su' not 'su -' then work around
395
396* Sun Nov 17 2002 Hugo Rabson <hugo@firstlinux.net> 1.51
397- pop-up list of changed files, at end of verification phase
398- better handling of changed.files list at restore-time
399- lots of CD-related fixes
400- added '-N' flag --- to let user exclude all NFS-related mounts&devices
401- better handling of 'kill'
402- restructuring of code to ease integration of mondo w/XMondo
403- fixed obscure bug in find_and_mount_actual_cd()
404- if / or /root has <50MB free then abort & complain
405- fixed install.sh
406- fixed .spec file
407- updated documentation
408- commented code
409- updated man page
410- added -v / --version flag
411- replace convoluted grep with wc (KP)
412- fixed bug affecting restoration of bigfiles from CD's created w/0 compression
413- fixed BurnProof-related bug
414- better at figuring out which is the best partition for temp/scratchdir
415- added do-not-compress-these (text file) to RPM
416- do not compress files of types listed in do-not-compress-these
417- dropped -U from call to afio - saves 20-30% runtime (Cosgrove)
418- added Cosgrove's do-not-compress-these list
419- included various patches from KP
420- chmod tmpdir, scratchdir to 700 before using
421- restore from specified backup device, even if its own cfg file disagrees
422- fixed multi-tape bug
423- fixed "Can't find first ISO when verifying nonbootable ISO" bug
424- multithreaded make_afioballs_and_images()
425- tmpdir and scratchdir are set sensibly whether mondoarchive is called with
426 command-line parameters or not
427- fixed bug in strip_spaces() which stopped it from handling
428 small strings correctly - affected mountlist editor
429- create a repaired copy of grub-install which is RAID-friendly;
430 use it when initializing boot sector with run_grub()
431- fixed bug in mondo-makefilelist
432
433* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 1.50
434- if restoring, don't try to find SCSI node of CD-ROM drive; find /dev entry
435- during selective restore, skip filesets which don't contain relevant archives
436- set /dev/null's perms to 777, just in case devfs-enabled kernel mangles it
437- remove /var/run/*.pid after restoring
438- move spurious lockfiles from /home/* to /home/*/.disabled
439- ask user to confirm the tape/CD device name
440- lots of multitape-related fixes
441- added code to autodetect the hardware of the user, if possible
442- if isodir does not exist then abort
443- more sanity-checking for -d flag
444- doubled 'biggiefile' threshold... to 32MB
445- exclude /root/images/mindi
446- fixed multi-imagedev bug (Emmanuel Druon)
447- unmount/remount /mnt/floppy before/after backing up, if Mandrake
448- restructured the source files
449- fixed serious bug in line 1546 - should have been !=, not ==; stopped
450 mondorestore from correctly restoring big files
451- added '#include <signal.h>' to my-stuff.h
452- exclude "incheckentry xwait()" from changed.files
453- fixed minor bug in find_cdrom_device()
454- fixed bug in friendly_sizestr...
455- insist on tape #1 when start verifying
456- added internal buffering, replacing the external 'buffer' exe
457- if differential backup then don't permit formatting or fdisking,
458 whether Interactive or Nuke mode
459- if mondorestore is run on live filesystem (or from ramdisk) without
460 parameters then mondorestore will ask which backup media (tape, CD, etc.)
461 was used; it will read the config file from the media and proceed from there
462- if tape streamer is softlink then resolve it first
463- incorporate post-nuke tarball
464- if user doesn't specify tape size, proceed anyway; behave intelligently
465 in the event of end-of-tape
466- prefix bkpinfo->restore_path to biggiefile fname before generating
467 checksum & comparing to archived biggiefile
468- if /etc/lilo.conf not found not /etc/lilo.conf.anaconda found
469 then create a softlink from the former to the latter, to work
470 around RH7.3's b0rken LILO support
471- LFS support (mharris, michele, hugo)
472- fixed verify bug --- CD#1 was being verified again & again & ...
473- differential mode fixed; supported again
474- ask user for boot loader + device if not detectible
475- list up to 512 files in file selection window at once (was 128)
476- better handling of bigfiles' checksums, perms and owns
477- delete final filelist if <=2 bytes long
478- if kernel not found and mondo in graphics mode then popup and ask
479 for kernel path+filename
480
481* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 1.45-1
482- 1.5x branch forked off from 1.4x branch
483
484
485
486
Note: See TracBrowser for help on using the repository browser.