source: MondoRescue/branches/2.06/mondo/distributions/gentoo/mondo.ebuild@ 307

Last change on this file since 307 was 307, checked in by bcornec, 18 years ago

preliminary gentoo support added

File size: 1.7 KB
Line 
1# Copyright 1999-2005 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Id$
4
5inherit libtool
6
7DESCRIPTION="The premier GPL disaster recovery solution."
8HOMEPAGE="http://www.mondorescue.org"
9SRC_URI="ftp://ftp.berlios.de/pub/mondorescue/src/${PN/-rescue/}-${PV}.tgz"
10
11LICENSE="GPL-2"
12SLOT="0"
13KEYWORDS="-* ~x86"
14IUSE=""
15
16DEPEND="virtual/libc
17 >=sys-libs/slang-1.4.1
18 >=dev-libs/newt-0.50"
19RDEPEND="app-arch/afio
20 sys-block/buffer
21 sys-devel/binutils
22 >=app-arch/bzip2-0.9
23 app-cdr/cdrtools
24 >=sys-apps/mindi-1.06
25 >=dev-libs/newt-0.50
26 >=sys-libs/slang-1.4.1
27 >=sys-boot/syslinux-1.52"
28
29S=${WORKDIR}/${PN/-rescue/}-${PV}
30
31src_unpack() {
32 unpack ${A}
33 cd ${S}
34 chmod 750 configure
35}
36
37src_compile() {
38 elibtoolize
39 econf || die "Configuration failed"
40 emake || die "Make failed"
41 #make VERSION=VVV CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_REENTRANT"
42}
43
44src_install() {
45 #make install DESTDIR=${D} || die "make install failed"
46 einstall || die "Install failed"
47 exeinto /usr/share/mondo
48 doexe mondo/autorun
49}
50
51pkg_postinst() {
52 einfo "${P} was successfully installed."
53 einfo "Please read the associated docs for help."
54 einfo "Or visit the website @ ${HOMEPAGE}"
55 echo
56 ewarn "This package is still in unstable."
57 ewarn "Please report bugs to http://bugs.gentoo.org/"
58 ewarn "However, please do an advanced query to search for bugs"
59 ewarn "before reporting. This will keep down on duplicates."
60 echo
61 einfo "Prior to running mondo, ensure /boot is mounted."
62 ewarn "Grub users need to have a symlink like this:"
63 ewarn "ln -s /boot/grub/menu.lst /etc/grub.conf"
64 einfo "Unless you want to have mondo backup your distfiles,"
65 einfo "append \"-E ${DISTDIR}\" to your mondoarchive command."
66 echo
67}
Note: See TracBrowser for help on using the repository browser.