source: MondoRescue/branches/2.06/mindi/mindi.spec@ 315

Last change on this file since 315 was 315, checked in by bcornec, 18 years ago
  • svn.log now part of the rpms
  • .spec factorisation continues (mkrel, requires, ...)
  • Property svn:keywords set to Id
File size: 12.2 KB
Line 
1#
2# $Id: mindi.spec 315 2006-01-13 19:07:06Z bcornec $
3#
4%define is_mandriva %(test -e /etc/mandriva-release && echo 1 || echo 0)
5%define is_mandrake %(test -e /etc/mandrake-release && echo 1 || echo 0)
6%define is_suse %(test -e /etc/SuSE-release && echo 1 || echo 0)
7%define is_fedora %(test -e /etc/fedora-release && echo 1 || echo 0)
8%define is_redhat %(test -e /etc/redhat-release && echo 1 || echo 0)
9
10%define name mindi
11%define version VVV
12%define mrel RRR
13%define release %{mrel}
14%define src %{name}-%{version}.tgz
15%define grp Archiving/Backup
16%define addreqb bzip2 >= 0.9, mkisofs, ncurses, binutils, gawk, dosfstools, afio
17
18# define the mkrel macro if it is not already defined
19%{?!mkrel:%define mkrel(c:) %{-c:0.%{-c*}.}%{!?_with_unstable:%(perl -e '$_="%{1}";m/(.\*)(\\d+)$/;$rel=${2}-1;re;print "$1$rel";').%{?subrel:%subrel}%{!?subrel:1}.%{?distversion:%distversion}%{?!distversion:%(echo $[%{mdkversion}/10])}}%{?_with_unstable:%{1}}%{?distsuffix:%distsuffix}%{?!distsuffix:mdk}}
20
21%if %is_redhat
22%define grp Applications/Archiving
23%define addreq %{addreqb}, which
24Autoreq: 0
25%endif
26
27%if %is_mandrake
28%define src %{name}-%{version}.tar.bz2
29%define addreq %{addreqb}, which
30%define release %{mkrel} %{mrel}
31Autoreqprov: no
32%endif
33
34%if %is_mandriva
35%define src %{name}-%{version}.tar.bz2
36%define addreq %{addreqb}, which
37%define release %{mkrel} %{mrel}
38Autoreqprov: no
39%endif
40
41%if %is_suse
42%define addreq %{addreqb}
43%endif
44
45Summary: Mindi creates emergency boot disks/CDs using your kernel, tools and modules
46Name: %name
47Version: %version
48Release: %release
49License: GPL
50Group: %{grp}
51Url: http://mondorescue.berlios.de
52Source: %{src}
53BuildRoot: %{_tmppath}/%{name}-%{version}
54Requires: %{addreq}
55# Not on all systems
56#Conflicts: bonnie++
57
58%description
59Mindi takes your kernel, modules, tools and libraries, and puts them on N
60bootable disks (or 1 bootable CD image). You may then boot from the disks/CD
61and do system maintenance - e.g. format partitions, backup/restore data,
62verify packages, etc.
63
64%prep
65%{__rm} -rf $RPM_BUILD_ROOT
66%setup -n %name-%{version}
67
68%build
69%ifarch ia64
70%{__make} -f Makefile.parted2fdisk clean
71%{__make} -f Makefile.parted2fdisk
72%endif
73
74%install
75export DONT_RELINK=1
76
77%{__rm} -rf $RPM_BUILD_ROOT
78export PREFIX=${RPM_BUILD_ROOT}%{_exec_prefix}
79export CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}
80export RPMBUILDMINDI="true"
81
82./install.sh
83
84%if %is_suse
85%{__rm} -rf $RPM_BUILD_ROOT/%{_datadir}/doc/%name-%{version}
86%endif
87
88%clean
89%{__rm} -rf $RPM_BUILD_ROOT
90
91%post
92for i in %{_libdir}/mindi/aux-tools/sbin/* %{_libdir}/mindi/rootfs/bin/* %{_libdir}/mindi/rootfs/sbin/* ; do
93 if [ ! -h $i ]; then
94 %{__chmod} 755 $i
95 fi
96done
97if [ -f /usr/local/sbin/mindi ]; then
98 echo "WARNING: /usr/local/sbin/mindi exists. You should probably remove your manual mindi installation !"
99fi
100
101%files
102%defattr(644,root,root,755)
103%config(noreplace) %{_sysconfdir}/mindi/deplist.txt
104%doc ChangeLog INSTALL COPYING README TODO README.ia64 README.pxe README.busybox svn.log
105%{_mandir}
106%{_libdir}/mindi
107%attr(755,root,root) %{_sbindir}/*
108
109%changelog
110* Fri Nov 05 2005 Bruno Cornec <bcornec@users.berlios.de> 1.05
111- ia64 is now working
112- use install.sh script
113- use libdir for binary data
114
115* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 1.04_berlios
116- Merge of patches mentionned on mondo ML + ia64 updates
117- Fix bugs when called alone
118
119* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 1.04_cvs_20050503
120- supports exec-shield
121
122* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 1.03
123- better support of SLES 8
124
125* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 1.02
126- better kernel-level logging
127- added ACL, xattr binaries to deplist.txt
128- fixed obscure bug which occasionally stopped mindi from correctly finding
129 and documenting all LVM2 LVM-on-RAID volumes
130
131* Fri Jun 25 2004 Hugo Rabson <hugorabson@msn.com> 1.01
132- added ide_tape and other modules to mindi's config detection
133- unmount errant ramdisk ($mtpt) if fail to create boot floppy
134- better support of ISO dirs at restore-time (Conor Daly)
135
136* Fri Jun 18 2004 Hugo Rabson <hugorabson@msn.com> 1.00
137- first 1.0x release
138- busybox now static
139- trap Ctrl-Alt-Del; trigger soft reset
140- better SuSE 9.1 support
141- added parted2fdisk.pl (IA64) (Bruno Cornec)
142- add LVM2 support for kernel 2.6 (Takeru Komoriya)
143- better detection of multiple Mindis (Martin Fürstenau)
144- don't complain if just a Mindi boot CD & not a platform for Mondo
145- updated busybox to 1.0.0pre10
146- removed uClibc
147- add memtest support
148- 2.6 kernel support
149- removed Embleer files (Andree Leidenfrost)
150- added kernel-only floppy support, to accommodate really big kernels
151- updated+rebuilt busybox
152- added star support
153- mount /sys at boot-time
154- better 64-bit and 2.6 kernel support
155- better LVM, failsafe kernel support (Jim Richard)
156- use LILO, not raw kernel, on 1.4MB boot floppy
157- record names of unsaved modules, for future reference
158- enlarged ramdisk by 8MB
159
160* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 0.95
161- changed some '==' to '=' --- now more RH6-friendly
162- allow absolute pathnames again in deplist
163- disable multifunc cd thing
164- better Gentoo support (Bill)
165- better OnStream support
166- better Slackware support (Laurenz)
167- added partimagehack-static to deplist.txt
168- recompiled Busybox - now 10k smaller; better stack-handling
169- fixed boot screen typo
170- added support for 'auto' fs format
171- better devfs support for Mandrake users
172- better Debian+LVM support (Ralph Grewe)
173- updated analyze-my-lvm to handle floating-point gigabyte -L values
174
175* Thu Jul 24 2003 Anonymous <root@rohan> 0.94
176- altered rootfs's /dev entry to stop cvs from becoming confused
177- tweaked MAX_COMPRESSED_SIZE
178- added multi-function CD support to mindi and sbin/post-init
179- re-mount root as rw just in case
180- ask user to remove last data (floppy) disk if nec. (Tom Mortell)
181- added support for 5th column in mountlist.txt for labels
182- added symlinks.tgz
183- suppress erroneous error msgs re: failsafe kernel
184
185* Sun May 18 2003 Hugo Rabson <hugorabson@msn.com> 0.93
186- added cciss.o to SCSI_MODS
187- if format type is (e.g.) ext3,ext2 then use 1st entry
188- re-enabled fsck*
189- if cciss in use the enable it at boot-time
190- added /dev/ataraid/* to boot disk via ataraid.tgz (Luc S.)
191- better ISO support
192- tweaked Mindi to use 10-15% fewer floppies
193- added RUN_AFTER_INITIAL_BOOT_PHASE to let user specify a command
194 to be run by Mindi before it bootstraps to aux data disks;
195 e.g. 'echo engage > /proc/scsi/something'
196- added RUN_AFTER_BOOT_PHASE_COMPLETE to let user specify a command
197 to be run by Mindi after it boots but before it runs mondorestore
198- allow for Debian & other Stiefkinder that use 'none', not 'swap'
199 as the mountpoint of the swap partition
200- removed afio dependency
201- re-worked install.sh and tarball not to use tgz's
202- cleared up the boot msg
203- updated busybox to 0.60.5; updated uClibc to 0.9.19
204- add #!/bin/sh to start of insert-all-my-modules
205- fixed obscure bug in install-additional-tools
206- changed grep -m to grep | head -n1 for Debian users
207- moved vmlinuz, lib.tar.bz2 to mindi-kernel tarball/rpm
208
209* Wed Apr 09 2003 Hugo Rabson <hugorabson@msn.com> 0.92
210- fixed LVM/RAID bugs (Brian Borgeson)
211- if bad lilo, give more verbose error before quitting
212- added mt and perl to deplist.txt
213- insist on gawk being present
214- insmod ide-cd, cdrom, isofs, just in case
215- boot-time tmpfs ramdisk is now 40m (was 34m)
216- cleaned up logs
217- iso mode now calls Interactive
218- make SizeOfPartition() more Debian-friendly (Andree Leidenfrost)
219- clean up some calls to grep, esp. partition_mountpt=...
220- corrected some bashisms, to suit Debian ped- er, users
221- made first line refer to bash, not sh, to make sure
222 the Debian people know Mindi requires bash, not hs
223- changed grep -v "#" and grep -vx "#.*" to grep -vx " *#.*"
224- disabled code which would have made Mindi use sfdisk instead of fdisk
225 if it looked as if Debian's fdisk would misbehave
226
227* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 0.91
228- new devel branch
229- EXTRA_SPACE=16384
230- updated ResolveSoftlinks() to work better with b0rkn Gentoo devfs /dev
231- patched analyze-my-lvm (Benjamin Mampaey)
232- detect built-in boot.b files in lilo
233- cleaned up spec file a bit, more use of macros (Jesse Keating)
234- return w/err, don't abort, if Matt Nelson's RH8 system is farked
235- better at finding isolinux.bin
236- better at analyzing dependencies when running on broken distributions
237- try harder to boot from CD, even if tape fails
238- added ADDITIONAL_BOOT_PARAMS to be sent to kernel
239- better resolution of relative softlinks, leading to fewer
240 duplicates on data disks and therefore fewer data disks
241- detect Debian+devfs; use sfdisk instead of fdisk in that
242 eventuality, to work around yet another of Debian's warts
243- removed /lib/libuuid.* from rootfs.tgz
244- fixed vi
245- mindi now uses gawk --traditional (making gawk behave in a functionally
246 identical way to awk) - PASS; great, so now Debian needs to fix its awk :)
247- removed / from list of dirs accessed when trying to resolve deplist entry
248- spinner bugfix; handle odd LABELs properly (Tom Mortell)
249- fixed LVM/RAID bugs (Brian Borgeson)
250
251* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 0.72_20021202
252- misc code clean-up
253- save boot device's boot sector
254- detect and beware Compaq diagnostic partitions
255- better handling of devfs V non-devfs kernels and boot devs
256- trimmed busybox 0.60.3 binary on boot disk
257- mindi now resides in /usr/local/bin
258- removed lilo from dependencies
259- more Gentoo-friendly
260
261* Sun Nov 18 2002 Hugo Rabson <hugo@firstlinux.net> 0.71
262- if your kernel's builddate doesn't match any of the kernels in
263 your /boot directory then fudge the issue & find the closest
264 match (*grumble* Debian)
265- scan tape & CD at start, to force inclusion of modules on boot device
266- double EXTRA_SPACE if >7 disks
267- slimmer, more lithesome logfile
268- now accepts --findkernel
269- line 1982 - dd count=24000 should be count=$ramdisksize (Andras Korn)
270- better handling of non-Linux partitions on DevFS-enabled kernels
271- misc clean-ups
272- fixed Debian/ramdisksize/bloat problem (Johannes Franken)
273- fixed 2.4.20/fdisk eccentricity (Alistair Stevens)
274- updated kernel to 2.4.18-mdk6
275- generate mountlist in dev-abetical order ;)
276- fixed minor bug in .spec file
277- better at finding /boot/boot.b if your distro breaks the de facto standard
278- fixed minor bug in MakeMountlist
279- fixed install.sh
280- cleaned up deplist.txt
281- added rudimentary -v / --version flag
282- line 1180 or so --- duplicate mindi.iso entries --- fixed
283- added /bin/[ - a softlink to /bin/sh
284- ListAllPartitions() - sanity fix (KP)
285- fixed .spec bug
286- better feedback
287- added Markus's RAID patch
288- ListAllPartitions() - include /mnt/win* (Hugo)
289
290* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 0.70
291- better logging by dependency-calculating code
292- better handling of dependencies, specifically softlinks
293- if called by mondo then use mondo's temp dir as our temp dir too
294- changed gawk to $AWK in a few places, to allow for Debian
295- added host* config files to deplist
296- added tftp, ifconfig to busybox
297- added RPC support to uClibc
298- cleaned up creation of Mondo-Mindi configuration file
299- fixed bug in TryToFindKernelPath which stopped it from handling
300 multiple, same-version kernels gracefully
301- cleaned up deplist.txt
302- receive 'DIFFERENTIAL' variable from Mondo
303- better Debian compatibility, esp. w/detection of ver# (Hector Alvarez)
304- better devfs support; call fgrep in places instead of grep (Andrew Korn)
305- fixed analyze-my-lvm (Ralph Gruwe)
306- moved 50K of stuff from rootfs.tgz to aux-tools.tgz
307- added x11-tools.tgz option
308- updated /dev/console and /dev/tty0 (Paul Stevens)
309- cleaned up /mnt/groovy-stuff V /tmp/tmpfs code
310- catch sigint, sighup, etc.
311- fixed LILO-related message.txt mistake
312- .spec file clean-up; automation; config file (Carl Wilhem Soderstrom)
313- better devfs support (Andrew Korn)
314
315* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 0.64-1
316- fixed RH7.3 readonly bug
317- improved nfs config file creation
318- search more locations for isolinux.bin
319- added isonuke option
320- faster data disk creation
321- better DevFS support (Hector Alvarez, DuckX)
322- nfs-related fix (Hans Lie)
323- abort if vfat filesystem present but mkfs.vfat missing
324- removed softlink to pico
325- allow Mondo to say no compression will be used
326- added [ to ramdisk
327- tar data disks with -b [block size] of 32k
328- don't autoboot to 'RESTORE' screen - it's scary!
329- let user choose lilo or syslinux as boot loader
330- added syslinux support
331- cleaned up message screens
332
Note: See TracBrowser for help on using the repository browser.