source: MondoRescue/branches/2.06/mindi/distributions/gentoo/mindi.ebuild

Last change on this file was 308, checked in by bcornec, 18 years ago

gentoo build files added for mindi as well

File size: 1.3 KB
Line 
1# Copyright 1999-2005 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/sys-apps/mindi/mindi-1.04.ebuild,v 1.1 2005/01/22 10:29:25 wschlich Exp $
4
5DESCRIPTION="A program that creates emergency boot disks/CDs using your kernel, tools and modules."
6HOMEPAGE="http://www.mondorescue.org"
7SRC_URI="ftp://ftp.berlios.de/pub/mondorescue/src/${P}.tgz"
8
9LICENSE="GPL-2"
10SLOT="0"
11KEYWORDS="~x86 -*"
12IUSE=""
13
14DEPEND="virtual/libc"
15RDEPEND=">=app-arch/bzip2-0.9
16 >=sys-apps/mindi-kernel-1.0-r1
17 app-cdr/cdrtools
18 sys-libs/ncurses
19 sys-devel/binutils
20 sys-fs/dosfstools
21 sys-apps/gawk"
22
23src_unpack() {
24 unpack ${A} || die "Failed to unpack ${A}"
25 cd ${S}/rootfs || die
26 tar xzf symlinks.tgz || die "Failed to unpack symlinks.tgz"
27
28 # This will need to change when IA64 is tested. Obviously.
29 rm -f bin/busybox-ia64 sbin/parted2fdisk-ia64
30 mv bin/busybox-i386 bin/busybox
31}
32
33src_install() {
34 ./install.sh
35}
36
37pkg_postinst() {
38 einfo "${P} was successfully installed."
39 einfo "Please read the associated docs for help."
40 einfo "Or visit the website @ ${HOMEPAGE}"
41 echo
42 ewarn "This package is still in unstable."
43 ewarn "Please report bugs to http://bugs.gentoo.org/"
44 ewarn "However, please do an advanced query to search for bugs"
45 ewarn "before reporting. This will keep down on duplicates."
46 echo
47}
Note: See TracBrowser for help on using the repository browser.