source: MondoRescue/branches/2.05/mondo/mondo.spec@ 217

Last change on this file since 217 was 206, checked in by bcornec, 18 years ago

No X11 dependency for mondo build

  • Property svn:keywords set to Id
File size: 18.8 KB
Line 
1#
2# $Id: mondo.spec 206 2005-12-14 16:24:02Z bcornec $
3#
4%define is_mandriva %(test -e /etc/mandriva-release && echo 1 || echo 0)
5%define is_mandrake %(test -e /etc/mandrake-release && echo 1 || echo 0)
6%define is_suse %(test -e /etc/SuSE-release && echo 1 || echo 0)
7%define is_fedora %(test -e /etc/fedora-release && echo 1 || echo 0)
8%define is_redhat %(test -e /etc/redhat-release && echo 1 || echo 0)
9
10%define name mondo
11%define version 2.05
12%define mrel 1
13
14%if %is_redhat
15%define src %{name}-%{version}.tgz
16Group: Applications/Archiving
17Autoreq: 0
18%endif
19
20%if %is_mandrake
21%define src %{name}-%{version}.tar.bz2
22Group: Archiving/Backup
23Autoreqprov: no
24%endif
25
26%if %is_mandriva
27%define src %{name}-%{version}.tar.bz2
28Group: Archiving/Backup
29Autoreqprov: no
30%endif
31
32
33Summary: A program which a Linux user can utilize to create a rescue/restore CD/tape
34Summary(fr): Un programme pour les utilisateurs de Linux pour cr�r un CD/tape de sauvegarde/restauration
35Summary(it): Un programma per utenti Linux per creare un CD/tape di rescue
36Summary(sp): Un programa para los usuarios de Linux por crear una CD/cinta de restoracion/rescate
37
38Name: %{name}
39Version: %{version}
40Release: %{mrel}
41License: GPL
42Url: http://mondorescue.berlios.de
43Source: %{src}
44BuildRoot: %{_tmppath}/%{name}-%{version}
45BuildRequires: newt-devel >= 0.50, slang-devel >= 1.4.1, gcc
46%ifarch ia64
47Requires: mindi >= 1.05, bzip2 >= 0.9, afio, mkisofs, binutils, elilo, newt >= 0.50, slang >= 1.4.1, buffer, parted
48%else
49Requires: mindi >= 1.05, bzip2 >= 0.9, afio, mkisofs, binutils, syslinux >= 1.52, newt >= 0.50, slang >= 1.4.1, cdrecord, buffer
50%endif
51
52#%package xmondo
53#Summary: A QT based graphical front end for %{name}
54#Group: Applications/Archiving
55#Requires: %{name} = %{version}-${release}, qt, kdelibs
56#
57#%package %{name}-devel
58#Summary: Header files for building against Mondo
59#%if %is_mandrake
60#Group: Development/Libraries
61#%endif
62#if %is_redhat
63#Group: Development/Other
64#%endif
65#Provides: libmondo-devel mondo-devel
66#Obsoletes: libmondo-devel
67#
68#%description -n %{name}-devel
69#Mondo libraries and includes
70
71%description
72Mondo is a GPL disaster recovery solution to create backup media (CD, DVD, tape, network images) that can be used to redeploy the damaged system, as well as deploy similar or less similar systems.
73
74%description -l fr
75Objectif
76""""""""
77Mondo est une solution GPL de sauvegarde en cas de désastre pour créer des médias (CD, DVD, bande, images réseau) qui peuvent être utilisés pour redéployer le système endomangé, aussi bien que des systèmes similaires, ou moins similaires.
78
79%description -l it
80Scopo
81"""""
82Mondo e' un programma che permette a qualsiasi utente Linux
83di creare un cd di rescue/restore (o piu' cd qualora l'installazione
84dovesse occupare piu' di 2Gb circa). Funziona con gli azionamenti di
85nastro, ed il NFS, anche.
86
87%description -l sp
88Objectivo
89"""""""""
90Mondo es un programa que permite cualquier usuario de Linux a crear una CD
91de restoracion/rescate (o CDs, si su instalacion es >2GO aprox.). Funciona
92con cintas y NFS, tambien.
93
94#%description xmondo
95#Xmondo is a QT based graphical frontend to mondoarchive. It can help you
96#set up a backup by following onscreen prompts.
97
98%prep
99%setup -q -n %name-%{version}
100
101%build
102%configure %{!?_without_xmondo:--with-x11}
103%{__make} VERSION=%{version} CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_REENTRANT"
104
105%install
106%{__rm} -rf $RPM_BUILD_ROOT
107%makeinstall
108
109%post
110/sbin/ldconfig
111%{__chmod} 755 %{_libdir}/%{name}/restore-scripts/%{name}/*
112
113%postun
114/sbin/ldconfig
115
116%clean
117%{__rm} -rf $RPM_BUILD_ROOT
118
119%files
120%defattr(644,root,root,755)
121%doc ChangeLog mondo/docs/en/1.6x-howto/*
122%doc INSTALL COPYING README TODO AUTHORS NEWS
123
124%attr(755,root,root) %{_sbindir}/*
125#%attr(755,root,root) %{_libdir}/%{name}/restore-scripts/%{name}/*
126%{_libdir}
127%{_mandir}
128
129#%{!?_without_xmondo:%files xmondo}
130#%{!?_without_xmondo:%{_sbindir}/xmondo}
131#%{!?_without_xmondo:%{_libdir}/libXmondo-%{libversion}.so}
132#%{!?_without_xmondo:%{_libdir}/libXmondo.so}
133#%{!?_without_xmondo:%{_datadir}/mondo/mondo.png}
134
135%changelog
136* Fri Nov 05 2005 Bruno Cornec <bcornec@users.berlios.de> 1.05
137- ia64 is now working
138- -p option related bug fixed
139- use libdir instead of datadir
140
141* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 2.04_berlios
142- Merge of patches mentionned on mondo ML + ia64 updates
143- Add -p option
144
145* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 2.04_cvs_20050503
146- made mondo more clever about finding its home. Avoids mondo considering
147 directories like '/usr/share/doc/momdo' as its home.
148
149* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 2.03
150- test sanity of user-specified tempdir
151- better SLES8 support
152
153* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 2.02
154- instead of using 'dd' to erase partition table, delete existing
155 partitions w/ the same call to fdisk that is used to create the
156 new partitions; this should avoids locking up the partition table
157- set bootable partition in the above same call to fdisk, for
158 the same reason (avoids locking up the partition table)
159- better software RAID support
160- mount ext3 partitions as ext2 when restoring - better for Debian
161- better star, ACL support
162- added ACL, xattr support for afio users
163
164* Fri Jun 26 2004 Hugo Rabson <hugorabson@msn.com> 2.01
165- fixed cvs for SuSE systems
166- fixed NTFS backup/restore bug relating to partimagehack
167 log file overflow and NTFS v non-NTFS differentiation
168- more reliable extraction of config info from CDs, floppies
169- better support of ISO dirs at restore-time (Conor Daly)
170- fixed spec file for SuSE users
171- added ldconfig to install section
172
173* Fri Jun 19 2004 Hugo Rabson <hugorabson@msn.com> 2.00
174- first 2.0 release
175- updated grub-install.patched to support SuSE and Red Hat
176- call 'mt' to set block size to 32K before opening in/out tape
177- updated mondo-prep.c to create each disk's partitions all at once
178 (one call per drive) instead of one call to fdisk per partition
179- when extracting cfg file and mountlist from all.tar.gz (tape copy),
180 use block size of INTERNAL_TAPE_BLK_SIZE, not TAPE_BLOCK_SIZE
181- added star and rudimentary SELinux support
182- fixed lots of bugs
183- all logging now goes to /var/log/mondo-archive.log, with symlink
184 to /tmp/mondo-restore.log for restore-time log-tracking
185- added grub-install.patched
186- removed embleer & other binaries
187- added '-b' to specify block size
188- added '-R' for star support
189
190* Thu Mar 25 2004 Bruno Cornec <Bruno.Cornec@hp.com> 1.7_cvs-20040325
191- ia64 fixes
192
193* Fri Nov 07 2003 Joshua Oreman <oremanj@get-linux.org> 1.7_cvs-20031107
194- fixed symbolic links for libraries
195- added support for boot/root multi floppies
196
197- added kdelibs as xmondo dependency
198- added xmondo pixmap installation
199- better find_cdrom_device(), to cope w/ multiple CD writers
200- fixed -m and -Vc flags
201- fixed NTFS support!
202- bootable CD uses native, not El Torito, support now
203- removed mondo-makefilelist
204- added 2.6 kernel support
205- if 2.6 kernel, insist that the user specify CD device
206- drop Embleer; insist on ms-sys and parted if Windows partition
207
208* Wed Nov 05 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031105.1
209- added -devel package
210
211* Tue Nov 04 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031104.1
212- made xmondo a second package
213- added ability to specify --without xmondo at build time
214
215* Sun Nov 02 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031102.1
216- Clean up, added spanish translation
217- Set prefix to be /usr
218- added/fixed Requires
219- remove CVS directories prior to building
220
221* Thu Oct 23 2003 Hugo Rabson <hugorabson@msn.com> 1.75_cvs_20031023
222- nothing yet
223
224* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 1.75
225- fixed chmod/chown bug (Jens Richter)
226- ask user to confirm NFS mountpoint in Interactive Mode
227- rewritten format_everything() to make sure LVMs, RAIDs and
228 regular partitions are prepped in the correct order
229- better magicdev support
230- rewritten external binary caller subroutine
231- DVD support added
232- better backup-time control gui; offer to exclude nfs if appl.
233- fixed multi-tape support
234- re-implemented -D and -J
235- fixed bug in extract_config_file_from_ramdisk() which
236 affected tape+floppy users
237- updated is_incoming_block_valid() to make it
238 return end-of-tape if >300 flotsam blocks
239- unmount CD-ROM before burning (necessary for RH8/9)
240- fixed some stray assert()'s
241- fixed bug in grub-MR (Christian)
242- make user remove floppy/CD before restoring interactively from tape
243- fixed bug in am_I_in_disaster_recovery_mode()
244- added code to nuke_mode() to make sure NFS
245 (backup) share is mounted in Nuke Mode
246- improved tape device detection code
247- better GRUB support
248- better logging of changed bigfiles at compare-time
249- better NTFS support, thanks to partimagehack-static
250- better logging
251- rewrote tape-handling code, breaking compatibility w/ previous versions
252- fixed ISO/CD biggiefile verification bug in mondoarchive
253- fixed bug which stopped boot/compare-time changelist from popping up
254- replaced mondo-makefilelist with C code - faster, cleaner
255- tweaked GUI - better feedback
256
257* Wed May 28 2003 Anonymous <root@rohan> 1.74
258- misc fixes (Michael Hanscho's friend)
259- added rudimentary support for SME
260- added better label support
261- fixed biggietime atime/ctime restoration bug 73
262- fixed 'default boot loader' detection bug (Joshua Oreman)
263- use single-threaded make_afioballs_and_images() if FreeBSD
264- fixed mondoarchive -Vi multi-CD verify bug (Tom Mortell)
265- superior get_phys_size_of_drive() (Joshua Oreman)
266- fixed RAID-related bug in where_is_root_mounted()
267- ISO tweaks
268- fixed silly bug in load_filelist() which stopped
269 funny German filenames from being handled properly
270- fixed various calls to popup_and_get_string()
271- fixed spec file
272- reject -E /
273- added partimagehack to the mix
274
275* Tue May 20 2003 Anonymous <root@rohan> 1.73
276- mark devices as bootable _after_ unmounting them
277- resolve boot device (-f) if softlink
278- post_param_configuration() --- store iso-dev and isodir
279- added post-nuke-sample.tgz to package
280- Nuke Mode now checks mountlist against hardware; offer user
281 opportunity to edit mountlist if insane; if user declines, abort
282- added lots of assert()'s and other checks
283- ran code thru Valgrind to catch & fix some memory leaks
284- made mondo-restore.c smaller by moving some subroutines to
285 common/libmondo-raid.c and mondorestore/mondo-rstr-compare.c
286- added '-Q' to let user test mondoarchive's ability to find
287 their boot loader and type
288- improved which_boot_loader()
289- when burning or comparing to a CD, defeat autorun if it is
290 running, to avoid confusing mondoarchive and the user
291- if original backup media no longer available at boot-time
292 then offer user chance to choose another media source
293- when booting, type 'nuke noresize' to nuke w/o resizing
294 mountlist to fill your drives
295- add 'textonly' when booting, to avoid using Newt gui
296- run nice(20) to prioritize mondoarchive at start
297- don't pause and wait for next blank CD at backup-time
298 unless necessary (e.g. previous CD has not been removed)
299- get_phys_size_of_drive() --- better support of older drives
300- don't eject if "donteject" is in kernel's command line
301- cleaned up segfault-handling
302- added Conor's strip_path() to improve file list display
303- added Herman Kuster's multi-level bkp patch
304- better boot-time screen/message
305- added Joshua Oreman's FreeBSD patches x3
306- fixed interactive/textonly support
307- fixed support for subdir-within-NFS-mount
308- fixed "Can't backup if ramdisk not mounted" bug
309- try to work around eccentricities of multi-CD drive PCs
310- misc clean-ups (Steve Hindle)
311
312* Tue Apr 08 2003 Hugo Rabson <hugorabson@msn.com> 1.72
313- LVM/RAID bugs fixed (Brian Borgeson)
314- major clean-up of code (Stan Benoit)
315- make-me-bootable fix (Juraj Ziegler)
316- fixed problem w/ multi-ISO verify cycle (Tom Mortell)
317- removed duplicate entry from makefile
318- if root is /dev/root then assume not a ramdisk
319- reject relative paths if -d flag (Alessandro Polverini)
320- fixed potentially infinite loop in log_to_screen (Tom Mortell)
321- add '/' to custom filelist as workaround for obscure bug
322- ask user speed of CDRW if writing to CD
323- find_cdrom_device() --- if nonexistent/not found then
324 make sure to return '' as dev str and 1 as res
325- tweaked restore scripts tgz
326- cleaned up find_cdrom_device()
327- if user creates /usr/share/mondo/payload.tgz then untar
328 payload to CD at backup-time
329- fixed insist_on_this_cd_number()
330- fixed am_i_in_disaster_recovery_mode()
331- misc clean-up (Tom Mortell)
332- made code more legible
333- fixed post-nuke support
334- added -e support
335- fixed nfs support
336- fixed iso support
337- at restore-time, only sort mountlist internally,
338 in mount_all_devices() and unmount_all_devices()
339- fixed cosmetic bug in label-partitions-as-necessary
340- updated documentation
341- fixed fstab-hacking scripts
342
343* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 1.71
344- log newt, slang, ncurses info
345- updated man page
346- handle %% chars in issue.net properly (Heiko Schlittermann)
347- fixed serious NFS restore bug
348- cleaned up spec file; it should cause fewer problems now (Jesse Keating)
349- changed various strcpy() calls to strncpy() calls
350- added mondo-makefilelist to makefile (Mikael Hultgren)
351- mount_cdrom() better at handling multiple CD drives
352- exclude /media/cdrom,cdrecorder,floppy
353- sensibly_set_tmpdir_and_scratchdir() --- exclude smb and smbfs
354- better logging by eval_call_to_make_ISO()
355- accept -J <fname> to let user provide their own fs catalog
356 instead of -I <paths> to backup
357- if dir excluded with -E or included with -I and dir is actually
358 a softlink then exclude/include the dir pointed to, as well
359- better location for manpage
360- adjusted block size of tarball at start of tape, to help
361 users w/ broken tape driver firmware
362- sort -u fstab after modifying it
363- if backup type is nfs then don't estimate noof media
364- fixed Makefile (Mikael Hultgren)
365- updated manpage
366
367* Mon Dec 07 2002 Hugo Rabson <hugo@firstlinux.net> 1.70
368- new devel branch opened
369
370* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 1.52
371- fixed bug in multithreading
372- use new grub-MR instead of grub-install
373- wipe only the partition table (not the MBR) when partitioning drives
374- ignore lilo.conf.anaconda when looking for lilo.conf file
375- accepts '-l RAW' to backup/restore original boot sector instead
376 of running grub or lilo to init it after restoring
377- fixed&updated stabgrub-me script; software RAID + GRUB work now
378- mount/unmount /boot partition for Gentoo 1.2 users
379- re-enabled extra tape checksums
380- disabled spurious warnings
381- unmount/remount supermounts at start/end of live restore, if nec.
382- cleaned up mondo's tape block handling (now, TAPE_BLOCK_SIZE=128K
383 and I've added INTERNAL_TAPE_BLK_SIZE=32K variable for buffering)
384- added Makefile
385- added -l RAW, to backup and restore original MBR
386- cleaned up iso_mode() and nfs restoring
387- create /mnt/RESTORING/mnt/.boot.d for Gentoo users
388- made mondorestore CD bootable for ArkLinux users
389- if user runs as 'su' not 'su -' then work around
390
391* Sun Nov 17 2002 Hugo Rabson <hugo@firstlinux.net> 1.51
392- pop-up list of changed files, at end of verification phase
393- better handling of changed.files list at restore-time
394- lots of CD-related fixes
395- added '-N' flag --- to let user exclude all NFS-related mounts&devices
396- better handling of 'kill'
397- restructuring of code to ease integration of mondo w/XMondo
398- fixed obscure bug in find_and_mount_actual_cd()
399- if / or /root has <50MB free then abort & complain
400- fixed install.sh
401- fixed .spec file
402- updated documentation
403- commented code
404- updated man page
405- added -v / --version flag
406- replace convoluted grep with wc (KP)
407- fixed bug affecting restoration of bigfiles from CD's created w/0 compression
408- fixed BurnProof-related bug
409- better at figuring out which is the best partition for temp/scratchdir
410- added do-not-compress-these (text file) to RPM
411- do not compress files of types listed in do-not-compress-these
412- dropped -U from call to afio - saves 20-30% runtime (Cosgrove)
413- added Cosgrove's do-not-compress-these list
414- included various patches from KP
415- chmod tmpdir, scratchdir to 700 before using
416- restore from specified backup device, even if its own cfg file disagrees
417- fixed multi-tape bug
418- fixed "Can't find first ISO when verifying nonbootable ISO" bug
419- multithreaded make_afioballs_and_images()
420- tmpdir and scratchdir are set sensibly whether mondoarchive is called with
421 command-line parameters or not
422- fixed bug in strip_spaces() which stopped it from handling
423 small strings correctly - affected mountlist editor
424- create a repaired copy of grub-install which is RAID-friendly;
425 use it when initializing boot sector with run_grub()
426- fixed bug in mondo-makefilelist
427
428* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 1.50
429- if restoring, don't try to find SCSI node of CD-ROM drive; find /dev entry
430- during selective restore, skip filesets which don't contain relevant archives
431- set /dev/null's perms to 777, just in case devfs-enabled kernel mangles it
432- remove /var/run/*.pid after restoring
433- move spurious lockfiles from /home/* to /home/*/.disabled
434- ask user to confirm the tape/CD device name
435- lots of multitape-related fixes
436- added code to autodetect the hardware of the user, if possible
437- if isodir does not exist then abort
438- more sanity-checking for -d flag
439- doubled 'biggiefile' threshold... to 32MB
440- exclude /root/images/mindi
441- fixed multi-imagedev bug (Emmanuel Druon)
442- unmount/remount /mnt/floppy before/after backing up, if Mandrake
443- restructured the source files
444- fixed serious bug in line 1546 - should have been !=, not ==; stopped
445 mondorestore from correctly restoring big files
446- added '#include <signal.h>' to my-stuff.h
447- exclude "incheckentry xwait()" from changed.files
448- fixed minor bug in find_cdrom_device()
449- fixed bug in friendly_sizestr...
450- insist on tape #1 when start verifying
451- added internal buffering, replacing the external 'buffer' exe
452- if differential backup then don't permit formatting or fdisking,
453 whether Interactive or Nuke mode
454- if mondorestore is run on live filesystem (or from ramdisk) without
455 parameters then mondorestore will ask which backup media (tape, CD, etc.)
456 was used; it will read the config file from the media and proceed from there
457- if tape streamer is softlink then resolve it first
458- incorporate post-nuke tarball
459- if user doesn't specify tape size, proceed anyway; behave intelligently
460 in the event of end-of-tape
461- prefix bkpinfo->restore_path to biggiefile fname before generating
462 checksum & comparing to archived biggiefile
463- if /etc/lilo.conf not found not /etc/lilo.conf.anaconda found
464 then create a softlink from the former to the latter, to work
465 around RH7.3's b0rken LILO support
466- LFS support (mharris, michele, hugo)
467- fixed verify bug --- CD#1 was being verified again & again & ...
468- differential mode fixed; supported again
469- ask user for boot loader + device if not detectible
470- list up to 512 files in file selection window at once (was 128)
471- better handling of bigfiles' checksums, perms and owns
472- delete final filelist if <=2 bytes long
473- if kernel not found and mondo in graphics mode then popup and ask
474 for kernel path+filename
475
476* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 1.45-1
477- 1.5x branch forked off from 1.4x branch
478
479
480
481
Note: See TracBrowser for help on using the repository browser.