source: MondoRescue/branches/2.05/mondo/mondo.spec@ 1012

Last change on this file since 1012 was 248, checked in by bcornec, 18 years ago

align mindi.spec to mondo.spec after sles9 changes

  • Property svn:keywords set to Id
File size: 19.0 KB
Line 
1#
2# $Id: mondo.spec 248 2005-12-20 12:28:31Z bcornec $
3#
4%define is_mandriva %(test -e /etc/mandriva-release && echo 1 || echo 0)
5%define is_mandrake %(test -e /etc/mandrake-release && echo 1 || echo 0)
6%define is_suse %(test -e /etc/SuSE-release && echo 1 || echo 0)
7%define is_fedora %(test -e /etc/fedora-release && echo 1 || echo 0)
8%define is_redhat %(test -e /etc/redhat-release && echo 1 || echo 0)
9
10%define name mondo
11%define version VVV
12%define mrel 1
13%define src %{name}-%{version}.tgz
14
15%if %is_redhat
16Group: Applications/Archiving
17Autoreq: 0
18%endif
19
20%if %is_mandrake
21%define src %{name}-%{version}.tar.bz2
22Group: Archiving/Backup
23Autoreqprov: no
24%endif
25
26%if %is_mandriva
27%define src %{name}-%{version}.tar.bz2
28Group: Archiving/Backup
29Autoreqprov: no
30%endif
31
32%if %is_suse
33Group: Archiving/Backup
34%endif
35
36Summary: A program which a Linux user can utilize to create a rescue/restore CD/tape
37Summary(fr): Un programme pour les utilisateurs de Linux pour cr�r un CD/tape de sauvegarde/restauration
38Summary(it): Un programma per utenti Linux per creare un CD/tape di rescue
39Summary(sp): Un programa para los usuarios de Linux por crear una CD/cinta de restoracion/rescate
40
41Name: %{name}
42Version: %{version}
43Release: %{mrel}
44License: GPL
45Url: http://mondorescue.berlios.de
46Source: %{src}
47BuildRoot: %{_tmppath}/%{name}-%{version}
48BuildRequires: newt-devel >= 0.50, slang-devel >= 1.4.1, gcc
49%ifarch ia64
50Requires: mindi >= 1.05, bzip2 >= 0.9, afio, mkisofs, binutils, elilo, newt >= 0.50, slang >= 1.4.1, buffer, parted
51%else
52Requires: mindi >= 1.05, bzip2 >= 0.9, afio, mkisofs, binutils, syslinux >= 1.52, newt >= 0.50, slang >= 1.4.1, buffer
53%endif
54
55#%package xmondo
56#Summary: A QT based graphical front end for %{name}
57#Group: Applications/Archiving
58#Requires: %{name} = %{version}-${release}, qt, kdelibs
59#
60#%package %{name}-devel
61#Summary: Header files for building against Mondo
62#%if %is_mandrake
63#Group: Development/Libraries
64#%endif
65#if %is_redhat
66#Group: Development/Other
67#%endif
68#Provides: libmondo-devel mondo-devel
69#Obsoletes: libmondo-devel
70#
71#%description -n %{name}-devel
72#Mondo libraries and includes
73
74%description
75Mondo is a GPL disaster recovery solution to create backup media (CD, DVD, tape, network images) that can be used to redeploy the damaged system, as well as deploy similar or less similar systems.
76
77%description -l fr
78Objectif
79""""""""
80Mondo est une solution GPL de sauvegarde en cas de désastre pour créer des médias (CD, DVD, bande, images réseau) qui peuvent être utilisés pour redéployer le système endomangé, aussi bien que des systèmes similaires, ou moins similaires.
81
82%description -l it
83Scopo
84"""""
85Mondo e' un programma che permette a qualsiasi utente Linux
86di creare un cd di rescue/restore (o piu' cd qualora l'installazione
87dovesse occupare piu' di 2Gb circa). Funziona con gli azionamenti di
88nastro, ed il NFS, anche.
89
90%description -l sp
91Objectivo
92"""""""""
93Mondo es un programa que permite cualquier usuario de Linux a crear una CD
94de restoracion/rescate (o CDs, si su instalacion es >2GO aprox.). Funciona
95con cintas y NFS, tambien.
96
97#%description xmondo
98#Xmondo is a QT based graphical frontend to mondoarchive. It can help you
99#set up a backup by following onscreen prompts.
100
101%prep
102%setup -q -n %name-%{version}
103
104%build
105%configure %{!?_without_xmondo:--with-x11}
106%{__make} VERSION=%{version} CFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_REENTRANT"
107
108%install
109%{__rm} -rf $RPM_BUILD_ROOT
110%makeinstall
111%if %is_suse
112%{__rm} -rf $RPM_BUILD_ROOT/%{_datadir}/doc/%name-%{version}
113%endif
114
115%post
116/sbin/ldconfig
117%{__chmod} 755 %{_libdir}/%{name}/restore-scripts/%{name}/*
118
119%postun
120/sbin/ldconfig
121
122%clean
123%{__rm} -rf $RPM_BUILD_ROOT
124
125%files
126%defattr(644,root,root,755)
127%doc ChangeLog mondo/docs/en/1.6x-howto/*
128%doc INSTALL COPYING README TODO AUTHORS NEWS
129
130%attr(755,root,root) %{_sbindir}/*
131#%attr(755,root,root) %{_libdir}/%{name}/restore-scripts/%{name}/*
132%{_libdir}
133%{_mandir}
134
135#%{!?_without_xmondo:%files xmondo}
136#%{!?_without_xmondo:%{_sbindir}/xmondo}
137#%{!?_without_xmondo:%{_libdir}/libXmondo-%{libversion}.so}
138#%{!?_without_xmondo:%{_libdir}/libXmondo.so}
139#%{!?_without_xmondo:%{_datadir}/mondo/mondo.png}
140
141%changelog
142* Fri Nov 05 2005 Bruno Cornec <bcornec@users.berlios.de> 1.05
143- ia64 is now working
144- -p option related bug fixed
145- use libdir instead of datadir
146
147* Tue Sep 06 2005 Bruno Cornec <bcornec@users.berlios.de> 2.04_berlios
148- Merge of patches mentionned on mondo ML + ia64 updates
149- Add -p option
150
151* Tue May 03 2005 Hugo Rabson <hugorabson@msn.com> 2.04_cvs_20050503
152- made mondo more clever about finding its home. Avoids mondo considering
153 directories like '/usr/share/doc/momdo' as its home.
154
155* Wed Aug 04 2004 Hugo Rabson <hugorabson@msn.com> 2.03
156- test sanity of user-specified tempdir
157- better SLES8 support
158
159* Mon Jun 28 2004 Hugo Rabson <hugorabson@msn.com> 2.02
160- instead of using 'dd' to erase partition table, delete existing
161 partitions w/ the same call to fdisk that is used to create the
162 new partitions; this should avoids locking up the partition table
163- set bootable partition in the above same call to fdisk, for
164 the same reason (avoids locking up the partition table)
165- better software RAID support
166- mount ext3 partitions as ext2 when restoring - better for Debian
167- better star, ACL support
168- added ACL, xattr support for afio users
169
170* Fri Jun 26 2004 Hugo Rabson <hugorabson@msn.com> 2.01
171- fixed cvs for SuSE systems
172- fixed NTFS backup/restore bug relating to partimagehack
173 log file overflow and NTFS v non-NTFS differentiation
174- more reliable extraction of config info from CDs, floppies
175- better support of ISO dirs at restore-time (Conor Daly)
176- fixed spec file for SuSE users
177- added ldconfig to install section
178
179* Fri Jun 19 2004 Hugo Rabson <hugorabson@msn.com> 2.00
180- first 2.0 release
181- updated grub-install.patched to support SuSE and Red Hat
182- call 'mt' to set block size to 32K before opening in/out tape
183- updated mondo-prep.c to create each disk's partitions all at once
184 (one call per drive) instead of one call to fdisk per partition
185- when extracting cfg file and mountlist from all.tar.gz (tape copy),
186 use block size of INTERNAL_TAPE_BLK_SIZE, not TAPE_BLOCK_SIZE
187- added star and rudimentary SELinux support
188- fixed lots of bugs
189- all logging now goes to /var/log/mondo-archive.log, with symlink
190 to /tmp/mondo-restore.log for restore-time log-tracking
191- added grub-install.patched
192- removed embleer & other binaries
193- added '-b' to specify block size
194- added '-R' for star support
195
196* Thu Mar 25 2004 Bruno Cornec <Bruno.Cornec@hp.com> 1.7_cvs-20040325
197- ia64 fixes
198
199* Fri Nov 07 2003 Joshua Oreman <oremanj@get-linux.org> 1.7_cvs-20031107
200- fixed symbolic links for libraries
201- added support for boot/root multi floppies
202
203- added kdelibs as xmondo dependency
204- added xmondo pixmap installation
205- better find_cdrom_device(), to cope w/ multiple CD writers
206- fixed -m and -Vc flags
207- fixed NTFS support!
208- bootable CD uses native, not El Torito, support now
209- removed mondo-makefilelist
210- added 2.6 kernel support
211- if 2.6 kernel, insist that the user specify CD device
212- drop Embleer; insist on ms-sys and parted if Windows partition
213
214* Wed Nov 05 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031105.1
215- added -devel package
216
217* Tue Nov 04 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031104.1
218- made xmondo a second package
219- added ability to specify --without xmondo at build time
220
221* Sun Nov 02 2003 Jesse Keating <jkeating@j2solutions.net> 1.7_cvs-20031102.1
222- Clean up, added spanish translation
223- Set prefix to be /usr
224- added/fixed Requires
225- remove CVS directories prior to building
226
227* Thu Oct 23 2003 Hugo Rabson <hugorabson@msn.com> 1.75_cvs_20031023
228- nothing yet
229
230* Wed Oct 22 2003 Hugo Rabson <hugorabson@msn.com> 1.75
231- fixed chmod/chown bug (Jens Richter)
232- ask user to confirm NFS mountpoint in Interactive Mode
233- rewritten format_everything() to make sure LVMs, RAIDs and
234 regular partitions are prepped in the correct order
235- better magicdev support
236- rewritten external binary caller subroutine
237- DVD support added
238- better backup-time control gui; offer to exclude nfs if appl.
239- fixed multi-tape support
240- re-implemented -D and -J
241- fixed bug in extract_config_file_from_ramdisk() which
242 affected tape+floppy users
243- updated is_incoming_block_valid() to make it
244 return end-of-tape if >300 flotsam blocks
245- unmount CD-ROM before burning (necessary for RH8/9)
246- fixed some stray assert()'s
247- fixed bug in grub-MR (Christian)
248- make user remove floppy/CD before restoring interactively from tape
249- fixed bug in am_I_in_disaster_recovery_mode()
250- added code to nuke_mode() to make sure NFS
251 (backup) share is mounted in Nuke Mode
252- improved tape device detection code
253- better GRUB support
254- better logging of changed bigfiles at compare-time
255- better NTFS support, thanks to partimagehack-static
256- better logging
257- rewrote tape-handling code, breaking compatibility w/ previous versions
258- fixed ISO/CD biggiefile verification bug in mondoarchive
259- fixed bug which stopped boot/compare-time changelist from popping up
260- replaced mondo-makefilelist with C code - faster, cleaner
261- tweaked GUI - better feedback
262
263* Wed May 28 2003 Anonymous <root@rohan> 1.74
264- misc fixes (Michael Hanscho's friend)
265- added rudimentary support for SME
266- added better label support
267- fixed biggietime atime/ctime restoration bug 73
268- fixed 'default boot loader' detection bug (Joshua Oreman)
269- use single-threaded make_afioballs_and_images() if FreeBSD
270- fixed mondoarchive -Vi multi-CD verify bug (Tom Mortell)
271- superior get_phys_size_of_drive() (Joshua Oreman)
272- fixed RAID-related bug in where_is_root_mounted()
273- ISO tweaks
274- fixed silly bug in load_filelist() which stopped
275 funny German filenames from being handled properly
276- fixed various calls to popup_and_get_string()
277- fixed spec file
278- reject -E /
279- added partimagehack to the mix
280
281* Tue May 20 2003 Anonymous <root@rohan> 1.73
282- mark devices as bootable _after_ unmounting them
283- resolve boot device (-f) if softlink
284- post_param_configuration() --- store iso-dev and isodir
285- added post-nuke-sample.tgz to package
286- Nuke Mode now checks mountlist against hardware; offer user
287 opportunity to edit mountlist if insane; if user declines, abort
288- added lots of assert()'s and other checks
289- ran code thru Valgrind to catch & fix some memory leaks
290- made mondo-restore.c smaller by moving some subroutines to
291 common/libmondo-raid.c and mondorestore/mondo-rstr-compare.c
292- added '-Q' to let user test mondoarchive's ability to find
293 their boot loader and type
294- improved which_boot_loader()
295- when burning or comparing to a CD, defeat autorun if it is
296 running, to avoid confusing mondoarchive and the user
297- if original backup media no longer available at boot-time
298 then offer user chance to choose another media source
299- when booting, type 'nuke noresize' to nuke w/o resizing
300 mountlist to fill your drives
301- add 'textonly' when booting, to avoid using Newt gui
302- run nice(20) to prioritize mondoarchive at start
303- don't pause and wait for next blank CD at backup-time
304 unless necessary (e.g. previous CD has not been removed)
305- get_phys_size_of_drive() --- better support of older drives
306- don't eject if "donteject" is in kernel's command line
307- cleaned up segfault-handling
308- added Conor's strip_path() to improve file list display
309- added Herman Kuster's multi-level bkp patch
310- better boot-time screen/message
311- added Joshua Oreman's FreeBSD patches x3
312- fixed interactive/textonly support
313- fixed support for subdir-within-NFS-mount
314- fixed "Can't backup if ramdisk not mounted" bug
315- try to work around eccentricities of multi-CD drive PCs
316- misc clean-ups (Steve Hindle)
317
318* Tue Apr 08 2003 Hugo Rabson <hugorabson@msn.com> 1.72
319- LVM/RAID bugs fixed (Brian Borgeson)
320- major clean-up of code (Stan Benoit)
321- make-me-bootable fix (Juraj Ziegler)
322- fixed problem w/ multi-ISO verify cycle (Tom Mortell)
323- removed duplicate entry from makefile
324- if root is /dev/root then assume not a ramdisk
325- reject relative paths if -d flag (Alessandro Polverini)
326- fixed potentially infinite loop in log_to_screen (Tom Mortell)
327- add '/' to custom filelist as workaround for obscure bug
328- ask user speed of CDRW if writing to CD
329- find_cdrom_device() --- if nonexistent/not found then
330 make sure to return '' as dev str and 1 as res
331- tweaked restore scripts tgz
332- cleaned up find_cdrom_device()
333- if user creates /usr/share/mondo/payload.tgz then untar
334 payload to CD at backup-time
335- fixed insist_on_this_cd_number()
336- fixed am_i_in_disaster_recovery_mode()
337- misc clean-up (Tom Mortell)
338- made code more legible
339- fixed post-nuke support
340- added -e support
341- fixed nfs support
342- fixed iso support
343- at restore-time, only sort mountlist internally,
344 in mount_all_devices() and unmount_all_devices()
345- fixed cosmetic bug in label-partitions-as-necessary
346- updated documentation
347- fixed fstab-hacking scripts
348
349* Wed Feb 12 2003 Hugo Rabson <hugorabson@msn.com> 1.71
350- log newt, slang, ncurses info
351- updated man page
352- handle %% chars in issue.net properly (Heiko Schlittermann)
353- fixed serious NFS restore bug
354- cleaned up spec file; it should cause fewer problems now (Jesse Keating)
355- changed various strcpy() calls to strncpy() calls
356- added mondo-makefilelist to makefile (Mikael Hultgren)
357- mount_cdrom() better at handling multiple CD drives
358- exclude /media/cdrom,cdrecorder,floppy
359- sensibly_set_tmpdir_and_scratchdir() --- exclude smb and smbfs
360- better logging by eval_call_to_make_ISO()
361- accept -J <fname> to let user provide their own fs catalog
362 instead of -I <paths> to backup
363- if dir excluded with -E or included with -I and dir is actually
364 a softlink then exclude/include the dir pointed to, as well
365- better location for manpage
366- adjusted block size of tarball at start of tape, to help
367 users w/ broken tape driver firmware
368- sort -u fstab after modifying it
369- if backup type is nfs then don't estimate noof media
370- fixed Makefile (Mikael Hultgren)
371- updated manpage
372
373* Mon Dec 07 2002 Hugo Rabson <hugo@firstlinux.net> 1.70
374- new devel branch opened
375
376* Mon Dec 02 2002 Hugo Rabson <hugo@firstlinux.net> 1.52
377- fixed bug in multithreading
378- use new grub-MR instead of grub-install
379- wipe only the partition table (not the MBR) when partitioning drives
380- ignore lilo.conf.anaconda when looking for lilo.conf file
381- accepts '-l RAW' to backup/restore original boot sector instead
382 of running grub or lilo to init it after restoring
383- fixed&updated stabgrub-me script; software RAID + GRUB work now
384- mount/unmount /boot partition for Gentoo 1.2 users
385- re-enabled extra tape checksums
386- disabled spurious warnings
387- unmount/remount supermounts at start/end of live restore, if nec.
388- cleaned up mondo's tape block handling (now, TAPE_BLOCK_SIZE=128K
389 and I've added INTERNAL_TAPE_BLK_SIZE=32K variable for buffering)
390- added Makefile
391- added -l RAW, to backup and restore original MBR
392- cleaned up iso_mode() and nfs restoring
393- create /mnt/RESTORING/mnt/.boot.d for Gentoo users
394- made mondorestore CD bootable for ArkLinux users
395- if user runs as 'su' not 'su -' then work around
396
397* Sun Nov 17 2002 Hugo Rabson <hugo@firstlinux.net> 1.51
398- pop-up list of changed files, at end of verification phase
399- better handling of changed.files list at restore-time
400- lots of CD-related fixes
401- added '-N' flag --- to let user exclude all NFS-related mounts&devices
402- better handling of 'kill'
403- restructuring of code to ease integration of mondo w/XMondo
404- fixed obscure bug in find_and_mount_actual_cd()
405- if / or /root has <50MB free then abort & complain
406- fixed install.sh
407- fixed .spec file
408- updated documentation
409- commented code
410- updated man page
411- added -v / --version flag
412- replace convoluted grep with wc (KP)
413- fixed bug affecting restoration of bigfiles from CD's created w/0 compression
414- fixed BurnProof-related bug
415- better at figuring out which is the best partition for temp/scratchdir
416- added do-not-compress-these (text file) to RPM
417- do not compress files of types listed in do-not-compress-these
418- dropped -U from call to afio - saves 20-30% runtime (Cosgrove)
419- added Cosgrove's do-not-compress-these list
420- included various patches from KP
421- chmod tmpdir, scratchdir to 700 before using
422- restore from specified backup device, even if its own cfg file disagrees
423- fixed multi-tape bug
424- fixed "Can't find first ISO when verifying nonbootable ISO" bug
425- multithreaded make_afioballs_and_images()
426- tmpdir and scratchdir are set sensibly whether mondoarchive is called with
427 command-line parameters or not
428- fixed bug in strip_spaces() which stopped it from handling
429 small strings correctly - affected mountlist editor
430- create a repaired copy of grub-install which is RAID-friendly;
431 use it when initializing boot sector with run_grub()
432- fixed bug in mondo-makefilelist
433
434* Sun Sep 08 2002 Hugo Rabson <hugo@firstlinux.net> 1.50
435- if restoring, don't try to find SCSI node of CD-ROM drive; find /dev entry
436- during selective restore, skip filesets which don't contain relevant archives
437- set /dev/null's perms to 777, just in case devfs-enabled kernel mangles it
438- remove /var/run/*.pid after restoring
439- move spurious lockfiles from /home/* to /home/*/.disabled
440- ask user to confirm the tape/CD device name
441- lots of multitape-related fixes
442- added code to autodetect the hardware of the user, if possible
443- if isodir does not exist then abort
444- more sanity-checking for -d flag
445- doubled 'biggiefile' threshold... to 32MB
446- exclude /root/images/mindi
447- fixed multi-imagedev bug (Emmanuel Druon)
448- unmount/remount /mnt/floppy before/after backing up, if Mandrake
449- restructured the source files
450- fixed serious bug in line 1546 - should have been !=, not ==; stopped
451 mondorestore from correctly restoring big files
452- added '#include <signal.h>' to my-stuff.h
453- exclude "incheckentry xwait()" from changed.files
454- fixed minor bug in find_cdrom_device()
455- fixed bug in friendly_sizestr...
456- insist on tape #1 when start verifying
457- added internal buffering, replacing the external 'buffer' exe
458- if differential backup then don't permit formatting or fdisking,
459 whether Interactive or Nuke mode
460- if mondorestore is run on live filesystem (or from ramdisk) without
461 parameters then mondorestore will ask which backup media (tape, CD, etc.)
462 was used; it will read the config file from the media and proceed from there
463- if tape streamer is softlink then resolve it first
464- incorporate post-nuke tarball
465- if user doesn't specify tape size, proceed anyway; behave intelligently
466 in the event of end-of-tape
467- prefix bkpinfo->restore_path to biggiefile fname before generating
468 checksum & comparing to archived biggiefile
469- if /etc/lilo.conf not found not /etc/lilo.conf.anaconda found
470 then create a softlink from the former to the latter, to work
471 around RH7.3's b0rken LILO support
472- LFS support (mharris, michele, hugo)
473- fixed verify bug --- CD#1 was being verified again & again & ...
474- differential mode fixed; supported again
475- ask user for boot loader + device if not detectible
476- list up to 512 files in file selection window at once (was 128)
477- better handling of bigfiles' checksums, perms and owns
478- delete final filelist if <=2 bytes long
479- if kernel not found and mondo in graphics mode then popup and ask
480 for kernel path+filename
481
482* Sun Jul 14 2002 Hugo Rabson <hugo@firstlinux.net> 1.45-1
483- 1.5x branch forked off from 1.4x branch
484
485
486
487
Note: See TracBrowser for help on using the repository browser.